Overclock.net › Forums › Graphics Cards › AMD/ATI › Help with Sapphire HD5750
New Posts  All Forums:Forum Nav:

Help with Sapphire HD5750

post #1 of 14
Thread Starter 
Hi, i recently updated to the latest ATI driver (11.2),

But now I started MSI Afterburner and the GPU gadget for windows 7.

My stock clock is 700 core mhz / 1100 memory

But in the windows gadget and in afterburner, my card is locked at 400 mhz core and 900 mhz memory clock and the temps stays at 55 instead of the normal 70.

No wonder i run sc2 at 20 fps..

So, whats wrong ???

Thanks !!
     
CPUGraphicsRAMOS
i7 4710q Nvidia GT840M 8GB DDR-3 1600 Windows 8.1 
Monitor
17" 1600x900 
CPUMotherboardGraphicsGraphics
Intel Core i7 930 D0 ASUS P6T-SE Sapphire 5750 1Gig @ 820/1275 Asus 6770 DirectCU 1Gig @ 908/1150 
RAMHard DriveOptical DriveOS
Kingston Value 18 Gigs 1086mhz CL8 Western Digital 640GB Black LG GH24LS50 24x Windows 7 Home Premium 64 
MonitorPowerCaseMouse
ASUS VW266H 26" 1920x1200 Antec True Power New 750 watts Thermaltake V3 Black Edition Logitech G5 V2 
  hide details  
Reply
     
CPUGraphicsRAMOS
i7 4710q Nvidia GT840M 8GB DDR-3 1600 Windows 8.1 
Monitor
17" 1600x900 
CPUMotherboardGraphicsGraphics
Intel Core i7 930 D0 ASUS P6T-SE Sapphire 5750 1Gig @ 820/1275 Asus 6770 DirectCU 1Gig @ 908/1150 
RAMHard DriveOptical DriveOS
Kingston Value 18 Gigs 1086mhz CL8 Western Digital 640GB Black LG GH24LS50 24x Windows 7 Home Premium 64 
MonitorPowerCaseMouse
ASUS VW266H 26" 1920x1200 Antec True Power New 750 watts Thermaltake V3 Black Edition Logitech G5 V2 
  hide details  
Reply
post #2 of 14
Thread Starter 
Edit: It doesnt even downclock when not in use. It stays at 400/900
     
CPUGraphicsRAMOS
i7 4710q Nvidia GT840M 8GB DDR-3 1600 Windows 8.1 
Monitor
17" 1600x900 
CPUMotherboardGraphicsGraphics
Intel Core i7 930 D0 ASUS P6T-SE Sapphire 5750 1Gig @ 820/1275 Asus 6770 DirectCU 1Gig @ 908/1150 
RAMHard DriveOptical DriveOS
Kingston Value 18 Gigs 1086mhz CL8 Western Digital 640GB Black LG GH24LS50 24x Windows 7 Home Premium 64 
MonitorPowerCaseMouse
ASUS VW266H 26" 1920x1200 Antec True Power New 750 watts Thermaltake V3 Black Edition Logitech G5 V2 
  hide details  
Reply
     
CPUGraphicsRAMOS
i7 4710q Nvidia GT840M 8GB DDR-3 1600 Windows 8.1 
Monitor
17" 1600x900 
CPUMotherboardGraphicsGraphics
Intel Core i7 930 D0 ASUS P6T-SE Sapphire 5750 1Gig @ 820/1275 Asus 6770 DirectCU 1Gig @ 908/1150 
RAMHard DriveOptical DriveOS
Kingston Value 18 Gigs 1086mhz CL8 Western Digital 640GB Black LG GH24LS50 24x Windows 7 Home Premium 64 
MonitorPowerCaseMouse
ASUS VW266H 26" 1920x1200 Antec True Power New 750 watts Thermaltake V3 Black Edition Logitech G5 V2 
  hide details  
Reply
post #3 of 14
What you are seeing on the 400 MHz core is the 2D clock it bumps up when you are running a game and such
Torch's Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6750 w/G0 ASUS P5KC Sapphire HD5770 1GB 4 GB G.Skill DDR3 1333 
Hard DriveOptical DriveOSMonitor
ADATA S510 120GB SSD, (2)Samsung F3 1TB, Seaga... Asus SATA DVD LinuxMint 13 x86 w/Mate Asus 23" HD 1080p HDMI LED LCD 
KeyboardPowerCaseMouse
Microsoft Sidewinder X4 610w PC Power & Cool Silencer Rosewill Blackbone Logitech G400 
Mouse Pad
DOLICA 
  hide details  
Reply
Torch's Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6750 w/G0 ASUS P5KC Sapphire HD5770 1GB 4 GB G.Skill DDR3 1333 
Hard DriveOptical DriveOSMonitor
ADATA S510 120GB SSD, (2)Samsung F3 1TB, Seaga... Asus SATA DVD LinuxMint 13 x86 w/Mate Asus 23" HD 1080p HDMI LED LCD 
KeyboardPowerCaseMouse
Microsoft Sidewinder X4 610w PC Power & Cool Silencer Rosewill Blackbone Logitech G400 
Mouse Pad
DOLICA 
  hide details  
Reply
post #4 of 14
Same thin happens with my 5770 i think. its gets downclocked when not in use to like 157mhz and 300 memory clock. but when i go in a game it will bring its speed up again.
post #5 of 14
Thats peculiar. Try a driver sweep? Revert to old drivers?
post #6 of 14
Quote:
Originally Posted by AlaskaFox View Post
Thats peculiar. Try a driver sweep? Revert to old drivers?
Wrong, this is a normal thing
Torch's Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6750 w/G0 ASUS P5KC Sapphire HD5770 1GB 4 GB G.Skill DDR3 1333 
Hard DriveOptical DriveOSMonitor
ADATA S510 120GB SSD, (2)Samsung F3 1TB, Seaga... Asus SATA DVD LinuxMint 13 x86 w/Mate Asus 23" HD 1080p HDMI LED LCD 
KeyboardPowerCaseMouse
Microsoft Sidewinder X4 610w PC Power & Cool Silencer Rosewill Blackbone Logitech G400 
Mouse Pad
DOLICA 
  hide details  
Reply
Torch's Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6750 w/G0 ASUS P5KC Sapphire HD5770 1GB 4 GB G.Skill DDR3 1333 
Hard DriveOptical DriveOSMonitor
ADATA S510 120GB SSD, (2)Samsung F3 1TB, Seaga... Asus SATA DVD LinuxMint 13 x86 w/Mate Asus 23" HD 1080p HDMI LED LCD 
KeyboardPowerCaseMouse
Microsoft Sidewinder X4 610w PC Power & Cool Silencer Rosewill Blackbone Logitech G400 
Mouse Pad
DOLICA 
  hide details  
Reply
post #7 of 14
Oh wait no its just you, i just checked MSI afterburner. My Core is at 850 Memory at 1200, sorry.
post #8 of 14
using afterburner manually set it to 700/1100
Swag box m8
(13 items)
 
7 x BL460c
(6 items)
 
 
CPUMotherboardGraphicsRAM
2500K Asus P8P67 Sapphire HD 5770 2x8GB Corsair 1333MHz 
Hard DriveMonitorMonitorPower
Corsair Force 3 120GB Aoc F22S+ Aoc F22S+ Powercool 850W 80+ 
Case
NZXT Phantom 
CPUCPUMotherboardRAM
Xeon E5520  Xeon E5520  BL460c G6 12GB ECC DDR3 
Hard DriveOS
1TB of SAN Server 2008 R2 
  hide details  
Reply
Swag box m8
(13 items)
 
7 x BL460c
(6 items)
 
 
CPUMotherboardGraphicsRAM
2500K Asus P8P67 Sapphire HD 5770 2x8GB Corsair 1333MHz 
Hard DriveMonitorMonitorPower
Corsair Force 3 120GB Aoc F22S+ Aoc F22S+ Powercool 850W 80+ 
Case
NZXT Phantom 
CPUCPUMotherboardRAM
Xeon E5520  Xeon E5520  BL460c G6 12GB ECC DDR3 
Hard DriveOS
1TB of SAN Server 2008 R2 
  hide details  
Reply
post #9 of 14
Thread Starter 
I went into the device manager , and clicked on "find a new driver", but canceled.

Then started GPU-Z to be sure, and it was back at 700/1150, and it now downclock properly.

That's odd, but it works fine now. Thanks for the help !!
     
CPUGraphicsRAMOS
i7 4710q Nvidia GT840M 8GB DDR-3 1600 Windows 8.1 
Monitor
17" 1600x900 
CPUMotherboardGraphicsGraphics
Intel Core i7 930 D0 ASUS P6T-SE Sapphire 5750 1Gig @ 820/1275 Asus 6770 DirectCU 1Gig @ 908/1150 
RAMHard DriveOptical DriveOS
Kingston Value 18 Gigs 1086mhz CL8 Western Digital 640GB Black LG GH24LS50 24x Windows 7 Home Premium 64 
MonitorPowerCaseMouse
ASUS VW266H 26" 1920x1200 Antec True Power New 750 watts Thermaltake V3 Black Edition Logitech G5 V2 
  hide details  
Reply
     
CPUGraphicsRAMOS
i7 4710q Nvidia GT840M 8GB DDR-3 1600 Windows 8.1 
Monitor
17" 1600x900 
CPUMotherboardGraphicsGraphics
Intel Core i7 930 D0 ASUS P6T-SE Sapphire 5750 1Gig @ 820/1275 Asus 6770 DirectCU 1Gig @ 908/1150 
RAMHard DriveOptical DriveOS
Kingston Value 18 Gigs 1086mhz CL8 Western Digital 640GB Black LG GH24LS50 24x Windows 7 Home Premium 64 
MonitorPowerCaseMouse
ASUS VW266H 26" 1920x1200 Antec True Power New 750 watts Thermaltake V3 Black Edition Logitech G5 V2 
  hide details  
Reply
post #10 of 14
Thread Starter 
Quote:
Originally Posted by overclocker23578 View Post
using afterburner manually set it to 700/1100
Didnt work, i tried it. But now it seems fixed
     
CPUGraphicsRAMOS
i7 4710q Nvidia GT840M 8GB DDR-3 1600 Windows 8.1 
Monitor
17" 1600x900 
CPUMotherboardGraphicsGraphics
Intel Core i7 930 D0 ASUS P6T-SE Sapphire 5750 1Gig @ 820/1275 Asus 6770 DirectCU 1Gig @ 908/1150 
RAMHard DriveOptical DriveOS
Kingston Value 18 Gigs 1086mhz CL8 Western Digital 640GB Black LG GH24LS50 24x Windows 7 Home Premium 64 
MonitorPowerCaseMouse
ASUS VW266H 26" 1920x1200 Antec True Power New 750 watts Thermaltake V3 Black Edition Logitech G5 V2 
  hide details  
Reply
     
CPUGraphicsRAMOS
i7 4710q Nvidia GT840M 8GB DDR-3 1600 Windows 8.1 
Monitor
17" 1600x900 
CPUMotherboardGraphicsGraphics
Intel Core i7 930 D0 ASUS P6T-SE Sapphire 5750 1Gig @ 820/1275 Asus 6770 DirectCU 1Gig @ 908/1150 
RAMHard DriveOptical DriveOS
Kingston Value 18 Gigs 1086mhz CL8 Western Digital 640GB Black LG GH24LS50 24x Windows 7 Home Premium 64 
MonitorPowerCaseMouse
ASUS VW266H 26" 1920x1200 Antec True Power New 750 watts Thermaltake V3 Black Edition Logitech G5 V2 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Help with Sapphire HD5750