Overclock.net › Forums › Video Games › PC Gaming › Bad Company 2 keeps on crashing my PC
New Posts  All Forums:Forum Nav:

Bad Company 2 keeps on crashing my PC - Page 19

post #181 of 241
re installed punk and disabled afterburner now i get ctd instead of freeze soundloop grrrrr. I got a new system last week i7 2600k p67 sabertooth 6970 asus directcu and all was working well then this bs with bc2! I thought it was my system and have been trying to fix stuff for the past week! now I find out its punkbuster THEY SUCK!!!!!!!!!!!!!!!!!!!! EA AND PUNKBUSTER FIX THIS NOW!!!!!!!!!!!!!!!
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 5ghz p67 Sabertooth  gigabyte 780 G. SKILL TridentX Series 2133ghz 
Hard DriveOSMonitorKeyboard
Corsair Force 3 120gig win7 64bit benq 27"X3 eyefinity Logitech G13 
PowerCaseMouse
Silverstone gold series 750w Corsair 650d Vengeance M60  
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 5ghz p67 Sabertooth  gigabyte 780 G. SKILL TridentX Series 2133ghz 
Hard DriveOSMonitorKeyboard
Corsair Force 3 120gig win7 64bit benq 27"X3 eyefinity Logitech G13 
PowerCaseMouse
Silverstone gold series 750w Corsair 650d Vengeance M60  
  hide details  
Reply
post #182 of 241
Having the same issues and I received this from even balance just a few minutes ago...I will update if this fixes the issue later tonight when I have a few minutes to hop into the field...

03/18/2011 16:16:38 - "Adam D"
Note #2: Please start pbsvc.exe and run through the uninstall process. After that, run it again and run through the install process. Make sure it uninstalls/installs correctly. Reboot the computer and then try playing again. Vista (and above) users need to start it explicitly with admin rights.

Please make sure you allow the service files in security software like virus scanners and/or firewalls. You will need to allow/unblock the services PnkBstrA.exe and PnkBstrB.exe from your "C:\\Windows\\system32\\" folder (or "C:\\Windows\\SysWOW64\\" on 64bit systems). In case of doubt, manually add both to your firewall's allow list. After the installation process you will only find PnkBstrA, so just make sure this process file is not blocked. Then try playing on a PB enabled server, in case of a kick, check if PnkBstrB was created and unblock it too.
03/17/2011 15:40:51 - "Craig"
Note #1: Ticket submitted to support staff.
post #183 of 241
Thread Starter 
That is NOT a solution.
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
post #184 of 241
This has worked for me so far. I went into my steam folder(C:\\Program Files (x86)\\Steam\\steamapps\\common\\battlefield bad company 2) There was the pb folder so I right clcked and deleted it. Then I reinstalled it and updated as per the instructions posted earlier in here. I might add that Trixx was disabled when I updated, I played for about 6 maps or 45 minutes and then loaded Trixx because my GPU temp was high, over 62c. I put in an overclock and played 2 more maps. So far so good.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom IIx4 955BE GIGabyte 870A-UD3 XFX5850 Corsair Dominator 2 Gb 1333 DDR3 
Hard DriveOSMonitorKeyboard
2x500Gb Sata II 3.0 Win 7 64bit Dell 19 lcd Dell 
PowerCaseMouse
Ultra LSP750 Xcruiser 2 Mid Logitech MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom IIx4 955BE GIGabyte 870A-UD3 XFX5850 Corsair Dominator 2 Gb 1333 DDR3 
Hard DriveOSMonitorKeyboard
2x500Gb Sata II 3.0 Win 7 64bit Dell 19 lcd Dell 
PowerCaseMouse
Ultra LSP750 Xcruiser 2 Mid Logitech MX518 
  hide details  
Reply
post #185 of 241
Thread Starter 
Quote:
Originally Posted by klook View Post
This has worked for me so far. I went into my steam folder(C:\\Program Files (x86)\\Steam\\steamapps\\common\\battlefield bad company 2) There was the pb folder so I right clcked and deleted it. Then I reinstalled it and updated as per the instructions posted earlier in here. I might add that Trixx was disabled when I updated, I played for about 6 maps or 45 minutes and then loaded Trixx because my GPU temp was high, over 62c. I put in an overclock and played 2 more maps. So far so good.
Just so you know, you did not fix the issue by deleting the PB folder, but because of closing Trixx.

Play for a few more rounds, your PC will freeze again, even with Afterburner, I am able to play up to 2 hours randomly with no freeze, 2 hours was the most I could play with Afterburner opened.

I just play without Afterburner or anything right now.
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
post #186 of 241
This is not official but I talked to a buddy of mine that writes software and so on. I told him about this and hes heard about the problem to . His thoughts are that EA or PB are doing one or all of a couple of things. There trying new software for a upcoming game or just putting a stop to the cheaters using software for things like aim bots.

He said to clear this up for certain ask someone who is using software for aim bots and so on and see it they can play.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 4790k Gigabyte Z97 EVGA 970 ftw G.SKILL Ripjaws X Series 
Hard DriveOptical DriveOSMonitor
Western Digital WD VelociRaptor ASUS DVD/CD combo Window 7 64 samsung 27 
PowerCaseMouseMouse Pad
Antec TP 650 NXZT Phantom Wolfking Truuper Blue 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 4790k Gigabyte Z97 EVGA 970 ftw G.SKILL Ripjaws X Series 
Hard DriveOptical DriveOSMonitor
Western Digital WD VelociRaptor ASUS DVD/CD combo Window 7 64 samsung 27 
PowerCaseMouseMouse Pad
Antec TP 650 NXZT Phantom Wolfking Truuper Blue 
  hide details  
Reply
post #187 of 241
Thinking I fixed the problem... I do have onboard sound and hadn't installed the Realtek drivers and was using the Windows 7 provided drivers for the sound. I went to Asus's website and downloaded the most recent realtek drivers for my mobo and just played 5 rounds uninterrupted. Thinking that did the trick with the recommended fixes on the first page of the thread.

Earlier I crashed out with all the recommended fixes w/out the realtek drivers....
post #188 of 241
Thread Starter 
Quote:
Originally Posted by cjwally View Post
Thinking I fixed the problem... I do have onboard sound and hadn't installed the Realtek drivers and was using the Windows 7 provided drivers for the sound. I went to Asus's website and downloaded the most recent realtek drivers for my mobo and just played 5 rounds uninterrupted. Thinking that did the trick with the recommended fixes on the first page of the thread.

Earlier I crashed out with all the recommended fixes w/out the realtek drivers....
Were you using MSI Afterburner or any similar program while you played those 5 rounds?

It really annoys me that I have to actually turn it off while playing Bad Company 2, I do need a custom fan profile... But Punkbuster doesn't seem to like these programs anymore.
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
post #189 of 241
Quote:
Originally Posted by kcuestag View Post
Were you using MSI Afterburner or any similar program while you played those 5 rounds?

It really annoys me that I have to actually turn it off while playing Bad Company 2, I do need a custom fan profile... But Punkbuster doesn't seem to like these programs anymore.
I was only running CCC w/ 11.4 drivers and manually set the fans at 80% w/ power control @ +20%...I am with you though...I prefer afterburner as well... Next step is to try with AB installed and running while playing. I almost can't believe that I may have fixed this...Over a week of tweaking and multiple fresh OS installs...
post #190 of 241
Thread Starter 
Quote:
Originally Posted by cjwally View Post
I was only running CCC w/ 11.4 drivers and manually set the fans at 80%... I am with you though...I prefer afterburner as well... Next step is to try with AB installed and running while playing. I almost can't believe that I may have fixed this...Over a week of tweaking and multiple fresh OS installs...
Just for your info, reinstalling the Realtek drivers didn't fix your problem, closing Afterburner did.

Try again with Afterburner, I'm sure within 1 hour and half your computer will freeze again.
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Bad Company 2 keeps on crashing my PC