Overclock.net › Forums › Software, Programming and Coding › Networking & Security › linksys e3000 pulling my hair out
New Posts  All Forums:Forum Nav:

linksys e3000 pulling my hair out

post #1 of 14
Thread Starter 
appoligies for posting this in other forums i was misguided. but here is the problem and i hope that i can get some insight to this problem.

ok im at my whits end here. last week i got a netgear wndr3400 and after many hours with tech support could not get it to run on my xps 1730 at 300mbps. i got so fed up i returned it and got a linksys e3000 {which supports dd-wrt} .wink.gif

although i do like the e3000 web interface much better, with way more function control, i still cannot get the dang wireless to link up at 300mbps. also i cannot get it to do it with my desktop that is running a d-link dir556 atheros adapter running the atheros drivers.

i have it set identical to my old router {d-link dir 615} that was picking up my dwa556 at 300 mbps. wpa2 (AES) only, auto channel, 20/40 mixed channel width, "N" network mode only . someone please tell me what i might be doing wrong. so far it seams that i am just throwing money at something that cannot be done. wondering why my 7 yr old router reports better numbers than the brand new one?

will dd-wrt help with achieving 300 mbps link with the e3000 router or is there just a little setting that i am missing?confused.gif
Edited by zenraider - 3/17/11 at 10:05am
the rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
64 x2 am2 4400+ 2.3ghz MSI k94n sli platnium MSI N260GTX core 216 ocv2 crucial lanfest 2gig balistix hybrid 
Hard DriveOptical DriveOSMonitor
seagate sata 3 160g generic dvd XP Pro w/ SP3 Samsung 22" wide 2ms 
KeyboardPowerCaseMouse
Ideazon merc gaming board OCX gameXstream 700 sli Antec 900 g500 Logitech laser 
Mouse Pad
none 
  hide details  
Reply
the rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
64 x2 am2 4400+ 2.3ghz MSI k94n sli platnium MSI N260GTX core 216 ocv2 crucial lanfest 2gig balistix hybrid 
Hard DriveOptical DriveOSMonitor
seagate sata 3 160g generic dvd XP Pro w/ SP3 Samsung 22" wide 2ms 
KeyboardPowerCaseMouse
Ideazon merc gaming board OCX gameXstream 700 sli Antec 900 g500 Logitech laser 
Mouse Pad
none 
  hide details  
Reply
post #2 of 14
unfortunately, their is no such thing as 300mbps, its a marketing/selling technique. Its actually 150up and 150down speeds, totaling 300mbps. HOWEVER, under wireless settings, theirs an option to select 20hz, 40hz, 20/40hz, or auto. Ive found to get full speed you must select 20/40hz, but it might be different for your router. Ive used this on two different netgears and a linksys to get full speeds.
P50
(15 items)
 
   
CPUGraphicsRAMHard Drive
Intel Core i7-6700HQ NVIDIA Quadro M1000M 4GB Gskill 32gb 4x8gb DDR4 2300mhz Samsung 850 PRO - 1TB SSD m2 
Hard DriveOptical DriveOSOS
Seagate 2TB w/ 128MB Cache (ST2000LM007) Pioneer External USB-C Blu-Ray Burner Fedora 25 Win 10 LTSB 
MonitorMonitorMonitorPower
15.6" 1920x1080 IPS BenQ GL2460HM 24" LED BenQ GL2460HM 24" LED Lenovo 170w Power adapter 
MouseOther
MX-580 or Razor bluetooth something or other Docking station 40A50230US 
CPUMotherboardRAMHard Drive
i7 3770k BIOSTAR TH67+ 32gb 4x8 Corsair Vengence 1600 1x 256gb m2 
Hard DriveOSPowerCase
6x Seagate 2.5" 3tb > ~8.5tb raid 10 OpenSuse Seasonic G 550w Silverstone SG11B 
Other
Raid card 
  hide details  
Reply
P50
(15 items)
 
   
CPUGraphicsRAMHard Drive
Intel Core i7-6700HQ NVIDIA Quadro M1000M 4GB Gskill 32gb 4x8gb DDR4 2300mhz Samsung 850 PRO - 1TB SSD m2 
Hard DriveOptical DriveOSOS
Seagate 2TB w/ 128MB Cache (ST2000LM007) Pioneer External USB-C Blu-Ray Burner Fedora 25 Win 10 LTSB 
MonitorMonitorMonitorPower
15.6" 1920x1080 IPS BenQ GL2460HM 24" LED BenQ GL2460HM 24" LED Lenovo 170w Power adapter 
MouseOther
MX-580 or Razor bluetooth something or other Docking station 40A50230US 
CPUMotherboardRAMHard Drive
i7 3770k BIOSTAR TH67+ 32gb 4x8 Corsair Vengence 1600 1x 256gb m2 
Hard DriveOSPowerCase
6x Seagate 2.5" 3tb > ~8.5tb raid 10 OpenSuse Seasonic G 550w Silverstone SG11B 
Other
Raid card 
  hide details  
Reply
post #3 of 14
Thread Starter 
Quote:
Originally Posted by Greensystemsgo;12726792 
unfortunately, their is no such thing as 300mbps, its a marketing/selling technique. Its actually 150up and 150down speeds, totaling 300mbps. HOWEVER, under wireless settings, theirs an option to select 20hz, 40hz, 20/40hz, or auto. Ive found to get full speed you must select 20/40hz, but it might be different for your router. Ive used this on two different netgears and a linksys to get full speeds.

ok i can deal with that, the router is set to 20/40 , laptop reports 144 and desktop reports 130, on the dlink router it reports 300 using the windows connection status window. or does it report the lower number because of the 150 up/down i.e. its more sensitive in the firmware than the dlink could be? . is there a more reliable source to see what i am getting?

all i realy want is to prove that i am getting the same speed with the e3000 that i was with the dlink, i dont realy care what the mbps says in the status window so long as i get full speed
the rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
64 x2 am2 4400+ 2.3ghz MSI k94n sli platnium MSI N260GTX core 216 ocv2 crucial lanfest 2gig balistix hybrid 
Hard DriveOptical DriveOSMonitor
seagate sata 3 160g generic dvd XP Pro w/ SP3 Samsung 22" wide 2ms 
KeyboardPowerCaseMouse
Ideazon merc gaming board OCX gameXstream 700 sli Antec 900 g500 Logitech laser 
Mouse Pad
none 
  hide details  
Reply
the rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
64 x2 am2 4400+ 2.3ghz MSI k94n sli platnium MSI N260GTX core 216 ocv2 crucial lanfest 2gig balistix hybrid 
Hard DriveOptical DriveOSMonitor
seagate sata 3 160g generic dvd XP Pro w/ SP3 Samsung 22" wide 2ms 
KeyboardPowerCaseMouse
Ideazon merc gaming board OCX gameXstream 700 sli Antec 900 g500 Logitech laser 
Mouse Pad
none 
  hide details  
Reply
post #4 of 14
150 is ideal settings. i think when that "hz" setting was wrong on mine i was getting around 90.

for me, i monitor my wlan speed and info using the program provided by the wlan chipset vendor. Yes my card is an asus, but its a ralink chipset. the chipset manf usually has the most up to date drivers over the manf (asus).

HOWEVER, you might want to look into nettools but thats is complete over kill. Right now, being less then a foot away from the wlan router, it bounces between 135-150mbps. Mind you my internet speed is only 15 down and rarely is media streamed so still, 135 is perfectly fine.

I definitely recommend dd-wrt, i find it has more options, control, better load handling, and better over all reliability then the lame firmwares that come on most routers. linksys firmware isnt BAD, but it also isnt good.
P50
(15 items)
 
   
CPUGraphicsRAMHard Drive
Intel Core i7-6700HQ NVIDIA Quadro M1000M 4GB Gskill 32gb 4x8gb DDR4 2300mhz Samsung 850 PRO - 1TB SSD m2 
Hard DriveOptical DriveOSOS
Seagate 2TB w/ 128MB Cache (ST2000LM007) Pioneer External USB-C Blu-Ray Burner Fedora 25 Win 10 LTSB 
MonitorMonitorMonitorPower
15.6" 1920x1080 IPS BenQ GL2460HM 24" LED BenQ GL2460HM 24" LED Lenovo 170w Power adapter 
MouseOther
MX-580 or Razor bluetooth something or other Docking station 40A50230US 
CPUMotherboardRAMHard Drive
i7 3770k BIOSTAR TH67+ 32gb 4x8 Corsair Vengence 1600 1x 256gb m2 
Hard DriveOSPowerCase
6x Seagate 2.5" 3tb > ~8.5tb raid 10 OpenSuse Seasonic G 550w Silverstone SG11B 
Other
Raid card 
  hide details  
Reply
P50
(15 items)
 
   
CPUGraphicsRAMHard Drive
Intel Core i7-6700HQ NVIDIA Quadro M1000M 4GB Gskill 32gb 4x8gb DDR4 2300mhz Samsung 850 PRO - 1TB SSD m2 
Hard DriveOptical DriveOSOS
Seagate 2TB w/ 128MB Cache (ST2000LM007) Pioneer External USB-C Blu-Ray Burner Fedora 25 Win 10 LTSB 
MonitorMonitorMonitorPower
15.6" 1920x1080 IPS BenQ GL2460HM 24" LED BenQ GL2460HM 24" LED Lenovo 170w Power adapter 
MouseOther
MX-580 or Razor bluetooth something or other Docking station 40A50230US 
CPUMotherboardRAMHard Drive
i7 3770k BIOSTAR TH67+ 32gb 4x8 Corsair Vengence 1600 1x 256gb m2 
Hard DriveOSPowerCase
6x Seagate 2.5" 3tb > ~8.5tb raid 10 OpenSuse Seasonic G 550w Silverstone SG11B 
Other
Raid card 
  hide details  
Reply
post #5 of 14
um for those saying 300 is only 150 thats wrong my wrt300n and the e2000 both link up at 270-300mps to my dlink wireless n card.
SABERWOLF
(18 items)
 
XEON-WOLF
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6800K MSI X99A GAMING PRO CARBON EVGA GTX 1080 FTW Hydro Copper G.SKILL TridentZ Series 
Hard DriveCoolingCoolingCooling
Samsung EVO 850 500 EK-SBAY Dual DDC 3.2 PWM Serial Alphacool NexXxoS ST30 Full Copper Radiator 360 Hardware Labs Black Ice SR2 Multiport Black Car... 
CoolingCoolingOSMonitor
EK-CoolStream RAD XTC 420 koolance 380i Windows 10 Pro ASUS VW246H Black 24" 2ms 
PowerCaseMouseAudio
SeaSonic M12D SS-850 850W  Thermaltake core x71 CM Storm Sentinel Advance II Corsair Void 
CPUMotherboardGraphicsRAM
X5675@4400 1.344 ASUS P6X58D-E XfX RX480 RS F3-12800CL7T-6GBPI 6-7-6-21 1T 
RAMHard DriveHard DriveHard Drive
F3-12800CL9S-4GBRL WDC WD1001FALS-00J7B1 ST31000340AS WDC WD7500AAKS-00RBA0 
Hard DriveOptical DriveCoolingOS
Hitachi HDS723020BLA642 ihas 624-A SilverStone Heligon HE01 windows 10 64 Pro 
MonitorPowerCase
Vizio 42inch lcd tv CORSAIR CMPSU-950TX Modded Rocketfish 
  hide details  
Reply
SABERWOLF
(18 items)
 
XEON-WOLF
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6800K MSI X99A GAMING PRO CARBON EVGA GTX 1080 FTW Hydro Copper G.SKILL TridentZ Series 
Hard DriveCoolingCoolingCooling
Samsung EVO 850 500 EK-SBAY Dual DDC 3.2 PWM Serial Alphacool NexXxoS ST30 Full Copper Radiator 360 Hardware Labs Black Ice SR2 Multiport Black Car... 
CoolingCoolingOSMonitor
EK-CoolStream RAD XTC 420 koolance 380i Windows 10 Pro ASUS VW246H Black 24" 2ms 
PowerCaseMouseAudio
SeaSonic M12D SS-850 850W  Thermaltake core x71 CM Storm Sentinel Advance II Corsair Void 
CPUMotherboardGraphicsRAM
X5675@4400 1.344 ASUS P6X58D-E XfX RX480 RS F3-12800CL7T-6GBPI 6-7-6-21 1T 
RAMHard DriveHard DriveHard Drive
F3-12800CL9S-4GBRL WDC WD1001FALS-00J7B1 ST31000340AS WDC WD7500AAKS-00RBA0 
Hard DriveOptical DriveCoolingOS
Hitachi HDS723020BLA642 ihas 624-A SilverStone Heligon HE01 windows 10 64 Pro 
MonitorPowerCase
Vizio 42inch lcd tv CORSAIR CMPSU-950TX Modded Rocketfish 
  hide details  
Reply
post #6 of 14
Quote:
Originally Posted by Bal3Wolf;12729845 
um for those saying 300 is only 150 thats wrong my wrt300n and the e2000 both link up at 270-300mps to my dlink wireless n card.

assuming you only have a single up and down stream, thats 150 each way. if you have dual down, then hypothetically you could have 300, or even quad you could have 600, BUT do those routers do that? are their any g devices on the network because if its only 2.4ghz, then everyone is brought down to the G's level UNLESS its 2.4 and 5ghz - dual channel. So many factors. heres a good comparison.

http://en.wikipedia.org/wiki/IEEE_802.11n-2009#Comparison
P50
(15 items)
 
   
CPUGraphicsRAMHard Drive
Intel Core i7-6700HQ NVIDIA Quadro M1000M 4GB Gskill 32gb 4x8gb DDR4 2300mhz Samsung 850 PRO - 1TB SSD m2 
Hard DriveOptical DriveOSOS
Seagate 2TB w/ 128MB Cache (ST2000LM007) Pioneer External USB-C Blu-Ray Burner Fedora 25 Win 10 LTSB 
MonitorMonitorMonitorPower
15.6" 1920x1080 IPS BenQ GL2460HM 24" LED BenQ GL2460HM 24" LED Lenovo 170w Power adapter 
MouseOther
MX-580 or Razor bluetooth something or other Docking station 40A50230US 
CPUMotherboardRAMHard Drive
i7 3770k BIOSTAR TH67+ 32gb 4x8 Corsair Vengence 1600 1x 256gb m2 
Hard DriveOSPowerCase
6x Seagate 2.5" 3tb > ~8.5tb raid 10 OpenSuse Seasonic G 550w Silverstone SG11B 
Other
Raid card 
  hide details  
Reply
P50
(15 items)
 
   
CPUGraphicsRAMHard Drive
Intel Core i7-6700HQ NVIDIA Quadro M1000M 4GB Gskill 32gb 4x8gb DDR4 2300mhz Samsung 850 PRO - 1TB SSD m2 
Hard DriveOptical DriveOSOS
Seagate 2TB w/ 128MB Cache (ST2000LM007) Pioneer External USB-C Blu-Ray Burner Fedora 25 Win 10 LTSB 
MonitorMonitorMonitorPower
15.6" 1920x1080 IPS BenQ GL2460HM 24" LED BenQ GL2460HM 24" LED Lenovo 170w Power adapter 
MouseOther
MX-580 or Razor bluetooth something or other Docking station 40A50230US 
CPUMotherboardRAMHard Drive
i7 3770k BIOSTAR TH67+ 32gb 4x8 Corsair Vengence 1600 1x 256gb m2 
Hard DriveOSPowerCase
6x Seagate 2.5" 3tb > ~8.5tb raid 10 OpenSuse Seasonic G 550w Silverstone SG11B 
Other
Raid card 
  hide details  
Reply
post #7 of 14
Quote:
Originally Posted by Greensystemsgo;12730109 
assuming you only have a single up and down stream, thats 150 each way. if you have dual down, then hypothetically you could have 300, or even quad you could have 600, BUT do those routers do that? are their any g devices on the network because if its only 2.4ghz, then everyone is brought down to the G's level UNLESS its 2.4 and 5ghz - dual channel. So many factors. heres a good comparison.

http://en.wikipedia.org/wiki/IEEE_802.11n-2009#Comparison

Yea but from what i can read from the op hes saying its only showing link speed of 150 when even if its 150 up and down the link should still show 270-300. It could be my card tho is why i can get 270-300 link speed my card has a external ant with 4 connectors.
Edited by Bal3Wolf - 3/14/11 at 2:54pm
SABERWOLF
(18 items)
 
XEON-WOLF
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6800K MSI X99A GAMING PRO CARBON EVGA GTX 1080 FTW Hydro Copper G.SKILL TridentZ Series 
Hard DriveCoolingCoolingCooling
Samsung EVO 850 500 EK-SBAY Dual DDC 3.2 PWM Serial Alphacool NexXxoS ST30 Full Copper Radiator 360 Hardware Labs Black Ice SR2 Multiport Black Car... 
CoolingCoolingOSMonitor
EK-CoolStream RAD XTC 420 koolance 380i Windows 10 Pro ASUS VW246H Black 24" 2ms 
PowerCaseMouseAudio
SeaSonic M12D SS-850 850W  Thermaltake core x71 CM Storm Sentinel Advance II Corsair Void 
CPUMotherboardGraphicsRAM
X5675@4400 1.344 ASUS P6X58D-E XfX RX480 RS F3-12800CL7T-6GBPI 6-7-6-21 1T 
RAMHard DriveHard DriveHard Drive
F3-12800CL9S-4GBRL WDC WD1001FALS-00J7B1 ST31000340AS WDC WD7500AAKS-00RBA0 
Hard DriveOptical DriveCoolingOS
Hitachi HDS723020BLA642 ihas 624-A SilverStone Heligon HE01 windows 10 64 Pro 
MonitorPowerCase
Vizio 42inch lcd tv CORSAIR CMPSU-950TX Modded Rocketfish 
  hide details  
Reply
SABERWOLF
(18 items)
 
XEON-WOLF
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6800K MSI X99A GAMING PRO CARBON EVGA GTX 1080 FTW Hydro Copper G.SKILL TridentZ Series 
Hard DriveCoolingCoolingCooling
Samsung EVO 850 500 EK-SBAY Dual DDC 3.2 PWM Serial Alphacool NexXxoS ST30 Full Copper Radiator 360 Hardware Labs Black Ice SR2 Multiport Black Car... 
CoolingCoolingOSMonitor
EK-CoolStream RAD XTC 420 koolance 380i Windows 10 Pro ASUS VW246H Black 24" 2ms 
PowerCaseMouseAudio
SeaSonic M12D SS-850 850W  Thermaltake core x71 CM Storm Sentinel Advance II Corsair Void 
CPUMotherboardGraphicsRAM
X5675@4400 1.344 ASUS P6X58D-E XfX RX480 RS F3-12800CL7T-6GBPI 6-7-6-21 1T 
RAMHard DriveHard DriveHard Drive
F3-12800CL9S-4GBRL WDC WD1001FALS-00J7B1 ST31000340AS WDC WD7500AAKS-00RBA0 
Hard DriveOptical DriveCoolingOS
Hitachi HDS723020BLA642 ihas 624-A SilverStone Heligon HE01 windows 10 64 Pro 
MonitorPowerCase
Vizio 42inch lcd tv CORSAIR CMPSU-950TX Modded Rocketfish 
  hide details  
Reply
post #8 of 14
Quote:
Originally Posted by Greensystemsgo;12730109 
assuming you only have a single up and down stream, thats 150 each way. if you have dual down, then hypothetically you could have 300, or even quad you could have 600, BUT do those routers do that? are their any g devices on the network because if its only 2.4ghz, then everyone is brought down to the G's level UNLESS its 2.4 and 5ghz - dual channel. So many factors. heres a good comparison.

http://en.wikipedia.org/wiki/IEEE_802.11n-2009#Comparison

The E3000 is a dual channel router, so his 2.4GHZ devices should be connected on a seperate network from his 5GHZ devices.

@op, make sure your 5GHZ is set to 40MHZ wide and play with the wireless channels. For my E3000 to show 300mbs I have to have mine on channel 5.29 I think. Also make sure it is set to N only, not A or mixed. Good luck and let us knwo what you find. I have no issues getting 300mbs with an intel 6200 and a E3000
Maxi
(11 items)
 
  
Reply
Maxi
(11 items)
 
  
Reply
post #9 of 14
Thread Starter 
Quote:
Originally Posted by Bal3Wolf;12731374 
Yea but from what i can read from the op hes saying its only showing link speed of 150 when even if its 150 up and down the link should still show 270-300. It could be my card tho is why i can get 270-300 link speed my card has a external ant with 4 connectors.

yes on my d-link dir 615 router, my dlink dwa-556 pci-e "N" links at 300 at a mere 15 feet away. the e3000 router was placed in the exact same spot and set exactly the same as the dlink. there is minimal interference in the area. so... in theory i should be connecting the 556 adapter at 300 , but is not the case. the e3000 links up at 130. though the laptop thats sitting right next to the router is linking at 144.5. a little better than the dlink router when it connected to it, it was only 130. but thats cause the intell 4965agn card in the laptop can only use 20hz channel width which slows its connect speeds on the dlink for compatibility reasons. the 615 does have 2 external antennas but im not savvy enough to know if external antennas would make that diff even though im getting near 100% signal strength with both
Edited by zenraider - 3/17/11 at 10:06am
the rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
64 x2 am2 4400+ 2.3ghz MSI k94n sli platnium MSI N260GTX core 216 ocv2 crucial lanfest 2gig balistix hybrid 
Hard DriveOptical DriveOSMonitor
seagate sata 3 160g generic dvd XP Pro w/ SP3 Samsung 22" wide 2ms 
KeyboardPowerCaseMouse
Ideazon merc gaming board OCX gameXstream 700 sli Antec 900 g500 Logitech laser 
Mouse Pad
none 
  hide details  
Reply
the rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
64 x2 am2 4400+ 2.3ghz MSI k94n sli platnium MSI N260GTX core 216 ocv2 crucial lanfest 2gig balistix hybrid 
Hard DriveOptical DriveOSMonitor
seagate sata 3 160g generic dvd XP Pro w/ SP3 Samsung 22" wide 2ms 
KeyboardPowerCaseMouse
Ideazon merc gaming board OCX gameXstream 700 sli Antec 900 g500 Logitech laser 
Mouse Pad
none 
  hide details  
Reply
post #10 of 14
Thread Starter 
update:

after performing a hard reset {30/30/30}and then looking into advanced settings i have discovered something interesting. in the e3000 i specifically set all the channel width to 40hz. then did a reboot and rechecked that the setting is 40 and then looked into the admin tab and looked up the wireless status. well apparently the router only wants to xmit at 20hz on the 2.4 and 5ghz , despite the setting at 40 hz might this be a bug in linksys firmware? btw i shut down all systems and devices except for my system with the dwa-556 adapter. i know that that one for sure will use the 40hz channel width. so it appears that maybe my router is faulty ? since it only wants to use 20hz even though 40 is manually set.eek.gif

btw props for all of you that are helping, i am gaining powerful insight into this problem.
Edited by zenraider - 3/17/11 at 10:07am
the rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
64 x2 am2 4400+ 2.3ghz MSI k94n sli platnium MSI N260GTX core 216 ocv2 crucial lanfest 2gig balistix hybrid 
Hard DriveOptical DriveOSMonitor
seagate sata 3 160g generic dvd XP Pro w/ SP3 Samsung 22" wide 2ms 
KeyboardPowerCaseMouse
Ideazon merc gaming board OCX gameXstream 700 sli Antec 900 g500 Logitech laser 
Mouse Pad
none 
  hide details  
Reply
the rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
64 x2 am2 4400+ 2.3ghz MSI k94n sli platnium MSI N260GTX core 216 ocv2 crucial lanfest 2gig balistix hybrid 
Hard DriveOptical DriveOSMonitor
seagate sata 3 160g generic dvd XP Pro w/ SP3 Samsung 22" wide 2ms 
KeyboardPowerCaseMouse
Ideazon merc gaming board OCX gameXstream 700 sli Antec 900 g500 Logitech laser 
Mouse Pad
none 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › linksys e3000 pulling my hair out