post #1 of 1
Thread Starter 
Hi,

I'm not sure if it's possible to do what I'm attempting. I have Dell Perc 6/i hardware raid card running in a poweredge T310, running Ubuntu Linux.

Trying to setup: a RAID 1 with 2 80gb drives.

I formatted and partitioned an 80gb SATA drive on a system with no-raid, just onboard SATA. Added some content to it.

Inserted 80gb disk #1 with my content, and #2 that had no partitions setup. Went to the BIOS, didn't initialize #1 it so it didn't erase the content. I think it tried to rebuild the array, but the data wasn't accessible.

Every time I tried to mount it, it complained that there was a problem with the filesystem, dmesg said "missing journal." So I tried to fsck it, it warned me about the block size being wrong but tried to fix it anyway. That was a total failure.

I deleted the partition; made a new one, and formatted it fresh and everything worked. The RAID 1 setup is working fine but I feel like I'm doing something wrong in regard to migration.

I highly believe it has something to do with the controller's view of the size of the disks, for example, it sees the 80gb disk as (when configured for RAID 1):

Quote:
Disk /dev/sdb: 79.5 GB, 79456894976 bytes
255 heads, 63 sectors/track, 9660 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Now the same drive in a no-raid system:

Quote:
Disk /dev/sdb: 80.0 GB, 80000000000 bytes
255 heads, 63 sectors/track, 9726 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
I may be wrong but I think this difference is what's throwing it off, but I'm not sure how to address it.

Thanks for any help or advice on this in advance.