Overclock.net › Forums › Video Games › PC Gaming › Bulletstorm performance issues
New Posts  All Forums:Forum Nav:

Bulletstorm performance issues

post #1 of 6
Thread Starter 
So, I kinda get a lot of frame drops on a single 5870 @stock clocks running with a dedicated gts250 for physX.
I'm not sure it's me or it's normal, but I would guess these performance drops are related to physX, since my 5870 never gets to 100% load (only up to 90%) and the physX card isn't used in this game.

I guess it could be two things, it's like mirror's edge, that you have to further tweak things to get the game to use the ati+nvidia physX mod or they just advertise the game with physX, when in reality it has none, which means my performance issues are related to something else.

btw, trying to play with everything maxed out @ 1920x1080

according to this: http://www.techspot.com/review/368-b...nce/page5.html
I should be getting at least 75 constant fps
Edited by EduFurtado - 3/15/11 at 10:31am
post #2 of 6
How much of a performance drop and when do you get them??
Money Blackhole
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3750k Asrock Z77 Extreme4 MSI GTX 680 Lightning G.Skill Ripjaws X 8GB 
Hard DriveCoolingOSMonitor
2 x Western Digital 500GB Caviar Black  Noctua NH-D15 Windows 7 64bit ASUS 24" VG248QE 
KeyboardPowerCaseMouse
Steelseries 6Gv2 Corsair HX 850 HAF X  Razer Deathadder / Naga 
Mouse Pad
Razer Goliahtus 
  hide details  
Reply
Money Blackhole
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3750k Asrock Z77 Extreme4 MSI GTX 680 Lightning G.Skill Ripjaws X 8GB 
Hard DriveCoolingOSMonitor
2 x Western Digital 500GB Caviar Black  Noctua NH-D15 Windows 7 64bit ASUS 24" VG248QE 
KeyboardPowerCaseMouse
Steelseries 6Gv2 Corsair HX 850 HAF X  Razer Deathadder / Naga 
Mouse Pad
Razer Goliahtus 
  hide details  
Reply
post #3 of 6
I wouldn't say it's PhysX. The game ran at a constant 30-40 FPS for me, such a horrible port. Good game though, I'll leave it at that.

My specs when I was playing it:

Phenom X3 720 @ 3.2ghz
5850 @ 900/1020
G.Skill DDR2 4GBS 1066
1680x1050
0xaa 16xaf

I read online that those who used a 16:10 resolution monitor had horrid performance, but I've also read even others have horrid performance too.
post #4 of 6
I just upraded to 5870CF a week ago. Before that I was playing bulletstorm with a single 5870. I was having some issues running 8X aa smoothly, but at 4x aa everything was great. What aa are you trying to run at?
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
post #5 of 6
Thread Starter 
Quote:
Originally Posted by Rakhasa View Post
How much of a performance drop and when do you get them??
Quote:
Originally Posted by E-Peen View Post
I wouldn't say it's PhysX. The game ran at a constant 30-40 FPS for me, such a horrible port. Good game though, I'll leave it at that.

My specs when I was playing it:

Phenom X3 720 @ 3.2ghz
5850 @ 900/1020
G.Skill DDR2 4GBS 1066
1680x1050
0xaa 16xaf

I read online that those who used a 16:10 resolution monitor had horrid performance, but I've also read even others have horrid performance too.
Quote:
Originally Posted by strap624 View Post
I just upraded to 5870CF a week ago. Before that I was playing bulletstorm with a single 5870. I was having some issues running 8X aa smoothly, but at 4x aa everything was great. What aa are you trying to run at?
I jsut went through a playing session at constant 60fps (it did drop, but I didn't notice)... before it was going below the 40s or 50s, not sure... what I did was disable AA. I'll try again at 4x AA later.

Really a good game, but yes, poor port. I hate when I need to set my mouse to the lowest DPI settings... it it's fine in game once I do that, but then it's a pain to move around the menus

btw, not just a poor port... A not very well programmed game.. I just had a scripting bug.. nothing serious, but ugly.. lol

as for the aspect ratio, at least to me that makes no sense, but who knows? I'm not a game developer

let's hope that maybe a future update fix these small issues
post #6 of 6
Use a non 16:10 resolution in window mode. Increased my frame insanely and I could play with AAx4.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Bulletstorm performance issues