Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Fedora 14: Jittery/Laggy Mouse
New Posts  All Forums:Forum Nav:

Fedora 14: Jittery/Laggy Mouse

post #1 of 37
Thread Starter 
So I've been running Fedora 14 on a desktop for almost a week now, and I like it a lot. It seems really solid.

But if you guys remember, I said that I've always liked Fedora except for the fact that it ALWAYS has ONE single problem that's a deal breaker. I've found out what it is for version 14...

At random times, the mouse will begin to lag. If I move it at a moderate speed, it's really, really slow. If I move it very quickly, it just stays put. If I move it very slowly, I can get it to go where I want it to, but the cursor still lags to keep up. The ONLY cure is to reboot. Neither logging out nor ctrl + alt + bksp remedy the problem.

I have tried USB and PS/2 mice. The problem affects both.

Any ideas? I really like this distro and would like to keep it, but if this problem persists, I will have no choice but to replace it.

Thanks in advance.
post #2 of 37
disable mouse acceleration in gnome?

have had this happen to me in gnome and kde, i just turn down the acceleration and it stops.

only had to turn it down all the way once, usually keeping at a quarter the way or 2/3 way up (some times matched to sensitivity).

the only other time i had this happen, and this didn't help, i had to reconfigure xorg...but i don't remember what i did, as it was back in 8.04 ubuntu on a laptop with a usb "travel" mouse.

edit:
btw you find mouse controls in gnome in:

system->preferences->mouse

^might be slightly different in fedora...
Bazinga Punk
(12 items)
 
ooh shiny!
(6 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon 3440 AsRock P55 extreme Evga 8800 GT 512 MB Gskill Ripjaws 
Hard DriveCoolingOSMonitor
Western Digital Blue Antec Khuler 620 Ubuntu 11.10 Asus vw264H 
KeyboardPowerCaseMouse
GIGABYTE KM7600 CORSAIR TX 650 Cooler Master 590 GIGABYTE GM-M6800 
CPUMotherboardGraphicsRAM
Intel Core I5 6500 Gigabyte z170xp-SLI Nvidia 970gtx Corsair 16gb ddr4 2666mhz  
Hard DriveOS
250gb Samsung Evo 850 Windows 10 & Ubuntu 15.10 
  hide details  
Reply
Bazinga Punk
(12 items)
 
ooh shiny!
(6 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon 3440 AsRock P55 extreme Evga 8800 GT 512 MB Gskill Ripjaws 
Hard DriveCoolingOSMonitor
Western Digital Blue Antec Khuler 620 Ubuntu 11.10 Asus vw264H 
KeyboardPowerCaseMouse
GIGABYTE KM7600 CORSAIR TX 650 Cooler Master 590 GIGABYTE GM-M6800 
CPUMotherboardGraphicsRAM
Intel Core I5 6500 Gigabyte z170xp-SLI Nvidia 970gtx Corsair 16gb ddr4 2666mhz  
Hard DriveOS
250gb Samsung Evo 850 Windows 10 & Ubuntu 15.10 
  hide details  
Reply
post #3 of 37
Thread Starter 
This only happens sometimes. Would disabling accel help if this only happens on occasion? I'll try it when I get home, though. Thanks.
post #4 of 37
Thread Starter 
By the way, you can't exactly disable the mouse acceleration. You can only turn it down low, and this makes moving the cursor difficult... Also, I'm not sure if this will help (we'll find out, but...) since the problem affects all users on the system, even at the login screen.

Another thing I forgot to add: this problem goes away if Firefox is in the foreground. If the problem starts acting up and I open up Firefox, then the problem stops for the FF window. When I close FF or move the cursor over non-FF area, then the mouse lags again.
post #5 of 37
Quote:
Originally Posted by The Hundred Gunner View Post
By the way, you can't exactly disable the mouse acceleration. You can only turn it down low, and this makes moving the cursor difficult... Also, I'm not sure if this will help (we'll find out, but...) since the problem affects all users on the system, even at the login screen.

Another thing I forgot to add: this problem goes away if Firefox is in the foreground. If the problem starts acting up and I open up Firefox, then the problem stops for the FF window. When I close FF or move the cursor over non-FF area, then the mouse lags again.
thats what i meant, turning it down to its lowest setting by disabled...poor choice of words on my part

mine happens at random. i get use to the unaccelerated cursor, then go into windows or on another computer that has it cranked up, and have no control, get use to it, and then go turn it back up in linux...only to have it happen again...

i don't use firefox, but i think firefox has its own mouse acceleration built in...you can change it in the about:config page...

i guess you could read up on the xorg input devices, and try to tweak /etc/X11/xorg.conf to better tune it to your mouse, as it does a very generic configuration...
Bazinga Punk
(12 items)
 
ooh shiny!
(6 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon 3440 AsRock P55 extreme Evga 8800 GT 512 MB Gskill Ripjaws 
Hard DriveCoolingOSMonitor
Western Digital Blue Antec Khuler 620 Ubuntu 11.10 Asus vw264H 
KeyboardPowerCaseMouse
GIGABYTE KM7600 CORSAIR TX 650 Cooler Master 590 GIGABYTE GM-M6800 
CPUMotherboardGraphicsRAM
Intel Core I5 6500 Gigabyte z170xp-SLI Nvidia 970gtx Corsair 16gb ddr4 2666mhz  
Hard DriveOS
250gb Samsung Evo 850 Windows 10 & Ubuntu 15.10 
  hide details  
Reply
Bazinga Punk
(12 items)
 
ooh shiny!
(6 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon 3440 AsRock P55 extreme Evga 8800 GT 512 MB Gskill Ripjaws 
Hard DriveCoolingOSMonitor
Western Digital Blue Antec Khuler 620 Ubuntu 11.10 Asus vw264H 
KeyboardPowerCaseMouse
GIGABYTE KM7600 CORSAIR TX 650 Cooler Master 590 GIGABYTE GM-M6800 
CPUMotherboardGraphicsRAM
Intel Core I5 6500 Gigabyte z170xp-SLI Nvidia 970gtx Corsair 16gb ddr4 2666mhz  
Hard DriveOS
250gb Samsung Evo 850 Windows 10 & Ubuntu 15.10 
  hide details  
Reply
post #6 of 37
id like to know how to FULLY disable mouse accel

mouse accel is teh devil and should die in a fire...

no accel ftw thats how i hit snap 90 degree shots CONSISTENTLY and snap 180 shots at least half the time hehe <3 quake
Kinda meh now...
(13 items)
 
  
CPUMotherboardGraphicsRAM
PhII 940 BE asus M4N82 Deluxe 2x 8800gts(g92) 2x 1g ocz ddr2 1066 
Hard DriveOptical DriveOSMonitor
/dev/sd[abc] /dev/sr0 WinXP/Linux 22in acer 
PowerCaseMouseMouse Pad
950w rosewill timebomb Antec 900 (2small) Voodoo Deathadder (RED!) X-Trac Pads Ripper XL 
  hide details  
Reply
Kinda meh now...
(13 items)
 
  
CPUMotherboardGraphicsRAM
PhII 940 BE asus M4N82 Deluxe 2x 8800gts(g92) 2x 1g ocz ddr2 1066 
Hard DriveOptical DriveOSMonitor
/dev/sd[abc] /dev/sr0 WinXP/Linux 22in acer 
PowerCaseMouseMouse Pad
950w rosewill timebomb Antec 900 (2small) Voodoo Deathadder (RED!) X-Trac Pads Ripper XL 
  hide details  
Reply
post #7 of 37
Thread Starter 
Sigh, well this is unacceptable... I haven't found a solution, and putting the acceleration down doesn't help. I'm going to see if an upgrade/reinstall fixes it. If not, then back to Debian it will be.

Damn you, Fedora! Why do you always have to haunt me with ONE, SINGLE, deal-breaking flaw?
post #8 of 37
Quote:
Originally Posted by The Hundred Gunner View Post
Sigh, well this is unacceptable... I haven't found a solution, and putting the acceleration down doesn't help. I'm going to see if an upgrade/reinstall fixes it. If not, then back to Debian it will be.

Damn you, Fedora! Why do you always have to haunt me with ONE, SINGLE, deal-breaking flaw?
Never seen exactly this issue, HOWEVER...

I did have a problem with my wireless mouse acting strangely, occasionally failing to work or moving slowly and intermittently. I finally isolated it to RF interference.
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
post #9 of 37
Thread Starter 
Well this is a PS2 ball mouse, but it lags USB mice and PS2 keyboards as well.

Major breakthrough, though! I found one cause of this: whenever a print comes through the network to this computer, begins lagging until I reboot. What about a network print could possibly cause my interface devices to lag like this? I did try rebooting CUPS, but it doesn't fix the issue after the lag begins.
post #10 of 37
What model of printer? Is it connected via USB? If so, try moving it to different USB ports.
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Fedora 14: Jittery/Laggy Mouse