Overclock.net › Forums › Intel › Intel - General › Help, no display, possibly RAM?
New Posts  All Forums:Forum Nav:

Help, no display, possibly RAM?

post #1 of 3
Thread Starter 
I finished off my PC today.
I turned it on and all the fans started spinning, but there was no image.
I looked under the GPU, and the GPU fan wasn't spinning.
I took the GPU back to the store and they tested it, and it works fine.
So I went back home and tried booting up without the GPU.
I instantly noticed the DRAM LED was flashing slowly.
So I got a single DIMM and put it in the first, then second, then third and then the last slot, but none of the combinations worked. I did the same with the second DIMM, and that also failed.

So is the problem the RAM, or possibly the motherboard?
Or could it even be that the 750 Watt PSU is not enough for the GTX 570 and i5 2500K?
If it is the RAM, then I'll RMA it tomorrow.

Thanks,
Jacob Kay

Rep will be given out to helpful posts.
    
CPUMotherboardGraphicsRAM
i5 2500k Asus P8P67 Pro GTX 570 4GB G-Skill 
Hard DriveOSMonitorKeyboard
1TB F3 Windows 7 Ultimate 64bit / Ubuntu Dual Boot BenQ XL2410T 3D Vision Filco 
PowerCaseMouseMouse Pad
Seasonic X-750 HAF X - Nvidia Edition Mionix Naos 5000 Mionix Propus 380 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5 2500k Asus P8P67 Pro GTX 570 4GB G-Skill 
Hard DriveOSMonitorKeyboard
1TB F3 Windows 7 Ultimate 64bit / Ubuntu Dual Boot BenQ XL2410T 3D Vision Filco 
PowerCaseMouseMouse Pad
Seasonic X-750 HAF X - Nvidia Edition Mionix Naos 5000 Mionix Propus 380 
  hide details  
Reply
post #2 of 3
wattage is enough, it sounds like it's the RAM.
The Raven
(16 items)
 
  
CPUMotherboardGraphicsGraphics
i7-2600K Gigabyte GA-P67A-UD5-B3 EVGA GTX 570 SC EVGA GTX 570 SC 
RAMHard DriveOptical DriveCooling
16GB G.SKILL Ripjaws X 1866 Samsung 840 Pro  iHAS324 - Lite-On DVD-RW Noctua NH-D14 
OSMonitorMonitorKeyboard
Windows 10 ASUS VN248 ASUS VN248 Logitech G510 
PowerCaseMouse
XFX 850W BE SILVERSTONE RV02B-EW Logitech MX518 
  hide details  
Reply
The Raven
(16 items)
 
  
CPUMotherboardGraphicsGraphics
i7-2600K Gigabyte GA-P67A-UD5-B3 EVGA GTX 570 SC EVGA GTX 570 SC 
RAMHard DriveOptical DriveCooling
16GB G.SKILL Ripjaws X 1866 Samsung 840 Pro  iHAS324 - Lite-On DVD-RW Noctua NH-D14 
OSMonitorMonitorKeyboard
Windows 10 ASUS VN248 ASUS VN248 Logitech G510 
PowerCaseMouse
XFX 850W BE SILVERSTONE RV02B-EW Logitech MX518 
  hide details  
Reply
post #3 of 3
Thread Starter 
Quote:
Originally Posted by bratas View Post
wattage is enough, it sounds like it's the RAM.
Okay, thanks.
I sent an RMA request now, and I'll be sending the RAM off tomorrow.
Hopefully it arrives soon.
    
CPUMotherboardGraphicsRAM
i5 2500k Asus P8P67 Pro GTX 570 4GB G-Skill 
Hard DriveOSMonitorKeyboard
1TB F3 Windows 7 Ultimate 64bit / Ubuntu Dual Boot BenQ XL2410T 3D Vision Filco 
PowerCaseMouseMouse Pad
Seasonic X-750 HAF X - Nvidia Edition Mionix Naos 5000 Mionix Propus 380 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5 2500k Asus P8P67 Pro GTX 570 4GB G-Skill 
Hard DriveOSMonitorKeyboard
1TB F3 Windows 7 Ultimate 64bit / Ubuntu Dual Boot BenQ XL2410T 3D Vision Filco 
PowerCaseMouseMouse Pad
Seasonic X-750 HAF X - Nvidia Edition Mionix Naos 5000 Mionix Propus 380 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel - General
Overclock.net › Forums › Intel › Intel - General › Help, no display, possibly RAM?