Overclock.net › Forums › Components › Power Supplies › Capacitor just blew - POP - smoke...odds any/everything else went with it?
New Posts  All Forums:Forum Nav:

Capacitor just blew - POP - smoke...odds any/everything else went with it?

post #1 of 4
Thread Starter 
Well I am really pissed off. I got this PSU, since my old silverstone one died. Bought an ABS 850W PSU, and since I had plenty of idle time due to the SB recall, I decided to sleeve the PSU. I finally get all my parts in today, so I assemble the system and power it up, it's doing fine boots to windows etc.

Leave, and come back an hour later and the system is off, with no light on the mobo. I think to myself, that's odd since it's plugged in. Flick the power switch, plug it into a different outlet. no luck. So I blow in the fan and I see a spark, hear a loud pop, and see a puff of smoke.

I look in the PSU now and see a leaking capacitor with a big break in the middle. I'm assuming the capacitor was doin fine till the leaking stuff broke and got separated.

My question is, what are the odds that it took anything else with it? I really don't have the money to replace the motherboard, RAM, etc. Do PSU's have things in place to prevent them from frying other components? Also, checked the warranty status, and it expired 6 days ago. just my luck...

Corsair 650W psu is on the way, so hopefully when I get that all done, it'll boot up without any issues. I just don't have a good feeling...
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
post #2 of 4
I have had two PSUs go on my and only one took a the mobo with it. Its hit or miss.

It sounds like the unit went when the PC was off so thats a plus.
post #3 of 4
its a possibility. Just kinda random.

Ive seen psu's that have died and done nothing to the motherboard and then ive also had it where the psu took my mb with it.

If the system was off you may be in luck but the only way to tell is to get another psu.
Project: Code Red
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 925 @ 3.29ghz Asus 88g M-ATX Asus Radeon 6850 DirectCU 4GB DDR-1333 
Hard DriveOptical DriveOSMonitor
500GB + 320gb Seagate LG DVD-burner Windows 7 Home Premium 64-Bit Acer 22in + Venturer 19in hdtv 
KeyboardPowerCaseMouse
Logitech G15 Corsair 650tx Antec 300 Razor Diamondback 3g 
  hide details  
Reply
Project: Code Red
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 925 @ 3.29ghz Asus 88g M-ATX Asus Radeon 6850 DirectCU 4GB DDR-1333 
Hard DriveOptical DriveOSMonitor
500GB + 320gb Seagate LG DVD-burner Windows 7 Home Premium 64-Bit Acer 22in + Venturer 19in hdtv 
KeyboardPowerCaseMouse
Logitech G15 Corsair 650tx Antec 300 Razor Diamondback 3g 
  hide details  
Reply
post #4 of 4
Thread Starter 
Well thankfully my roommate had an extra PSU and I used it to boot the system. Looks like everything is functioning normally and I got through a windows 7 install.

I just wish I hadn't lost all that time sleeving all the cables... All the materials / time.... And the $105 for a new PSU.


Sent from my iPhone using Tapatalk
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Capacitor just blew - POP - smoke...odds any/everything else went with it?