Overclock.net › Forums › Intel › Intel Motherboards › Those With P67 Sabertooth
New Posts  All Forums:Forum Nav:

Those With P67 Sabertooth

post #1 of 15
Thread Starter 
What Ram are you using? I ask because I am having trouble with my build and the RAM will not POST. I went with this http://www.newegg.com/Product/Produc...82E16820231445 because its states that its specifically designed for SB CPUs and P67 platforms. Well, apparently, it isn't. The list of supported vendors in the manual that came with the board isn't very long, so I figured I'd check their website and they don't list any supported RAM at all. Must be some type of glitch with their site, I dunno.

So anyway, what are you guys using and is it on their list?
Missing Sue
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K 4.8 @ 1.375v 24/7 ASUS P8P67 Deluxe GTX680 16GB (4GB x4) G. Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
C300 128GB, WD 1TB, Samsung F4 2TB LG 10x Blu-ray Burner Windows 7 Home Premium Samsung 27" 
PowerCase
Thermaltake TR2 RX 850W COOLER MASTER HAF X 942 
  hide details  
Reply
Missing Sue
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K 4.8 @ 1.375v 24/7 ASUS P8P67 Deluxe GTX680 16GB (4GB x4) G. Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
C300 128GB, WD 1TB, Samsung F4 2TB LG 10x Blu-ray Burner Windows 7 Home Premium Samsung 27" 
PowerCase
Thermaltake TR2 RX 850W COOLER MASTER HAF X 942 
  hide details  
Reply
post #2 of 15
I have these sticks..
Running 2133 mhz Cas 9..

EDIT:
Have you pressed the Mem Ok button? Are you sure its a RAM issue?
Edited by Capwn - 3/16/11 at 6:33pm
post #3 of 15
Thread Starter 
Quote:
Originally Posted by Capwn View Post
I have these sticks..
Running 2133 mhz Cas 9..

EDIT:
Have you pressed the Mem Ok button? Are you sure its a RAM issue?
Yes, I have pressed the Mem Ok button. I am not sure of anything at this point, but logic tends to say its a memory issue. I tried to power it up and the I watch it go through the tests. The CPU comes on very briefly and then goes out. Next, the memory light comes on and stays red. It won't go any further. I press the Mem ok button and the led starts flashing like its supposed to, but it won't recognize the RAM. Either I have bad RAM, or the Sabertooth won't detect it, IMO. The Ram I have is Gskill but its not listed in the manual under qualified vendors. Other gskill dimms are though. The one I bought sated it was designed for SB CPUs and P67 platforms. I am going to pick up RAM that IS list in the QVL and see what happens. I am not going to get anywhere with what I have.
Missing Sue
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K 4.8 @ 1.375v 24/7 ASUS P8P67 Deluxe GTX680 16GB (4GB x4) G. Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
C300 128GB, WD 1TB, Samsung F4 2TB LG 10x Blu-ray Burner Windows 7 Home Premium Samsung 27" 
PowerCase
Thermaltake TR2 RX 850W COOLER MASTER HAF X 942 
  hide details  
Reply
Missing Sue
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K 4.8 @ 1.375v 24/7 ASUS P8P67 Deluxe GTX680 16GB (4GB x4) G. Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
C300 128GB, WD 1TB, Samsung F4 2TB LG 10x Blu-ray Burner Windows 7 Home Premium Samsung 27" 
PowerCase
Thermaltake TR2 RX 850W COOLER MASTER HAF X 942 
  hide details  
Reply
post #4 of 15
Is 8GB displayed at post?

I have the red set and it works fine. Enable XMP in the bios and see if it works.
If not, try one stick at a time, or clear CMOS and see if it works(this usually fixes the issue).
Lastly, run Memtest to see if you have bad sticks.
Render Bender
(10 items)
 
On The Move
(11 items)
 
 
CPUGraphicsRAMHard Drive
Intel X5690 Xeon (12 Cores @ 3.46) Nvidia Titan Xp 64GB 1333MHz ECC DDR3 Samsung 850 EVO 1TB x2 - RAID 0 
MonitorCaseAudio
Samsung UN40JU6700 40" 4K Curved Apple Mac Pro 2010 Klipsch 2.1 
CPUGraphicsRAMHard Drive
Intel Core 2 Duo Nvidia GeForce 9400M 8GB 1067 MHz DDR3 Toshiba 500GB 
OSMonitorKeyboardCase
Mavericks 10.9 Dell U3011 Rosewill Mech Reds 2010 Unibody 
MouseMouse PadAudio
Logitech G700 Multi-Touch Kilpsch 2.1 
  hide details  
Reply
Render Bender
(10 items)
 
On The Move
(11 items)
 
 
CPUGraphicsRAMHard Drive
Intel X5690 Xeon (12 Cores @ 3.46) Nvidia Titan Xp 64GB 1333MHz ECC DDR3 Samsung 850 EVO 1TB x2 - RAID 0 
MonitorCaseAudio
Samsung UN40JU6700 40" 4K Curved Apple Mac Pro 2010 Klipsch 2.1 
CPUGraphicsRAMHard Drive
Intel Core 2 Duo Nvidia GeForce 9400M 8GB 1067 MHz DDR3 Toshiba 500GB 
OSMonitorKeyboardCase
Mavericks 10.9 Dell U3011 Rosewill Mech Reds 2010 Unibody 
MouseMouse PadAudio
Logitech G700 Multi-Touch Kilpsch 2.1 
  hide details  
Reply
post #5 of 15
There is a memory compatibility list, its under asus website sabertooth page, memory/device support and its a pdf file call QVL list...
Stormy
(13 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core I5-3570K Gigabyte Z77X-D3H Geforce GTX Titan Geforce GTX Titan 
RAMHard DriveHard DriveOS
Samsung 30nm 16GB Corsair Neutron GTX 120GB Plextor M5P 256GB Win 8 Pro 
MonitorKeyboardPowerCase
Dell U3011 Razer Blackwidow Tournament Edition Coolermaster Silent Pro Platinum 1000W Coolermaster Storm Stryker 
Mouse
Razer Taipan 
  hide details  
Reply
Stormy
(13 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core I5-3570K Gigabyte Z77X-D3H Geforce GTX Titan Geforce GTX Titan 
RAMHard DriveHard DriveOS
Samsung 30nm 16GB Corsair Neutron GTX 120GB Plextor M5P 256GB Win 8 Pro 
MonitorKeyboardPowerCase
Dell U3011 Razer Blackwidow Tournament Edition Coolermaster Silent Pro Platinum 1000W Coolermaster Storm Stryker 
Mouse
Razer Taipan 
  hide details  
Reply
post #6 of 15
Thread Starter 
Quote:
Originally Posted by WorldExclusive View Post
Is 8GB displayed at post?

I have the red set and it works fine. Enable XMP in the bios and see if it works.
If not, try one stick at a time, or clear CMOS and see if it works(this usually fixes the issue).
Lastly, run Memtest to see if you have bad sticks.
Can't get that far to try anything you mentioned. I can't get to the BIOS yet. It goes through the start up tests and fails at the RAM and won't go any further.
Missing Sue
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K 4.8 @ 1.375v 24/7 ASUS P8P67 Deluxe GTX680 16GB (4GB x4) G. Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
C300 128GB, WD 1TB, Samsung F4 2TB LG 10x Blu-ray Burner Windows 7 Home Premium Samsung 27" 
PowerCase
Thermaltake TR2 RX 850W COOLER MASTER HAF X 942 
  hide details  
Reply
Missing Sue
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K 4.8 @ 1.375v 24/7 ASUS P8P67 Deluxe GTX680 16GB (4GB x4) G. Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
C300 128GB, WD 1TB, Samsung F4 2TB LG 10x Blu-ray Burner Windows 7 Home Premium Samsung 27" 
PowerCase
Thermaltake TR2 RX 850W COOLER MASTER HAF X 942 
  hide details  
Reply
post #7 of 15
Quote:
Originally Posted by Lou3824 View Post
Can't get that far to try anything you mentioned. I can't get to the BIOS yet. It goes through the start up tests and fails at the RAM and won't go any further.
Clear CMOS. Turn off your PC, wait 30 seconds, unplug your PC from the wall, press the power button on your PC for about 10 seconds to eliminate any remaining charge, the green light on the motherboard should turn off. Move the CMOS clip by the SATA ports over to the next pin for about 10 seconds, then move it back. Reconnect the PSU and power up. Let me know what happens.
Render Bender
(10 items)
 
On The Move
(11 items)
 
 
CPUGraphicsRAMHard Drive
Intel X5690 Xeon (12 Cores @ 3.46) Nvidia Titan Xp 64GB 1333MHz ECC DDR3 Samsung 850 EVO 1TB x2 - RAID 0 
MonitorCaseAudio
Samsung UN40JU6700 40" 4K Curved Apple Mac Pro 2010 Klipsch 2.1 
CPUGraphicsRAMHard Drive
Intel Core 2 Duo Nvidia GeForce 9400M 8GB 1067 MHz DDR3 Toshiba 500GB 
OSMonitorKeyboardCase
Mavericks 10.9 Dell U3011 Rosewill Mech Reds 2010 Unibody 
MouseMouse PadAudio
Logitech G700 Multi-Touch Kilpsch 2.1 
  hide details  
Reply
Render Bender
(10 items)
 
On The Move
(11 items)
 
 
CPUGraphicsRAMHard Drive
Intel X5690 Xeon (12 Cores @ 3.46) Nvidia Titan Xp 64GB 1333MHz ECC DDR3 Samsung 850 EVO 1TB x2 - RAID 0 
MonitorCaseAudio
Samsung UN40JU6700 40" 4K Curved Apple Mac Pro 2010 Klipsch 2.1 
CPUGraphicsRAMHard Drive
Intel Core 2 Duo Nvidia GeForce 9400M 8GB 1067 MHz DDR3 Toshiba 500GB 
OSMonitorKeyboardCase
Mavericks 10.9 Dell U3011 Rosewill Mech Reds 2010 Unibody 
MouseMouse PadAudio
Logitech G700 Multi-Touch Kilpsch 2.1 
  hide details  
Reply
post #8 of 15
Thread Starter 
Quote:
Originally Posted by WorldExclusive View Post
Clear CMOS. Turn off your PC, wait 30 seconds, unplug your PC from the wall, press the power button on your PC for about 10 seconds to eliminate any remaining charge, the green light on the motherboard should turn off. Move the CMOS clip by the SATA ports over to the next pin for about 10 seconds, then move it back. Reconnect the PSU and power up. Let me know what happens.
Done. I did exactly as you said. I still have the exact same problem. The red light came on when I powered up. I pressed the MEM OK button and it went through the cycles of blinking at different speeds until it finally came back on as a constant red light.
Missing Sue
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K 4.8 @ 1.375v 24/7 ASUS P8P67 Deluxe GTX680 16GB (4GB x4) G. Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
C300 128GB, WD 1TB, Samsung F4 2TB LG 10x Blu-ray Burner Windows 7 Home Premium Samsung 27" 
PowerCase
Thermaltake TR2 RX 850W COOLER MASTER HAF X 942 
  hide details  
Reply
Missing Sue
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K 4.8 @ 1.375v 24/7 ASUS P8P67 Deluxe GTX680 16GB (4GB x4) G. Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
C300 128GB, WD 1TB, Samsung F4 2TB LG 10x Blu-ray Burner Windows 7 Home Premium Samsung 27" 
PowerCase
Thermaltake TR2 RX 850W COOLER MASTER HAF X 942 
  hide details  
Reply
post #9 of 15
Thread Starter 
Quote:
Originally Posted by Capwn View Post
I have these sticks..
Running 2133 mhz Cas 9..

EDIT:
Have you pressed the Mem Ok button? Are you sure its a RAM issue?
Those sticks are in the QVL. I am guessing its my fault for trusting the words written on Newegg instead of checking the QVL with Asus first. My sticks say they will work on a P67, but apparently not with my board.
Missing Sue
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K 4.8 @ 1.375v 24/7 ASUS P8P67 Deluxe GTX680 16GB (4GB x4) G. Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
C300 128GB, WD 1TB, Samsung F4 2TB LG 10x Blu-ray Burner Windows 7 Home Premium Samsung 27" 
PowerCase
Thermaltake TR2 RX 850W COOLER MASTER HAF X 942 
  hide details  
Reply
Missing Sue
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K 4.8 @ 1.375v 24/7 ASUS P8P67 Deluxe GTX680 16GB (4GB x4) G. Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
C300 128GB, WD 1TB, Samsung F4 2TB LG 10x Blu-ray Burner Windows 7 Home Premium Samsung 27" 
PowerCase
Thermaltake TR2 RX 850W COOLER MASTER HAF X 942 
  hide details  
Reply
post #10 of 15
Are the sticks in slot in the light brown slots? They shouldn't be in the dark brown slots.

Don't worry about the MemOK button. Try one stick at a time, if neither works, then it could be the sticks. One last try would be to remove the CMOS battery from the mother board and then replace it after 30 seconds, you'll have to remove the cover off the board to access it. If it still doesn't work. RMA/exchange the sticks.
Edited by WorldExclusive - 3/16/11 at 8:21pm
Render Bender
(10 items)
 
On The Move
(11 items)
 
 
CPUGraphicsRAMHard Drive
Intel X5690 Xeon (12 Cores @ 3.46) Nvidia Titan Xp 64GB 1333MHz ECC DDR3 Samsung 850 EVO 1TB x2 - RAID 0 
MonitorCaseAudio
Samsung UN40JU6700 40" 4K Curved Apple Mac Pro 2010 Klipsch 2.1 
CPUGraphicsRAMHard Drive
Intel Core 2 Duo Nvidia GeForce 9400M 8GB 1067 MHz DDR3 Toshiba 500GB 
OSMonitorKeyboardCase
Mavericks 10.9 Dell U3011 Rosewill Mech Reds 2010 Unibody 
MouseMouse PadAudio
Logitech G700 Multi-Touch Kilpsch 2.1 
  hide details  
Reply
Render Bender
(10 items)
 
On The Move
(11 items)
 
 
CPUGraphicsRAMHard Drive
Intel X5690 Xeon (12 Cores @ 3.46) Nvidia Titan Xp 64GB 1333MHz ECC DDR3 Samsung 850 EVO 1TB x2 - RAID 0 
MonitorCaseAudio
Samsung UN40JU6700 40" 4K Curved Apple Mac Pro 2010 Klipsch 2.1 
CPUGraphicsRAMHard Drive
Intel Core 2 Duo Nvidia GeForce 9400M 8GB 1067 MHz DDR3 Toshiba 500GB 
OSMonitorKeyboardCase
Mavericks 10.9 Dell U3011 Rosewill Mech Reds 2010 Unibody 
MouseMouse PadAudio
Logitech G700 Multi-Touch Kilpsch 2.1 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › Those With P67 Sabertooth