Overclock.net › Forums › Graphics Cards › AMD/ATI › Crossfire 5770's - Problem
New Posts  All Forums:Forum Nav:

Crossfire 5770's - Problem

post #1 of 11
Thread Starter 
Hello everyone! It's been a while since i've posted here, however, i've built my computer, and it's treating me nicely

I'm running 2 Sapphire Vapor-X's (5770's), everything else is in the sig.

Well, up until now that is. I haven't been using it much due to school - however, i've recently bought Rift, and it's all i've been doing lol. After a few days, it came to my attention that my framerate is definitely not what it should be with 2 1GB cards, so I started checking everything out.

Upon opening GPU-Z, it came to my attention that only one card was working. I went to the Catalyst Control Center, and nothing crossfire related was showing. MSI Afterburner confirms this with showing the temp of only 1 card. So, after a fair-amount of tripping out, i decided to try both cards on their own. I did, and each worked fine alone. When I put the two together, and pop in the Crossfire bridge, close everything up, and turn it on - my screen doesn't register any hint of a signal from the PC - the screen goes to it's idle standby mode, while the computer is still roaring to its full capacity.

I can't check BIOS, i can't check anything with both cards, there is just no signal annywheereee! I tried using the HDMI port of the second card, but still no luck.

So why is it that they're fine alone, but ****ty together? This was working just 2 months ago - both temps were showing, both GPU usages

Any suggestions?
If you need any more information, please let me know, I'd really like to solve this problem

Thank you for your time!
Ordenador mk. 3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k ASUS Sabertooth Z87 Twin Frozr GTX 770 G.SKILL 16GB (2x8GB) 
Hard DriveCoolingOSMonitor
Samsung 840 PRO (256GB) + WD Black 1TB + 1TB Corsair H80i Windows 7 64-bit Asus 27" 1080p + Asus 23" + Asus 23" 
KeyboardPowerCase
Corsair K70 Corsair HX 750w HAF 932 
  hide details  
Reply
Ordenador mk. 3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k ASUS Sabertooth Z87 Twin Frozr GTX 770 G.SKILL 16GB (2x8GB) 
Hard DriveCoolingOSMonitor
Samsung 840 PRO (256GB) + WD Black 1TB + 1TB Corsair H80i Windows 7 64-bit Asus 27" 1080p + Asus 23" + Asus 23" 
KeyboardPowerCase
Corsair K70 Corsair HX 750w HAF 932 
  hide details  
Reply
post #2 of 11
I've heard talk that RIFT doesn't utilise crossfire technology so yeah .
Also you ARE using only 1 cable to connect to one monitor right?
If I were you I'd try to use a different crossfire bridge and update the drivers but even I doubt that will resolve this problem.
Rex Machina
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-2500K @4.39GHz ASRock P67 Extreme4 XFX Radeon HD 6870 G.SKILL Ripjaws 8GB DDR3 1333 Mhz 
Hard DriveHard DriveOptical DriveCooling
Samsung 830 128GB SAMSUNG Spinpoint F3 1TB LG DVD±RW SuperMulti Drive Black Noctua NH-D14 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit LG E2050T-SN 20" 1600x900 Daskeyboard Ultimate Silent NZXT HALE 90 HALE90-650-M 650W 
CaseMouseMouse PadAudio
NZXT Phantom White Logitech G9x from staples, with wrist rest :D Klipsch Promedia 2.1 
  hide details  
Reply
Rex Machina
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-2500K @4.39GHz ASRock P67 Extreme4 XFX Radeon HD 6870 G.SKILL Ripjaws 8GB DDR3 1333 Mhz 
Hard DriveHard DriveOptical DriveCooling
Samsung 830 128GB SAMSUNG Spinpoint F3 1TB LG DVD±RW SuperMulti Drive Black Noctua NH-D14 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit LG E2050T-SN 20" 1600x900 Daskeyboard Ultimate Silent NZXT HALE 90 HALE90-650-M 650W 
CaseMouseMouse PadAudio
NZXT Phantom White Logitech G9x from staples, with wrist rest :D Klipsch Promedia 2.1 
  hide details  
Reply
post #3 of 11
Have you tried using different display inputs? If not, try doing a driver reinstall. Also, Rift has poor Crossfire support. http://forums.amd.com/game/messagevi...hreadid=147138
The Dude Abides
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon II X4 620 @ 3.38 Ghz 1.360 vCore ASUS M3N72-D nForce 750a GTX 460 HAWK 930/1860/2200 @ 1.087v (+ 30 AUXv) Kingston DDR2 8500 4GB (2x 2GB) 5-5-5-18-2T 
Hard DriveOptical DriveOSMonitor
2x Barracuda 7200.12 1TB RAID 0 ASUS DRW-B1ST Windows 7 Ultimate 64 Bit LG W2040T 1600 x 900 
KeyboardPowerCaseMouse
Logitech K120 Corsair AX750 Corsair Obsidian 700D + 800D Side Panel Microsoft Optical/MX518 
Mouse Pad
Staples Brand $4.99 
  hide details  
Reply
The Dude Abides
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon II X4 620 @ 3.38 Ghz 1.360 vCore ASUS M3N72-D nForce 750a GTX 460 HAWK 930/1860/2200 @ 1.087v (+ 30 AUXv) Kingston DDR2 8500 4GB (2x 2GB) 5-5-5-18-2T 
Hard DriveOptical DriveOSMonitor
2x Barracuda 7200.12 1TB RAID 0 ASUS DRW-B1ST Windows 7 Ultimate 64 Bit LG W2040T 1600 x 900 
KeyboardPowerCaseMouse
Logitech K120 Corsair AX750 Corsair Obsidian 700D + 800D Side Panel Microsoft Optical/MX518 
Mouse Pad
Staples Brand $4.99 
  hide details  
Reply
post #4 of 11
Thread Starter 
Regardless of RIFT, the two-cards won't work together now, which is absolutely mind boggling, cause I turned it on in the morning, and it booted up just fine, sent it's little signal through to the screen.

After trying both individually, and then together, my screen won't boot up.

Gonna try suggestions and get back to you guys. Haven't played around much with drivers, as 10.6 were ****ty, and 10.7 was fine for me, didn't want to shoot my self in the foot - ATI's known for the botchy drivers.
Ordenador mk. 3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k ASUS Sabertooth Z87 Twin Frozr GTX 770 G.SKILL 16GB (2x8GB) 
Hard DriveCoolingOSMonitor
Samsung 840 PRO (256GB) + WD Black 1TB + 1TB Corsair H80i Windows 7 64-bit Asus 27" 1080p + Asus 23" + Asus 23" 
KeyboardPowerCase
Corsair K70 Corsair HX 750w HAF 932 
  hide details  
Reply
Ordenador mk. 3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k ASUS Sabertooth Z87 Twin Frozr GTX 770 G.SKILL 16GB (2x8GB) 
Hard DriveCoolingOSMonitor
Samsung 840 PRO (256GB) + WD Black 1TB + 1TB Corsair H80i Windows 7 64-bit Asus 27" 1080p + Asus 23" + Asus 23" 
KeyboardPowerCase
Corsair K70 Corsair HX 750w HAF 932 
  hide details  
Reply
post #5 of 11
Thread Starter 
Quote:
Originally Posted by shuojinz View Post
Also you ARE using only 1 cable to connect to one monitor right?
Yep. Also, been looking for my other crossfire bridge - it's in my motherboard case - now, to find that somewhere in this mess.
Ordenador mk. 3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k ASUS Sabertooth Z87 Twin Frozr GTX 770 G.SKILL 16GB (2x8GB) 
Hard DriveCoolingOSMonitor
Samsung 840 PRO (256GB) + WD Black 1TB + 1TB Corsair H80i Windows 7 64-bit Asus 27" 1080p + Asus 23" + Asus 23" 
KeyboardPowerCase
Corsair K70 Corsair HX 750w HAF 932 
  hide details  
Reply
Ordenador mk. 3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k ASUS Sabertooth Z87 Twin Frozr GTX 770 G.SKILL 16GB (2x8GB) 
Hard DriveCoolingOSMonitor
Samsung 840 PRO (256GB) + WD Black 1TB + 1TB Corsair H80i Windows 7 64-bit Asus 27" 1080p + Asus 23" + Asus 23" 
KeyboardPowerCase
Corsair K70 Corsair HX 750w HAF 932 
  hide details  
Reply
post #6 of 11
Quote:
Originally Posted by Oxid View Post
Yep. Also, been looking for my other crossfire bridge - it's in my motherboard case - now, to find that somewhere in this mess.
Good to know, I just wanted to make sure because some users do silly things they're not suppose to .
Also I was also thinking of maybe updating your BIOS as that may be a factor but also unlikely.
Rex Machina
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-2500K @4.39GHz ASRock P67 Extreme4 XFX Radeon HD 6870 G.SKILL Ripjaws 8GB DDR3 1333 Mhz 
Hard DriveHard DriveOptical DriveCooling
Samsung 830 128GB SAMSUNG Spinpoint F3 1TB LG DVD±RW SuperMulti Drive Black Noctua NH-D14 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit LG E2050T-SN 20" 1600x900 Daskeyboard Ultimate Silent NZXT HALE 90 HALE90-650-M 650W 
CaseMouseMouse PadAudio
NZXT Phantom White Logitech G9x from staples, with wrist rest :D Klipsch Promedia 2.1 
  hide details  
Reply
Rex Machina
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-2500K @4.39GHz ASRock P67 Extreme4 XFX Radeon HD 6870 G.SKILL Ripjaws 8GB DDR3 1333 Mhz 
Hard DriveHard DriveOptical DriveCooling
Samsung 830 128GB SAMSUNG Spinpoint F3 1TB LG DVD±RW SuperMulti Drive Black Noctua NH-D14 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit LG E2050T-SN 20" 1600x900 Daskeyboard Ultimate Silent NZXT HALE 90 HALE90-650-M 650W 
CaseMouseMouse PadAudio
NZXT Phantom White Logitech G9x from staples, with wrist rest :D Klipsch Promedia 2.1 
  hide details  
Reply
post #7 of 11
Quote:
Originally Posted by Oxid View Post
Regardless of RIFT, the two-cards won't work together now, which is absolutely mind boggling, cause I turned it on in the morning, and it booted up just fine, sent it's little signal through to the screen.

After trying both individually, and then together, my screen won't boot up.

Gonna try suggestions and get back to you guys. Haven't played around much with drivers, as 10.6 were ****ty, and 10.7 was fine for me, didn't want to shoot my self in the foot - ATI's known for the botchy drivers.
11.4 preview has been great for most people. Make sure you click on custom install and check the Catalyst Application Profiles. http://support.amd.com/us/kbarticles...lypreview.aspx
post #8 of 11
Thread Starter 
Quick update to the problem! Went to the store today to help my brother assemble his computer, and I ended up walking out with a 6950 - such a beautiful card! Outta the box, it had unbelievable performance!
Ordenador mk. 3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k ASUS Sabertooth Z87 Twin Frozr GTX 770 G.SKILL 16GB (2x8GB) 
Hard DriveCoolingOSMonitor
Samsung 840 PRO (256GB) + WD Black 1TB + 1TB Corsair H80i Windows 7 64-bit Asus 27" 1080p + Asus 23" + Asus 23" 
KeyboardPowerCase
Corsair K70 Corsair HX 750w HAF 932 
  hide details  
Reply
Ordenador mk. 3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k ASUS Sabertooth Z87 Twin Frozr GTX 770 G.SKILL 16GB (2x8GB) 
Hard DriveCoolingOSMonitor
Samsung 840 PRO (256GB) + WD Black 1TB + 1TB Corsair H80i Windows 7 64-bit Asus 27" 1080p + Asus 23" + Asus 23" 
KeyboardPowerCase
Corsair K70 Corsair HX 750w HAF 932 
  hide details  
Reply
post #9 of 11
Quote:
Originally Posted by Oxid View Post
Quick update to the problem! Went to the store today to help my brother assemble his computer, and I ended up walking out with a 6950 - such a beautiful card! Outta the box, it had unbelievable performance!
Congratulations!
So problem solved?
Now you're going to sell your old cards?
Rex Machina
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-2500K @4.39GHz ASRock P67 Extreme4 XFX Radeon HD 6870 G.SKILL Ripjaws 8GB DDR3 1333 Mhz 
Hard DriveHard DriveOptical DriveCooling
Samsung 830 128GB SAMSUNG Spinpoint F3 1TB LG DVD±RW SuperMulti Drive Black Noctua NH-D14 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit LG E2050T-SN 20" 1600x900 Daskeyboard Ultimate Silent NZXT HALE 90 HALE90-650-M 650W 
CaseMouseMouse PadAudio
NZXT Phantom White Logitech G9x from staples, with wrist rest :D Klipsch Promedia 2.1 
  hide details  
Reply
Rex Machina
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-2500K @4.39GHz ASRock P67 Extreme4 XFX Radeon HD 6870 G.SKILL Ripjaws 8GB DDR3 1333 Mhz 
Hard DriveHard DriveOptical DriveCooling
Samsung 830 128GB SAMSUNG Spinpoint F3 1TB LG DVD±RW SuperMulti Drive Black Noctua NH-D14 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit LG E2050T-SN 20" 1600x900 Daskeyboard Ultimate Silent NZXT HALE 90 HALE90-650-M 650W 
CaseMouseMouse PadAudio
NZXT Phantom White Logitech G9x from staples, with wrist rest :D Klipsch Promedia 2.1 
  hide details  
Reply
post #10 of 11
Thread Starter 
Quote:
Originally Posted by shuojinz View Post
Congratulations!
So problem solved?
Now you're going to sell your old cards?
Yeah, I got both cards to work, (crossfire bridge was pooped out), and gave em to my brother for $150.

Could not want much more from a card. I don't think the $70 difference was worth the 6970 - apparently, I can flash the '50 to a '70, I'm gonna look into that
Ordenador mk. 3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k ASUS Sabertooth Z87 Twin Frozr GTX 770 G.SKILL 16GB (2x8GB) 
Hard DriveCoolingOSMonitor
Samsung 840 PRO (256GB) + WD Black 1TB + 1TB Corsair H80i Windows 7 64-bit Asus 27" 1080p + Asus 23" + Asus 23" 
KeyboardPowerCase
Corsair K70 Corsair HX 750w HAF 932 
  hide details  
Reply
Ordenador mk. 3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k ASUS Sabertooth Z87 Twin Frozr GTX 770 G.SKILL 16GB (2x8GB) 
Hard DriveCoolingOSMonitor
Samsung 840 PRO (256GB) + WD Black 1TB + 1TB Corsair H80i Windows 7 64-bit Asus 27" 1080p + Asus 23" + Asus 23" 
KeyboardPowerCase
Corsair K70 Corsair HX 750w HAF 932 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Crossfire 5770's - Problem