Overclock.net › Forums › Components › Mice › MX Revolution lagging
New Posts  All Forums:Forum Nav:

MX Revolution lagging

post #1 of 5
Thread Starter 
Hi,

my Revolution started to frustrate me with his lagging. I'm talking about cursor lagging, stopping for 3-4 sec and so on. I've tried a new setpoint, I've tired without it, but not of this helped. What can it be?? Is there a softwere problem or hardware (receiver, mouse?)

Thanks for helping
White Spirit
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 760 @ 4.53GHz ASUS P7P55D-Pro Gigabyte 6870 Crossfire 4GB G-Skill 1333 Ripjaws CL7 
Hard DriveOSMonitorKeyboard
Samsung 200+500+500 Win7 64 bit Ultimate Samsung 2032BW Logitech G11 
PowerCaseMouseMouse Pad
Corsair 520W Chieftech Dragon modded Logitech MX Revolution Razer Sphex 
  hide details  
Reply
White Spirit
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 760 @ 4.53GHz ASUS P7P55D-Pro Gigabyte 6870 Crossfire 4GB G-Skill 1333 Ripjaws CL7 
Hard DriveOSMonitorKeyboard
Samsung 200+500+500 Win7 64 bit Ultimate Samsung 2032BW Logitech G11 
PowerCaseMouseMouse Pad
Corsair 520W Chieftech Dragon modded Logitech MX Revolution Razer Sphex 
  hide details  
Reply
post #2 of 5
Plug in another mouse and see if it happens. If it does it's software related. If it doesn't, try uninstalling and reinstalling. If no success, try contacting logitech. Just be prepared that if they do replace it, it may be with the newer performance model.
post #3 of 5
Thread Starter 
Hi, I'm from Croatia , here we don't have any logitech dealer, and the warranty is gone. I've tried in another computer and somehow it works. I have a wireless router near the mouse , can it be that he produces the interference??
White Spirit
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 760 @ 4.53GHz ASUS P7P55D-Pro Gigabyte 6870 Crossfire 4GB G-Skill 1333 Ripjaws CL7 
Hard DriveOSMonitorKeyboard
Samsung 200+500+500 Win7 64 bit Ultimate Samsung 2032BW Logitech G11 
PowerCaseMouseMouse Pad
Corsair 520W Chieftech Dragon modded Logitech MX Revolution Razer Sphex 
  hide details  
Reply
White Spirit
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 760 @ 4.53GHz ASUS P7P55D-Pro Gigabyte 6870 Crossfire 4GB G-Skill 1333 Ripjaws CL7 
Hard DriveOSMonitorKeyboard
Samsung 200+500+500 Win7 64 bit Ultimate Samsung 2032BW Logitech G11 
PowerCaseMouseMouse Pad
Corsair 520W Chieftech Dragon modded Logitech MX Revolution Razer Sphex 
  hide details  
Reply
post #4 of 5
Thread Starter 
maybe the problem is solved, I've blocked the WLAN and for now the mouse is feeling ok and natural, so maybe there was some issue between the WLAN and the mouse receiver
White Spirit
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 760 @ 4.53GHz ASUS P7P55D-Pro Gigabyte 6870 Crossfire 4GB G-Skill 1333 Ripjaws CL7 
Hard DriveOSMonitorKeyboard
Samsung 200+500+500 Win7 64 bit Ultimate Samsung 2032BW Logitech G11 
PowerCaseMouseMouse Pad
Corsair 520W Chieftech Dragon modded Logitech MX Revolution Razer Sphex 
  hide details  
Reply
White Spirit
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 760 @ 4.53GHz ASUS P7P55D-Pro Gigabyte 6870 Crossfire 4GB G-Skill 1333 Ripjaws CL7 
Hard DriveOSMonitorKeyboard
Samsung 200+500+500 Win7 64 bit Ultimate Samsung 2032BW Logitech G11 
PowerCaseMouseMouse Pad
Corsair 520W Chieftech Dragon modded Logitech MX Revolution Razer Sphex 
  hide details  
Reply
post #5 of 5
Its a possibility that the wireless signal is interfering. If you can, try to change the radio signal of the wireless router. Channel 11, if I remember correctly, is the most often used channel. Try other channels to see if this fixes the issue.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › MX Revolution lagging