Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Samba Not working on openSUSE
New Posts  All Forums:Forum Nav:

Samba Not working on openSUSE

post #1 of 19
Thread Starter 
Not too happy here ... It's a 5 minute job on Debian but Intel doesn't support Deiban based distros on our raid card.

I'm trying to get Samba to work on opensuse. Apparently it's included by default.

There is NOTHING saying why it doesn't work.

When I type in \\ipaddress into windows explorer, I get that it can't be accessed ...

Checking on the GUI configuration utility for Samba that is in openSUSE, it shows that I have file shares configured.

I just can't access it over the network?

Any help
    
CPUMotherboardGraphicsRAM
E6300 @ 2.3 GHz Foxconn Intel x3100 4.5 Rendition 
Hard DriveOptical DriveOSMonitor
160+500 DVDRW Server 08 x64 Princeton 17'' square 
KeyboardPowerCaseMouse
Unicomp Germanic Model M 250W Dell Vostro 200 Gateway Ball Mouse 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
E6300 @ 2.3 GHz Foxconn Intel x3100 4.5 Rendition 
Hard DriveOptical DriveOSMonitor
160+500 DVDRW Server 08 x64 Princeton 17'' square 
KeyboardPowerCaseMouse
Unicomp Germanic Model M 250W Dell Vostro 200 Gateway Ball Mouse 
  hide details  
Reply
post #2 of 19
What do you have in your /etc/samba/smb.conf file? Dont include anything that is commented out.
Scream Machine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770K Gigabyte Z87X-UD3H EVGA GTX 780 16GB DDR3 
Hard DriveCoolingOSMonitor
256GB Samsung 840 Pro Kraken X60 Windows 7 Shimian 2560x1440 
Case
Phantom 630 
  hide details  
Reply
Scream Machine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770K Gigabyte Z87X-UD3H EVGA GTX 780 16GB DDR3 
Hard DriveCoolingOSMonitor
256GB Samsung 840 Pro Kraken X60 Windows 7 Shimian 2560x1440 
Case
Phantom 630 
  hide details  
Reply
post #3 of 19
Thread Starter 
Would that cuase

"The network path was not found"


Pretty sure the problem is something with SUSE , NOT samba configuration ...
    
CPUMotherboardGraphicsRAM
E6300 @ 2.3 GHz Foxconn Intel x3100 4.5 Rendition 
Hard DriveOptical DriveOSMonitor
160+500 DVDRW Server 08 x64 Princeton 17'' square 
KeyboardPowerCaseMouse
Unicomp Germanic Model M 250W Dell Vostro 200 Gateway Ball Mouse 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
E6300 @ 2.3 GHz Foxconn Intel x3100 4.5 Rendition 
Hard DriveOptical DriveOSMonitor
160+500 DVDRW Server 08 x64 Princeton 17'' square 
KeyboardPowerCaseMouse
Unicomp Germanic Model M 250W Dell Vostro 200 Gateway Ball Mouse 
  hide details  
Reply
post #4 of 19
Not sure how suse would be the issue if samba is configured correctly, unless the suse machine's networking is not working. Is the suse machine reachable from the other machines? Try pinging it from a windows computer.
Scream Machine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770K Gigabyte Z87X-UD3H EVGA GTX 780 16GB DDR3 
Hard DriveCoolingOSMonitor
256GB Samsung 840 Pro Kraken X60 Windows 7 Shimian 2560x1440 
Case
Phantom 630 
  hide details  
Reply
Scream Machine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770K Gigabyte Z87X-UD3H EVGA GTX 780 16GB DDR3 
Hard DriveCoolingOSMonitor
256GB Samsung 840 Pro Kraken X60 Windows 7 Shimian 2560x1440 
Case
Phantom 630 
  hide details  
Reply
post #5 of 19
Thread Starter 
I can ping the server from another computer on the network. It can ping other computers on the network.

Samba isn't able to start from what I can gather.

runninga cat of /var/log/samba/swat
Code:
  NOTE: Service collections is flagged unavailable.
[2011/03/18 16:04:14.312258,  0] param/loadparm.c:6883(service_ok)
  WARNING: No path in service collections - making it unavailable!
[2011/03/18 16:04:14.312457,  1] param/loadparm.c:6890(service_ok)
  NOTE: Service collections is flagged unavailable.
[2011/03/18 16:04:14.337298,  0] param/loadparm.c:6883(service_ok)
  WARNING: No path in service collections - making it unavailable!
[2011/03/18 16:04:14.337400,  1] param/loadparm.c:6890(service_ok)
  NOTE: Service collections is flagged unavailable.
[2011/03/18 16:04:21.165325,  0] param/loadparm.c:6883(service_ok)
  WARNING: No path in service collections - making it unavailable!
[2011/03/18 16:04:21.165529,  1] param/loadparm.c:6890(service_ok)
  NOTE: Service collections is flagged unavailable.
[2011/03/18 16:04:49.119720,  0] param/loadparm.c:6883(service_ok)
  WARNING: No path in service collections - making it unavailable!
[2011/03/18 16:04:49.119959,  1] param/loadparm.c:6890(service_ok)
  NOTE: Service collections is flagged unavailable.
[2011/03/18 16:04:50.366695,  0] param/loadparm.c:6883(service_ok)
  WARNING: No path in service collections - making it unavailable!
[2011/03/18 16:04:50.366805,  1] param/loadparm.c:6890(service_ok)
  NOTE: Service collections is flagged unavailable.
[2011/03/18 16:04:50.943547,  0] locking/brlock.c:289(brl_init)
  Failed to open byte range locking database /var/lib/samba/brlock.tdb
[2011/03/18 16:04:50.943658,  0] locking/locking.c:434(locking_init_internal)
  ERROR: Failed to initialise locking database
[2011/03/18 16:04:53.770504,  0] param/loadparm.c:6883(service_ok)
  WARNING: No path in service collections - making it unavailable!
[2011/03/18 16:04:53.770615,  1] param/loadparm.c:6890(service_ok)
  NOTE: Service collections is flagged unavailable.
[2011/03/18 16:04:57.331637,  0] locking/brlock.c:289(brl_init)
  Failed to open byte range locking database /var/lib/samba/brlock.tdb
[2011/03/18 16:04:57.331698,  0] locking/locking.c:434(locking_init_internal)
  ERROR: Failed to initialise locking database
[2011/03/18 16:05:01.510778,  0] param/loadparm.c:6883(service_ok)
  WARNING: No path in service collections - making it unavailable!
[2011/03/18 16:05:01.511016,  1] param/loadparm.c:6890(service_ok)
  NOTE: Service collections is flagged unavailable.
[2011/03/18 16:05:05.070404,  0] locking/brlock.c:289(brl_init)
  Failed to open byte range locking database /var/lib/samba/brlock.tdb
[2011/03/18 16:05:05.070509,  0] locking/locking.c:434(locking_init_internal)
  ERROR: Failed to initialise locking database


Running a cat of /var/lob/samba/smbd
Code:
  smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2010
[2011/03/18 16:05:01.524199,  0] param/loadparm.c:6883(service_ok)
  WARNING: No path in service collections - making it unavailable!
[2011/03/18 16:05:01.524271,  1] param/loadparm.c:6890(service_ok)
  NOTE: Service collections is flagged unavailable.
[2011/03/18 16:05:01.528269,  0] passdb/secrets.c:73(secrets_init)
  Failed to open /etc/samba/secrets.tdb
[2011/03/18 16:05:01.528723,  0] passdb/secrets.c:73(secrets_init)
  Failed to open /etc/samba/secrets.tdb
[2011/03/18 16:05:01.528774,  0] smbd/server.c:1234(main)
  ERROR: smbd can not open secrets.tdb
[2011/03/18 16:29:07,  0] lib/fault.c:250(dump_core_setup)
  Unable to setup corepath for smbd: Permission denied
[2011/03/18 16:29:08,  0] smbd/server.c:1134(main)
  smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2010
[2011/03/18 16:29:08.015503,  0] passdb/secrets.c:73(secrets_init)
  Failed to open /etc/samba/secrets.tdb
[2011/03/18 16:29:08.016027,  0] passdb/secrets.c:73(secrets_init)
  Failed to open /etc/samba/secrets.tdb
[2011/03/18 16:29:08.016085,  0] smbd/server.c:1234(main)
  ERROR: smbd can not open secrets.tdb




Running a cat of /var/log/samba/nmbd.
Code:
  write_browse_list: Can't open file /var/lib/samba/browse.dat.. Error was Permission denied
[2011/03/18 16:23:11.367978,  0] nmbd/nmbd_serverlistdb.c:343(write_browse_list)
  write_browse_list: Can't open file /var/lib/samba/browse.dat.. Error was Permission denied
[2011/03/18 16:23:15.868171,  0] nmbd/nmbd_serverlistdb.c:343(write_browse_list)
  write_browse_list: Can't open file /var/lib/samba/browse.dat.. Error was Permission denied
[2011/03/18 16:23:21.374374,  0] nmbd/nmbd.c:71(terminate)
  Got SIGTERM: going down...
[2011/03/18 16:29:07,  0] lib/fault.c:250(dump_core_setup)
  Unable to setup corepath for nmbd: Permission denied
[2011/03/18 16:29:07,  0] nmbd/nmbd.c:857(main)
  nmbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2010
[2011/03/18 16:29:21.611650,  0] nmbd/nmbd_serverlistdb.c:343(write_browse_list)
  write_browse_list: Can't open file /var/lib/samba/browse.dat.. Error was Permission denied
[2011/03/18 16:29:26.859811,  0] nmbd/nmbd_serverlistdb.c:343(write_browse_list)
  write_browse_list: Can't open file /var/lib/samba/browse.dat.. Error was Permission denied
RSSCOLLSRV1:~ #
Just for testing I'm running on the default config ...
Edited by IBuyJunk - 3/18/11 at 1:31pm
    
CPUMotherboardGraphicsRAM
E6300 @ 2.3 GHz Foxconn Intel x3100 4.5 Rendition 
Hard DriveOptical DriveOSMonitor
160+500 DVDRW Server 08 x64 Princeton 17'' square 
KeyboardPowerCaseMouse
Unicomp Germanic Model M 250W Dell Vostro 200 Gateway Ball Mouse 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
E6300 @ 2.3 GHz Foxconn Intel x3100 4.5 Rendition 
Hard DriveOptical DriveOSMonitor
160+500 DVDRW Server 08 x64 Princeton 17'' square 
KeyboardPowerCaseMouse
Unicomp Germanic Model M 250W Dell Vostro 200 Gateway Ball Mouse 
  hide details  
Reply
post #6 of 19
Quote:
Originally Posted by IBuyJunk;12781137 
Samba isn't able to start from what I can gather.

Just for testing I'm running on the default config ...

I think you might be right. You can tell if its running with ps -e | grep smb

Even if it is running, its obviously not running correctly. I really don't know what the majority of those errors are about, so idk what to tell you...
I guess you could try removing it from you system and reinstalling it?

Also, I have no experience with using samba over a gui.
Edited by Xazen - 3/18/11 at 1:47pm
Scream Machine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770K Gigabyte Z87X-UD3H EVGA GTX 780 16GB DDR3 
Hard DriveCoolingOSMonitor
256GB Samsung 840 Pro Kraken X60 Windows 7 Shimian 2560x1440 
Case
Phantom 630 
  hide details  
Reply
Scream Machine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770K Gigabyte Z87X-UD3H EVGA GTX 780 16GB DDR3 
Hard DriveCoolingOSMonitor
256GB Samsung 840 Pro Kraken X60 Windows 7 Shimian 2560x1440 
Case
Phantom 630 
  hide details  
Reply
post #7 of 19
Thread Starter 
It has to be something specific to OpenSUSE ...

While I was messing around with this extremely fustrating server running openSUSE, I was able to configure Samba ... TWICE ... from the smb.conf file on an ubuntu box. Something is up with openSUSE.

Ps -el | grep smb ... no smb running or samba (same service, just lookd for both ...)

Google around for the errors I am getting does not seem to give any good results
    
CPUMotherboardGraphicsRAM
E6300 @ 2.3 GHz Foxconn Intel x3100 4.5 Rendition 
Hard DriveOptical DriveOSMonitor
160+500 DVDRW Server 08 x64 Princeton 17'' square 
KeyboardPowerCaseMouse
Unicomp Germanic Model M 250W Dell Vostro 200 Gateway Ball Mouse 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
E6300 @ 2.3 GHz Foxconn Intel x3100 4.5 Rendition 
Hard DriveOptical DriveOSMonitor
160+500 DVDRW Server 08 x64 Princeton 17'' square 
KeyboardPowerCaseMouse
Unicomp Germanic Model M 250W Dell Vostro 200 Gateway Ball Mouse 
  hide details  
Reply
post #8 of 19
I see that you're getting permission denied.
what's the output of
ls -l /etc/samba /var/lib/samba

and what user is your samba server configure to run as?

Addendum: also, if you can see that the service is running, what's the output of `netstat -ln4` you should be listening on 445
Edited by hometoast - 3/18/11 at 2:13pm
RAWR
(13 items)
 
Home Server
(11 items)
 
 
CPUMotherboardGraphicsRAM
i7-4790k msi z97 gaming 7 gtx 760 4gb 32GB GSkill  
Hard DriveHard DriveCoolingOS
Kingston HyperX 3K 120GB SSD Hitachi 2TB Cooler Master Hyper 212+ Windows 8.1 Pro 
MonitorKeyboardPowerCase
Vizio M492-b2 Logitech Wireless  Corsair HX620 NZXT Phantom White 
Mouse
Logitech Wireless 
  hide details  
Reply
RAWR
(13 items)
 
Home Server
(11 items)
 
 
CPUMotherboardGraphicsRAM
i7-4790k msi z97 gaming 7 gtx 760 4gb 32GB GSkill  
Hard DriveHard DriveCoolingOS
Kingston HyperX 3K 120GB SSD Hitachi 2TB Cooler Master Hyper 212+ Windows 8.1 Pro 
MonitorKeyboardPowerCase
Vizio M492-b2 Logitech Wireless  Corsair HX620 NZXT Phantom White 
Mouse
Logitech Wireless 
  hide details  
Reply
post #9 of 19
Yea it seems specific to suse. It might have something to do with the gui samba utility that comes bundled. If you can remove all of that and install basic samba it might work.
Scream Machine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770K Gigabyte Z87X-UD3H EVGA GTX 780 16GB DDR3 
Hard DriveCoolingOSMonitor
256GB Samsung 840 Pro Kraken X60 Windows 7 Shimian 2560x1440 
Case
Phantom 630 
  hide details  
Reply
Scream Machine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770K Gigabyte Z87X-UD3H EVGA GTX 780 16GB DDR3 
Hard DriveCoolingOSMonitor
256GB Samsung 840 Pro Kraken X60 Windows 7 Shimian 2560x1440 
Case
Phantom 630 
  hide details  
Reply
post #10 of 19
have you looked at the services/runlevel thing in yast and made sure smb or samba is enabled?
It's working fine for me.
Primary
(16 items)
 
   
CPUMotherboardGraphicsRAM
Q9450 Gigabyte EP45-UD3P Powercolor PCS+ HD7870 Myst 4x 2GB G.skill DDR2 1100 
Hard DriveHard DriveHard DriveOptical Drive
OCZ Vertex 3 120GB WD Velociraptor 300GB Caviar Green 500GB LG 24x Super-Multi 
CoolingOSMonitorPower
Thermalright Venomous-X RT Win 7 Home Premium x64 ASUS VH222H Corsair HX650 
CaseMouseAudio
Corsair 600T SE White Cyborg R.A.T. 7 AKG K 702 
  hide details  
Reply
Primary
(16 items)
 
   
CPUMotherboardGraphicsRAM
Q9450 Gigabyte EP45-UD3P Powercolor PCS+ HD7870 Myst 4x 2GB G.skill DDR2 1100 
Hard DriveHard DriveHard DriveOptical Drive
OCZ Vertex 3 120GB WD Velociraptor 300GB Caviar Green 500GB LG 24x Super-Multi 
CoolingOSMonitorPower
Thermalright Venomous-X RT Win 7 Home Premium x64 ASUS VH222H Corsair HX650 
CaseMouseAudio
Corsair 600T SE White Cyborg R.A.T. 7 AKG K 702 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Samba Not working on openSUSE