Overclock.net › Forums › Graphics Cards › AMD/ATI › Massive Sapphire 6950 2GB artifacts.
New Posts  All Forums:Forum Nav:

Massive Sapphire 6950 2GB artifacts.

post #1 of 4
Thread Starter 
Ever since I started playing with my sig rig I've been getting very large amounts of artifacts on startup, it'd work again after a minute and then artifacts would randomly kick in. Games run just as fast as they should, I just keep getting black squares. My PSU is a Hec Cougar 750w pro 80+ and I'm using two 6-pins on a single rail. PSU or bad card?


Also, my computer would randomly just shuts down after 20-40minutes of BC2. That's obviously a PSU issue but could it also create artifacts?
Edited by OptimusCaik - 3/19/11 at 4:26pm
Skyline
(13 items)
 
  
CPUMotherboardGraphicsRAM
|B55 3.6| |Gigabyte MA770UD3| |GTX460SE 900/2000| |4GB G.Skill 1600| 
Hard DriveOSMonitorPower
|1Tb 7200rpm| |W7u 64bit| |23" Acer LED| |Hec-X Pro 750w| 
Case
|Blitz Mid-Tower| 
  hide details  
Reply
Skyline
(13 items)
 
  
CPUMotherboardGraphicsRAM
|B55 3.6| |Gigabyte MA770UD3| |GTX460SE 900/2000| |4GB G.Skill 1600| 
Hard DriveOSMonitorPower
|1Tb 7200rpm| |W7u 64bit| |23" Acer LED| |Hec-X Pro 750w| 
Case
|Blitz Mid-Tower| 
  hide details  
Reply
post #2 of 4
I ordered the same card, the wait is hell, this will be the highest level card I ever bought.

That I remember, I had a

Nvida MX440 64MB
Radeon x1300pro 256MB
Radeon 5670 1GB

and in less than a week

sapphire 6950 2GB
Car replacement
(13 items)
 
  
CPUMotherboardGraphicsRAM
pII x4 40 @ 3.72GHz NB @ 2.79GHz M4A89gtd PRO/USB3 Sapphire 6950 2GB nonRef 950/1520 @1.2V 4GB Gskill DDR3 CL7eco @1656 6-8-6-20-24-1T 
Hard DriveOSMonitorPower
WD Black 640GB SATA3 Windows 7 Ultimate BenQ 24" G2420HD 1920x1080 SeaSonic M12II 520W 
Case
TV stand on wheels + cardboard door 
  hide details  
Reply
Car replacement
(13 items)
 
  
CPUMotherboardGraphicsRAM
pII x4 40 @ 3.72GHz NB @ 2.79GHz M4A89gtd PRO/USB3 Sapphire 6950 2GB nonRef 950/1520 @1.2V 4GB Gskill DDR3 CL7eco @1656 6-8-6-20-24-1T 
Hard DriveOSMonitorPower
WD Black 640GB SATA3 Windows 7 Ultimate BenQ 24" G2420HD 1920x1080 SeaSonic M12II 520W 
Case
TV stand on wheels + cardboard door 
  hide details  
Reply
post #3 of 4
Quote:
Originally Posted by OptimusCaik View Post
Ever since I started playing with my sig rig I've been getting very large amounts of artifacts on startup, it'd work again after a minute and then artifacts would randomly kick in. Games run just as fast as they should, I just keep getting black squares. My PSU is a Hec Cougar 750w pro 80+ and I'm using two 6-pins on a single rail. PSU or bad card?


Also, my computer would randomly just shuts down after 20-40minutes of BC2. That's obviously a PSU issue but could it also create artifacts?
If you get artifacts at startup, it's time to RMA the card. At startup it's not using much power.
Money dump
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k 4.4Ghz @ 1.22v ASRock Z77 Pro4 Sapphire R9 Nano @ Fury X clocks Crucial Ballistix VLP 2x8GB 1600 @ 2133 
Hard DriveOptical DriveCoolingOS
Samsung 830 128GB SSD, Seagate 3TB, Samsung 1TB Sony DVD/Rw 24x Thermalright Ultra 120 Extreme + GT AP-14 Windows 10 Pro 64-bit 
MonitorKeyboardPowerCase
Samsung U24E590D UHD Saitek Eclipse II Seasonic Prime 850w Titanium Corsair Carbide Air 540 
MouseAudio
Steelseries Xai Asus Xonar D1 / M-Audio AV40 / Ultrasone HFI-650 
  hide details  
Reply
Money dump
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k 4.4Ghz @ 1.22v ASRock Z77 Pro4 Sapphire R9 Nano @ Fury X clocks Crucial Ballistix VLP 2x8GB 1600 @ 2133 
Hard DriveOptical DriveCoolingOS
Samsung 830 128GB SSD, Seagate 3TB, Samsung 1TB Sony DVD/Rw 24x Thermalright Ultra 120 Extreme + GT AP-14 Windows 10 Pro 64-bit 
MonitorKeyboardPowerCase
Samsung U24E590D UHD Saitek Eclipse II Seasonic Prime 850w Titanium Corsair Carbide Air 540 
MouseAudio
Steelseries Xai Asus Xonar D1 / M-Audio AV40 / Ultrasone HFI-650 
  hide details  
Reply
post #4 of 4
RMA it, it has nothing to do with power consumption. I know it is a pain to RMA but for a $250 card, you should RMA
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Massive Sapphire 6950 2GB artifacts.