Overclock.net › Forums › Graphics Cards › AMD/ATI › Ati Radeon 5770/System problems. Any help very much appreciated!
New Posts  All Forums:Forum Nav:

Ati Radeon 5770/System problems. Any help very much appreciated!

post #1 of 9
Thread Starter 
Hey guys/gals i'm completely new to system building and im in a pickle :/
Im sorry for the essay of a post but im really in need of some guidance!

around 5 months ago i though i would invest in a new system and to save money and learn something new so i decided build it myself. I bought my system components. The build went fine. But then issues began to surface. My GPU a XFX ATI Radeon 5770 after any sort of game play randomly drops frame rate to 0.5 - 1 frames per second and really loud buzzing from the speakers occurred. I had 2 options 1) try to get out of the game and wait at the desktop for the issue to subside which it did after around 30 minuets. 2) Hard shut down the system. This issue was completely random it could happen after 10 minuets or 8 hours of game play. (System works fine with everything else just in gaming this occurs)

So i did the basic protocol with graphic issues- Reinstall Drivers,check temps, check if its physically installed correctly. Everything seemed dandy and the issue continued. So i contacted XFX they recommend updating the sound drivers. i did this, still same problem. After various emails they said to contact my supplier. I contacted them they told me to run MEMtest,update BIO's, check voltages(using everest), try another card ( At the time i didn't have another to test!) but all was fine with system as far as i knew. i was finally sent the card back for testing. The results to my dismay NO FAULT FOUND. So i paid for the shipping and wasted time for nothing!

I managed to get my hands on another 5770 and tested that in my system and had the same issue (but the card just crashed/ black screen). At this point the only thing that seemed logical for the issue was a power problem. I had a volt/amp meter knocking around and tested the 12V rails idle and under load. Sadly voltages stayed solid at 12.1v(ish). At this point i was getting desperate so i contacted the supplier again after many many many phone calls and email's they gave me the option to send in my GPU in for a "more extensive" test or my PSU. i was very reluctant to do this but i sent in my PSU as i though it was more likely to be this at fault. You guessed it folks "NO FAULT FOUND". They then suggested that i send my MOBO in or magically find another and test it in my system. i was not very happy with this response as this would mean having to re activating my system with windows and practically building the computer again.

Well i recently tried putting the cards in crossfire (god knows what i was trying to achieve) but this had some interesting results. The game still occurred the same problem randomly after a certain amount of gameplay, but if i didnt move the mouse or press any keys it instantly was running fine. if i tried to do anything the sound would buzz and freeze/dramatically drop frame rate. Games aren't really fun not being able to interact with it

Sorry essay over!

This means its the MOBO or some software/driver issue?
Im sorry to ask such a demanding question but im so lost right now for where to turn!
Any suggestions on fixes or potential causes will be great thank you!

System Spec:

AMD Phenom 2 x4 955
4GB corsair kit (2GB x 2)
XFX 1GB ATI Radeon 5770 (other card in crossfire is a Sapphire version of same card)
2 x 500GB Seagate HDD
Asus M4A89GTD/USB3 Pro mobo
850W Power Colour PSU

Thank you so much for your time and effort!
.
(7 items)
 
  
Power
850W Powercool 
  hide details  
Reply
.
(7 items)
 
  
Power
850W Powercool 
  hide details  
Reply
post #2 of 9
Sounds like Mobo. You've ruled out anything else it could be (power, video card, temps, memory etc.)

Might could try a reformat / clean install to rule out any possible software issues. (Load windows, load graphic drivers, try game)

If I was at your point I'd probably just RMA the motherboard.
Raven 2012
(16 items)
 
BigHeavy 2009
(10 items)
 
 
CPUMotherboardGraphicsRAM
Intel 3770k (4.6ghz) Asus Sabertooth z77 Galaxy GTX680 4GB SLI 16GB Corsair Vengeance LP 
Hard DriveHard DriveOptical DriveCooling
Samsung 840 PRO 256GB Western Digital Black 1TB ASUS DVD-RW Tuniq Extreme 120 with Gelid blue fan 
OSMonitorKeyboardPower
Windows 7 Overlord x270oc Logitech G510 Seasonic Platinum 1000w 
CaseMouseMouse PadAudio
Silverstone Raven RV03 Logitech G600 Logitech g440 Sound Blaster ZXR 
CPUMotherboardGraphicsRAM
I7-920 (oc 3.5ghz) Asus P6T V2 EVGA GTX580 SC (SLI) 12GB Corsair Dominator (2Gb x 6) 
Hard DriveOptical DriveOSMonitor
Crucial M4 256GB + Western Digital Black 750GB DVD-RW x2 Windows 7 pro Samsung SyncMaster XL 2370 
PowerCase
Silverstone Strider 850watt CM HAF 932 
  hide details  
Reply
Raven 2012
(16 items)
 
BigHeavy 2009
(10 items)
 
 
CPUMotherboardGraphicsRAM
Intel 3770k (4.6ghz) Asus Sabertooth z77 Galaxy GTX680 4GB SLI 16GB Corsair Vengeance LP 
Hard DriveHard DriveOptical DriveCooling
Samsung 840 PRO 256GB Western Digital Black 1TB ASUS DVD-RW Tuniq Extreme 120 with Gelid blue fan 
OSMonitorKeyboardPower
Windows 7 Overlord x270oc Logitech G510 Seasonic Platinum 1000w 
CaseMouseMouse PadAudio
Silverstone Raven RV03 Logitech G600 Logitech g440 Sound Blaster ZXR 
CPUMotherboardGraphicsRAM
I7-920 (oc 3.5ghz) Asus P6T V2 EVGA GTX580 SC (SLI) 12GB Corsair Dominator (2Gb x 6) 
Hard DriveOptical DriveOSMonitor
Crucial M4 256GB + Western Digital Black 750GB DVD-RW x2 Windows 7 pro Samsung SyncMaster XL 2370 
PowerCase
Silverstone Strider 850watt CM HAF 932 
  hide details  
Reply
post #3 of 9
tried reinstalling windows yet?

Very strange issue you have there.
Alienware M9700
(14 items)
 
Wackbook pro
(12 items)
 
Mpowerlicous
(12 items)
 
CPUCPUMotherboardGraphics
AMD Turion ML-42 2.4GHz AMD Turion ML-40 Alienware nForce3 2X nVidia GeForce Go 7900GS SLI 
RAMHard DriveOSMonitor
1GB DDR 333MHz Samsung Spinpoint 250GB Windows XP Professional 1920X1200 Integrated LCD 
Case
Alienware M9700 chassis 
CPUMotherboardGraphicsGraphics
Core i7 3615QM @2.3GHz Apple Logic Board Intel HD 4000 Nvidia GT 650M 512MB 
RAMHard DriveOSMonitor
16GB 1600MHz DDR3 500GB Samsung 840  OSX 10.10 1440x900  
PowerAudioAudioAudio
85W PSU Schiit Modi Schiit Magni 2 Über DT770 Pro 
CPUMotherboardGraphicsRAM
Intel i7 3770K MSI Z77 Big Bang MPower Radeon R9 270X 4X4GB G.Skill  
Hard DriveCoolingOSMonitor
Intel X25-V Cooler Master Hyper 212+ Life without walls? Who needs windows? Acer 
KeyboardPowerCaseMouse
G15 Raidmax RX-1000AE Brooks shoebox  Acer G500 
  hide details  
Reply
Alienware M9700
(14 items)
 
Wackbook pro
(12 items)
 
Mpowerlicous
(12 items)
 
CPUCPUMotherboardGraphics
AMD Turion ML-42 2.4GHz AMD Turion ML-40 Alienware nForce3 2X nVidia GeForce Go 7900GS SLI 
RAMHard DriveOSMonitor
1GB DDR 333MHz Samsung Spinpoint 250GB Windows XP Professional 1920X1200 Integrated LCD 
Case
Alienware M9700 chassis 
CPUMotherboardGraphicsGraphics
Core i7 3615QM @2.3GHz Apple Logic Board Intel HD 4000 Nvidia GT 650M 512MB 
RAMHard DriveOSMonitor
16GB 1600MHz DDR3 500GB Samsung 840  OSX 10.10 1440x900  
PowerAudioAudioAudio
85W PSU Schiit Modi Schiit Magni 2 Über DT770 Pro 
CPUMotherboardGraphicsRAM
Intel i7 3770K MSI Z77 Big Bang MPower Radeon R9 270X 4X4GB G.Skill  
Hard DriveCoolingOSMonitor
Intel X25-V Cooler Master Hyper 212+ Life without walls? Who needs windows? Acer 
KeyboardPowerCaseMouse
G15 Raidmax RX-1000AE Brooks shoebox  Acer G500 
  hide details  
Reply
post #4 of 9
Thread Starter 
Yeah i did the windows 7 update. where it replaces/reinstalls all your windows files but this had no effect
.
(7 items)
 
  
Power
850W Powercool 
  hide details  
Reply
.
(7 items)
 
  
Power
850W Powercool 
  hide details  
Reply
post #5 of 9
I think you motherboard is faulty. I have two XFX 5770s and they ran in crossfire for months and never had issues.
     
CPUMotherboardGraphicsRAM
Intel I7 860  Asus P7P55D-E Pro MSI ATI 6990 8gb G.Skill 1600 DDR3 (4x2Gb) 
RAMHard DriveHard DriveOptical Drive
G. Skill 1600 DDR3 OCZ Agility 2 120Gb  Seagate SATA Barracuda 160GB TSH663B DVD burner 
CoolingCoolingCoolingCooling
EK Supreme HF XSPC RC360 XSPC DDC Reservoir EK-FC6990 - EN (Nickel) 
OSMonitorKeyboardPower
Windows 10 64bit Pro Gateway FHX2300 Microsoft Wireless Multimedia V2 PC Power & Cooling Silencer 750 Quad 
CaseMouseAudio
Cooler Master HAF 932 Microsoft Wireless Optical Creative 5.1 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel I7 860  Asus P7P55D-E Pro MSI ATI 6990 8gb G.Skill 1600 DDR3 (4x2Gb) 
RAMHard DriveHard DriveOptical Drive
G. Skill 1600 DDR3 OCZ Agility 2 120Gb  Seagate SATA Barracuda 160GB TSH663B DVD burner 
CoolingCoolingCoolingCooling
EK Supreme HF XSPC RC360 XSPC DDC Reservoir EK-FC6990 - EN (Nickel) 
OSMonitorKeyboardPower
Windows 10 64bit Pro Gateway FHX2300 Microsoft Wireless Multimedia V2 PC Power & Cooling Silencer 750 Quad 
CaseMouseAudio
Cooler Master HAF 932 Microsoft Wireless Optical Creative 5.1 
  hide details  
Reply
post #6 of 9
I would say its your PSU
AV-8B
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K @ 5.0 P8P67 DELUXE gigabyte windforce OC GTX 1060 G.Skill DDR3 @ 1950 
Hard DriveHard DriveHard DriveOptical Drive
intel 520 SSD PNY CS1211 WD CAVIAR BLUE 640 gb LG BD Combo 
CoolingOSMonitorPower
Heatkiller 3.0 Seven 64 24" & 22" Gateway, 22" Dell 1000w TruePower Quattro 
Case
Antec 1200 
  hide details  
Reply
AV-8B
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K @ 5.0 P8P67 DELUXE gigabyte windforce OC GTX 1060 G.Skill DDR3 @ 1950 
Hard DriveHard DriveHard DriveOptical Drive
intel 520 SSD PNY CS1211 WD CAVIAR BLUE 640 gb LG BD Combo 
CoolingOSMonitorPower
Heatkiller 3.0 Seven 64 24" & 22" Gateway, 22" Dell 1000w TruePower Quattro 
Case
Antec 1200 
  hide details  
Reply
post #7 of 9
Which socket is the GPU in?
And is it set in the BIOS to the socket the GPU resides in?
Black Edition
(17 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X4 870K @ 4.50 ASUS A68HM-Plus FM2+ EVGA GeForce GTX 760 Crucial Ballistix Sports (8GB.) (DDR3-1600) 
Hard DriveHard DriveHard DriveHard Drive
SanDisk SSD Plus 240GB. Toshiba (500GB.) Hitachi Deskstar (500GB.) WD Ultra Passport 
Optical DriveCoolingOSMonitor
Samsung DVD Burner 24X SH-224DB/BEBE Cooler Master Hyper T4 Windows 10 Pro x64 Samsung S23A350H 23" 1080p 
KeyboardPowerCaseMouse
Logitech G105 Gaming Keyboard CORSAIR CX series CX600M 600W Thermaltake V3 Black Edition Logitech G300s Gaming Mouse 
Audio
ASUS DG 5.1 DD 
  hide details  
Reply
Black Edition
(17 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X4 870K @ 4.50 ASUS A68HM-Plus FM2+ EVGA GeForce GTX 760 Crucial Ballistix Sports (8GB.) (DDR3-1600) 
Hard DriveHard DriveHard DriveHard Drive
SanDisk SSD Plus 240GB. Toshiba (500GB.) Hitachi Deskstar (500GB.) WD Ultra Passport 
Optical DriveCoolingOSMonitor
Samsung DVD Burner 24X SH-224DB/BEBE Cooler Master Hyper T4 Windows 10 Pro x64 Samsung S23A350H 23" 1080p 
KeyboardPowerCaseMouse
Logitech G105 Gaming Keyboard CORSAIR CX series CX600M 600W Thermaltake V3 Black Edition Logitech G300s Gaming Mouse 
Audio
ASUS DG 5.1 DD 
  hide details  
Reply
post #8 of 9
I was having same issues with my Powercolor 5770, i believe it was a bad overclock, and i re installed windows just to be safe, but if you've already installed windows again id say its the mobo
Epic LanBox
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600 ASrock H61 M-ITX GTX 560 TI Zotac Amp G.Skill Ripjaws 
Hard DriveOSPowerCase
WD Scorpio Black Win7 Pro x64 Silverstone SFX 450 Silverstone SG05 
  hide details  
Reply
Epic LanBox
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600 ASrock H61 M-ITX GTX 560 TI Zotac Amp G.Skill Ripjaws 
Hard DriveOSPowerCase
WD Scorpio Black Win7 Pro x64 Silverstone SFX 450 Silverstone SG05 
  hide details  
Reply
post #9 of 9
It sure sounds to me like the Mother board. You have tested everything i can think of to test. Accept maybe rebuild the MBR. but in all it kinda sounds to me like its a bus problem. Sure wish you the best.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Ati Radeon 5770/System problems. Any help very much appreciated!