Overclock.net › Forums › Graphics Cards › NVIDIA › GTX 570 Stops Displaying
New Posts  All Forums:Forum Nav:

GTX 570 Stops Displaying

post #1 of 3
Thread Starter 
I'm posting on behalf of my friend, whose GTX 570 has failed.

He can see POST information from his motherboard and see the Windows boot logo. During boot, he gets blue artifacts. But after Windows loads, his display stops working right when the login screen is supposed to show. He has tried safe mode and safe VGA mode. Both don't work. BIOS works just fine with no artifacts.

His motherboard is the Gigabyte GA-EX58-UD5, and he has the reference MSI GTX 570.
Marshmallow
(14 items)
 
Corsair H100 - Excellent Compact Cooler
Corsair Hydro Series H100 Extreme Performance Liquid CPU Cooler (CWCH100)
 
CPUMotherboardGraphicsRAM
Core i7 920 @ 4.0GHz - 1.21v EVGA Classified X58 Asus GTX 580 DirectCU II 6GB Mushkin Blackline 
Hard DriveCoolingOSMonitor
Corsair F60 + 1TB Spinpoint F3 Corsair H100 Windows 7 Ultimate x64 Asus MK241H 24" 1920x1200 
KeyboardPowerCaseMouse
Das Model S Professional Silent Antec BP550 Plus NZXT Phantom Razer DeathAdder 
  hide details  
Reply
Marshmallow
(14 items)
 
Corsair H100 - Excellent Compact Cooler
Corsair Hydro Series H100 Extreme Performance Liquid CPU Cooler (CWCH100)
 
CPUMotherboardGraphicsRAM
Core i7 920 @ 4.0GHz - 1.21v EVGA Classified X58 Asus GTX 580 DirectCU II 6GB Mushkin Blackline 
Hard DriveCoolingOSMonitor
Corsair F60 + 1TB Spinpoint F3 Corsair H100 Windows 7 Ultimate x64 Asus MK241H 24" 1920x1200 
KeyboardPowerCaseMouse
Das Model S Professional Silent Antec BP550 Plus NZXT Phantom Razer DeathAdder 
  hide details  
Reply
post #2 of 3
By failed, I'm assuming it was working fine at some point?

First, try just re-seating the card on the motherboard, if the case has been moved, it might have been jarred loose. If that doesn't work, try taking his card out and using yours, see if there are any problems, and try his card in your system. Let's work from there.
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
post #3 of 3
Did he OC or disable OCP?
Sandyman
(14 items)
 
Lenovo Y500
(8 items)
 
 
CPUGraphicsRAMHard Drive
i7 3630QM GT 650M SLI 2x4GB DDR3 1600 MHz Sandisk Extreme II 240GB 
Optical DriveOSMonitorMouse
None Windows 8 15.6" 1080p Steelseries Sensei RAW 
  hide details  
Reply
Sandyman
(14 items)
 
Lenovo Y500
(8 items)
 
 
CPUGraphicsRAMHard Drive
i7 3630QM GT 650M SLI 2x4GB DDR3 1600 MHz Sandisk Extreme II 240GB 
Optical DriveOSMonitorMouse
None Windows 8 15.6" 1080p Steelseries Sensei RAW 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › GTX 570 Stops Displaying