Overclock.net › Forums › Graphics Cards › AMD/ATI › Bad Company 2 and HD6950 keeps hanging on me! (SOLUTION)
New Posts  All Forums:Forum Nav:

Bad Company 2 and HD6950 keeps hanging on me! (SOLUTION)

post #1 of 19
Thread Starter 
So,the history is:

-Bought it.
-Flashed to HD6970.Played BC2 about 20 minutes with stock settings and crash.Several times.
-Flashed back to original bios,keep crashing.
-Flashed back to 6970,upped Vcore,keeps crashing.
-Flashed back to original,same.

SOLUTION:Turn MSI Afterburner OFF.
Edited by legend999 - 3/21/11 at 8:24pm
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500K GA-Z68X-UD4-B3 R9 280X Vapor-X Corsair 
Hard DriveHard DriveOptical DriveCooling
WD Green  Samsung SSD Pioneer Corsair H70 
OSMonitorKeyboardPower
Windows 7 x86 Hp EliteDisplay E271i Mad Catz V.7 XFX PRO550W Core Edition 
CaseMouseMouse Pad
Thermaltake Spedo Advance Package Logitech G700 Roccat Sense 
  hide details  
Reply
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500K GA-Z68X-UD4-B3 R9 280X Vapor-X Corsair 
Hard DriveHard DriveOptical DriveCooling
WD Green  Samsung SSD Pioneer Corsair H70 
OSMonitorKeyboardPower
Windows 7 x86 Hp EliteDisplay E271i Mad Catz V.7 XFX PRO550W Core Edition 
CaseMouseMouse Pad
Thermaltake Spedo Advance Package Logitech G700 Roccat Sense 
  hide details  
Reply
post #2 of 19
New card, used card? Did you overclock it? How far did you push it? Have you tried bios setting 2?
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
post #3 of 19
There's a problem with BC2 and 6900 cards.
It's a PunkBuster issue. Play another game and see if the problem persists.

Potential Fix:
http://www.overclock.net/pc-games/96...l#post12704643
Render Bender
(10 items)
 
On The Move
(11 items)
 
 
CPUGraphicsRAMHard Drive
Intel X5690 Xeon (12 Cores @ 3.46) Nvidia Titan Xp 64GB 1333MHz ECC DDR3 Samsung 850 EVO 1TB x2 - RAID 0 
MonitorCaseAudio
Samsung UN40JU6700 40" 4K Curved Apple Mac Pro 2010 Klipsch 2.1 
CPUGraphicsRAMHard Drive
Intel Core 2 Duo Nvidia GeForce 9400M 8GB 1067 MHz DDR3 Toshiba 500GB 
OSMonitorKeyboardCase
Mavericks 10.9 Dell U3011 Rosewill Mech Reds 2010 Unibody 
MouseMouse PadAudio
Logitech G700 Multi-Touch Kilpsch 2.1 
  hide details  
Reply
Render Bender
(10 items)
 
On The Move
(11 items)
 
 
CPUGraphicsRAMHard Drive
Intel X5690 Xeon (12 Cores @ 3.46) Nvidia Titan Xp 64GB 1333MHz ECC DDR3 Samsung 850 EVO 1TB x2 - RAID 0 
MonitorCaseAudio
Samsung UN40JU6700 40" 4K Curved Apple Mac Pro 2010 Klipsch 2.1 
CPUGraphicsRAMHard Drive
Intel Core 2 Duo Nvidia GeForce 9400M 8GB 1067 MHz DDR3 Toshiba 500GB 
OSMonitorKeyboardCase
Mavericks 10.9 Dell U3011 Rosewill Mech Reds 2010 Unibody 
MouseMouse PadAudio
Logitech G700 Multi-Touch Kilpsch 2.1 
  hide details  
Reply
post #4 of 19
Thread Starter 
New card,reference Asus.

Yes,i tried once 920 and 1400,same thing.

I'm now with the sapphire HD6970 Bios,doing a furmark burn-in as we speak.

You mean,try playing with bios 2?Used it once,but only to recover bios 1 to original.

~
Quote:
Originally Posted by WorldExclusive View Post
There's a problem with BC2 and 6900 cards.
It's a PunkBuster issue. Play another game and see if the problem persists.
The game hangs with sound loop,no BSOD,nothing,have to restart by case button.Is it that?
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500K GA-Z68X-UD4-B3 R9 280X Vapor-X Corsair 
Hard DriveHard DriveOptical DriveCooling
WD Green  Samsung SSD Pioneer Corsair H70 
OSMonitorKeyboardPower
Windows 7 x86 Hp EliteDisplay E271i Mad Catz V.7 XFX PRO550W Core Edition 
CaseMouseMouse Pad
Thermaltake Spedo Advance Package Logitech G700 Roccat Sense 
  hide details  
Reply
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500K GA-Z68X-UD4-B3 R9 280X Vapor-X Corsair 
Hard DriveHard DriveOptical DriveCooling
WD Green  Samsung SSD Pioneer Corsair H70 
OSMonitorKeyboardPower
Windows 7 x86 Hp EliteDisplay E271i Mad Catz V.7 XFX PRO550W Core Edition 
CaseMouseMouse Pad
Thermaltake Spedo Advance Package Logitech G700 Roccat Sense 
  hide details  
Reply
post #5 of 19
Did you try 11.4 drivers?
Black Sand
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.8GHz ASUS Maximus IV Extreme-Z EVGA GTX 580 SLI 8GB Corsair Dominator GT @ 1885 MHz 
Hard DriveOSMonitorPower
60GB Mushkin Callisto Deluxe +1TB WD Caviar Black Windows 7 Home Premium ASUS VW246 Corsair HX-850 
Case
HAF 932 
  hide details  
Reply
Black Sand
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.8GHz ASUS Maximus IV Extreme-Z EVGA GTX 580 SLI 8GB Corsair Dominator GT @ 1885 MHz 
Hard DriveOSMonitorPower
60GB Mushkin Callisto Deluxe +1TB WD Caviar Black Windows 7 Home Premium ASUS VW246 Corsair HX-850 
Case
HAF 932 
  hide details  
Reply
post #6 of 19
Quote:
Originally Posted by legend999 View Post
New card,reference Asus.

Yes,i tried once 920 and 1400,same thing.

I'm now with the sapphire HD6970 Bios,doing a furmark burn-in as we speak.

You mean,try playing with bios 2?Used it once,but only to recover bios 1 to original.

~

The game hangs with sound loop,no BSOD,nothing,have to restart by case button.Is it that?
Yea, setting 2 is the failsafe. Confirm that the card works fine at stock with setting 2. You should reinstall drivers after going to failsafe to clean the slate.
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
post #7 of 19
Quote:
Originally Posted by legend999 View Post
New card,reference Asus.

Yes,i tried once 920 and 1400,same thing.

I'm now with the sapphire HD6970 Bios,doing a furmark burn-in as we speak.

You mean,try playing with bios 2?Used it once,but only to recover bios 1 to original.

~

The game hangs with sound loop,no BSOD,nothing,have to restart by case button.Is it that?
Yes. It happens when Afterburner or another GPU app is active, PB freezes the game about 15-20min into a match. Sometimes the game crashes without it. It's not your card, no need to worry or change stuff around hardware wise. Use that link I gave you to fix your issue.
Edited by WorldExclusive - 3/21/11 at 4:55pm
Render Bender
(10 items)
 
On The Move
(11 items)
 
 
CPUGraphicsRAMHard Drive
Intel X5690 Xeon (12 Cores @ 3.46) Nvidia Titan Xp 64GB 1333MHz ECC DDR3 Samsung 850 EVO 1TB x2 - RAID 0 
MonitorCaseAudio
Samsung UN40JU6700 40" 4K Curved Apple Mac Pro 2010 Klipsch 2.1 
CPUGraphicsRAMHard Drive
Intel Core 2 Duo Nvidia GeForce 9400M 8GB 1067 MHz DDR3 Toshiba 500GB 
OSMonitorKeyboardCase
Mavericks 10.9 Dell U3011 Rosewill Mech Reds 2010 Unibody 
MouseMouse PadAudio
Logitech G700 Multi-Touch Kilpsch 2.1 
  hide details  
Reply
Render Bender
(10 items)
 
On The Move
(11 items)
 
 
CPUGraphicsRAMHard Drive
Intel X5690 Xeon (12 Cores @ 3.46) Nvidia Titan Xp 64GB 1333MHz ECC DDR3 Samsung 850 EVO 1TB x2 - RAID 0 
MonitorCaseAudio
Samsung UN40JU6700 40" 4K Curved Apple Mac Pro 2010 Klipsch 2.1 
CPUGraphicsRAMHard Drive
Intel Core 2 Duo Nvidia GeForce 9400M 8GB 1067 MHz DDR3 Toshiba 500GB 
OSMonitorKeyboardCase
Mavericks 10.9 Dell U3011 Rosewill Mech Reds 2010 Unibody 
MouseMouse PadAudio
Logitech G700 Multi-Touch Kilpsch 2.1 
  hide details  
Reply
post #8 of 19
Thread Starter 
Quote:
Originally Posted by blackbalt89 View Post
Did you try 11.4 drivers?
Does it solve the problem?i did try,and i think it was the same. :S

Do you have yours fixed?

Quote:
Originally Posted by tsm106 View Post
Yea, setting 2 is the failsafe. Confirm that the card works fine at stock with setting 2. You should reinstall drivers after going to failsafe to clean the slate.
Thanks all for the answers.
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500K GA-Z68X-UD4-B3 R9 280X Vapor-X Corsair 
Hard DriveHard DriveOptical DriveCooling
WD Green  Samsung SSD Pioneer Corsair H70 
OSMonitorKeyboardPower
Windows 7 x86 Hp EliteDisplay E271i Mad Catz V.7 XFX PRO550W Core Edition 
CaseMouseMouse Pad
Thermaltake Spedo Advance Package Logitech G700 Roccat Sense 
  hide details  
Reply
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500K GA-Z68X-UD4-B3 R9 280X Vapor-X Corsair 
Hard DriveHard DriveOptical DriveCooling
WD Green  Samsung SSD Pioneer Corsair H70 
OSMonitorKeyboardPower
Windows 7 x86 Hp EliteDisplay E271i Mad Catz V.7 XFX PRO550W Core Edition 
CaseMouseMouse Pad
Thermaltake Spedo Advance Package Logitech G700 Roccat Sense 
  hide details  
Reply
post #9 of 19
Quote:
Originally Posted by legend999 View Post
Does it solve the problem?i did try,and i think it was the same. :S

Do you have yours fixed?

If you were directing that question to me I do not have a 69xx card. I have a GTX 570, but the first thing I ask when drivers crash when they should be stable is if the drivers are up to date. Sorry I can't offer more assistance.
Black Sand
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.8GHz ASUS Maximus IV Extreme-Z EVGA GTX 580 SLI 8GB Corsair Dominator GT @ 1885 MHz 
Hard DriveOSMonitorPower
60GB Mushkin Callisto Deluxe +1TB WD Caviar Black Windows 7 Home Premium ASUS VW246 Corsair HX-850 
Case
HAF 932 
  hide details  
Reply
Black Sand
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.8GHz ASUS Maximus IV Extreme-Z EVGA GTX 580 SLI 8GB Corsair Dominator GT @ 1885 MHz 
Hard DriveOSMonitorPower
60GB Mushkin Callisto Deluxe +1TB WD Caviar Black Windows 7 Home Premium ASUS VW246 Corsair HX-850 
Case
HAF 932 
  hide details  
Reply
post #10 of 19
Quote:
Originally Posted by legend999 View Post
The game hangs with sound loop,no BSOD,nothing,have to restart by case button.Is it that?
Punkbuster be your problem. I had this with my GTX 470 and 5850, not having it with my 6950 though nor 6850. PB really sucks. You may wanna try that fix that guy linked to.
    
CPUMotherboardGraphicsRAM
i5-2500k @ 4300Mhz Biostar TP67XE Waiting to buy a new one 8GB 1600Mhz 7-8-7-21 1T 
Hard DriveCoolingOSMonitor
Samsung 840 SSD [250GB] Antec H20 620 Windows 7 x64 Acer S242HL 
PowerCase
Thermaltake 775W NZXT Phantom [White] 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2500k @ 4300Mhz Biostar TP67XE Waiting to buy a new one 8GB 1600Mhz 7-8-7-21 1T 
Hard DriveCoolingOSMonitor
Samsung 840 SSD [250GB] Antec H20 620 Windows 7 x64 Acer S242HL 
PowerCase
Thermaltake 775W NZXT Phantom [White] 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Bad Company 2 and HD6950 keeps hanging on me! (SOLUTION)