Overclock.net › Forums › Graphics Cards › AMD/ATI › Problems with Radeon 4670
New Posts  All Forums:Forum Nav:

Problems with Radeon 4670

post #1 of 9
Thread Starter 
Hi. I installed a Radon HD4670 passively cooled last week and was working phenominally and all the benchmarks were through the roof. Yesterday I noticed poor 2D graphics performance, specifically when looking at jpeg and btmp photographs, as well as graphics displayed on websites. I checked the benchmarks and everything is down slightly, but the 2D graphics were working at half of what the integrated graphics was at previously. The 2D Graphics Windows Interaface was reduced the most. My FSB clock was raised from 133 to 159, 3.06GgHz to 3.6gHZ and my cpu voltage I was experimenting with was only raised about .04v. I have since set all the bios settings to default as well as the graphics settings. I never OC'd my graphics card and never pushed it hard, (although its used). I have done a system restore and deleted the hardware, drivers, and Catalyst software and reinstalled it. This is frustrating because I have NO IDEA whether this is a software or hardware issue. I have CPUid and SIW and can display any info or settings that someone thinks is relevant. I am going to try pulling the card and reinstalling the integrated graphics and see if the problem is resolved. Does anyone else have any ideas? I know it's a long post. I really appreciate the help.
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k Asus P8Z68-V Radeon HD4670 Samsung MV-3V2G3D/US low profile  
Hard DriveHard DriveHard DriveOptical Drive
Samsung HD503HI  Samsung 830 Series SSD 128 GB Samsung HD155UI Lite-on IHOS-104 Blu Ray 
CoolingOSMonitorKeyboard
Thermalright Silver Arrow Win 7 Professional HP LP2065 20" LCD Cherry MX Board 3.0 
PowerCaseAudio
Antec Earthwatts EA380D Fractal Design Arc Midi Klipsch THX 
  hide details  
Reply
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k Asus P8Z68-V Radeon HD4670 Samsung MV-3V2G3D/US low profile  
Hard DriveHard DriveHard DriveOptical Drive
Samsung HD503HI  Samsung 830 Series SSD 128 GB Samsung HD155UI Lite-on IHOS-104 Blu Ray 
CoolingOSMonitorKeyboard
Thermalright Silver Arrow Win 7 Professional HP LP2065 20" LCD Cherry MX Board 3.0 
PowerCaseAudio
Antec Earthwatts EA380D Fractal Design Arc Midi Klipsch THX 
  hide details  
Reply
post #2 of 9
did you notice the graphics performance before or after you did the overclock to your cpu?
Beast
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9400 @ 3.6ghz @1.192v asus p5q-e xfx Radeon hd 6850 + Geforce 9500gt Dedicated Phys corsair ddr2 pc8500 4gb 
Hard DriveOSMonitorPower
Hitachi 640 gb win 7 ultimate 64bit ctl 190lx ultra lsp 750 pro 
Case
nzxt zero 2 
  hide details  
Reply
Beast
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9400 @ 3.6ghz @1.192v asus p5q-e xfx Radeon hd 6850 + Geforce 9500gt Dedicated Phys corsair ddr2 pc8500 4gb 
Hard DriveOSMonitorPower
Hitachi 640 gb win 7 ultimate 64bit ctl 190lx ultra lsp 750 pro 
Case
nzxt zero 2 
  hide details  
Reply
post #3 of 9
Are you using the latest CCC? 11.2? I reckon right now those drivers are bugged to all hell get much worse performance on them than I was on 10.xx
Main
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500K Gigabyte P67 UD5 r7970 BEDD Corsair Vengeance 
Hard DriveCoolingOSMonitor
Crucial C300 256gb EK HF supreme full copper Win 7 Ultimate 120hz 1920x1080 23" LG 
KeyboardPowerCaseMouse
Ducky ocn edition 1000w Corsair hx Corsair 800D G9x 
Mouse PadAudio
Steelseries I-2 AKG K702 
  hide details  
Reply
Main
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500K Gigabyte P67 UD5 r7970 BEDD Corsair Vengeance 
Hard DriveCoolingOSMonitor
Crucial C300 256gb EK HF supreme full copper Win 7 Ultimate 120hz 1920x1080 23" LG 
KeyboardPowerCaseMouse
Ducky ocn edition 1000w Corsair hx Corsair 800D G9x 
Mouse PadAudio
Steelseries I-2 AKG K702 
  hide details  
Reply
post #4 of 9
Thread Starter 
Quote:
Originally Posted by oconoc View Post
did you notice the graphics performance before or after you did the overclock to your cpu?
The cpu was OC'd already when I installed the card and had been for a few months. The card was working perfect when I installed it for about 5 days. Correct it is the newest CCC 11.2. I have since pulled the card and reinstalled the integrated graphics. Did not fix problem. Edges of fonts and areas of shading/color changes in graphics appear pixelated. Although I probably replaced the older drivers which I no longer have with the newest ones. Does this sound like software? My biggest concern is that I damaged something on the board perhaps. Maybe try an older version of CCC? I just purchased a new hard drive because I can't stand the noise of the old one and I wanted a faster one. Maybe a clean install of windows will solve problem? I'm stumped (and frustrated)
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k Asus P8Z68-V Radeon HD4670 Samsung MV-3V2G3D/US low profile  
Hard DriveHard DriveHard DriveOptical Drive
Samsung HD503HI  Samsung 830 Series SSD 128 GB Samsung HD155UI Lite-on IHOS-104 Blu Ray 
CoolingOSMonitorKeyboard
Thermalright Silver Arrow Win 7 Professional HP LP2065 20" LCD Cherry MX Board 3.0 
PowerCaseAudio
Antec Earthwatts EA380D Fractal Design Arc Midi Klipsch THX 
  hide details  
Reply
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k Asus P8Z68-V Radeon HD4670 Samsung MV-3V2G3D/US low profile  
Hard DriveHard DriveHard DriveOptical Drive
Samsung HD503HI  Samsung 830 Series SSD 128 GB Samsung HD155UI Lite-on IHOS-104 Blu Ray 
CoolingOSMonitorKeyboard
Thermalright Silver Arrow Win 7 Professional HP LP2065 20" LCD Cherry MX Board 3.0 
PowerCaseAudio
Antec Earthwatts EA380D Fractal Design Arc Midi Klipsch THX 
  hide details  
Reply
post #5 of 9
Try the older drivers, make sure you properly scrub the old ones, don't just blind install over the top. Aside from that I have no idea, possibly if it is software then a reinstall will fix it.
Main
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500K Gigabyte P67 UD5 r7970 BEDD Corsair Vengeance 
Hard DriveCoolingOSMonitor
Crucial C300 256gb EK HF supreme full copper Win 7 Ultimate 120hz 1920x1080 23" LG 
KeyboardPowerCaseMouse
Ducky ocn edition 1000w Corsair hx Corsair 800D G9x 
Mouse PadAudio
Steelseries I-2 AKG K702 
  hide details  
Reply
Main
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500K Gigabyte P67 UD5 r7970 BEDD Corsair Vengeance 
Hard DriveCoolingOSMonitor
Crucial C300 256gb EK HF supreme full copper Win 7 Ultimate 120hz 1920x1080 23" LG 
KeyboardPowerCaseMouse
Ducky ocn edition 1000w Corsair hx Corsair 800D G9x 
Mouse PadAudio
Steelseries I-2 AKG K702 
  hide details  
Reply
post #6 of 9
If pulling the card didn't solve it, I guess I can safely say the 4670 is fine. Its probably a driver issue; Completely remove catalyst 11.2 ( and from other user experience, install either a newer or older version if you want) and see the outcome. If a driver reinstall doesn't fix it, let's blame windows and do a clean install.

Oh, does this happen in safemode as well?
The Dark Knight
(13 items)
 
Rebirth
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5 2500K. 4.5Ghz (Summer Clocks) ASUS P8P67 Pro ( Rev 3.0 ) MSI 6970 Lightning (downclocked) CFX with MSI 6... 8GB G.Skill Sniper 1600Mhz 
Hard DriveOptical DriveOSMonitor
1 TB Spinpoint F3 +2TB F4(backups) Random LG drive Win7 SP1 64bit ASUS VH236H @1080p 
KeyboardPowerCase
Saitek Gaming keyboard ... >_> Corsair TX750 Rosewill Gear x3 
CPUMotherboardGraphicsRAM
C2D P8600 @ 2.4Ghz (undervolted) Crappy dell Studio XPS one 4670M (1GB) I don't remember... 
Hard DriveOptical DriveOSMonitor
Crucial M4 4x Blu-ray ROM Win7 SP1 64bit 15.6" WLED @ 1080p 
KeyboardPower
Old Saitek Gaming Keyboard 90W adapter 
  hide details  
Reply
The Dark Knight
(13 items)
 
Rebirth
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5 2500K. 4.5Ghz (Summer Clocks) ASUS P8P67 Pro ( Rev 3.0 ) MSI 6970 Lightning (downclocked) CFX with MSI 6... 8GB G.Skill Sniper 1600Mhz 
Hard DriveOptical DriveOSMonitor
1 TB Spinpoint F3 +2TB F4(backups) Random LG drive Win7 SP1 64bit ASUS VH236H @1080p 
KeyboardPowerCase
Saitek Gaming keyboard ... >_> Corsair TX750 Rosewill Gear x3 
CPUMotherboardGraphicsRAM
C2D P8600 @ 2.4Ghz (undervolted) Crappy dell Studio XPS one 4670M (1GB) I don't remember... 
Hard DriveOptical DriveOSMonitor
Crucial M4 4x Blu-ray ROM Win7 SP1 64bit 15.6" WLED @ 1080p 
KeyboardPower
Old Saitek Gaming Keyboard 90W adapter 
  hide details  
Reply
post #7 of 9
Thread Starter 
Quote:
Originally Posted by dklimitless View Post
If pulling the card didn't solve it, I guess I can safely say the 4670 is fine. Its probably a driver issue; Completely remove catalyst 11.2 ( and from other user experience, install either a newer or older version if you want) and see the outcome. If a driver reinstall doesn't fix it, let's blame windows and do a clean install.

Oh, does this happen in safemode as well?
I tried booting in safe mode, did not help. I also swept for spyware/malware/viruses. Guess I will try a different driver version. I will keep you all posted on the outcome. I appreciate the input!

It is so strange how 3D graphics are fine but 2D is compromised. Although this didn't help me I found an interesting article about some advanced graphic cards that have problems rendering simple 2d graphics in certain environments.
http://www.tomshardware.com/reviews/...-gdi,2539.html
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k Asus P8Z68-V Radeon HD4670 Samsung MV-3V2G3D/US low profile  
Hard DriveHard DriveHard DriveOptical Drive
Samsung HD503HI  Samsung 830 Series SSD 128 GB Samsung HD155UI Lite-on IHOS-104 Blu Ray 
CoolingOSMonitorKeyboard
Thermalright Silver Arrow Win 7 Professional HP LP2065 20" LCD Cherry MX Board 3.0 
PowerCaseAudio
Antec Earthwatts EA380D Fractal Design Arc Midi Klipsch THX 
  hide details  
Reply
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k Asus P8Z68-V Radeon HD4670 Samsung MV-3V2G3D/US low profile  
Hard DriveHard DriveHard DriveOptical Drive
Samsung HD503HI  Samsung 830 Series SSD 128 GB Samsung HD155UI Lite-on IHOS-104 Blu Ray 
CoolingOSMonitorKeyboard
Thermalright Silver Arrow Win 7 Professional HP LP2065 20" LCD Cherry MX Board 3.0 
PowerCaseAudio
Antec Earthwatts EA380D Fractal Design Arc Midi Klipsch THX 
  hide details  
Reply
post #8 of 9
My 4670M has served me pretty well ( I even overclock it on occasion and its still stable ... and this is a laptop ).

Ok, if safemode doesn't work and its a software issue, then something might be wrong with the core windows files. Do you have a second installation/harddrive to test with?

Until then, lets see how the different driver works.
(also, I'd love to see pics of the problem is you can get us some ^_^ )
The Dark Knight
(13 items)
 
Rebirth
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5 2500K. 4.5Ghz (Summer Clocks) ASUS P8P67 Pro ( Rev 3.0 ) MSI 6970 Lightning (downclocked) CFX with MSI 6... 8GB G.Skill Sniper 1600Mhz 
Hard DriveOptical DriveOSMonitor
1 TB Spinpoint F3 +2TB F4(backups) Random LG drive Win7 SP1 64bit ASUS VH236H @1080p 
KeyboardPowerCase
Saitek Gaming keyboard ... >_> Corsair TX750 Rosewill Gear x3 
CPUMotherboardGraphicsRAM
C2D P8600 @ 2.4Ghz (undervolted) Crappy dell Studio XPS one 4670M (1GB) I don't remember... 
Hard DriveOptical DriveOSMonitor
Crucial M4 4x Blu-ray ROM Win7 SP1 64bit 15.6" WLED @ 1080p 
KeyboardPower
Old Saitek Gaming Keyboard 90W adapter 
  hide details  
Reply
The Dark Knight
(13 items)
 
Rebirth
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5 2500K. 4.5Ghz (Summer Clocks) ASUS P8P67 Pro ( Rev 3.0 ) MSI 6970 Lightning (downclocked) CFX with MSI 6... 8GB G.Skill Sniper 1600Mhz 
Hard DriveOptical DriveOSMonitor
1 TB Spinpoint F3 +2TB F4(backups) Random LG drive Win7 SP1 64bit ASUS VH236H @1080p 
KeyboardPowerCase
Saitek Gaming keyboard ... >_> Corsair TX750 Rosewill Gear x3 
CPUMotherboardGraphicsRAM
C2D P8600 @ 2.4Ghz (undervolted) Crappy dell Studio XPS one 4670M (1GB) I don't remember... 
Hard DriveOptical DriveOSMonitor
Crucial M4 4x Blu-ray ROM Win7 SP1 64bit 15.6" WLED @ 1080p 
KeyboardPower
Old Saitek Gaming Keyboard 90W adapter 
  hide details  
Reply
post #9 of 9
Thread Starter 
Quote:
Originally Posted by dklimitless View Post
My 4670M has served me pretty well ( I even overclock it on occasion and its still stable ... and this is a laptop ).

Ok, if safemode doesn't work and its a software issue, then something might be wrong with the core windows files. Do you have a second installation/harddrive to test with?

Until then, lets see how the different driver works.
(also, I'd love to see pics of the problem is you can get us some ^_^ )
I'm waiting for my new hard drive to be shipped to me. I deleted all CCC software and drivers and installed an older version... 10.6. The problem is not solved. I would like to show an image so you may see exactly what I am talking about, however I think that the problem is the way the images are rendered so these problems will not be visible to you if I attach an image. It is very subtle, but I can see it. Pictures I know very well that I've had for many years appear different, more pixelated. I do have the 2d benchmarks to compare to the integrated chipset. You can see that my card is performing worse than the stock graphics. My earlier benchmarks were even worse. If there is any other info you would like please do tell me.
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k Asus P8Z68-V Radeon HD4670 Samsung MV-3V2G3D/US low profile  
Hard DriveHard DriveHard DriveOptical Drive
Samsung HD503HI  Samsung 830 Series SSD 128 GB Samsung HD155UI Lite-on IHOS-104 Blu Ray 
CoolingOSMonitorKeyboard
Thermalright Silver Arrow Win 7 Professional HP LP2065 20" LCD Cherry MX Board 3.0 
PowerCaseAudio
Antec Earthwatts EA380D Fractal Design Arc Midi Klipsch THX 
  hide details  
Reply
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k Asus P8Z68-V Radeon HD4670 Samsung MV-3V2G3D/US low profile  
Hard DriveHard DriveHard DriveOptical Drive
Samsung HD503HI  Samsung 830 Series SSD 128 GB Samsung HD155UI Lite-on IHOS-104 Blu Ray 
CoolingOSMonitorKeyboard
Thermalright Silver Arrow Win 7 Professional HP LP2065 20" LCD Cherry MX Board 3.0 
PowerCaseAudio
Antec Earthwatts EA380D Fractal Design Arc Midi Klipsch THX 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Problems with Radeon 4670