Overclock.net › Forums › Cooling › Water Cooling › X2O 750 12V Pump/Reservoir is very loud - w/ video! - UPDATE 3-30-2011
New Posts  All Forums:Forum Nav:

X2O 750 12V Pump/Reservoir is very loud - w/ video! - UPDATE 3-30-2011

post #1 of 16
Thread Starter 

Brand new setup ... got the RS240 kit, everything looked great.

flushed the rad, only one little spec of black came out, did it a few more times, looked great.

I hook up the loop, and all I hear is this annoying rattle, like the pump is just .. rattling inside the little cage. Is there anything I can do to fix it, or RMA?

This thing is brand new.


update :

XSPC sent me a new one, which is much quieter .
Edited by vivithemage - 3/30/11 at 6:17am
post #2 of 16
Is the unit itself loud, or is the noise caused by vibrations against the case?
post #3 of 16
Thread Starter 
watch the video?

it sounds like the pump itself is rattling inside the acrylic.
post #4 of 16
I had the same issue. I even took the pump out of the case and ran it. It was loud. I contacted XSPC via jab-tech. I sent XSPC a video of how loud the pump was. They sent me a replacement pump and it is all good now. Some of these XSPC pumps has been really crappy.
Wife's bane
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.5 Ghz Gigabyte Z77 UD3H HIS R9-290 8 GB Samsung Wonder RAM 
Hard DriveHard DriveOptical DriveCooling
Crucial SSD for OS Samsung Spinpoint F3 Asus XSPC water block, 360 radiator, and 720 reservo... 
CoolingOSMonitorKeyboard
GPU cooling - XSPC Razer full GPU blocks Win 7 Home Premium Asus PB278Q 2560 X 1440p ISP Logitech G15 
PowerCaseMouseMouse Pad
NZXT Hale90 V2 NZXT Switch 810 Logitech G500 Steelseries QcK 
Audio
Optical out to Sony receiver; Deftech Monitor 3... 
  hide details  
Reply
Wife's bane
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.5 Ghz Gigabyte Z77 UD3H HIS R9-290 8 GB Samsung Wonder RAM 
Hard DriveHard DriveOptical DriveCooling
Crucial SSD for OS Samsung Spinpoint F3 Asus XSPC water block, 360 radiator, and 720 reservo... 
CoolingOSMonitorKeyboard
GPU cooling - XSPC Razer full GPU blocks Win 7 Home Premium Asus PB278Q 2560 X 1440p ISP Logitech G15 
PowerCaseMouseMouse Pad
NZXT Hale90 V2 NZXT Switch 810 Logitech G500 Steelseries QcK 
Audio
Optical out to Sony receiver; Deftech Monitor 3... 
  hide details  
Reply
post #5 of 16
Thread Starter 
okay, guess i'll get in touch with jab, since that is where i bought it.

how'd you open it up to look at the pump? I thought it was sealed.

how was your replacement?
post #6 of 16
Quote:
Originally Posted by vivithemage View Post
watch the video?
I would, but I don't think I can install Flash on this computer. Sorry.

Quote:
Originally Posted by vivithemage View Post
it sounds like the pump itself is rattling inside the acrylic.
If that's the case, I think a RMA is your best option.
post #7 of 16
Hey I had the same thing. I contacted xspc and they asked for video. Sent them one and I got a new one in about a week. Second one started out quiet but then started getting louder. So I took one put a hose from outlet to inlet and filled it with 50/50 antifreeze just for kicks. Started it up and it was silent. tried it in second and it too is now silent. thought it was strange. maybe because its thicker. it does run about 2c warmer though using antifreeze.
post #8 of 16
Yeah, I'd RMA.
post #9 of 16
Thread Starter 
I RMA'd, new one is much quiter, MUCH. Shipment came from China, within 2-3 days!

IF the new one gets louder, are you running 50/50 with antifreeze constantly now? Wont that eventually gunk it up?
post #10 of 16
Thread Starter 
Are these possible to open up? I am curious, i'd like to see if I could fix the old one...

and is that CAR Antifreeze you used?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › X2O 750 12V Pump/Reservoir is very loud - w/ video! - UPDATE 3-30-2011