post #1 of 1
Thread Starter 
So I have this weird issue with my bro's computer. I installed a new mobo,processor,ram. (it was working fine before, but he wanted an upgrade for his b-day)

He had previously a little belkin wireless adapter.

ANYWAYS I reformat, reinstall vista (ewww) install new Belkin drivers that came on CD......and now the Adapter WILL connect but it will always say "Limited or no Connectivity"

It worked before the reformat? and the reformat went fine, and our home network (unsecured because we live SO far away from any other houses) shows up on the list......but connects but with limited connectivity (aka no internet)

Any ideas? it worked before. I've even tried reinstalling the Drivers like 3 times......I dunno what to do?

edit: By the way the router/modem is working because I have another computer wireless connected and it works fine, and my brothers computer IS in range (4 bars) although weirdly when it says "Limited or No Connectivity" it drops down to 2 bars..... but it worked before in the same place so I have no idea?
Edited by Mercfh - 3/25/11 at 6:25am