Overclock.net › Forums › Graphics Cards › NVIDIA › NVIDIA GTX 590 Owners Club
New Posts  All Forums:Forum Nav:

NVIDIA GTX 590 Owners Club - Page 108

post #1071 of 5154
Quote:
Originally Posted by rush2049 View Post
When I go from 612 mhz and force 630 or 631 mhz the vcore jumps to
core1: .913
core2: .912

Then after ~15 seconds falls back to idle voltage of .875 on both cores.

When running furmark with forced 630mhz voltages stay at:
core1: .913
core2: .912

When running furmark with stock 612mhz voltages stay at:
core1: .913
core2: .912


I find it interesting that the idle voltage is equal, but the 3d mode voltage is not... Maybe one of them is a better sample, but chances are that the cherry picked chips were paired to be very close..... and they should be set equal, not having one be suffocated of energy.


edit:
done with msi afterburner v2.2.0 Beta 2
Thats exactly the voltages I would expect for an ASUS GTX 590. When overclocking, about every 23~27 MHz requires +12/13mv for stability. That would put it right inline with EVGA's over the stock 607 / 0.913v cores. Also why ASUS would not need 0.925v, and 1 mV of variation is perfectly fine. However, having 13mV is not due to the stability.

Are your BIOS's the same in GPU-z for each GPU?
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
post #1072 of 5154
wow, you spotted that one quick, I didn't notice, but no they are not....

GPU1 Bios: 70.10.37.00.02
GPU2 Bios: 70.10.37.00.01


And this is an Asus 590 that has not used Asus's custom new bios.....
 
Tragbar
(14 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1800X Asus Crosshair VI Hero Nvidia Geforce Titan X F4-3600C15D-16GTZ 
Hard DriveHard DriveHard DriveHard Drive
Combined: 6.13 TB of space Samsung SSD 960 EVO 500GB Crucial_CT1050MX300SSD1 M4-CT128M4SSD2 
CoolingCoolingCoolingCooling
EK-Supremacy EVO White Edition PrimoChill PrimoFlex Advanced LRT EK-RES X4 250 (R2.0) Reservoir EK-CoolStream XE 360 
CoolingCoolingCoolingOS
EK-Vardar F4-120ER (2200rpm)  EK-Ekoolant EVO Liquid Coolant EK-XTOP Revo D5 PWM Pump Windows 10 Pro 
MonitorKeyboardPowerCase
Asus VG278H Ducky YOTG Keyboard Corsair AX1200 Corsair Obsidian 800D 
MouseAudioAudioAudio
Logitech G700s Schiit Gungnir Multibit Schiit Mjolnir 2 Schiit LISST 
Audio
Audeze LCD 2 - pre fazor 
CPUMotherboardGraphicsRAM
intel i7 4770K ASRock Z87E-ITX Nvidia Geforce GTX Titan X GSkill F3-2400C10D-16GTX R 
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro 512GB Silverstone 12.7mm Slot Load Blu-Ray Burner Noctua NH-L12 Windows 8 Pro 
MonitorCaseAudioAudio
LG PA75U Slim LED Projector Silverstone SG08 Schiit Bifrost Schiit Asgard 2 
AudioOther
AKG Q701 Headphones Pelican 1510 Green Case  
  hide details  
Reply
 
Tragbar
(14 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1800X Asus Crosshair VI Hero Nvidia Geforce Titan X F4-3600C15D-16GTZ 
Hard DriveHard DriveHard DriveHard Drive
Combined: 6.13 TB of space Samsung SSD 960 EVO 500GB Crucial_CT1050MX300SSD1 M4-CT128M4SSD2 
CoolingCoolingCoolingCooling
EK-Supremacy EVO White Edition PrimoChill PrimoFlex Advanced LRT EK-RES X4 250 (R2.0) Reservoir EK-CoolStream XE 360 
CoolingCoolingCoolingOS
EK-Vardar F4-120ER (2200rpm)  EK-Ekoolant EVO Liquid Coolant EK-XTOP Revo D5 PWM Pump Windows 10 Pro 
MonitorKeyboardPowerCase
Asus VG278H Ducky YOTG Keyboard Corsair AX1200 Corsair Obsidian 800D 
MouseAudioAudioAudio
Logitech G700s Schiit Gungnir Multibit Schiit Mjolnir 2 Schiit LISST 
Audio
Audeze LCD 2 - pre fazor 
CPUMotherboardGraphicsRAM
intel i7 4770K ASRock Z87E-ITX Nvidia Geforce GTX Titan X GSkill F3-2400C10D-16GTX R 
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro 512GB Silverstone 12.7mm Slot Load Blu-Ray Burner Noctua NH-L12 Windows 8 Pro 
MonitorCaseAudioAudio
LG PA75U Slim LED Projector Silverstone SG08 Schiit Bifrost Schiit Asgard 2 
AudioOther
AKG Q701 Headphones Pelican 1510 Green Case  
  hide details  
Reply
post #1073 of 5154
Okay.... well I half hoped that it was indicative of there being an error in EVGA's cards, and the fix would be flash both to the same GPU version. I wouldn't do that, but just food for thought. For instance thinking or assuming .02 is newer than .01, but I doubt thats the case now that you have repoorted the same.

It may very well be how they differentiate between .01 is GPU1 and .02 is GPU2, maybe how they know how to flash which BIOS to which GPU. That also leads me to the conclusion that perhaps nvFlash is extremely risky. If the nVflash flashes each bios to whatever GPU it finds willy nilly, you could definitely end up with a bricked card. On the other hand, if nvflash ONLY recognizes GPU1 for BIOS .01, and the same for GPU2 with BIOS .02, then it would work with no problems.

I find it strange they would need two different BIOS, but then dual-gpu cards are a new territory for me.
Edited by RagingCain - 4/25/11 at 10:18am
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
post #1074 of 5154
Thread Starter 
Quote:
Originally Posted by Masked View Post
I wish to withdraw from this "club" please, Alatar.
if that's what you want. You're welcome back at any time.
 
Benching
(17 items)
 
 
CPUMotherboardGraphicsRAM
[i7 5960X @ 4.8GHz] [Rampage V Extreme] [Titan 1400MHz (1500MHz bench)] [Various] 
Hard DriveCoolingCoolingCooling
[250GB 840EVO +2x SpinpointF3 1TB RAID0] [LD PC-V2 SS Phase Change] [XSPC X2O 750 pump/res] [Monsta 360 full copper + EK XT 360 + XT 240] 
MonitorPowerCaseAudio
[Crossover 27Q LED-P 1440p+ASUS 1200p+LG 1080p] [Corsair AX1200] [Dimastech Easy v3.0] [Sennheiser HD558s] 
CPUCPUMotherboardGraphics
FX 8320, FX 8350, Phenom II x2 555BE i7 3930K, i7 860, i7 4770K, 68x Celeron D CVF, commando, 2x RIVE, Z87X-OC Asus 4870x2, Sapphire 4870 
GraphicsGraphicsGraphicsGraphics
2x 5870, 5850, 5830, 5770 2x 3870x2, 3870 GTX Titan, GTX 480, GTX 590 GTX 285, GTX 260, 4x 9800GT, 8800GTX 
RAMHard DriveCoolingCooling
4x4GB vengeance, 2x4GB predatorX, 2x1GB OCZ DDR2 Intel X25-M 80GB LD PC-V2 SS Phase Change OCN Marksman 
CoolingCoolingOSPower
2x old tek slims (GPU) Various watercooling stuff win7, winxp AX1200 
Case
test bench / cardboard box 
  hide details  
Reply
 
Benching
(17 items)
 
 
CPUMotherboardGraphicsRAM
[i7 5960X @ 4.8GHz] [Rampage V Extreme] [Titan 1400MHz (1500MHz bench)] [Various] 
Hard DriveCoolingCoolingCooling
[250GB 840EVO +2x SpinpointF3 1TB RAID0] [LD PC-V2 SS Phase Change] [XSPC X2O 750 pump/res] [Monsta 360 full copper + EK XT 360 + XT 240] 
MonitorPowerCaseAudio
[Crossover 27Q LED-P 1440p+ASUS 1200p+LG 1080p] [Corsair AX1200] [Dimastech Easy v3.0] [Sennheiser HD558s] 
CPUCPUMotherboardGraphics
FX 8320, FX 8350, Phenom II x2 555BE i7 3930K, i7 860, i7 4770K, 68x Celeron D CVF, commando, 2x RIVE, Z87X-OC Asus 4870x2, Sapphire 4870 
GraphicsGraphicsGraphicsGraphics
2x 5870, 5850, 5830, 5770 2x 3870x2, 3870 GTX Titan, GTX 480, GTX 590 GTX 285, GTX 260, 4x 9800GT, 8800GTX 
RAMHard DriveCoolingCooling
4x4GB vengeance, 2x4GB predatorX, 2x1GB OCZ DDR2 Intel X25-M 80GB LD PC-V2 SS Phase Change OCN Marksman 
CoolingCoolingOSPower
2x old tek slims (GPU) Various watercooling stuff win7, winxp AX1200 
Case
test bench / cardboard box 
  hide details  
Reply
post #1075 of 5154
Quote:
Originally Posted by RagingCain View Post
Okay.... well I half hoped that it was indicative of there being an error in EVGA's cards, and the fix would be flash both to the same GPU version. I wouldn't do that, but just food for thought. For instance thinking or assuming .02 is newer than .01, but I doubt thats the case now that you have repoorted the same.

It may very well be how they differentiate between .01 is GPU1 and .02 is GPU2, maybe how they know how to flashing which BIOS to which GPU. That also leads me to the conclusion that perhaps nvFlash is extremely risky. If the nVflash's each bios to whatever GPU it finds willy nilly, you could definitely end up with a brick card. On the other hand, if nvflash ONLY recognizes GPU1 for BIOS .01, and the same for GPU2 with BIOS .02, then it would worky with no problems.

I find it strange they would need two different BIOS, but then dual-gpu cards are a new territory for me.
This is pretty usual on dual GPU cards, my 5970 has master and slave bios, the 295 was that way too...
Temp Derp
(21 items)
 
  
CPUMotherboardGraphicsRAM
2600K MSI Mpower Z77 7970 Reference G.Skill RipjawsZ 4x4GB 
Hard DriveHard DriveCoolingCooling
OCZ Vertex 4 Seagate Barracuda 7200.11 Apogee HD XSPC RX360 V2 
CoolingCoolingCoolingOS
EKFC-7970NA Swiftech D5 XSPC Dual Bay D5 Reservoir Windows 8.1 
MonitorMonitorKeyboardPower
Overlord Tempest X270OC (@114Hz) Dell U2412m Ducky DK-9008 Corsair TX950 V1 
CaseMouseMouse PadAudio
Cooler Master CM290 Logitech G600 - Razer Naga Epic Steelseries 9HD Asus Essence STX 
Audio
Denon AH-D2000 
  hide details  
Reply
Temp Derp
(21 items)
 
  
CPUMotherboardGraphicsRAM
2600K MSI Mpower Z77 7970 Reference G.Skill RipjawsZ 4x4GB 
Hard DriveHard DriveCoolingCooling
OCZ Vertex 4 Seagate Barracuda 7200.11 Apogee HD XSPC RX360 V2 
CoolingCoolingCoolingOS
EKFC-7970NA Swiftech D5 XSPC Dual Bay D5 Reservoir Windows 8.1 
MonitorMonitorKeyboardPower
Overlord Tempest X270OC (@114Hz) Dell U2412m Ducky DK-9008 Corsair TX950 V1 
CaseMouseMouse PadAudio
Cooler Master CM290 Logitech G600 - Razer Naga Epic Steelseries 9HD Asus Essence STX 
Audio
Denon AH-D2000 
  hide details  
Reply
post #1076 of 5154
Quote:
Originally Posted by armartins View Post
This is pretty usual on dual GPU cards, my 5970 has master and slave bios, the 295 was that way too...
Ah, okay, very cool. Thanks for that tidbit, I learn something new everday I assumed as much.

Spoke to EVGA_Jacob, and they are looking into the information I have brought up, I asked permission to share that message with you guys.

Just that though, no promises, however EVGA support is top notch in my book, and if there really is a problem they can find/fix it. If not, the temporary solution is still working.
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
post #1077 of 5154
So raging what you're trying to say is that the GPU's are incorrectly volted and they fluctuate on some cards hence causing instability? I'd be glad to help out, I'll check the BIOS' and voltages again for you tomorrow if this is all you needed?

And lets stop freaking arguing over these damn cards and lets start being constructive on how we can improve milk them for performance.
post #1078 of 5154
Quote:
Originally Posted by ReignsOfPower View Post
So raging what you're trying to say is that the GPU's are incorrectly volted and they fluctuate on some cards hence causing instability? I'd be glad to help out, I'll check the BIOS' and voltages again for you tomorrow if this is all you needed?

And lets stop freaking arguing over these damn cards and lets start being constructive on how we can improve milk them for performance.
I am a nobody, I am just some guy.

I whole heartedly believe that even at stock settings, there may have been stability issues right out of the box for EVGA users due to this tiny vCore difference. I tested every 10 Mhz on this all the way up to 830. I know what difference 12~13mv of vcore can do. I just initially made the mistake of waving off the voltage as just fluctuation or within acceptable parameters, but even still its really hard to see the errors. I mean its fairly common to have a benchmark stutter for us due to what we thought was just new drivers for a new card.

I mean we probably didn't think anything of it. However, it makes a lot of sense to me now, that many people who had crashing benchmarks and performance issues at stock could have that at least fixed. I am sure there will still be quite a few errors for us to diagnose and we still have the aggressive OCP, but I believe this is 100% slam dunk spot on bug w/ fix.
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
post #1079 of 5154
One bios is the master and one is the slave bios.
largerthanlife v3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7 3820 @4.8 asrock fatal1ty pro 3 way sli gtx titan kingston hyper x beast  
Hard DriveCoolingOSMonitor
samsung 250gb ssd custom water loop windows 8 pro 3 lg 2560x1600 
KeyboardPowerCaseMouse
logitek g11 lepa 1600w mountain mods acension r.a.t. 7 
  hide details  
Reply
largerthanlife v3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7 3820 @4.8 asrock fatal1ty pro 3 way sli gtx titan kingston hyper x beast  
Hard DriveCoolingOSMonitor
samsung 250gb ssd custom water loop windows 8 pro 3 lg 2560x1600 
KeyboardPowerCaseMouse
logitek g11 lepa 1600w mountain mods acension r.a.t. 7 
  hide details  
Reply
post #1080 of 5154
Yup it only recognizes .01 and .02 u can't write the .02 bios to the .01 or via versa bc it will not find a match unless u force it via command such would be really stupid..01 can only be flashed to .01
largerthanlife v3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7 3820 @4.8 asrock fatal1ty pro 3 way sli gtx titan kingston hyper x beast  
Hard DriveCoolingOSMonitor
samsung 250gb ssd custom water loop windows 8 pro 3 lg 2560x1600 
KeyboardPowerCaseMouse
logitek g11 lepa 1600w mountain mods acension r.a.t. 7 
  hide details  
Reply
largerthanlife v3
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7 3820 @4.8 asrock fatal1ty pro 3 way sli gtx titan kingston hyper x beast  
Hard DriveCoolingOSMonitor
samsung 250gb ssd custom water loop windows 8 pro 3 lg 2560x1600 
KeyboardPowerCaseMouse
logitek g11 lepa 1600w mountain mods acension r.a.t. 7 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › NVIDIA GTX 590 Owners Club