Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 32.0.3: 8 October [Firefox 64-Bit]
New Posts  All Forums:Forum Nav:

Waterfox 32.0.3: 8 October [Firefox 64-Bit] - Page 394

post #3931 of 6180
Really? I've used Chrome for years now and never had a single crash. =\ Never had Firefox/Waterfox crashing either with Flash. Very odd.
    
CPUMotherboardGraphicsRAM
Intel Core i7-4970K 4.0GHz ASUS MAXIMUS VII FORMULA LGA 1150 Intel Z97 HDM... ASUS DirectCU II OC Radeon R9 290X 4GB GDDR5 PC... Team Xtreem 16GB (2 x 8GB) 2666MHz CL11 DDR3 RAM 
Hard DriveHard DriveHard DriveHard Drive
SAMSUNG 840 Pro Series 256GB SATA III SSD (Wind... SAMSUNG 840 Pro Series 128GB SATA III SSD (Mac) SAMSUNG 850 Pro Series 128GB SATA III SSD (Ubuntu) HGST Deskstar NAS H3IKNAS40003272SN(0S03664) 4T... 
Hard DriveHard DriveHard DriveOptical Drive
HGST Deskstar NAS H3IKNAS40003272SN(0S03664) 4T... HGST Deskstar NAS H3IKNAS40003272SN(0S03664) 4T... HGST Deskstar NAS H3IKNAS40003272SN(0S03664) 4T... Pioneer BDR-208DBK 15X Internal Blu-ray Burner 
CoolingCoolingCoolingCooling
Alphacool NexXxoS UT60 Full Copper 360mm Radiator Monsoon Series Two Premium D5 / MCP655 Dual Bay... Swiftech MCP655 Variable Speed Pump EK Supremacy EVO Universal CPU Liquid Cooling B... 
CoolingCoolingCoolingCooling
PrimoChill PrimoFlex Advanced LRT 3/8" ID x 5/8... Koolance QD3 Quick Disconnect Black Male 3/8” I... Koolance QD3 Quick Disconnect Black Female Thre... Mayhems Pastel Gigabyte Orange Coolant 
CoolingOSOSOS
Noctua NF-F12 PWM Fans (Push/Pull) Windows 8.1 Pro WMC 64-bit Mac OS X Yosemite 10.10 Ubuntu 14.10 Utopic Unicorn 64-bit 
MonitorKeyboardPowerCase
QNIX QX2710 LED Evolution ll 27" 2560x1440 WQHD... Razer BlackWidow Ultimate 2014 Mechanical Gamin... EVGA Supernova 1200 P2 80 PLUS PLATINUM Certifi... Phanteks Enthoo Primo White Full Tower Case 
MouseMouse PadAudioAudio
Logitech G502 Proteus Core Tunable Gaming Mouse Logitech G440 Hard Gaming Mouse Pad Schiit Audio Bifrost USB DAC (Uber Analog + USB... Audioengine A5+ Powered Speakers 
Other
Drobo USB 3.0 4-Bay Storage Array (DDR3A21) 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7-4970K 4.0GHz ASUS MAXIMUS VII FORMULA LGA 1150 Intel Z97 HDM... ASUS DirectCU II OC Radeon R9 290X 4GB GDDR5 PC... Team Xtreem 16GB (2 x 8GB) 2666MHz CL11 DDR3 RAM 
Hard DriveHard DriveHard DriveHard Drive
SAMSUNG 840 Pro Series 256GB SATA III SSD (Wind... SAMSUNG 840 Pro Series 128GB SATA III SSD (Mac) SAMSUNG 850 Pro Series 128GB SATA III SSD (Ubuntu) HGST Deskstar NAS H3IKNAS40003272SN(0S03664) 4T... 
Hard DriveHard DriveHard DriveOptical Drive
HGST Deskstar NAS H3IKNAS40003272SN(0S03664) 4T... HGST Deskstar NAS H3IKNAS40003272SN(0S03664) 4T... HGST Deskstar NAS H3IKNAS40003272SN(0S03664) 4T... Pioneer BDR-208DBK 15X Internal Blu-ray Burner 
CoolingCoolingCoolingCooling
Alphacool NexXxoS UT60 Full Copper 360mm Radiator Monsoon Series Two Premium D5 / MCP655 Dual Bay... Swiftech MCP655 Variable Speed Pump EK Supremacy EVO Universal CPU Liquid Cooling B... 
CoolingCoolingCoolingCooling
PrimoChill PrimoFlex Advanced LRT 3/8" ID x 5/8... Koolance QD3 Quick Disconnect Black Male 3/8” I... Koolance QD3 Quick Disconnect Black Female Thre... Mayhems Pastel Gigabyte Orange Coolant 
CoolingOSOSOS
Noctua NF-F12 PWM Fans (Push/Pull) Windows 8.1 Pro WMC 64-bit Mac OS X Yosemite 10.10 Ubuntu 14.10 Utopic Unicorn 64-bit 
MonitorKeyboardPowerCase
QNIX QX2710 LED Evolution ll 27" 2560x1440 WQHD... Razer BlackWidow Ultimate 2014 Mechanical Gamin... EVGA Supernova 1200 P2 80 PLUS PLATINUM Certifi... Phanteks Enthoo Primo White Full Tower Case 
MouseMouse PadAudioAudio
Logitech G502 Proteus Core Tunable Gaming Mouse Logitech G440 Hard Gaming Mouse Pad Schiit Audio Bifrost USB DAC (Uber Analog + USB... Audioengine A5+ Powered Speakers 
Other
Drobo USB 3.0 4-Bay Storage Array (DDR3A21) 
  hide details  
Reply
post #3932 of 6180
Quote:
Originally Posted by JTD121 View Post

Yep, just tried that, and still does it. I must be missing something somewhere....a setting? Couldn't be a plugin that's missing, could it?
And by resetting your preferences (start with shift).
post #3933 of 6180
Quote:
Originally Posted by Lord Venom View Post

Really? I've used Chrome for years now and never had a single crash. =\ Never had Firefox/Waterfox crashing either with Flash. Very odd.
maybe the computer components? I have 2 PC, on the desktop PC no problem with flash (good GC and CPU), with my laptop, crash and freeze are frequently.
post #3934 of 6180
I'm still having issues with opening links from other programs; using Waterfox 15.0, and also the pinned menu items being default icons and not working.

I've dug around in the registry, and I've found (I think) a smoking gun:

HKEY_CLASSES_ROOT\FirefoxURL\shell\open\command

has it's default value set to:

"C:\Program Files\Waterfox\firefox.exe" -requestPending -osint -url "%1"

This would, on the face of it appear to be a bit of a problem. I don't have a firefox.exe in that folder. However, if I create a symbolic link to waterfox.exe from firefox.exe, everything starts working correctly.

I think that although the Waterfox branding inside the executable itself is good, it seems that there's a string substitution missing in the installer, making it point to firefox.exe instead of the (correct) waterfox.exe.

If I change the text "firefox.exe" in this registry entry to "waterfox.exe" then URLs clicked from other applications start working again.
The only way I can get the jumplist from the taskbar working correctly is by creating the aforementioned symlink from firefox.exe to waterfox.exe in the porgram's install directory.

I'll assume (but haven't dug for yet - as I'm unsure how they work) that the jumplists are likewise a little wrong, thanks to the installer.

Other keys I've found which reference firefox (I don't have firefox installed on my computer) are:

HKEY_CLASSES_ROOT\ftp\Defaultcon
HKEY_CLASSES_ROOT\ftp\shell\open\command
HKEY_CLASSES_ROOT\http\DefaultIcon
HKEY_CLASSES_ROOT\http\shell\open\command
HKEY_CLASSES_ROOT\https\DefaultIcon
HKEY_CLASSES_ROOT\https\shell\open\command

HKEY_CLASSES_ROOT\MacromediaFlashPaper.MacromediaFlashPaper\DefaultIcon
HKEY_CLASSES_ROOT\MacromediaFlashPaper.MacromediaFlashPaper\shell\open\command

Similarly, all these values in HKEY_CURRENT_USER.

HKEY_CURRENT_USER\Software\Clients\StartMenuInternet has a Default value of "FIREFOX.EXE"

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\firefox.exe has a default value containing "c:\Program Files\Waterfox\firefox.exe"

HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Waterfox\13.0 (en-US)\Main has a value "PathToExe" which contains "c:\Program Files\Waterfox\firefox.exe"
HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Waterfox\13.0\bin has a value "PathToExe" which contains "c:\Program Files\Waterfox\firefox.exe"

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Clients\StartMenuInternet\FIREFOX.EXE\Capabilities has a value "ApplicationIcon" with the value: "C:\Program Files\Waterfox\firefox.exe,0"

There are a fair number of places where the string "C:\Program Files\Waterfox\Firefox.exe" appears; too many to list here, but I give you this list as an indication that something seems to have gone wrong with the installer somewhere.
post #3935 of 6180
Thread Starter 

Waterfox 16 will be released next week, with fixed registry entries.

    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Mavericks" 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Mavericks" 
  hide details  
Reply
post #3936 of 6180
Quote:
Originally Posted by kxtcd950 View Post

post reply (Click to show)
I'm still having issues with opening links from other programs; using Waterfox 15.0, and also the pinned menu items being default icons and not working.
I've dug around in the registry, and I've found (I think) a smoking gun:
HKEY_CLASSES_ROOT\FirefoxURL\shell\open\command
has it's default value set to:
"C:\Program Files\Waterfox\firefox.exe" -requestPending -osint -url "%1"
This would, on the face of it appear to be a bit of a problem. I don't have a firefox.exe in that folder. However, if I create a symbolic link to waterfox.exe from firefox.exe, everything starts working correctly.
I think that although the Waterfox branding inside the executable itself is good, it seems that there's a string substitution missing in the installer, making it point to firefox.exe instead of the (correct) waterfox.exe.
If I change the text "firefox.exe" in this registry entry to "waterfox.exe" then URLs clicked from other applications start working again.
The only way I can get the jumplist from the taskbar working correctly is by creating the aforementioned symlink from firefox.exe to waterfox.exe in the porgram's install directory.
I'll assume (but haven't dug for yet - as I'm unsure how they work) that the jumplists are likewise a little wrong, thanks to the installer.
Other keys I've found which reference firefox (I don't have firefox installed on my computer) are:
HKEY_CLASSES_ROOT\ftp\Defaultcon
HKEY_CLASSES_ROOT\ftp\shell\open\command
HKEY_CLASSES_ROOT\http\DefaultIcon
HKEY_CLASSES_ROOT\http\shell\open\command
HKEY_CLASSES_ROOT\https\DefaultIcon
HKEY_CLASSES_ROOT\https\shell\open\command
HKEY_CLASSES_ROOT\MacromediaFlashPaper.MacromediaFlashPaper\DefaultIcon
HKEY_CLASSES_ROOT\MacromediaFlashPaper.MacromediaFlashPaper\shell\open\command
Similarly, all these values in HKEY_CURRENT_USER.
HKEY_CURRENT_USER\Software\Clients\StartMenuInternet has a Default value of "FIREFOX.EXE"
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\firefox.exe has a default value containing "c:\Program Files\Waterfox\firefox.exe"
HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Waterfox\13.0 (en-US)\Main has a value "PathToExe" which contains "c:\Program Files\Waterfox\firefox.exe"
HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Waterfox\13.0\bin has a value "PathToExe" which contains "c:\Program Files\Waterfox\firefox.exe"
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Clients\StartMenuInternet\FIREFOX.EXE\Capabilities has a value "ApplicationIcon" with the value: "C:\Program Files\Waterfox\firefox.exe,0"
There are a fair number of places where the string "C:\Program Files\Waterfox\Firefox.exe" appears; too many to list here, but I give you this list as an indication that something seems to have gone wrong with the installer somewhere
.
For your problem, clean uninstall (delete folders, Ccleaner, ...) and instal again. I know, but it's the better for resolve this problem.
Edited by fullmoon - 10/6/12 at 6:41pm
post #3937 of 6180
13.0 was the only version I could actually install. v14.0, 14.2, and 15.0 just kept giving me an error message about a version of Waterfox either currently already installed or can't be deleted. So I'm thinking the issue is with the new installer that gives you the option to add AVG for the installation because when I installed that version using the same setup installer as Firefox there wasn't an issue.
Edited by DCY - 10/5/12 at 12:29pm
post #3938 of 6180
I was just made aware of a video plugin that doesn't work on Waterfox (but works just fine in firefox) Widevine Used by Showtime Anywhere. Never heard of that plugin until I got the e-mail from my mom about it.
RedMyst
(18 items)
 
   
CPUMotherboardGraphicsGraphics
Intel Core i3/i5/i7 TZ77B NVIDIA GeForce GTX 560 Ti  Powercolor HD 7770 
RAMHard DriveHard DriveOptical Drive
G. Skill Sniper Mushkin Chronos SSD Western Digital 640gb SATA Sony Optiarc AD-7280S-0B 
CoolingOSMonitorMonitor
Coolermaster Hyper 212+ Windows 8 Professional HANNspree 21.5" LED LCD Dell E228WFP 
KeyboardPowerCaseMouse
Microsoft Desktop 400 OCD ModXStream 700 Watt  Coolermaster HAF 912 CM Storm Inferno 
AudioAudio
Creative Labs WoW Soundblaster. Logitech X-140 
CPUMotherboardGraphicsRAM
AMD FX8320 Gigabyte 990FXA-UD3 Asus GTX 770 DC II G.Skill sniper DDR3 1866 
Hard DriveHard DriveCoolingCooling
PNY XLR8 SSD WD Blue 1tb EK L360 watercooling EK Asus DC II GTX 770 
OSPowerCaseMouse
Windows 8.1 Pro OCZ ModXStream 700w Corsair Cube Air 540 Coolermaster Storm Inferno 
  hide details  
Reply
RedMyst
(18 items)
 
   
CPUMotherboardGraphicsGraphics
Intel Core i3/i5/i7 TZ77B NVIDIA GeForce GTX 560 Ti  Powercolor HD 7770 
RAMHard DriveHard DriveOptical Drive
G. Skill Sniper Mushkin Chronos SSD Western Digital 640gb SATA Sony Optiarc AD-7280S-0B 
CoolingOSMonitorMonitor
Coolermaster Hyper 212+ Windows 8 Professional HANNspree 21.5" LED LCD Dell E228WFP 
KeyboardPowerCaseMouse
Microsoft Desktop 400 OCD ModXStream 700 Watt  Coolermaster HAF 912 CM Storm Inferno 
AudioAudio
Creative Labs WoW Soundblaster. Logitech X-140 
CPUMotherboardGraphicsRAM
AMD FX8320 Gigabyte 990FXA-UD3 Asus GTX 770 DC II G.Skill sniper DDR3 1866 
Hard DriveHard DriveCoolingCooling
PNY XLR8 SSD WD Blue 1tb EK L360 watercooling EK Asus DC II GTX 770 
OSPowerCaseMouse
Windows 8.1 Pro OCZ ModXStream 700w Corsair Cube Air 540 Coolermaster Storm Inferno 
  hide details  
Reply
post #3939 of 6180
Quote:
Originally Posted by matada View Post

I was just made aware of a video plugin that doesn't work on Waterfox (but works just fine in firefox) Widevine Used by Showtime Anywhere. Never heard of that plugin until I got the e-mail from my mom about it.
most plugins aren't made for 64bit browsers; some do have a 64bit counterpart, some don't. So sadily unless theres a 64bit version of the plugin it won't work in waterfox.
post #3940 of 6180
Hi guys,
i got this error installing Waterfox on Windows 7, 64 bit. This is the first time i try to install WF.
Code:
[SEH_AV_DEP_BADPTR] ACCESS_VIOLATION (0xc0000005) at address [0x00fd14e9]

*** Stack Trace (x86) ***

[0x00fd14e9]  -----
[0x6f2ae59b]  MsiLoadStringW()
[0x6f2ae537]  MsiLoadStringW()
[0x6f30a58e]  MsiInvalidateFeatureCache()
[0x6f365d12]  MsiGetPropertyW()
[0x01466286]  -----
[0x0147a035]  -----
[0x0147340d]  -----
[0x0147101e]  -----
[0x0146ff9d]  -----
[0x01476f44]  -----
[0x0147bdc9]  -----
[0x7782030a]  LdrGetProcedureAddressEx()
[0x77820382]  LdrGetProcedureAddressEx()
[0x7781e1b2]  RtlFreeAnsiString()
[0x77820358]  LdrGetProcedureAddressEx()
[0x778201e2]  LdrGetProcedureAddress()
[0x0142548d]  -----
[0x01425c05]  -----
[0x014300e2]  -----
[0x77829ef2]  RtlInitializeExceptionChain()
[0x77829ec5]  RtlInitializeExceptionChain()

What's wrong?

Ciao
Andrea
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 32.0.3: 8 October [Firefox 64-Bit]