Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 48.0.2: 06 September [Firefox 64-Bit]
New Posts  All Forums:Forum Nav:

Waterfox 48.0.2: 06 September [Firefox 64-Bit] - Page 265

post #2641 of 7225
Quote:
Originally Posted by oriented View Post

In Firefox, yes it used to jitter every now and then. This tweak was also applied to my Firefox... but now quite happy with Waterfox although does crash on the new Google map interface.

But as I've said, I have no problems with Firefox playing youtube videos?
post #2642 of 7225
Thread Starter 
Quote:
Originally Posted by omeyg View Post

Since installing Waterfox V13 PL1, the tabs dont seem to be working properly.

Waterfox is supposed to open up the tabs that were open in the previous session but now opens up a blank new tab everytime regardless of the browser settings.

The group tabs button also seems to be stuffing up. When I click the group tabs button, nothing happens...

Somehow by trial and error I can manage to reach the group tabs screen but when I click on a tab in the group it doesnt load in the window and I have to end the session before I can use Waterfox normally.

I tried reinstalling the Waterfox V12 but the problem is now "permanent".

I would like to solve these problems and run them on Waterfox V13 PL1. The tabs were one of the few reasons that I would still use Waterfox so I am disappointed about this recent update.

Any ideas as to solve this problem? Should I reinstall Waterfox V13 PL1 again?

 

Try Firefox and tell me if you get the same problem? If not, have you tried a different profile?

    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
post #2643 of 7225
Quote:
Originally Posted by kevindd992002 View Post

Ok, thanks. If it's not too much to ask, can you add this tweak in your list of tweaks here? smile.gif I follow that list whenever I delete my profile.
EDIT: By the way, I followed your steps in applying the minimize tweak but it seems to not work? The RAM usage is not dropping to a lower amount when I minimize WF.

you can try with this Addon

506

https://addons.mozilla.org/en-US/firefox/addon/configuration-mania-4420/

.....
extra tweak for smoother page rendering smile.gif
497
post #2644 of 7225
Quote:
Originally Posted by TheHunter View Post

you can try with this Addon
506
https://addons.mozilla.org/en-US/firefox/addon/configuration-mania-4420/
.....
extra tweak for smoother page rendering smile.gif
497

Thanks but isn't it supposed to work with the tweak provided by djkilla?
post #2645 of 7225
Quote:
Originally Posted by kevindd992002 View Post

Thanks but isn't it supposed to work with the tweak provided by djkilla?

It should fine, but with this addon you have a handy GUI and all in one place.
post #2646 of 7225
Quote:
Originally Posted by kevindd992002 View Post

Thanks but isn't it supposed to work with the tweak provided by djkilla?

Most of those tweaks I've included. This is an add-on which lets you tweak the settings without manually using about:config. It's not a bad add-on. It lets you do changes quickly and might be perfect for you to try to see if it improves or solve the YouTube jittering issue. If you get it, I would recommend changing the settings under 'Paint & Rendering'. Those settings control the page reflow which could be causing the jittering in YouTube. You can try increasing the numbers. This will cause Waterfox to not reflow the page as often.

Now that I think about it, you may want to try changing my tweak to reduce the amount of RAM Firefox uses for its cache feature from 0 to -1

1. Type “about:config” (no quotes) in the adress bar in the browser.
2. Find “browser.sessionhistory.max_total_viewer”
3. Set it’s value to “-1“

'0' keeps everything from being cached to RAM. But if you're streaming a YouTube video, you may need this setting to be '-1' so the video will play smoother by caching/buffering the video to RAM. You may notice more memory/RAM being used to do this to get smoother video play. When I get time, I'll see if there's another way to reduce the RAM used by Waterfox.
Edited by djkilla - 6/13/12 at 3:14pm
post #2647 of 7225
Quote:
Those settings control the page reflow which could be causing the jittering in YouTube. You can try increasing the numbers. This will cause Waterfox to not reflow the page as often.

Hi,

You mean interval for the initial reflows?

I saw that it can glitch by gif pictures and cause a small hickup if its to high, same for maximum time to interrupt process..

its like so at default

120000 (i use 100000)
360000 (260000)
750000 (850000)

Any extra tips how to adjust properly? smile.gif


And I also get this weird stutter in youtube, but sometimes its better with other drivers (almost none) so i thought its a driver thing thinking.gif



or is this enough,

browser.sessionhistory.max_total_viewer -1

i dont mind extra ram usage, i use Ramdisk (500mb) for WF default cache biggrin.gif



edit: ah its already at -1..
Edited by TheHunter - 6/13/12 at 4:13pm
post #2648 of 7225
Quote:
Originally Posted by TheHunter View Post

Quote:
Those settings control the page reflow which could be causing the jittering in YouTube. You can try increasing the numbers. This will cause Waterfox to not reflow the page as often.
Hi,
You mean interval for the initial reflows?
I saw that it can glitch by gif pictures and cause a small hickup if its to high, same for maximum time to interrupt process..
its like so at default
120000 (i use 100000)
360000 (260000)
750000 (850000)

Yes, this is the interval in microseconds before it reflows the page. There's a couple of settings to look at to improve the jitter.

content.notify.interval:
Sets the minimum amount of time (1 second = 1,000,000 microseconds) to wait between periodic reflowing of the page to 0.12 seconds – stops Firefox becoming slow by reflowing too frequently. This is a new integer value. Default is 120000. content.notify.ontimer must be set to true for this preference to take effect.

content.notify.ontimer:
Ensures Firefox does not reflow pages at an interval any higher than that specified by content.notify.interval above. This is a new Boolean value. Default is True

content.max.tokenizing.time:
Sets the maximum amount of time Firefox will be unresponsive while rendering pages – set to 3 times the content.notify.interval above. This is a new integer value. Default is 360000. Lowering the interval will make the application more responsive at the expense of page load time.
Edited by djkilla - 6/13/12 at 4:49pm
post #2649 of 7225
Quote:
Originally Posted by djkilla View Post

Yes, this is the interval in microseconds before it reflows the page. There's a couple of settings to look at to improve the jitter.
content.notify.interval:
Sets the minimum amount of time (1 second = 1,000,000 microseconds) to wait between periodic reflowing of the page to 0.12 seconds – stops Firefox becoming slow by reflowing too frequently. This is a new integer value. Default is 120000. content.notify.ontimer must be set to true for this preference to take effect.
content.notify.ontimer:
Ensures Firefox does not reflow pages at an interval any higher than that specified by content.notify.interval above. This is a new Boolean value. Default is True
content.max.tokenizing.time:
Sets the maximum amount of time Firefox will be unresponsive while rendering pages – set to 3 times the content.notify.interval above. This is a new integer value. Default is 360000. Lowering the interval will make the application more responsive at the expense of page load time.

Thanks,

so the best effect is to set

content.notify.interval: to 1 sec (1000000)

then i need content.max.tokenizing.time: 3.6sec (3600000), Isn't that a bit high compared to 360ms?


edit: i 've set it like so (1sec; 3.6sec) and it looks good, i also disabled initial paint delay to 0ms and it looks snappy, youtube videos are ok too smile.gif



edit2: content.max.tokenizing.time: 3.6sec (3600000) lagged animated looped gifs, setting it back to 360ms fixed it.
Edited by TheHunter - 6/13/12 at 7:14pm
post #2650 of 7225
Quote:
Originally Posted by omeyg View Post

Since installing Waterfox V13 PL1, the tabs dont seem to be working properly.
Waterfox is supposed to open up the tabs that were open in the previous session but now opens up a blank new tab everytime regardless of the browser settings.
The group tabs button also seems to be stuffing up. When I click the group tabs button, nothing happens...
Somehow by trial and error I can manage to reach the group tabs screen but when I click on a tab in the group it doesnt load in the window and I have to end the session before I can use Waterfox normally.
I tried reinstalling the Waterfox V12 but the problem is now "permanent".
I would like to solve these problems and run them on Waterfox V13 PL1. The tabs were one of the few reasons that I would still use Waterfox so I am disappointed about this recent update.
Any ideas as to solve this problem? Should I reinstall Waterfox V13 PL1 again?
Quote:
Originally Posted by MrAlex View Post

Try Firefox and tell me if you get the same problem? If not, have you tried a different profile?

After rebooting the computer, all of the problems have been fixed.thumbsupsmiley.png

BUT this is still only on Waterfox V12 and not V13 PL1...thumbsdownsmileyanim.gif

Do the tabs work for everyone else?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 48.0.2: 06 September [Firefox 64-Bit]