Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 48.0.2: 06 September [Firefox 64-Bit]
New Posts  All Forums:Forum Nav:

Waterfox 48.0.2: 06 September [Firefox 64-Bit] - Page 364

post #3631 of 7225
Quote:
Originally Posted by MrAlex View Post

I don't see what's so bad about Google with some extra security?

AVG in general is crapware, IMO. Avast is way, way better. Also, I wouldn't call AVG 'extra security' unless you want it eventually flagging vital system files as malware, like in the past. tongue.gif It really is the Norton/McAfee of the modern age.
Edited by Lord Venom - 8/31/12 at 5:58am
The Batcomputer
(24 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7-6700K @ 4.6 GHz ASUS Z170-PREMIUM LGA 1151 ATX Intel Motherboard ASUS ROG GeForce GTX 1070 STRIX-GTX1070-O8G-GAM... ASUS ROG GeForce GTX 1070 STRIX-GTX1070-O8G-GAM... 
RAMHard DriveHard DriveHard Drive
G.SKILL Trident Z Series 32GB (2 x 16GB) 3200MH... SAMSUNG 950 PRO M.2 256GB SSD (Windows) SAMSUNG 840 PRO 128GB SATA III SSD (macOS) SAMSUNG 850 PRO 128GB SATA III SSD (Ubuntu) 
Hard DriveHard DriveHard DriveHard Drive
SAMSUNG 850 EVO 500GB SATA III SSD (Games + Vir... Seagate Ironwolf 10TB NAS 7200 RPM 256MB Cache ... Seagate Ironwolf 10TB NAS 7200 RPM 256MB Cache ... Seagate Ironwolf 10TB NAS 7200 RPM 256MB Cache ... 
CoolingOSOSOS
Swiftech H320-X2 Prestige AIO Water Cooling Windows 10 Pro Anniversary Update 64-bit macOS 10.12 Sierra Ubuntu 16.04.1 Xenial Xerus 64-bit 
MonitorKeyboardPowerCase
QNIX QX2710 LED Evolution ll 27" 2560x1440 WQHD... Ducky Shine 5 RGB LED Backlit Mechanical Keyboa... EVGA Supernova 1200 P2 80 PLUS PLATINUM Certifi... Phanteks Enthoo Primo ATX Full Tower Computer C... 
MouseMouse PadAudioAudio
Ducky Secret RGB Mouse Ducky Flipper Mouse Pad Schiit Modi 2 Uber USB DAC Behringer MS40 Studio Monitors 
  hide details  
Reply
The Batcomputer
(24 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7-6700K @ 4.6 GHz ASUS Z170-PREMIUM LGA 1151 ATX Intel Motherboard ASUS ROG GeForce GTX 1070 STRIX-GTX1070-O8G-GAM... ASUS ROG GeForce GTX 1070 STRIX-GTX1070-O8G-GAM... 
RAMHard DriveHard DriveHard Drive
G.SKILL Trident Z Series 32GB (2 x 16GB) 3200MH... SAMSUNG 950 PRO M.2 256GB SSD (Windows) SAMSUNG 840 PRO 128GB SATA III SSD (macOS) SAMSUNG 850 PRO 128GB SATA III SSD (Ubuntu) 
Hard DriveHard DriveHard DriveHard Drive
SAMSUNG 850 EVO 500GB SATA III SSD (Games + Vir... Seagate Ironwolf 10TB NAS 7200 RPM 256MB Cache ... Seagate Ironwolf 10TB NAS 7200 RPM 256MB Cache ... Seagate Ironwolf 10TB NAS 7200 RPM 256MB Cache ... 
CoolingOSOSOS
Swiftech H320-X2 Prestige AIO Water Cooling Windows 10 Pro Anniversary Update 64-bit macOS 10.12 Sierra Ubuntu 16.04.1 Xenial Xerus 64-bit 
MonitorKeyboardPowerCase
QNIX QX2710 LED Evolution ll 27" 2560x1440 WQHD... Ducky Shine 5 RGB LED Backlit Mechanical Keyboa... EVGA Supernova 1200 P2 80 PLUS PLATINUM Certifi... Phanteks Enthoo Primo ATX Full Tower Computer C... 
MouseMouse PadAudioAudio
Ducky Secret RGB Mouse Ducky Flipper Mouse Pad Schiit Modi 2 Uber USB DAC Behringer MS40 Studio Monitors 
  hide details  
Reply
post #3632 of 7225
When I tried installing waterfox 15, I was not going to want AVG to infect my computer with it's own "friendly" spyware/annoyance so like a sensible computer user I opted for custom with the tick boxes unchecked. This SHOULD in theory, if all was right with the world, have meant that AVG toolbar would not have been installed. I was wrong. It got through anyway and bunged up my chrome install. AVG start page, home page and default search provider. I did not want this and ad to uninstall the toolbar from windows and change all the chrome settings back to MY personal preferences that I had chosen.

Not only that but the waterfox install failed. Missing dll. Deeply irritating. I tried repairing the install, and unistalling and reinstalling but to no avail. I am sure there is some tedious fiddly fix that would make it work again by downloading some suspect thing from some suspect website, but frankly I am not about to go and chase after this. It should just work right? Thankfully I had the old 14.02 or 14.01 installer hanging around my computer and reinstalled this with no problems.

I know that you need a revenue stream from this great project, and you deserve one, but bundling it with software that users cannot opt out of is wrong. Simple. Chose different software, chose something that those who want to can say no to. Chose something with a great big "I don't want this" button rather than some unticked tick boxes that don't actually work.

Also fix the dll thing.

Thanks.
post #3633 of 7225
RE: AVG options screen:
Quote:
Originally Posted by MrAlex View Post

I've explained it countless times. It's in the news post, and the posts in this thread,
No, you've explained WHY it's there and that it's OPTIONAL, but you don't say how to say "No".

You've left it very blurry as to how to fully opt out and a lot of people aren't as likely to work out to click Custom and not check the boxes.

If you don't understand how that's underhanded then I'm at a loss.

Is it really complicated to have "Express", "Custom", "Do not install"?

Surely the revenue from the AVG support is from having the option of the toolbar/search not that people actually opt in? If it's from people opting in it makes the case of having no "No" selection even worse.

By the way, I have no issue with you needing to include an option like AVG, my issue is that you've done it in such a way.
Edited by HanFox - 8/31/12 at 6:12am
post #3634 of 7225
Quote:
Originally Posted by coolspotover View Post

When I tried installing waterfox 15, I was not going to want AVG to infect my computer with it's own "friendly" spyware/annoyance so like a sensible computer user I opted for custom with the tick boxes unchecked. This SHOULD in theory, if all was right with the world, have meant that AVG toolbar would not have been installed. I was wrong. It got through anyway and bunged up my chrome install. AVG start page, home page and default search provider. I did not want this and ad to uninstall the toolbar from windows and change all the chrome settings back to MY personal preferences that I had chosen.
Not only that but the waterfox install failed. Missing dll. Deeply irritating. I tried repairing the install, and unistalling and reinstalling but to no avail. I am sure there is some tedious fiddly fix that would make it work again by downloading some suspect thing from some suspect website, but frankly I am not about to go and chase after this. It should just work right? Thankfully I had the old 14.02 or 14.01 installer hanging around my computer and reinstalled this with no problems.
I know that you need a revenue stream from this great project, and you deserve one, but bundling it with software that users cannot opt out of is wrong. Simple. Chose different software, chose something that those who want to can say no to. Chose something with a great big "I don't want this" button rather than some unticked tick boxes that don't actually work.
Also fix the dll thing.
Thanks.

I installed WF15 just fine without the toolbar. Definitely something wrong on your side.

I had no DLL problem, either.

I do agree that the installer should say "Install" and "Don't Install" instead of the "Custom" stuff. A bit odd, I think.
post #3635 of 7225
Don't pin this on me buddy. Others are having the dll issue and the AVG settings and toolbar should NOT have installed. Simple. Don't argue with that, don't dare make it out to be my fault as the dll should be installed along with the rest of the program and it was missing, and I had the correct settings unticked to disallow the AVG bar. Be helpful or stop being an irritation. There are surely a great many things that you have done that I have not done, that does not make you somehow the better one or have the only way. It's not like this for you, so surely it can't be that way for ANYONE? Think before you deride.

I have highlighted a bug, in fact 2 bugs, that should not be a problem.

Missing dll which has been mentioned already by others here and around the net, and AVG sneaking through even with the unobvious options set to not install it.
post #3636 of 7225
Quote:
Originally Posted by coolspotover View Post

Missing dll which has been mentioned already by others here and around the net, and AVG sneaking through even with the unobvious options set to not install it.

Try installing Intel C++ Redistributables: http://registrationcenter.intel.com/irc_nas/2025/w_cproc_p_11.1.070_redist_intel64.exe

That maybe the cause of the missing dll files. And please be calm smile.gif I'm pretty sure he didn't mean to upset you. About the AVG option make sure you tick Custom and leave the other 3 options unticked too. Mr. Alex would probably revise the installer to have better options including proper boxes to exclude that option. thumb.gif
Edited by qwerty77 - 8/31/12 at 8:17am
    
CPUGraphicsRAMRAM
Intel® Core™ i3-2100 Intel HD Graphics 2000 Patriot Memory 4GB DDR3 1333MHz Sharetonic 2GB DDR3 1333MHz 
Hard DriveOSMonitorKeyboard
Samsung HD502HJ 500GB 7200 RPM Windows 7 Ultimate 64bit SP1 Lenovo L2061wA A4Tech KD-800L Backlit Keyboard 
PowerCaseMouseAudio
FSP 180W slim-tower power supply Lenovo OEM Lenovo OEM Realtek High Definition Audio 
  hide details  
Reply
    
CPUGraphicsRAMRAM
Intel® Core™ i3-2100 Intel HD Graphics 2000 Patriot Memory 4GB DDR3 1333MHz Sharetonic 2GB DDR3 1333MHz 
Hard DriveOSMonitorKeyboard
Samsung HD502HJ 500GB 7200 RPM Windows 7 Ultimate 64bit SP1 Lenovo L2061wA A4Tech KD-800L Backlit Keyboard 
PowerCaseMouseAudio
FSP 180W slim-tower power supply Lenovo OEM Lenovo OEM Realtek High Definition Audio 
  hide details  
Reply
post #3637 of 7225
Quote:
Originally Posted by kennyparker1337 View Post

I installed WF15 just fine without the toolbar. Definitely something wrong on your side.
I had no DLL problem, either.
I do agree that the installer should say "Install" and "Don't Install" instead of the "Custom" stuff. A bit odd, I think.


Same here ... I just checked my Chrome and found no traces of AVG installed. eh-smiley.gif

I should also mentioned that after WF v15 installed I went straight to "Control Panel > Program and Features" just to insure AVG wasn't installed. I did this before I launched WF v15 for the first time.

I did get the DLL problem back when v12(?) came out. the fix for me was to uninstall v12 and v11 (taking care not to nuke the profile folder) and then reinstall. I've done that with each version release. thumb.gif
post #3638 of 7225
Quote:
Originally Posted by qwerty77 View Post

make sure you tick Custom and leave the other 3 options unticked too. thumb.gif

That's exactly what I did, and yet the AVG settings and toolbar installed anyway.

I'm going to wait for waterfox 15 to fix itself before I dive into any fixes. 14 works, what's so broken about 15? I also want 15 to be my browser, but until the AVG toolbar option is fixed, I'm not willing to have it change all my settings again.
post #3639 of 7225
Just like WF 14, my 3-finger swipe right/left is page up/down instead of back/forward. Was there a change in the WF code that caused this to happen? :/
post #3640 of 7225
Getting a weird issue on my task bar. The Waterfox icon which I have pinned to my task bar can be clicked, but when the program opens, a new icon opens up to control the program.

Any suggestions?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 48.0.2: 06 September [Firefox 64-Bit]