Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 53: 24 April [Firefox 64-Bit]
New Posts  All Forums:Forum Nav:

Waterfox 53: 24 April [Firefox 64-Bit] - Page 603

post #6021 of 7308
So I tried out this browser on my work computer and I have to say it was not pleasant. Chrome was still way faster in all regards. I even tried version 30 since everyone said that they were having issues with the new one and I was pretty disappointed..
post #6022 of 7308
Quote:
Originally Posted by Ddreder View Post

So I tried out this browser on my work computer and I have to say it was not pleasant. Chrome was still way faster in all regards. I even tried version 30 since everyone said that they were having issues with the new one and I was pretty disappointed..

Firefox can be faster than Chrome for a lot of stuff, but that's just on paper really. There's choppiness in the UI and scrolling while stuff loads and that makes it appear slow.

Take another look in 2015. By then those issues might have been solved as the Firefox developers are slowly working towards getting it to run in multiple processes/threads, which should solve that.
post #6023 of 7308
Quote:
Originally Posted by bIOforger View Post

thechas, not much point posting all that without your spec, so whats your spec, are you AMD or Intel?

Laptop is an I5 with 8 GB RAM and Windows 7 x64 Home.

Desktop is AMD Phenom II X4 970 at 3.5GHz with 16GB RAM Windows 7 x64 Pro.

Desktop Experience Index is 5.9 limited by motherboard HDD interface.

I have not run any browser speed tests, but I see no difference with Waterfox 31 compared to the month or so that I was running Waterfox 30.

Chas
post #6024 of 7308
Quote:
Originally Posted by thechas View Post

Laptop is an I5 with 8 GB RAM and Windows 7 x64 Home.

Desktop is AMD Phenom II X4 970 at 3.5GHz with 16GB RAM Windows 7 x64 Pro.

Desktop Experience Index is 5.9 limited by motherboard HDD interface.

I have not run any browser speed tests, but I see no difference with Waterfox 31 compared to the month or so that I was running Waterfox 30.

Chas

Thanks, weird your lappy is similar spec to my desktop, mine is o/c to 4.6ghz and has an SSD. win exp is 6.9 limited by the gfx card.
post #6025 of 7308
Well since It's a laptop and uses onboard graphics instead of dedicated GPU that's why your windows exp is stuck at a 6.9 rating.
post #6026 of 7308
Quote:
Originally Posted by coldroll View Post

Well since It's a laptop and uses onboard graphics instead of dedicated GPU that's why your windows exp is stuck at a 6.9 rating.

i meant its weird he has no issues with wfox v31 with a very similar core spec to my desktop. I was thinking it was an intel thing, but obviously not. I still reckon its flash being cack as usual.
post #6027 of 7308
I think it's either Adobe flash or a coding error.
post #6028 of 7308
For what it's worth, I upgraded from 30 to 31 a week ago and have been using it without issue since then. With only overclock.net open in a tab, Waterfox 31 is using 577k kb and 2% CPU. After opening Popurls Reddit, The New York Times and The Huffington Post in additional tabs, it is using 629k kb and 3-5%CPU. Closing all the tabs but overclock.net drops the mem usage back down to 570k kb. Checking out several sites using Flash all seemed to work without crashes or slowdowns. I wonder what you guys are running into.
Edited by Cosanostra - 8/6/14 at 1:58pm
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD 1090T Gigabyte GA-990FXA-UD3 Sapphire Vapor-X HD7770 OC 16GB G.Skill RipjawsX 1333 
Hard DriveCoolingOSMonitor
WD Black 640, 3x2TB, 4TB HGST NAS Corsair H60i water cooled Window 7 Ultimate X64 Dell U2713H + Dell 2001FP 
PowerCaseMouseAudio
Seasonic X-750 Antec P182 Razer DeathAdder Creative X-Fi Elite Pro 
  hide details  
Reply
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD 1090T Gigabyte GA-990FXA-UD3 Sapphire Vapor-X HD7770 OC 16GB G.Skill RipjawsX 1333 
Hard DriveCoolingOSMonitor
WD Black 640, 3x2TB, 4TB HGST NAS Corsair H60i water cooled Window 7 Ultimate X64 Dell U2713H + Dell 2001FP 
PowerCaseMouseAudio
Seasonic X-750 Antec P182 Razer DeathAdder Creative X-Fi Elite Pro 
  hide details  
Reply
post #6029 of 7308
I am at a loss to all these issues, except to say that I really haven't had any problems with this latest release as Cosanostra too has stated. I don't doubt that there can be issues with unique setups, unique demands, or the like and hate to hear of anyone having issues like the ones reported, but from the likes of a heavy internet users of all kinds of sites...I have had no crashes, excessive memory use, or anything notable of a problem with WF31. I don't generally install on top of other installations with any software I use regularly...preferring to reinstall over upgrading with all the software my primary machine and what I did on my Primary Machine. However, when it comes to the laptop...upgrade away...and that is the path I took for this latest WF31 on it and also have not had any issues with much of the average surfing this unit sees. Good luck to all those with issues...I do hope you find a fix.
Edited by seti - 8/9/14 at 12:55pm
post #6030 of 7308
@ MrAlex,

How can I tell what version Waterfox I am running? I've had V28, just downloaded v31. Closed WF, ran the ...setup.exe. Don't know how to tell which version I'm running. They both appear identical.

Another point I have is the following:
In FF, in the address bar, there was a 'star' shape which you could select to save the current page into your bookmarks.
I don't see that option available in WF.

I've started using WF since FF was either slow to start or did not start at all.
Am running this on a Win8.1 laptop.

Cheers,
MPep
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 53: 24 April [Firefox 64-Bit]