Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 53: 24 April [Firefox 64-Bit]
New Posts  All Forums:Forum Nav:

Waterfox 53: 24 April [Firefox 64-Bit] - Page 606

post #6051 of 7308
Quote:
Originally Posted by MrAlex View Post

Okay everyone I've noticed some weird performance issues that have definitely been fixed in version 32. I think profiling went wrong and so the compiler essentially unoptimized parts of the program that were critical.
You can test version 32 here. Hopefully it should be back to being faster than most other browsers wink.gif

Waterfox is now also releasing for Mac! Since Firefox for Mac is lacking in H264 support I added that and enabled MediaStreamingExtensions as well so now the YouTube HTML5 player will work too.

Sorry for not replying in a while, been working really hard on this release to try and fix everything. Let me know if it all works!
Release for everything is tomorrow smile.gif

Thanks for sorting it all out! I'm going to be reinstalling Windows on a test PC soon, so I'll have a chance to give WF 32 a bit of a workout once you formally release it. smile.gifthumb.gif
4690K System
(12 items)
 
HTPC
(9 items)
 
HP dv6 laptop
(13 items)
 
CPUMotherboardGraphicsRAM
Core i5 4690K ASRock Z97 Extreme4 XFX Radeon 7950 32 GB DDR3-2133 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO SSD Samsung DVD/CD-writer Corsair Hydro H60 Windows 7 
MonitorMonitorPowerCase
ASUS PA248Q Dell U2412M XFX 850W Black Edition XXX Fractal Design Arc Midi 2 
CPUMotherboardGraphicsRAM
Pentium Dual Core E6700 MSI G41M-P33 Combo ATI HD4350 Kingston ValueRAM DDR3-1333 
RAMHard DriveOSMonitor
Kingston ValueRAM DDR3-1333 WD Caviar Blue Windows 7 64-bit Sony 32" TV set 
Case
Apex TX-381 
CPUGraphicsRAMHard Drive
Core i5 430M GT230M (1 Gb dedicated) 8 GB DDR3-1066 640 GB 
OSMonitor
Windows 7 Home Premium (64-bit) 15.6" 
  hide details  
Reply
4690K System
(12 items)
 
HTPC
(9 items)
 
HP dv6 laptop
(13 items)
 
CPUMotherboardGraphicsRAM
Core i5 4690K ASRock Z97 Extreme4 XFX Radeon 7950 32 GB DDR3-2133 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO SSD Samsung DVD/CD-writer Corsair Hydro H60 Windows 7 
MonitorMonitorPowerCase
ASUS PA248Q Dell U2412M XFX 850W Black Edition XXX Fractal Design Arc Midi 2 
CPUMotherboardGraphicsRAM
Pentium Dual Core E6700 MSI G41M-P33 Combo ATI HD4350 Kingston ValueRAM DDR3-1333 
RAMHard DriveOSMonitor
Kingston ValueRAM DDR3-1333 WD Caviar Blue Windows 7 64-bit Sony 32" TV set 
Case
Apex TX-381 
CPUGraphicsRAMHard Drive
Core i5 430M GT230M (1 Gb dedicated) 8 GB DDR3-1066 640 GB 
OSMonitor
Windows 7 Home Premium (64-bit) 15.6" 
  hide details  
Reply
post #6052 of 7308
Thanks Alex!

The Waterfox 32 preview does appear to be loading pages faster than 31 had.

I have been running Waterfox 32 all evening and have not had any problems.

Keep up the good work!

Chas
post #6053 of 7308
Alright! v32 seems to be working well! Thanks Alex smile.gif

Something to note:

In Waterfox and Firefox, I've always noticed that on some pages (almost all) there is a delay, while the page renders, before I am able to scroll down the page. There is a new setting (not sure if it appeared in 31 or 32) named "browser.cache.disk.preload_chunk_count."

The default setting is 4 and I doubled it to 8 and that delay is almost completely gone. On a newly opened instance of Waterfox it is almost as fast as if the page had already been visited in the same session.

The explanation is "Number of data chunks we always preload ahead of read to speed up load of larger content like images. Currently size of one chunk is 256kB, and by default we preload 4 chunks – i.e. 1MB of data in advance" (from http://www.janbambas.cz/new-firefox-http-cache-enabled/).

I also changed "browser.cache.disk.metadata_memory_limit" from 250 to 1000 but I don't think it had any effect.
post #6054 of 7308
Thanks for the hard work Alex! I am sure most understand what "busy" is like, but on the same token most can't understand "busy" with maintaining a software release to the world for free tacked on to it. Totally psyched about the news of a Mac release! Is this something you are looking to release in the coming months or next year? Will this lead to an eventual linux version as well? Regardless of the "whens" I find wine and waterfox a good pair to get me by until then. Thanks again.
post #6055 of 7308
Looking forward to using Waterfox 32.

I have a question about Waterfox and video playing. YouTube, Brightcove and other video players work normally in Waterfox. However, I cannot get Adobe Flash videos to play in Waterfox. I have redownloaded and reinstalled the latest version on Adobe Flash (64-bit) on this Windows 8.1 (64-bit) system. Flash videos play normally in Internet Explorer, but do not load at all in Waterfox. I am left with a blank white space where the player should be. Is there a setting I need to change in Waterfox, perhaps in the AboutConfig file? Is the Flash player looking for Firefox.exe rather than Waterfox.exe? Do I need to change a key in the Windows Registry?

Thanks for any help.
post #6056 of 7308
Thread Starter 
Quote:
Originally Posted by Quantum Reality View Post
 
Quote:
Originally Posted by MrAlex View Post

Okay everyone I've noticed some weird performance issues that have definitely been fixed in version 32. I think profiling went wrong and so the compiler essentially unoptimized parts of the program that were critical.
You can test version 32 here. Hopefully it should be back to being faster than most other browsers wink.gif

Waterfox is now also releasing for Mac! Since Firefox for Mac is lacking in H264 support I added that and enabled MediaStreamingExtensions as well so now the YouTube HTML5 player will work too.

Sorry for not replying in a while, been working really hard on this release to try and fix everything. Let me know if it all works!
Release for everything is tomorrow smile.gif

Thanks for sorting it all out! I'm going to be reinstalling Windows on a test PC soon, so I'll have a chance to give WF 32 a bit of a workout once you formally release it. smile.gifthumb.gif

 

Great, let me know how it goes!

 

Quote:
Originally Posted by thechas View Post

Thanks Alex!

The Waterfox 32 preview does appear to be loading pages faster than 31 had.

I have been running Waterfox 32 all evening and have not had any problems.

Keep up the good work!

Chas

 

That's great, glad to hear!

 

Quote:
Originally Posted by Prime2515102 View Post

Alright! v32 seems to be working well! Thanks Alex smile.gif

Something to note:

In Waterfox and Firefox, I've always noticed that on some pages (almost all) there is a delay, while the page renders, before I am able to scroll down the page. There is a new setting (not sure if it appeared in 31 or 32) named "browser.cache.disk.preload_chunk_count."

The default setting is 4 and I doubled it to 8 and that delay is almost completely gone. On a newly opened instance of Waterfox it is almost as fast as if the page had already been visited in the same session.

The explanation is "Number of data chunks we always preload ahead of read to speed up load of larger content like images. Currently size of one chunk is 256kB, and by default we preload 4 chunks – i.e. 1MB of data in advance" (from http://www.janbambas.cz/new-firefox-http-cache-enabled/).

I also changed "browser.cache.disk.metadata_memory_limit" from 250 to 1000 but I don't think it had any effect.

 

No worries! And thanks for that information, I'll look into it! Looks like it could be quite a good thing to increase.

 

Quote:
Originally Posted by seti View Post

Thanks for the hard work Alex! I am sure most understand what "busy" is like, but on the same token most can't understand "busy" with maintaining a software release to the world for free tacked on to it. Totally psyched about the news of a Mac release! Is this something you are looking to release in the coming months or next year? Will this lead to an eventual linux version as well? Regardless of the "whens" I find wine and waterfox a good pair to get me by until then. Thanks again.

 

No worries and thanks for the support :)

 

Quote:
Originally Posted by Spurred View Post

Looking forward to using Waterfox 32.

I have a question about Waterfox and video playing. YouTube, Brightcove and other video players work normally in Waterfox. However, I cannot get Adobe Flash videos to play in Waterfox. I have redownloaded and reinstalled the latest version on Adobe Flash (64-bit) on this Windows 8.1 (64-bit) system. Flash videos play normally in Internet Explorer, but do not load at all in Waterfox. I am left with a blank white space where the player should be. Is there a setting I need to change in Waterfox, perhaps in the AboutConfig file? Is the Flash player looking for Firefox.exe rather than Waterfox.exe? Do I need to change a key in the Windows Registry?

Thanks for any help.

 

Hmm that definitely shouldn't be happening! I'll look into this and get back to you.

    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
post #6057 of 7308
I just installed waterfox 32 and seems everything is running smooth .

10x alex smile.gif
post #6058 of 7308
Just installed WF32, the only thing problem I have is the updater is really slow to download.

The updater was downloading at 100KB/s and the installer downloaded at 4.5MB/s (maxxed my connection), are the downloads coming from different sources?
post #6059 of 7308
Quote:
Originally Posted by Bitemarks and bloodstains View Post

Just installed WF32, the only thing problem I have is the updater is really slow to download.

The updater was downloading at 100KB/s and the installer downloaded at 4.5MB/s (maxxed my connection), are the downloads coming from different sources?

Hi,

I will ditto this problem.
post #6060 of 7308
Thanks for your reply MrAlex.
Quote:
[Hmm that definitely shouldn't be happening!

I kinda figured that. Waterfox is installed on my new-in-April Windows 8.1 PC. I also have a new, two week old laptop running Windows 8.1, on which I installed Waterfox last week. Flash does not work in Waterfox on either machine. However, on each machine I have now tried logging in as a different user (after creating new user accounts) and opened Waterfox in the new user account on each machine with unaltered default profiles. In both, Flash played as it should, so the problem is not with the Waterfox code. The problem is with my profile.

When I first set up the new PC, I installed Firefox. I copied over my complete Firefox profile folder from my old Windows XP Pro 32-bit machine to my new Windows 8.1 (64-blt) PC. The new profile folder was setup with the same folder path as on the old XP machine, so there was no location mismatch. Then I uninstalled Firefox and installed Waterfox, I set it up to use the same Firefox profile folder, Other than with Flash, I've had no problems with Waterfox on the new Windows 8.1 PC.

Neither Firefox now Waterfox was installed on the new laptop. I installed Waterfox clean. Then, using MozBackup, I imported the Waterfox profile from the new Windows 8.1 PC to the new Windows 8.1 laptop. Whatever the problem is with Flash, it was copied over to the laptop with the profile.

Do you have any ideas where I should look for the conflict and how I can correct it, other than creating my profile from scratch? Can I manually uninstall or delete Adobe Flash from Waterfox and let Adobe install it anew?

Thanks, I realize Adobe Flash is not your responsibility, but I don't think Adobe will be any help.
Tony
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 53: 24 April [Firefox 64-Bit]