Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 53: 24 April [Firefox 64-Bit]
New Posts  All Forums:Forum Nav:

Waterfox 53: 24 April [Firefox 64-Bit] - Page 628

post #6271 of 7308
Hi Mr Alex,

I have found that updating today to the new version (33.0.2-10Nov14) seems to have cured the script, copy & paste problem as I can now click on tabs & get a response & high-lite script, right click & this gives me the copy & paste option.thumb.gif

Cheers

Teddals
Edited by Teddals - 11/12/14 at 2:02am
post #6272 of 7308
Hello,

Unfortunately after updating today Waterfox to 33.0.2 any script or extensions don't works for making "Multirow Bookmarks Toolbar". I have only two lines of bookmark toolbar right now. I don't know why, but I assume that errors are common after updating to new Waterfox version.
Some help with that would be appreciated thumb.gif

Cheers

I have found solution:

If you are using the MBT extension,
simply add this userChrome.css file, or style whtvr. ;-)
Code:
@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
#PersonalToolbar {
max-height: none !important;
}

Edited by futer - 11/12/14 at 5:51am
post #6273 of 7308
Hello,

the Sync function is no longer working with latest or previous build. I have to revert to Firefox to sync bookmarks with other devices

thanks
My Rig
(29 items)
 
  
CPUMotherboardGraphicsRAM
2600K  GA-Z68X-UD5-B3 ASUS HD7970 DCii TOP 3GB G.Skill Ripjaws X F3-1600C9D-16GXM 16GB (2x8GB)... 
Hard DriveHard DriveHard DriveHard Drive
Samsung 830 128GB Samsung 830 256GB Western Digital WD Green 1TB WD10EZRX  Western Digital WD Blue 1TB WD10EZEX  
Optical DriveOptical DriveCoolingCooling
Silverstone FP58B 5.25in Cover Bay for Slot loa... Silverstone SOD02 Slim DVDRW Optical Drive  EK Supremacy CPU Waterblock Clean CSQ Acetal  EK-FB KIT GA P67A (UD7) - Acetal + Nickel  
CoolingCoolingCoolingCooling
EK Full Cover VGA Block EK-FC7970 DCII Acetal N... Koolance RP-452X2 Reservoir for PMP-450/S Pumps... Alphacool VPP655 Single Edition 12V Variable Sp... Alphacool NexXxoS UT60 Full Copper 120mm 
CoolingCoolingCoolingOS
Alphacool NexXxoS XT45 Full Copper 360mm  4 x Noctua NF-F12 PWM 120mm Fan  Noctua NF-A15 PWM 140mm Fan Windows 7 Pro 64 Bit 
MonitorKeyboardPowerCase
4 x Dell U2412M Logitech G710+ Mechanical Gaming Keyboard  Seasonic XP-660 Platinum 660W Power Supply V2 Silverstone FT02 
MouseMouse PadAudioAudio
Logitech G600 MMO Gaming Mouse  Roccat SOTA Xonar STX with APA2107 opamp AudioEngine AE2 
  hide details  
Reply
My Rig
(29 items)
 
  
CPUMotherboardGraphicsRAM
2600K  GA-Z68X-UD5-B3 ASUS HD7970 DCii TOP 3GB G.Skill Ripjaws X F3-1600C9D-16GXM 16GB (2x8GB)... 
Hard DriveHard DriveHard DriveHard Drive
Samsung 830 128GB Samsung 830 256GB Western Digital WD Green 1TB WD10EZRX  Western Digital WD Blue 1TB WD10EZEX  
Optical DriveOptical DriveCoolingCooling
Silverstone FP58B 5.25in Cover Bay for Slot loa... Silverstone SOD02 Slim DVDRW Optical Drive  EK Supremacy CPU Waterblock Clean CSQ Acetal  EK-FB KIT GA P67A (UD7) - Acetal + Nickel  
CoolingCoolingCoolingCooling
EK Full Cover VGA Block EK-FC7970 DCII Acetal N... Koolance RP-452X2 Reservoir for PMP-450/S Pumps... Alphacool VPP655 Single Edition 12V Variable Sp... Alphacool NexXxoS UT60 Full Copper 120mm 
CoolingCoolingCoolingOS
Alphacool NexXxoS XT45 Full Copper 360mm  4 x Noctua NF-F12 PWM 120mm Fan  Noctua NF-A15 PWM 140mm Fan Windows 7 Pro 64 Bit 
MonitorKeyboardPowerCase
4 x Dell U2412M Logitech G710+ Mechanical Gaming Keyboard  Seasonic XP-660 Platinum 660W Power Supply V2 Silverstone FT02 
MouseMouse PadAudioAudio
Logitech G600 MMO Gaming Mouse  Roccat SOTA Xonar STX with APA2107 opamp AudioEngine AE2 
  hide details  
Reply
post #6274 of 7308
Will we be entitled to version 33.0.3 or 33.1?
post #6275 of 7308
Thread Starter 
Quote:
Originally Posted by kevindd992002 View Post
 
Quote:
Originally Posted by MrAlex View Post

I don't think there's anything you can do on your part. I'm going to try and get jemalloc working with ICC. It should sort out a lot of memory issues if I get it working in time for 34.0!

I really hope you can do that as the point of having a 64-bit variant of FF is for it to be memory efficient and not the other way around, right? thumb.gif

 

Well, it's expected to use a bit more memory for performance gains, just not as much as what you're experiencing ;)

 

Quote:
Originally Posted by thepersuader View Post

Hi there:

Love Waterfox—though for me the memory usage is higher than on Firefox.

I confess I go between Waterfox and Firefox. Basically, when one messes up, I go to the other. By the time the other messes up, I switch back.

Right now, both are stuffed, at least on their latest version. I had to downgrade to v. 32 to type this.

Neither Firefox nor Waterfox displays much text. This is a known bug on Mozilla (https://bugzilla.mozilla.org/show_bug.cgi?id=1090298) but the solution of turning OMTC off does not seem to work.

Here’s how Waterfox looks on my computer when using Firefox:



Is this something you could look at, please? Maybe there is a solution that does not involve turning OMTC off. I can confirm that it’s really, really hard to do anything in about:config:



Yes, I had to it all blind … frown.gif

 

This looks like an issue with the Firefox code base itself. 33.0.3/33.1 seems to have resolved these issues, but 34.0 releases in 11 days so I might release the next Waterfox update then.

 

Quote:
Originally Posted by Jokerfish View Post

Unfortunately, after the update I'm back to the problem with viewing GIF files where it plays the first 1-2 seconds, then freezes the browser until the rest is loaded, then resumes but skips ahead for as long as the load time took. This varies depending on the size of the file. This happened with several earlier versions of Waterfox as well. 32.0 worked flawlessly for me.

 Seems to be an issue with the 33.0.2 codebase, but the next release will sort it out.

 

Quote:
Originally Posted by btgbullseye View Post

Problem: I just updated to 33.0.2 via the auto-update system, and now taking any link anywhere is causing Waterfox to crash, and take my video drivers with it. (bookmarks work fine)

Going to try reinstalling with a direct download from the site.

[EDIT] Did not work. Even tried disabling all my addons, to no significant effect. (just delaying the lock of the interactive area of the browser, and then delaying the crash of the browser and video driver) Now using Firefox 34.0 Beta until you get this sorted.

[EDIT2] Bookmarks work for the first bookmark used, unless there are 2 tabs or more open. Even causes a crash when trying to edit settings.

 

Unfortunately, same issue as above!

Quote:
Originally Posted by sciprophet5 View Post

So far 33.0.2 is running just fine for me. Even the YouTube loading problem that others have mentioned (due to that 'HD' extension), has gone away. I had bookmarked trouble videos to double check on a future update and everything loads up just fine for me now. thumb.gif

 

Glad to hear it's at least working for you!

 

Quote:
Originally Posted by malcomX View Post
 
Quote:
Originally Posted by MrAlex View Post

I can't enable jemalloc unfortunately, I use mozalloc instead. Either way there shouldn't be any security issues because of it!

no there is security issue with memory leak if not use jemalloc
quote my tech friend
Code:
Jemalloc translates how firefox handles its memory allocation, Think of Jemalloc as a spider and the memory as a web, Now think of malloc() as a broken ball of spider web that continues breaking and growing in size., Firefox is a Jemalloc application and requires it to prevent large memory fragmentation over time with the memory fragmentation it will eventually become predictable and allow an attacker to have a field day.

he say you watchhe say simlar happen if Jemalloc disable

 

Your friend is very right. Fortunately enough Waterfox isn't that popular that people will want to find security vulnerabilities. At least I hope not! Great video by the way. Hopefully jemalloc will be working next release :)

 

Quote:
Originally Posted by Teddals View Post

Hi Mr Alex,

I have found that updating today to the new version (33.0.2-10Nov14) seems to have cured the script, copy & paste problem as I can now click on tabs & get a response & high-lite script, right click & this gives me the copy & paste option.thumb.gif

Cheers

Teddals

 

Excellent! Glad it works well for you.

 

Quote:
Originally Posted by futer View Post

Hello,

Unfortunately after updating today Waterfox to 33.0.2 any script or extensions don't works for making "Multirow Bookmarks Toolbar". I have only two lines of bookmark toolbar right now. I don't know why, but I assume that errors are common after updating to new Waterfox version.
Some help with that would be appreciated thumb.gif

Cheers

I have found solution:

If you are using the MBT extension,
simply add this userChrome.css file, or style whtvr. ;-)
Code:
@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
#PersonalToolbar {
max-height: none !important;
}

 

Hmm that could be due to an incompatibility with the add-on since it hasn't been update in a while! But looks like you've found a fix for it though. Maybe message the developer and let them know?

 

Quote:
Originally Posted by kickmic View Post

Hello,

the Sync function is no longer working with latest or previous build. I have to revert to Firefox to sync bookmarks with other devices

thanks

 

Hmm that's not good at all. Haven't heard of any other reports of this, I'll have a look for you though.

Quote:
Originally Posted by Mr6686 View Post

Will we be entitled to version 33.0.3 or 33.1?

Possibly, I'm not too sure yet. I've got quite a lot of work to do, but 34.0 comes out in about 11 days, so hopefully that won't be too far off to wait? What do you think?

    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
post #6276 of 7308
I seem to be getting a lot of lockups with 33.0.2 where Waterfox will randomly freeze (goes pale with "not responding" and uses a lot of CPU) after opening a new page. I haven't managed to find a pattern but reverting to 32.0.3 seems to have fixed it for now.

PS I miss the new darker blue icon - any chance of bringing this back?
Edited by bobsleigh - 11/13/14 at 6:41am
post #6277 of 7308
Quote:
Originally Posted by kickmic View Post

Hello,
the Sync function is no longer working with latest or previous build. I have to revert to Firefox to sync bookmarks with other devices
thanks
Do you mean you can't set up new sync or you have a working profile with working sync and it doesn't work?
I have it fully working in WF33.02. Tho I run agains private old version sync server. Not FF default.
Edited by Screemer - 11/13/14 at 6:57am
post #6278 of 7308
I have used firefox alpha builds before...but one day it is started to eat all available RAM in my PC, this is happened only when firefox is running in background for hours. I switched to waterfox some time ago, I think it was just same alpha firefox build but an earlier version, no problem with memory leak... and now, again, after updating to 33.0.2 I have this problem. I tried to report this bug to mozilla with no luck, because the 64-bit version is build only for test purposes, they mean if it builded then it's OK. The question is, is there any chances that somebody fixes this annoying bug?
post #6279 of 7308
Quote:
Originally Posted by MrAlex View Post

Well, it's expected to use a bit more memory for performance gains, just not as much as what you're experiencing wink.gif

Yes and it should perform faster but I'm experiencing the other way around.
Quote:
Originally Posted by w0wkin View Post

I have used firefox alpha builds before...but one day it is started to eat all available RAM in my PC, this is happened only when firefox is running in background for hours. I switched to waterfox some time ago, I think it was just same alpha firefox build but an earlier version, no problem with memory leak... and now, again, after updating to 33.0.2 I have this problem. I tried to report this bug to mozilla with no luck, because the 64-bit version is build only for test purposes, they mean if it builded then it's OK. The question is, is there any chances that somebody fixes this annoying bug?

MrAlex, this is the exact same thing that's happening to me.
post #6280 of 7308
Thank you so much, MrAlex—great to get a personal reply. I’ll look forward to downloading the latest in 11 days.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 53: 24 April [Firefox 64-Bit]