Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 55.0.2: 22 August [Firefox 64-Bit]
New Posts  All Forums:Forum Nav:

Waterfox 55.0.2: 22 August [Firefox 64-Bit] - Page 455

post #4541 of 7341
Working fine for me, I copied over the files to my existing installation (like I did from the 16 portable from 15) overwriting anything it brought up and for the last hour no problems.Restarted maybe 8 times so far without a hitch.
post #4542 of 7341
Just tested it. I get 2 launches then it breaks every time.
Gojira
(20 items)
 
Mosura
(10 items)
 
Jira
(11 items)
 
CPUMotherboardGraphicsRAM
i7-6800k @ 4.2Ghz ASUS Strix X99 Gaming MSI GTX 1080 SeaHawk EK X Corsair Dominator Platinum 32GB (4x8GB) 3000Mhz... 
Hard DriveCoolingCoolingCooling
1TB Samsung 960 Pro EK CoolStream XE 360 EK-FB ASUS X99 Monoblock SeaHawk EK X 
CoolingCoolingOSMonitor
Corsair ML120 Pro x3 Corsair ML140 Pro x1 Windows 10 Pro x64 3x ASUS VS248H-P 
MonitorKeyboardPowerCase
Acer Predator XB241H Corsair K95 RGB Cherry MX Brown CORSAIR AX860i Fractal Design S 
MouseMouse PadAudioAudio
Corsair Scimitar Black Edition Vipamz Extended XXXL Gaming Mouse Pad 36"x12"x0... ASUS Zonar Essence STX Beyerdynamic DT 990 PRO 
CPUMotherboardRAMHard Drive
AMD Opteron 6276 SuperMicro H8SGL-F 64GB (8x8GB) Hynix PC3L-10600R 8x WD Red 3TB in RAID-Z2 Storage 
Hard DriveHard DriveCoolingOS
2x Corsair Force LE RAID-Z Jails 2x LSI 9211 8i Noctua NH-U12DO A3 FreeNAS 
PowerCase
SeaSonic SS-660XP2 Fractal Design Define R5 
CPUGraphicsRAMHard Drive
Intel Core i7-6700HQ Processor 2.6GHz NVIDIA GeForce GTX 960M 2GB GDDR5 16GB RAM Samsung 960 Evo 250GB 
Hard DriveOSMonitorMouse
Samsung 850 Evo 250GB Windows 10 Pro IPS Touchscreen 1080p Razer Naga 2014 
Mouse PadAudioAudio
Razer Vespula FiiO Q1 Brainwavz M2 
  hide details  
Reply
Gojira
(20 items)
 
Mosura
(10 items)
 
Jira
(11 items)
 
CPUMotherboardGraphicsRAM
i7-6800k @ 4.2Ghz ASUS Strix X99 Gaming MSI GTX 1080 SeaHawk EK X Corsair Dominator Platinum 32GB (4x8GB) 3000Mhz... 
Hard DriveCoolingCoolingCooling
1TB Samsung 960 Pro EK CoolStream XE 360 EK-FB ASUS X99 Monoblock SeaHawk EK X 
CoolingCoolingOSMonitor
Corsair ML120 Pro x3 Corsair ML140 Pro x1 Windows 10 Pro x64 3x ASUS VS248H-P 
MonitorKeyboardPowerCase
Acer Predator XB241H Corsair K95 RGB Cherry MX Brown CORSAIR AX860i Fractal Design S 
MouseMouse PadAudioAudio
Corsair Scimitar Black Edition Vipamz Extended XXXL Gaming Mouse Pad 36"x12"x0... ASUS Zonar Essence STX Beyerdynamic DT 990 PRO 
CPUMotherboardRAMHard Drive
AMD Opteron 6276 SuperMicro H8SGL-F 64GB (8x8GB) Hynix PC3L-10600R 8x WD Red 3TB in RAID-Z2 Storage 
Hard DriveHard DriveCoolingOS
2x Corsair Force LE RAID-Z Jails 2x LSI 9211 8i Noctua NH-U12DO A3 FreeNAS 
PowerCase
SeaSonic SS-660XP2 Fractal Design Define R5 
CPUGraphicsRAMHard Drive
Intel Core i7-6700HQ Processor 2.6GHz NVIDIA GeForce GTX 960M 2GB GDDR5 16GB RAM Samsung 960 Evo 250GB 
Hard DriveOSMonitorMouse
Samsung 850 Evo 250GB Windows 10 Pro IPS Touchscreen 1080p Razer Naga 2014 
Mouse PadAudioAudio
Razer Vespula FiiO Q1 Brainwavz M2 
  hide details  
Reply
post #4543 of 7341
confirmed
i'm getting the startup bug now on the 2nd test version.
deleting startupCache.8.little allows running it 2 times, then we get it again.
earlier 1st test did the same.
Edited by kronckew - 1/19/13 at 6:46am
post #4544 of 7341
Thread Starter 

Here's 18.0.1:

http://www.mediafire.com/?oies79vy1dp0vt3

The startup bug should be fixed now, let me know if its not. I'd like to release WF18.0.1 tonight :) As always, just move over the missing .dll's

    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
post #4545 of 7341
Quote:
Originally Posted by charlir View Post

I have been a fan of waterfox till the 14+ came out... alas as of late went to IE.. it is fast.. it sucks cause it wont save pw no matter what I have tried.. still.. Waterfox (or its pluugins) hangs and hangs.. thanks so much MrAlex but I use it less and less now - you did a wonderful job no idea what is going on.. but it hangs so much etc.. I go to a page and nothing happens.. I watch the net it isnt even pagin it .. granted could be the site but well IM testing --- at the moment IE is winnning .. althouigh I hate it .. so sucks bish can not remember a pw or sing on for anything

Sorry

Sorry to hear that,

it works best if you have the AVX Instruction set, IE will be faster other as Microsoft has total control of their proper API documentation and its integrated into the NT kernal. They have the power to tweak it properly so it works well with their OS's. Firefox at its backbone is still a memory hog and that lineage carries on to its forks. I knew that the author would run into problems eventually once he got into the nitty gritty of Gecko and I ascertained that he would have more breathing room to tweak it the way he liked longterm if he used Webkit.

I think Chrome the best speed but Waterfox is my second browser when Chrome starts to act weird. The reason Waterfox isn't the best right now is not because of the authors hard work, 64 bit is still not implemented well enough to give the speed advantages it will have down the line like the 16 to 32 bit transition finally had. Adobe just released a 64 bit flash, like what a year or two ago? We have had consumer 64 bit since 2003 and its now 2013....

My two cents...Waterfox has better 3rd party plugins than Chrome so I fire it up at least once a day to download blip.tv stuff,etc. Its a good backup browser that I would like turn into my primary at some point.

I think the next step for Waterfox should be gpu accelerated web rendering, as AMD's APU's will be flooded on the market within 5 years. Besides that Waterfox's disadvantages go hand in hand with 64's bit shortcomings we have seen so far in regards to industry standard software support. There are still huge big name programs out that are still 32 bit that won't see a 64 bit for a good while. The code is still not where it needs to be across the board.
Edited by dlee7283 - 1/19/13 at 9:05am
    
CPUMotherboardGraphicsRAM
Intel i7 6700 MSI B150 Mortar Artic Zotac GTX 1060 3GB Crucial 8 GB DDR4-2400 
Hard DriveOptical DriveOSMonitor
256 Mushkin Triactor Pioneer BR-RW Windows 10 LTSB x64 Seiki 4K 60HZ 42 inch 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i7 6700 MSI B150 Mortar Artic Zotac GTX 1060 3GB Crucial 8 GB DDR4-2400 
Hard DriveOptical DriveOSMonitor
256 Mushkin Triactor Pioneer BR-RW Windows 10 LTSB x64 Seiki 4K 60HZ 42 inch 
  hide details  
Reply
post #4546 of 7341
Still running the "18" waterfox(2) build with no problems(posting on it now), one thing I did though was download "VSU1\vcredist_x64.exe" the update, for Visual Studio 2012 runtime components for things compiled in C++
which you can find through your link "http://www.microsoft.com/en-us/download/details.aspx?id=30679" which takes you to the page and it is the 2nd link down, have to wonder if the startup problem people arn not missing something in this. May have to somehow incorporate this into the download or link to it off the install page saying it must be installed first?
Realize you don't know me yet Alex, am running a Intel rig with AMD video (Intel processor/chipsets, VisionTek graphics card) and my name is Jay of course.thumb.gif Hope any of this helps
post #4547 of 7341
Thread Starter 
Quote:
Originally Posted by dlee7283 View Post

Quote:
Originally Posted by charlir View Post

I have been a fan of waterfox till the 14+ came out... alas as of late went to IE.. it is fast.. it sucks cause it wont save pw no matter what I have tried.. still.. Waterfox (or its pluugins) hangs and hangs.. thanks so much MrAlex but I use it less and less now - you did a wonderful job no idea what is going on.. but it hangs so much etc.. I go to a page and nothing happens.. I watch the net it isnt even pagin it .. granted could be the site but well IM testing --- at the moment IE is winnning .. althouigh I hate it .. so sucks bish can not remember a pw or sing on for anything

Sorry

Sorry to hear that,

it works best if you have the AVX Instruction set, IE will be faster other as Microsoft has total control of their proper API documentation and its integrated into the NT kernal. They have the power to tweak it properly so it works well with their OS's.

I like Chrome the best speed but Waterfox is my second browser when Chrome starts to act weird. The reason Waterfox isn't the best right now is not because of the authors hard work, 64 bit is still not implemented well enough to give the speed advantages it will have down the line like the 16 to 32 bit transition finally had. Adobe just released a 64 bit flash, like what a year or two ago? We have had consumer 64 bit since 2003 and its now 2013....

My two cents...Waterfox has better 3rd party plugins than Chrome so I fire it up at least once a day to download blip.tv stuff,etc.

I think the next step for Waterfox should be gpu accelerated web rendering, as AMD's APU's will be flooded on the market within 5 years. Besides that Waterfox's disadvantages go hand in hand with 64's bit shortcomings we have seen so far in regards to industry standard software support. There are still huge big name programs out that are still 32 bit.

 

Firefox has support for hardware acceleration:

http://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

 

Quote:
Originally Posted by JayBart View Post

Still running the "18" waterfox(2) build with no problems(posting on it now), one thing I did though was download "VSU1\vcredist_x64.exe" the update, for Visual Studio 2012 runtime components for things compiled in C++
which you can find through your link "http://www.microsoft.com/en-us/download/details.aspx?id=30679" which takes you to the page and it is the 2nd link down, have to wonder if the startup problem people arn not missing something in this. May have to somehow incorporate this into the download or link to it off the install page saying it must be installed first?
Realize you don't know me yet Alex, am running a Intel rig with AMD video (Intel processor/chipsets, VisionTek graphics card) and my name is Jay of course.thumb.gif Hope any of this helps

It seems that the startup bug is completely random, I still haven't found a direct reason for it. Either way it's the -Qax switch that causes the bug (a simple fix available here ).

    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
post #4548 of 7341
18.0.1 working great ty Mr Alex never got the startup or dll bug like oithers on any other version of 18.0 you tested so far
post #4549 of 7341
No startup bug for me anymore. Works wonderfully.
post #4550 of 7341
18.01 ok for me thumb.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 55.0.2: 22 August [Firefox 64-Bit]