Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 55.0.2: 22 August [Firefox 64-Bit]
New Posts  All Forums:Forum Nav:

Waterfox 55.0.2: 22 August [Firefox 64-Bit] - Page 650

post #6491 of 7359
@MrAlex
Quote:
Originally Posted by MrAlex View Post

Yes I've seen the TBB malloc but haven't had time to test it yet. I'll definitely look into it!
Cool thumb.gif, can you send me a PM and post the results here so me and other people know if its useful to replace malloc in other programs as well? wink.gif

One more question, or actually three.
Can you tell me which version of visual studio, Windows SDK and Intel Compiller you use?

Btw: the download link on this thread's first post doesn't work: https://waterfoxproject.org/download.php
Btw 2: Would you be interested in recompiling other programs (for a fee?) I wonder if PHP 5.6 for windows NTS could be made faster with the Intel Compiler.
Btw 3: Would you be interested in Donations or a fast dedicated or VPS server to help with compiling? (Intel® Xeon® E3 1230 v3, or a shared Intel Xeon
E5-1620v2)
X299
(9 items)
 
Z77
(19 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-7820X Asus ROG Strix X299-E Gaming EVGA GeForce GTX 1080 8GB SC GAMING ACX 3.0 G.SKILL F4-3600C16Q-32GTZR 
Hard DriveCoolingOSPower
Intel 750 SSD NZXT Kraken X62 Windows 10 pro 64bit Corsair AX860i 
Case
Corsair Crystal 570X RGB 
  hide details  
Reply
X299
(9 items)
 
Z77
(19 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-7820X Asus ROG Strix X299-E Gaming EVGA GeForce GTX 1080 8GB SC GAMING ACX 3.0 G.SKILL F4-3600C16Q-32GTZR 
Hard DriveCoolingOSPower
Intel 750 SSD NZXT Kraken X62 Windows 10 pro 64bit Corsair AX860i 
Case
Corsair Crystal 570X RGB 
  hide details  
Reply
post #6492 of 7359
I've also noticed another problem with the new version of Waterfox (this does not happen in the older versions). I have a lot of tabs opened and my WF is set to "show tabs and windows from last time". I close WF and as soon as I open it, the tabs do open but the highlighted tab (from BEFORE I close WF) is always a "New tab" tab and I have to click Back on that tab to get the actual content from before I close WF. Any ideas?
My System
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K Asus P8Z68-V/GEN3 EVGA GTX 1080 Ti FTW3 2x8GB G.Skill Trident X (F3-2400C10D-16GTX) @ 2... 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500GB Samsung Spinpoint F3 1TB CPU: Swiftech H220-X Windows 10 x64 Enterprise 
MonitorKeyboardPowerCase
Dell S2716DG Ducky Shine 3 DK9008 MX Brown and Red LED Seasonic P-760 SS-760XP2 Cooler Master HAF 922 
MouseMouse PadAudioAudio
Roccat Savu Steelseries QCK Mass Edifier HCS2330 2.1 Speaker System (using Onboa... HyperX Cloud Revolver Gaming Headset 
Other
APC BR1500GI UPS 
  hide details  
Reply
My System
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K Asus P8Z68-V/GEN3 EVGA GTX 1080 Ti FTW3 2x8GB G.Skill Trident X (F3-2400C10D-16GTX) @ 2... 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500GB Samsung Spinpoint F3 1TB CPU: Swiftech H220-X Windows 10 x64 Enterprise 
MonitorKeyboardPowerCase
Dell S2716DG Ducky Shine 3 DK9008 MX Brown and Red LED Seasonic P-760 SS-760XP2 Cooler Master HAF 922 
MouseMouse PadAudioAudio
Roccat Savu Steelseries QCK Mass Edifier HCS2330 2.1 Speaker System (using Onboa... HyperX Cloud Revolver Gaming Headset 
Other
APC BR1500GI UPS 
  hide details  
Reply
post #6493 of 7359
mega.co.nx fix build when release time wait long not hope sites other affect does random close desktop show like mega switch browser must use sites mad.gif

many site asm.js use waterfox crash it does work it not see http://kripken.github.io/Massive/ many peoples issue same mega not use mad.gif
post #6494 of 7359
Quote:
Originally Posted by MrAlex View Post


Yes, HW acceleration isn't very consistent with Firefox/Waterfox unfortunately.

Yes that's right. HW acceleration either works or causes lots of issues.

So I heard, but personally it has been very consistent for me since Firefox 4 through a multitude of Nvidia and ATI/AMD chips. Anyways, I created fresh test profile to try to isolate it a while back, but it still the same thing happened. It seems to be ongoing AMD(Southern Island series of chips)/Firefox issues and by extension any recompiled builds like Waterfox.

For this specific issue, It started after Mozilla ver 33 or 32, I have also seen it in 34 stable, and 35 beta, so Mozilla did something with hardware acceleration with a version update. The ESR version based on Ver 31, which I am using for now, never experiences this issue at all. I run separate instances of the channels (esr, release, Beta, Nightly), with their own profiles so that's how I test.

It is infrequent so I guess people will probably ignore b/c it is infrequent and goes away if you scroll enough. Here is the closest bugzilla report I can find of it.
https://bugzilla.mozilla.org/show_bug.cgi?id=1066839

There might be others, but I didn't want to filter through the literally hundreds of reported graphics bugs to find anything else. Most people will also probably switch hardware acceleration off and be on their merry way if it becomes enough of an annoyance. I won't b/c there are website I visit sometimes that use hardware acceleration. I will just eventually switch to Chrome if the issue isn't fixed by the time Firefox 31 esr is no long supported.
post #6495 of 7359
Speaking of HW Acceleration, my roomie uses Firefox and he was having problems with Skyrim bogging down occasionally. A lot of that went away when ti turned out he liked to have FF in the background while Skyrim was running, and we disabled HW acceleration on the browser.
4690K System
(12 items)
 
HTPC
(9 items)
 
HP dv6 laptop
(13 items)
 
CPUMotherboardGraphicsRAM
Core i5 4690K ASRock Z97 Extreme4 XFX Radeon 7950 32 GB DDR3-2133 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO SSD Samsung DVD/CD-writer Corsair Hydro H60 Windows 7 
MonitorMonitorPowerCase
ASUS PA248Q Dell U2412M XFX 850W Black Edition XXX Fractal Design Arc Midi 2 
CPUMotherboardGraphicsRAM
Pentium Dual Core E6700 MSI G41M-P33 Combo ATI HD4350 Kingston ValueRAM DDR3-1333 
RAMHard DriveOSMonitor
Kingston ValueRAM DDR3-1333 WD Caviar Blue Windows 7 64-bit Sony 32" TV set 
Case
Apex TX-381 
CPUGraphicsRAMHard Drive
Core i5 430M GT230M (1 Gb dedicated) 8 GB DDR3-1066 640 GB 
OSMonitor
Windows 7 Home Premium (64-bit) 15.6" 
  hide details  
Reply
4690K System
(12 items)
 
HTPC
(9 items)
 
HP dv6 laptop
(13 items)
 
CPUMotherboardGraphicsRAM
Core i5 4690K ASRock Z97 Extreme4 XFX Radeon 7950 32 GB DDR3-2133 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO SSD Samsung DVD/CD-writer Corsair Hydro H60 Windows 7 
MonitorMonitorPowerCase
ASUS PA248Q Dell U2412M XFX 850W Black Edition XXX Fractal Design Arc Midi 2 
CPUMotherboardGraphicsRAM
Pentium Dual Core E6700 MSI G41M-P33 Combo ATI HD4350 Kingston ValueRAM DDR3-1333 
RAMHard DriveOSMonitor
Kingston ValueRAM DDR3-1333 WD Caviar Blue Windows 7 64-bit Sony 32" TV set 
Case
Apex TX-381 
CPUGraphicsRAMHard Drive
Core i5 430M GT230M (1 Gb dedicated) 8 GB DDR3-1066 640 GB 
OSMonitor
Windows 7 Home Premium (64-bit) 15.6" 
  hide details  
Reply
post #6496 of 7359
Thread Starter 

Hi all, sorry for being away so long, in the midst of exam period! Here's Waterfox 34.0.2 for testing:

 

Download

 

  • Fixed mega.co.nz issues thanks to InternalError503
  • Testing tbb_malloc as tcmalloc has issues registering it's .dll with regsvr32
  • Implemented some patches from FX36,37 in regards to what HW acceleration gets enabled with some systems as Mozilla have been losing users due to some issues related to it.

 

Quote:

Originally Posted by malcomX View Post
 
Quote:
Originally Posted by MrAlex View Post

Haven't been aware of sponsored tabs being enabled in 3rd party builds yet. It won't be long now smile.gif

eyes check must i tile sponsored look do they
image see must

I'll look into that :)

 

Quote:
Originally Posted by gijs007 View Post

@MrAlex
Quote:
Originally Posted by MrAlex View Post

Yes I've seen the TBB malloc but haven't had time to test it yet. I'll definitely look into it!
Cool thumb.gif, can you send me a PM and post the results here so me and other people know if its useful to replace malloc in other programs as well? wink.gif

One more question, or actually three.
Can you tell me which version of visual studio, Windows SDK and Intel Compiller you use?

Btw: the download link on this thread's first post doesn't work: https://waterfoxproject.org/download.php
Btw 2: Would you be interested in recompiling other programs (for a fee?) I wonder if PHP 5.6 for windows NTS could be made faster with the Intel Compiler.
Btw 3: Would you be interested in Donations or a fast dedicated or VPS server to help with compiling? (Intel® Xeon® E3 1230 v3, or a shared Intel Xeon
E5-1620v2)

You can test above if you'd like!  Currently use VS2010, 7.0A SDK and Intel C++ 13 SP 1 Update 3.

 

I'll fix the link thanks. And as for recompiling I could give it a test for free, no reason to charge to see if it's easily doable and then just post a guide?

 

I might open up donations again, but everything is ok on the VPS/compiling side thanks for the offer :D

 

Quote:
Originally Posted by kevindd992002 View Post

I've also noticed another problem with the new version of Waterfox (this does not happen in the older versions). I have a lot of tabs opened and my WF is set to "show tabs and windows from last time". I close WF and as soon as I open it, the tabs do open but the highlighted tab (from BEFORE I close WF) is always a "New tab" tab and I have to click Back on that tab to get the actual content from before I close WF. Any ideas?

 

Ooh that is strange. Don't suppose you could take some screenshots on how to reproduce?

Quote:
Originally Posted by malcomX View Post

mega.co.nx fix build when release time wait long not hope sites other affect does random close desktop show like mega switch browser must use sites mad.gif

many site asm.js use waterfox crash it does work it not see http://kripken.github.io/Massive/ many peoples issue same mega not use mad.gif

 

Don't worry it is fixed in above build, if everything is okay with everyone I'll release tonight/tomorrow.

 

Quote:
Originally Posted by Levisas View Post
 
Quote:
Originally Posted by MrAlex View Post


Yes, HW acceleration isn't very consistent with Firefox/Waterfox unfortunately.

Yes that's right. HW acceleration either works or causes lots of issues.

So I heard, but personally it has been very consistent for me since Firefox 4 through a multitude of Nvidia and ATI/AMD chips. Anyways, I created fresh test profile to try to isolate it a while back, but it still the same thing happened. It seems to be ongoing AMD(Southern Island series of chips)/Firefox issues and by extension any recompiled builds like Waterfox.

For this specific issue, It started after Mozilla ver 33 or 32, I have also seen it in 34 stable, and 35 beta, so Mozilla did something with hardware acceleration with a version update. The ESR version based on Ver 31, which I am using for now, never experiences this issue at all. I run separate instances of the channels (esr, release, Beta, Nightly), with their own profiles so that's how I test.

It is infrequent so I guess people will probably ignore b/c it is infrequent and goes away if you scroll enough. Here is the closest bugzilla report I can find of it.
https://bugzilla.mozilla.org/show_bug.cgi?id=1066839

There might be others, but I didn't want to filter through the literally hundreds of reported graphics bugs to find anything else. Most people will also probably switch hardware acceleration off and be on their merry way if it becomes enough of an annoyance. I won't b/c there are website I visit sometimes that use hardware acceleration. I will just eventually switch to Chrome if the issue isn't fixed by the time Firefox 31 esr is no long supported.

 

Yes Firefox has some issues with AMD cards and so in the newer beta/alpha builds they're blacklisting them so HW acceleration is off. I think they're trying to fix it but there's no specific bug for it since it doesn't seem to be just one issue.

 

Quote:
Originally Posted by Quantum Reality View Post

Speaking of HW Acceleration, my roomie uses Firefox and he was having problems with Skyrim bogging down occasionally. A lot of that went away when ti turned out he liked to have FF in the background while Skyrim was running, and we disabled HW acceleration on the browser.

 

Ah dear, that's a shame but hopefully it won't impact his browsing experience!


Edited by MrAlex - 1/4/15 at 10:22am
    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
post #6497 of 7359
Quote:
Originally Posted by MrAlex View Post

I'll look into that smile.gif

You can test above if you'd like!  Currently use VS2010, 7.0A SDK and Intel C++ 13 SP 1 Update 3.

I'll fix the link thanks. And as for recompiling I could give it a test for free, no reason to charge to see if it's easily doable and then just post a guide?

I might open up donations again, but everything is ok on the VPS/compiling side thanks for the offer biggrin.gif
That's cool, is there any reason you don't use the latest VS, SDK and Intel C++?
A guide would be appreciated, I'm not really a programmer but if I could learn how to recompile app's in the Intel Compiler that could be useful to see if there is a performance increase smile.gif
X299
(9 items)
 
Z77
(19 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-7820X Asus ROG Strix X299-E Gaming EVGA GeForce GTX 1080 8GB SC GAMING ACX 3.0 G.SKILL F4-3600C16Q-32GTZR 
Hard DriveCoolingOSPower
Intel 750 SSD NZXT Kraken X62 Windows 10 pro 64bit Corsair AX860i 
Case
Corsair Crystal 570X RGB 
  hide details  
Reply
X299
(9 items)
 
Z77
(19 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-7820X Asus ROG Strix X299-E Gaming EVGA GeForce GTX 1080 8GB SC GAMING ACX 3.0 G.SKILL F4-3600C16Q-32GTZR 
Hard DriveCoolingOSPower
Intel 750 SSD NZXT Kraken X62 Windows 10 pro 64bit Corsair AX860i 
Case
Corsair Crystal 570X RGB 
  hide details  
Reply
post #6498 of 7359
Quote:
Originally Posted by MrAlex View Post


Hi thecreator, thanks for the info. Looks like print preview isn't working properly on some systems. If you disable hardware acceleration does this solve the issue?

Hi MrAlex,

With Hardware-Acceleration on and also Off, Print Preview actually works. I was able to see what I wanted to print. I printed to Nuance Power PDF Advanced and only the URL, being the Header printed. And the Footer printed showing the time it printed. But the information, itself, did not print. And I attempted to print to my physical printer and the information did not which was what I ordered.

I went to my other computer where still using Windows 7 Ultimate 64-Bit Service Pack 1, with 64-Bit Firefox Nightly is installed, I was able to print out the information in the Print Preview Window.

http://haband.blair.com/p/men/outerwear/heavyweight-workwear/ice-house174-insulated-parka/pc/3470/c/3486/sc/3490/93866.uts?store=18&count=500&q2=3486~Outerwear&q1=3470~Men&intl=n&q=*&q3=3490~Heavyweight+%26+Workwear&sc=N&x2=c.t2&x3=c.t3&x1=c.t1#

That is the URL of what I printed out using 64-Bit Firefox Nightly 37.0a1. And what I attempted to print from Waterfox 34.0.1 where it prints out blank, except for the header and footer information.

Just went back to the same computer where I have Waterfox 34.0.1 installed. I loaded the same page with Firefox 34.0.5 and Print Preview loaded just fine and it printed to Nuance Power PDF Advanced just fine.
post #6499 of 7359
My WF doesn't have the "+" symbol on the upper-right hand side to add tabs. I'm not sure what happened but it was there all along until now. How do I add it back? The other computers that I have with WF also have that symbol.
My System
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K Asus P8Z68-V/GEN3 EVGA GTX 1080 Ti FTW3 2x8GB G.Skill Trident X (F3-2400C10D-16GTX) @ 2... 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500GB Samsung Spinpoint F3 1TB CPU: Swiftech H220-X Windows 10 x64 Enterprise 
MonitorKeyboardPowerCase
Dell S2716DG Ducky Shine 3 DK9008 MX Brown and Red LED Seasonic P-760 SS-760XP2 Cooler Master HAF 922 
MouseMouse PadAudioAudio
Roccat Savu Steelseries QCK Mass Edifier HCS2330 2.1 Speaker System (using Onboa... HyperX Cloud Revolver Gaming Headset 
Other
APC BR1500GI UPS 
  hide details  
Reply
My System
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K Asus P8Z68-V/GEN3 EVGA GTX 1080 Ti FTW3 2x8GB G.Skill Trident X (F3-2400C10D-16GTX) @ 2... 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500GB Samsung Spinpoint F3 1TB CPU: Swiftech H220-X Windows 10 x64 Enterprise 
MonitorKeyboardPowerCase
Dell S2716DG Ducky Shine 3 DK9008 MX Brown and Red LED Seasonic P-760 SS-760XP2 Cooler Master HAF 922 
MouseMouse PadAudioAudio
Roccat Savu Steelseries QCK Mass Edifier HCS2330 2.1 Speaker System (using Onboa... HyperX Cloud Revolver Gaming Headset 
Other
APC BR1500GI UPS 
  hide details  
Reply
post #6500 of 7359
The new version 34.0.2 doesn't display correctly this page
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 55.0.2: 22 August [Firefox 64-Bit]