Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 56.0.1: 13 December [Free, open and private web browser.]
New Posts  All Forums:Forum Nav:

Waterfox 56.0.1: 13 December [Free, open and private web browser.] - Page 675

post #6741 of 7372
Quote:
Originally Posted by MrAlex View Post

Hmm. As seti mentioned below, does setting webgl.disable-angle to true still invoke memory leaks?

Yes. I did both of the config tweaks mentioned, went to the tester page to confirm ANGLE isn't in use (sizes are now 4096), closed and reopened WF for good measure, and then checked out the WebGL demo pages. And the leak continues.

Something's up on my end but what?
post #6742 of 7372
Alex,

v36 is a great release, RAM usage is back to under 1.5gigs for my setup, performance is also much snappier generally than before, probably better than it was in V34.

One tiny gripe the help/about page doesn't seem to be looking for an update, so i had to download it manually. Great work, keep it up thumb.gif
post #6743 of 7372
MrAlex, isn't the updater already fixed? My v35 WF still doesn't see that there's a v36 update.
My System
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K Asus P8Z68-V/GEN3 EVGA GTX 1080 Ti FTW3 2x8GB G.Skill Trident X (F3-2400C10D-16GTX) @ 2... 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500GB Samsung Spinpoint F3 1TB CPU: Swiftech H220-X Windows 10 x64 Enterprise 
MonitorKeyboardPowerCase
Dell S2716DG Ducky Shine 3 DK9008 MX Brown and Red LED Seasonic P-760 SS-760XP2 Cooler Master HAF 922 
MouseMouse PadAudioAudio
Roccat Savu Steelseries QCK Mass Edifier HCS2330 2.1 Speaker System (using Onboa... HyperX Cloud Revolver Gaming Headset 
Other
APC BR1500GI UPS 
  hide details  
Reply
My System
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K Asus P8Z68-V/GEN3 EVGA GTX 1080 Ti FTW3 2x8GB G.Skill Trident X (F3-2400C10D-16GTX) @ 2... 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500GB Samsung Spinpoint F3 1TB CPU: Swiftech H220-X Windows 10 x64 Enterprise 
MonitorKeyboardPowerCase
Dell S2716DG Ducky Shine 3 DK9008 MX Brown and Red LED Seasonic P-760 SS-760XP2 Cooler Master HAF 922 
MouseMouse PadAudioAudio
Roccat Savu Steelseries QCK Mass Edifier HCS2330 2.1 Speaker System (using Onboa... HyperX Cloud Revolver Gaming Headset 
Other
APC BR1500GI UPS 
  hide details  
Reply
post #6744 of 7372
My update work. It informed me of the new V36. I downloaded it and it installed fine. No issues yet with WF36.
post #6745 of 7372
Thread Starter 
Quote:
Originally Posted by themushroom View Post
 
Quote:
Originally Posted by MrAlex View Post

Hmm. As seti mentioned below, does setting webgl.disable-angle to true still invoke memory leaks?

Yes. I did both of the config tweaks mentioned, went to the tester page to confirm ANGLE isn't in use (sizes are now 4096), closed and reopened WF for good measure, and then checked out the WebGL demo pages. And the leak continues.

Something's up on my end but what?

 

Hmm I don't think any config changes will help for this. I'm going to be making a new build in a bit and I'll also post here for you to test out to see if it makes a difference for you. Also just to clarify, this happens on Firefox as well?

Quote:
Originally Posted by kevindd992002 View Post

MrAlex, isn't the updater already fixed? My v35 WF still doesn't see that there's a v36 update.

It is fixed but the issue is that the 35.0 updater only accepts signed MAR files (for some reason this was changed and enabled by default in 35.0!) so I've been scavenging the Mozilla docs to see how to sign the update file properly!! Old builds didn't have this on by default and I've disabled it for 36.0 but I'll make sure to find out how to sign MAR files for 35.0! Sorry about the inconvenience, I've been trying for a few weeks now to get this to work but I'm sure I'll figure it out soon. :D

 

Quote:
Originally Posted by chorse View Post

My update work. It informed me of the new V36. I downloaded it and it installed fine. No issues yet with WF36.

 

Yes only 35.0 hasn't received the update as I'm not seeding it to that version until I can sign the update files correctly. Good to hear it worked for you!

 

Quote:
Originally Posted by bIOforger View Post

Alex,

v36 is a great release, RAM usage is back to under 1.5gigs for my setup, performance is also much snappier generally than before, probably better than it was in V34.

One tiny gripe the help/about page doesn't seem to be looking for an update, so i had to download it manually. Great work, keep it up thumb.gif

 

Great to hear! And yes sorry about that, it's the issue I've mentioned above.

    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
post #6746 of 7372
Anyone else having issues with HTML5 video not playing?
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.2/3.5GHz core/uncore, 1.175/1.15v Gigabyte X99 SOC Champion (F22n) Gigabyte AORUS GTX 1080 Ti (F3P) @ 2025/1485, 1... 4x4GiB Crucial @ 2667, 12-12-12-28-T1, 1.34v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.06) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Sapphire Fury Nitro OC+ @ 1053/500, 1.225vGPU/1... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.2/3.5GHz core/uncore, 1.175/1.15v Gigabyte X99 SOC Champion (F22n) Gigabyte AORUS GTX 1080 Ti (F3P) @ 2025/1485, 1... 4x4GiB Crucial @ 2667, 12-12-12-28-T1, 1.34v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.06) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Sapphire Fury Nitro OC+ @ 1053/500, 1.225vGPU/1... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
post #6747 of 7372
Thread Starter 
Quote:
Originally Posted by Blameless View Post

Anyone else having issues with HTML5 video not playing?

 

Is this for YouTube or any HTML5 video? If it's for any HTML5 video separate from YouTube, you can go to about:config and change media.mediasource.youtubeonly to true.

I enabled media streaming extensions for everything, because Mozilla only got it fully working for YouTube, but on most systems most of the time it works well.

    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
post #6748 of 7372
Quote:
Originally Posted by MrAlex View Post

Hmm I don't think any config changes will help for this. I'm going to be making a new build in a bit and I'll also post here for you to test out to see if it makes a difference for you. Also just to clarify, this happens on Firefox as well?

Yep, FF 36.0 as well. So it's either something in the core program or something on my computer. I haven't yet installed WF on another machine or tried out WebGL in FF 36 on another machine for comparison, which I realize I should.
post #6749 of 7372
Quote:
Originally Posted by MrAlex View Post

Is this for YouTube or any HTML5 video? If it's for any HTML5 video separate from YouTube, you can go to about:config and change media.mediasource.youtubeonly to true.
I enabled media streaming extensions for everything, because Mozilla only got it fully working for YouTube, but on most systems most of the time it works well.

YouTube, so far as I've tried, and it doesn't matter what I set "media.mediasource.youtubeonly" too.

When I look at https://www.youtube.com/html5 it shows that h.264 is not supported.
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.2/3.5GHz core/uncore, 1.175/1.15v Gigabyte X99 SOC Champion (F22n) Gigabyte AORUS GTX 1080 Ti (F3P) @ 2025/1485, 1... 4x4GiB Crucial @ 2667, 12-12-12-28-T1, 1.34v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.06) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Sapphire Fury Nitro OC+ @ 1053/500, 1.225vGPU/1... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.2/3.5GHz core/uncore, 1.175/1.15v Gigabyte X99 SOC Champion (F22n) Gigabyte AORUS GTX 1080 Ti (F3P) @ 2025/1485, 1... 4x4GiB Crucial @ 2667, 12-12-12-28-T1, 1.34v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.06) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Sapphire Fury Nitro OC+ @ 1053/500, 1.225vGPU/1... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
post #6750 of 7372
Hi Mr. Alex,

I waited and I was able to install the update.

However, on my Dell Laptop, with Windows 7 Home Premium 64-Bit Service Pack 1 full patched, I can't upgrade going through the program.

I get errors that FireFox is currently running and that I should close it.

2015-03-03-UnabletoUpgradeWaterFoxthroughUpdater.jpg 249k .jpg file

Also I manually upgraded to WaterFox 36.0 and WaterFox 36.0 in now in a circle. When I open WaterFox, it detects an Update is ready to be applied and when I attempt to apply the Update, Updater shows another instance of FireFox is running.

How do I permanently fix this issue? Thank you!

2015-03-03-RestartWaterfoxtoUpdate.jpg 366k .jpg file
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 56.0.1: 13 December [Free, open and private web browser.]