Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 56.0: 30 November [Free, open and private web browser.]
New Posts  All Forums:Forum Nav:

Waterfox 56.0: 30 November [Free, open and private web browser.] - Page 649

post #6481 of 7367
Quote:
Originally Posted by kevindd992002 View Post

What do you mean "HW turning off"? Do you mean turning off HW acceleration?

The most important thing Chrome doesn't have is to display a fixed tab length when you're using hundreds of tabs. In Chrome, it will display all those tabs in one window length making all tabs minute and very hard to select.

Yes HW acceleration off, also I quoted the wrong post, edited original post for context. The issue is HW acceleration not working properly with Firefox and by extension Waterfox. The past couple of years, I used both Chrome and Firefox, preferred Firefox 80 percent of time, but this issue is important enough for me to switch to Chrome. Though I am not a heavy tab user, so I never personally ran into your issue.
post #6482 of 7367
Quote:
Originally Posted by Levisas View Post

Yes HW acceleration off, also I quoted the wrong post, edited original post for context. The issue is HW acceleration not working properly with Firefox and by extension Waterfox. The past couple of years, I used both Chrome and Firefox, preferred Firefox 80 percent of time, but this issue is important enough for me to switch to Chrome. Though I am not a heavy tab user, so I never personally ran into your issue.

How did you know that HW acceleration is not working though?
My System
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K Asus P8Z68-V/GEN3 EVGA GTX 1080 Ti FTW3 2x8GB G.Skill Trident X (F3-2400C10D-16GTX) @ 2... 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500GB Samsung Spinpoint F3 1TB CPU: Swiftech H220-X Windows 10 x64 Enterprise 
MonitorKeyboardPowerCase
Dell S2716DG Ducky Shine 3 DK9008 MX Brown and Red LED Seasonic P-760 SS-760XP2 Cooler Master HAF 922 
MouseMouse PadAudioAudio
Roccat Savu Steelseries QCK Mass Edifier HCS2330 2.1 Speaker System (using Onboa... HyperX Cloud Revolver Gaming Headset 
Other
APC BR1500GI UPS 
  hide details  
Reply
My System
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K Asus P8Z68-V/GEN3 EVGA GTX 1080 Ti FTW3 2x8GB G.Skill Trident X (F3-2400C10D-16GTX) @ 2... 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500GB Samsung Spinpoint F3 1TB CPU: Swiftech H220-X Windows 10 x64 Enterprise 
MonitorKeyboardPowerCase
Dell S2716DG Ducky Shine 3 DK9008 MX Brown and Red LED Seasonic P-760 SS-760XP2 Cooler Master HAF 922 
MouseMouse PadAudioAudio
Roccat Savu Steelseries QCK Mass Edifier HCS2330 2.1 Speaker System (using Onboa... HyperX Cloud Revolver Gaming Headset 
Other
APC BR1500GI UPS 
  hide details  
Reply
post #6483 of 7367
Quote:
Originally Posted by MrAlex View Post


Do you already see them in Waterfox? If so I'll have to backtrack quite a few bugs that Mozilla have implemented

sponsored new tab tiles in waterfox https://support.mozilla.org/bg/kb/how-do-tiles-work-firefox
mega.co.nx fix build when release time wait long not hope
post #6484 of 7367
Quote:
Originally Posted by kevindd992002 View Post

How did you know that HW acceleration is not working though?

http://www.overclock.net/t/975626/waterfox-34-0-1-17-december-firefox-64-bit/6470#post_23335526
post #6485 of 7367

Are you referring to the display corruption issue on that post?
My System
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K Asus P8Z68-V/GEN3 EVGA GTX 1080 Ti FTW3 2x8GB G.Skill Trident X (F3-2400C10D-16GTX) @ 2... 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500GB Samsung Spinpoint F3 1TB CPU: Swiftech H220-X Windows 10 x64 Enterprise 
MonitorKeyboardPowerCase
Dell S2716DG Ducky Shine 3 DK9008 MX Brown and Red LED Seasonic P-760 SS-760XP2 Cooler Master HAF 922 
MouseMouse PadAudioAudio
Roccat Savu Steelseries QCK Mass Edifier HCS2330 2.1 Speaker System (using Onboa... HyperX Cloud Revolver Gaming Headset 
Other
APC BR1500GI UPS 
  hide details  
Reply
My System
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K Asus P8Z68-V/GEN3 EVGA GTX 1080 Ti FTW3 2x8GB G.Skill Trident X (F3-2400C10D-16GTX) @ 2... 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500GB Samsung Spinpoint F3 1TB CPU: Swiftech H220-X Windows 10 x64 Enterprise 
MonitorKeyboardPowerCase
Dell S2716DG Ducky Shine 3 DK9008 MX Brown and Red LED Seasonic P-760 SS-760XP2 Cooler Master HAF 922 
MouseMouse PadAudioAudio
Roccat Savu Steelseries QCK Mass Edifier HCS2330 2.1 Speaker System (using Onboa... HyperX Cloud Revolver Gaming Headset 
Other
APC BR1500GI UPS 
  hide details  
Reply
post #6486 of 7367
Hi All,

Problem when printing. uses Waterfox 34.01.

What is being printed: Belarc Advisor 8.4 Output to Power PDF Advanced 1.0 file. Only Page 1 has information printed on it The rest of the pages are blank.

Using Firefox 34.0.5 32-Bit browser as the default Browser for test.

What is being printed: Belarc Advisor 8.4 Output to Power PDF Advanced 1.0 file. All pages have information printed on them.
post #6487 of 7367
Quote:
Originally Posted by amiew View Post

I would assume it does, since when I went back to it, I had to update everything, including bookmarks and some Add-ons. It's not installed in the FF programs file, so you have to clean the history manually, whereas WF gets cleaned by CCleaner when I run it. I don't have FF desktop installed in the programs folder anymore, just WF, and CCleaner identifies it as FF.

I have tried running it in safe mode, which makes it a little faster, but haven't tried a blank profile. Since FF portable is working for me right now, I don't want to take the time to mess with WF. Once I get time, I may do a clean install and see if that fixes the problems, but I won't have time to do that for awhile, at least after the holidays.

I have been having the exact same problems with WF for some time now. A blank profile fixes it but not for long. As soon as you Bookmark any websites or just from daily usage it begins to become very slow. The browser just becomes unusable.

I have tested it next to PaleMoon and FFnightly and both browser performed brilliantly while WF lagged behind. At this point I don`t know what to do... maybe give chrome a try.

I have also found that right after WF updates itself then that is when the browser even gets slower.
post #6488 of 7367
@MrAlex
Since I read about the new tcmalloc memory manager in Waterfox I was wondering if you've considered using: intel tbb malloc
It's a malloc memory manager by intel which makes use of Intel® TBB(Threading Building Blocks) so it might be even faster.

I found out about its existence trough arma 2 and 3 which both have it included as memory manager.

It's source can be found here:
https://www.threadingbuildingblocks.org/sites/default/files/software_releases/source/tbb42_20131118oss_src.tgz

Precompiled version can be downloaded from: https://www.threadingbuildingblocks.org/sites/default/files/software_releases/windows/tbb43_20141204oss_win_0.zip

Newer versions can be found here under stable and development releases.:
https://www.threadingbuildingblocks.org/download#code-samples
X299
(9 items)
 
Z77
(19 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-7820X Asus ROG Strix X299-E Gaming EVGA GeForce GTX 1080 8GB SC GAMING ACX 3.0 G.SKILL F4-3600C16Q-32GTZR 
Hard DriveCoolingOSPower
Intel 750 SSD NZXT Kraken X62 Windows 10 pro 64bit Corsair AX860i 
Case
Corsair Crystal 570X RGB 
  hide details  
Reply
X299
(9 items)
 
Z77
(19 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-7820X Asus ROG Strix X299-E Gaming EVGA GeForce GTX 1080 8GB SC GAMING ACX 3.0 G.SKILL F4-3600C16Q-32GTZR 
Hard DriveCoolingOSPower
Intel 750 SSD NZXT Kraken X62 Windows 10 pro 64bit Corsair AX860i 
Case
Corsair Crystal 570X RGB 
  hide details  
Reply
post #6489 of 7367
Thread Starter 
Quote:
Originally Posted by btgbullseye View Post
 
Quote:
Originally Posted by MrAlex View Post

Any chance you could have it so crash logs don't clear on restart? Would make finding out the issue a bit easier!
Did, and it provided no crash log. It acts like it didn't crash at all, contrary to what my eyes witness.

 

I'm really curious why it always crashes for you. So the following has been tried, please correct me if I miss anything out:

 

  • On a fresh install
  • Fresh profile (for Waterfox)
  • HW acceleration disable
  • No add-ons

And it happens to be randomly right?

 

v35 might fix some issues you'll be having. I'm attempting to build a preview release to test everything and I'll be upgrading the tools I'm using so maybe this issue will be resolved.

Quote:
Originally Posted by Lopser View Post

And I have.

 

Hmm yes this isn't good, I think I know what the problem is.

 

Quote:
Originally Posted by GunnzAkimbo View Post

Clear disk cache
Update Java
Tweak some network settings and cache settings.
Get CCleaner with the extra addons and clear out nearly all the firefox options (except passwords, session, site prefs, any others you want to keep).

Should run better with lots of addons after doing the above.

 

Okay good to hear!

Quote:
Originally Posted by RevZ View Post

Waterfox is corrupting my folder thumbnails when I browse folders inside the Save Image dialog to save images (in this case .jpg files from i.imgur.com) to image folders containing large amounts of subfolders and files (over 75000).

I do not know in the least what is causing this, but here are some key points which I think are recurring:
  • The thumbnails most often do not corrupt if they're already in cache after having been generated by Windows itself;
  • If no thumbnail exists for a subfolder, when you browse into its parent folder WF will generate the above corrupted thumbnail image;
  • The image it generates is the same for every folder it generates a thumbnail for;
  • When clearing the thumbnail cache, if generated by Windows the thumbnails are good, but if generated by WF they're always bad now.
  • It started happening after version 34 at the earliest, and I think even only after the update to 34.0.1.

Here's what it generates:



EDIT: I was doing some more image saves just now, and going into a folder I hadn't visited with WF's Save Image dialog yet until I regenerated the thumbnails via Windows first. killed random thumbnails which were already existing in cache.. They got replaced with similar pink-ish colored noise patterns, just like the above example but not quite the same. Once this happes the change is permanent until the cache is cleared, a PC restart obviously does not help.

I saved at least fifteen of these images before this happened, so it's not consistent! But doing many manipulations via Windows Explorer in the same folders did not affect anything and neither did any thumbnails corrupt when I was doing the same image browsing/saving via IE..

Yes I think I know what's wrong I'll have a look :)

 

Quote:
Originally Posted by Levisas View Post
 
Quote:
Originally Posted by msuguy71 View Post

Hi all, been having weird display corruption issues in Waterfox since updating to the new Cataylst Omega drivers when hardware acceleration is checked in the Waterfox options. I unchecked hardware acceleration to see if it is any better. Here is a screenshot



Any thoughts?

Rick

System specs:

i4790K
Gigabyte Gaming 7 MB
16GB DDR3 1866 ram
XFX DD R9 270X
Gigabyte 6870OC
Windows 8.1 pro x64

Using Windows 8.1, R9 290 getting the same exact problem too for Firefox 34 official. HW turning off solve it of course, but I think it is enough of a problem to finally migrate to Chrome.

Edit: Wrong quote

 

Yes, HW acceleration isn't very consistent with Firefox/Waterfox unfortunately.

Quote:
Originally Posted by kevindd992002 View Post
 
Quote:
Originally Posted by Levisas View Post

Using Windows 8.1, R9 290 getting the same exact problem too for Firefox 34 official. HW turning off solve it of course, but I think it is enough of a problem to finally migrate to Chrome.

What do you mean "HW turning off"? Do you mean turning off HW acceleration?

The most important thing Chrome doesn't have is to display a fixed tab length when you're using hundreds of tabs. In Chrome, it will display all those tabs in one window length making all tabs minute and very hard to select.

 

Yes that's right. HW acceleration either works or causes lots of issues.

 

 

Quote:
Originally Posted by malcomX View Post
 
Quote:
Originally Posted by MrAlex View Post


Do you already see them in Waterfox? If so I'll have to backtrack quite a few bugs that Mozilla have implemented

sponsored new tab tiles in waterfox https://support.mozilla.org/bg/kb/how-do-tiles-work-firefox
mega.co.nx fix build when release time wait long not hope

 

Haven't been aware of sponsored tabs being enabled in 3rd party builds yet. It won't be long now :)

 

 

 

Quote:
Originally Posted by thecreator1965 View Post

Hi All,

Problem when printing. uses Waterfox 34.01.

What is being printed: Belarc Advisor 8.4 Output to Power PDF Advanced 1.0 file. Only Page 1 has information printed on it The rest of the pages are blank.

Using Firefox 34.0.5 32-Bit browser as the default Browser for test.

What is being printed: Belarc Advisor 8.4 Output to Power PDF Advanced 1.0 file. All pages have information printed on them.

 

Hi thecreator, thanks for the info. Looks like print preview isn't working properly on some systems. If you disable hardware acceleration does this solve the issue?

 

Quote:
Originally Posted by blackshap9 View Post
 
Quote:
Originally Posted by amiew View Post

I would assume it does, since when I went back to it, I had to update everything, including bookmarks and some Add-ons. It's not installed in the FF programs file, so you have to clean the history manually, whereas WF gets cleaned by CCleaner when I run it. I don't have FF desktop installed in the programs folder anymore, just WF, and CCleaner identifies it as FF.

I have tried running it in safe mode, which makes it a little faster, but haven't tried a blank profile. Since FF portable is working for me right now, I don't want to take the time to mess with WF. Once I get time, I may do a clean install and see if that fixes the problems, but I won't have time to do that for awhile, at least after the holidays.

I have been having the exact same problems with WF for some time now. A blank profile fixes it but not for long. As soon as you Bookmark any websites or just from daily usage it begins to become very slow. The browser just becomes unusable.

I have tested it next to PaleMoon and FFnightly and both browser performed brilliantly while WF lagged behind. At this point I don`t know what to do... maybe give chrome a try.

I have also found that right after WF updates itself then that is when the browser even gets slower.

 

Hmm, that isn't good at all. I'm making a few changes in 35.0 so maybe this will solve some of the issues you've been seeing.

Quote:
Originally Posted by gijs007 View Post

@MrAlex
Since I read about the new tcmalloc memory manager in Waterfox I was wondering if you've considered using: intel tbb malloc
It's a malloc memory manager by intel which makes use of Intel® TBB(Threading Building Blocks) so it might be even faster.

I found out about its existence trough arma 2 and 3 which both have it included as memory manager.

It's source can be found here:
https://www.threadingbuildingblocks.org/sites/default/files/software_releases/source/tbb42_20131118oss_src.tgz

Precompiled version can be downloaded from: https://www.threadingbuildingblocks.org/sites/default/files/software_releases/windows/tbb43_20141204oss_win_0.zip

Newer versions can be found here under stable and development releases.:
https://www.threadingbuildingblocks.org/download#code-samples

 

Yes I've seen the TBB malloc but haven't had time to test it yet. I'll definitely look into it!

    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
Intel Core i7-4650U Intel HD Graphics 5000 Samsung 8GB DDR3 Samsung 512GB SSD 
OS
Macintosh OS X "Yosemite" 
  hide details  
Reply
post #6490 of 7367
Quote:
Originally Posted by MrAlex View Post

Haven't been aware of sponsored tabs being enabled in 3rd party builds yet. It won't be long now smile.gif

eyes check must i tile sponsored look do they
image see must

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Waterfox 56.0: 30 November [Free, open and private web browser.]