post #1 of 1
Thread Starter 
Hey there OCNers
I just built my new rig, and the one thing i cant for the life of me figure out is why my center speaker wont play any sound in certain programs. i have logitech X-540 5.1 speakers which i used on my old rig, and never had any problems, i also use the latest realtek audio manager.

When i play crysis or TF2 i have no problems, sound plays from all speakers including the center speaker. but when i play BFBC2 or the witcher i get no sound from the center, and it sounds like what should be played through the center is missing. like in BFBC2 when i fire a gun it sounds all twangy and echoed in the front speakers, like its missing the "punch" from the center. it used to work fine with my old system, but now its just being a pain in the butt!

Anyone have any ideas or suggestions? iv tryed pretty much everything i can think of.
    
CPUMotherboardGraphicsRAM
Intel I5 2500k Asus P67 Sabertooth Gigabyte G1 Gtx970 8gb G.skill Ripjaw X 1333 Cl7 
Hard DriveHard DriveHard DriveHard Drive
1TB WD caviar black 7200rpm 64mb cache Crucial M4 128gb Crucial  Crucial  
Hard DriveCoolingOSKeyboard
Crucial  Zalman 9900max windows 7 64bit G11 
PowerCaseMouse Pad
Corsair HX750 antec eleven hundred Deathadder 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel I5 2500k Asus P67 Sabertooth Gigabyte G1 Gtx970 8gb G.skill Ripjaw X 1333 Cl7 
Hard DriveHard DriveHard DriveHard Drive
1TB WD caviar black 7200rpm 64mb cache Crucial M4 128gb Crucial  Crucial  
Hard DriveCoolingOSKeyboard
Crucial  Zalman 9900max windows 7 64bit G11 
PowerCaseMouse Pad
Corsair HX750 antec eleven hundred Deathadder 
  hide details  
Reply