Overclock.net › Forums › Graphics Cards › NVIDIA › Asus GTX 570 severe FPS drops >SOLVED<
New Posts  All Forums:Forum Nav:

Asus GTX 570 severe FPS drops >SOLVED<

post #1 of 11
Thread Starter 
I've tried it overclocked, stock. just smartdoctor open, just afterburner open, neither, ect, all the combinations I can think of, but when playing WoW or AC:B, I get MASSIVE frame rate drops ( under 3 fps for more than 2 seconds from a steady 57+/240+ fps (with/without vsync)) when I rotate the camera, and enabling monitoring of my gpu load/ gpu core shows that during these drops my gpu utilization drops under 10% and my core drops down to 405 (regardless of what the 3d clocks should be), and this happens at any graphics level from low to ultra. This never happens in LoL however.

Any ideas on what I should do? I see Rivatuner could prevent this for the 200 series, but the newest version i can find is from 2009, before the 500 series launched.

FIXED:
There are issues caused by the registry changes made by the program ASUS Gamer OSD that continue even when OSD is not running. This can be solved by removing Gamer OSD from the add/remove programs tab, the removal of OSD has no effect on the functionality of Smartdoctor. (It is impossible to install Smartdoctor without also installing OSD)
Edited by -Apocalypse- - 3/30/11 at 7:05pm
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
post #2 of 11
Do you have Power Management Mode set to Maximum Performance in the Nvidia Control Panel?
 
CPUMotherboardGraphicsRAM
Intel Core i7 3770K @ 4.1ghz Gigabyte Z77X-UP4 TH EVGA 780Ti Classified HydroCopper Samsung 16GB (4x4GB) Wonder RAM 
Hard DriveHard DriveHard DriveCooling
Corsair Performance Pro 256GB  Western Digital Elements 2TB Samsung F4 2TB EK Supremacy  
CoolingCoolingCoolingCooling
EK-CoolStream XTX 360 (X2) D5 w/ EK Top XSPC Photon 270 Tube Reservoir EK Compression Fittings 
CoolingOSMonitorKeyboard
Yate Loon Medium (x13) Windows 10 Pro x64 Dell UltraSharp U2715H  Corsair Strafe RGB w/ MX Cherry Silent 
PowerCaseMouseOther
NZXT Hale90-1000-M Caselabs SM8 Logitech M705 Marathon  NZXT Sleeved Extensions 
Other
NZXT Sentry 2 Fan Controller  
  hide details  
Reply
 
CPUMotherboardGraphicsRAM
Intel Core i7 3770K @ 4.1ghz Gigabyte Z77X-UP4 TH EVGA 780Ti Classified HydroCopper Samsung 16GB (4x4GB) Wonder RAM 
Hard DriveHard DriveHard DriveCooling
Corsair Performance Pro 256GB  Western Digital Elements 2TB Samsung F4 2TB EK Supremacy  
CoolingCoolingCoolingCooling
EK-CoolStream XTX 360 (X2) D5 w/ EK Top XSPC Photon 270 Tube Reservoir EK Compression Fittings 
CoolingOSMonitorKeyboard
Yate Loon Medium (x13) Windows 10 Pro x64 Dell UltraSharp U2715H  Corsair Strafe RGB w/ MX Cherry Silent 
PowerCaseMouseOther
NZXT Hale90-1000-M Caselabs SM8 Logitech M705 Marathon  NZXT Sleeved Extensions 
Other
NZXT Sentry 2 Fan Controller  
  hide details  
Reply
post #3 of 11
Thread Starter 
Quote:
Originally Posted by theonedub View Post
Do you have Power Management Mode set to Maximum Performance in the Nvidia Control Panel?
Doing that stopped the downclocking, but otherwise the problem remains, the gpu usage drops down under 10%, sometimes even 0%, and the fps does the same, typically below 3 fps.
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
post #4 of 11
Your PSU seems sufficeint and in thoery you rig should run fine with one of the best PSU's on the market, just check the cables connected to the GPU and PSU. Sounds silly but just check.

Re seat the card. make sure it is PCI-E slot 1.

Can you hear/see the fan moving?

Try another PSU if possible.

clearly i am trying to eleminate a hardware issue. but could be software issue.

not much else i can think without being there to play with it.
    
CPUMotherboardGraphicsRAM
3970X Rampage IV Formula EVGA 980Ti SC+ w/ACX BP Corsair Dominator Platinum 1866mhz 16GB 9-11-10-27 
Hard DriveCoolingCoolingOS
3.2TB Samsung/Corsair SSD's Corsair H100i Corsair Air Series SP120 Quiet Edition x2 Win7 64bit 
MonitorKeyboardPowerCase
2xAcer 23" 1080P  Corsair K70 Black (Red LED's) Corsair AX1200i Corsair 760T 
MouseAudioAudioAudio
Corsair M60 Sennheiser HD600 Corsair Void RGB Xonar Essence One 
Other
Corsair sleeved Cables (Red) 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
3970X Rampage IV Formula EVGA 980Ti SC+ w/ACX BP Corsair Dominator Platinum 1866mhz 16GB 9-11-10-27 
Hard DriveCoolingCoolingOS
3.2TB Samsung/Corsair SSD's Corsair H100i Corsair Air Series SP120 Quiet Edition x2 Win7 64bit 
MonitorKeyboardPowerCase
2xAcer 23" 1080P  Corsair K70 Black (Red LED's) Corsair AX1200i Corsair 760T 
MouseAudioAudioAudio
Corsair M60 Sennheiser HD600 Corsair Void RGB Xonar Essence One 
Other
Corsair sleeved Cables (Red) 
  hide details  
Reply
post #5 of 11
Thread Starter 
Quote:
Originally Posted by Antistatic12 View Post
Your PSU seems sufficeint and in thoery you rig should run fine with one of the best PSU's on the market, just check the cables connected to the GPU and PSU. Sounds silly but just check.

Re seat the card. make sure it is PCI-E slot 1.

Can you hear/see the fan moving?

Try another PSU if possible.

clearly i am trying to eleminate a hardware issue. but could be software issue.

not much else i can think without being there to play with it.
Fan's definitely there, card won't pass ~49C in WoW, ~60C in ACB. I think LoL might push it to like 43C heh. Runs through the Crysis benchmark (I've done up to 50 loops)/Heaven/Kombustor without any issues.

I should expand this to include, that in ACB, I can spin the camera outside the city (fewer textures, but still a fair bit) and it won't drop below 30 FPS. In the city, spinning my camera or riding too fast on a horse in a straight line for too long will give me a good 1-2s screen pause, (the AI gladly keeps attacking me though). The game is on more or less medium. In WoW, spinning the camera anywhere causes issues.

Also, I could play Crysis 2's demo on extreme settings without the FPS dropping below 55. Seems insane that I would under any circumstance see WoW put me below 20 outside a city, no less below 1 fps (my last test gave me a nice look at 0.2 FPS... fyi, it's pretty damn slow)
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
post #6 of 11
Thread Starter 
If no one else has any ideas, I'm going to be re-building this system (new case, a 212+, adding a new ssd and putting the old one back in) either this weekend or next, I'm waiting on Newegg to send me the case, but I don't have a tracking number since it was a contest prize, not a purchase.

If it keeps up after that, I'll re-install windows (that's the purpose of the smaller 30gb ssd anyways) earlier than I had planned. Keeps up after even that, and I'm going to be on the phone with Asus.
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
post #7 of 11
I suggest:
1) a complete defrag of your HDD
2) with VSync enabled, make sure triple buffering is also enabled. If unsure, go to Program Settings under NVCP and force it On.

Lastly, as this problem is not caused by downclocking, perhaps you should edit the Title of this thread to reflect the current status.
(Actually, I suspect this has nothing to do with your GTX570 because I did a brief web search and it seems that other cards (eg a HD5870) also have this mysterious drop of framerate as well.)

Edit 1
One question: once the dipping happens, does the framerate ever recover to its previous level?
Edited by windfire - 3/29/11 at 7:53pm
post #8 of 11
Thread Starter 
Quote:
Originally Posted by windfire View Post
I suggest:
1) a complete defrag of your HDD
2) with VSync enabled, make sure triple buffering is also enabled. If unsure, go to Program Settings under NVCP and force it On.

Lastly, as this problem is not caused by downclocking, perhaps you should edit the Title of this thread to reflect the current status.
(Actually, I suspect this has nothing to do with your GTX570 because I did a brief web search and it seems that other cards (eg a HD5870) also have this mysterious drop of framerate as well.)
HDD will likely be formatted this weekend (moving a lot of stuff around games to new ssd, OS to currently inactive* ssd, everything else will stay on the old school hd), however I defragment my hd weekly, it defragged this morning without any issues.

As for triple buffering, that made it worse, far worse. V-Sync was on.

*It's inactive because I only had one 90 degree Sata cable, so my 570 blocked the rest of my mobo sata ports off.

EDIT to respond to your edit: Yes, it returns to it's 60 fps average within a couple seconds of this horrible drop, but I do go at least a half second at 0 fps when this occurs. In PvP it's brutal, especially in ACB.

EDIT2: My OS does list 1760MB of shared video memory, I know it should be just overflow though. It would explain the constant 30%+ memory usage on desktop that I've had since I installed win 7 though, I thought it was due to prefetching (the physically used does not match the full list of .exe's even closely, never has)
Edited by -Apocalypse- - 3/29/11 at 8:25pm
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
post #9 of 11
Thread Starter 
Hmm. Just an update:

Installed the new beta drivers, the issue persists.

Also, I can cause the spikes to only drop into the mid-40s by tilting my camera so that am looking down at > 50 degree angle (no skybox visible, top of the screen has ground showing), and I can zoom out as far as I want with no ill-effects. However, rotating my camera down to a more horizontal position causes the same drops as spinning the camera with it horizontal.
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
post #10 of 11
Thread Starter 
FIXED IT

I'll throw this bump on this one last time, so that it might help someone else. I uninstalled ASUS Gamer OSD that automatically installs anytime you install smartdoctor (required for DCII voltage control). After doing this, I can spin the camera all I want and it's not dropping below 59FPS. I knew it had to be software related for a 570 to not handle WoW.

For reference, I got the idea here (finally got the google search right): http://www.tomshardware.com/forum/305448-33-huge-drops

I'm just waiting to see how much better ACB is gonna perform now.

Just for clarification: OSD doesn't have to be running to affect performance. It must be a registry change or something that cripples the card.
Edited by -Apocalypse- - 3/30/11 at 12:47pm
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
The Obelisk
(19 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus Maximus IV Extreme-Z (Z68) Asus GTX 570 DirectCU II  EVGA 9800GT ECO 
RAMHard DriveHard DriveHard Drive
8GB Corsair Vengeance 1600mhz  WD Black 1TB OCZ Vertex 2 90GB OCZ Agility 4 128GB 
Hard DriveOSMonitorMonitor
Samsung 840 128GB Windows 7 Professional 64-bit ViewSonic VX2250 Asus VE248 
KeyboardPowerCaseMouse
Logitech G110 Corsair AX850 Corsair 800D Logitech G600 
Mouse PadAudio
C4 NGen Logitech G930 Headset 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Asus GTX 570 severe FPS drops >SOLVED<