Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Crossfire HD5870 - Black Screen when Disabling/Re-enabling Crossfire
New Posts  All Forums:Forum Nav:

Crossfire HD5870 - Black Screen when Disabling/Re-enabling Crossfire

post #1 of 10
Thread Starter 
Hi everyone,

Hope you can help with this as its driving me nuts!



I have 2 HD5870s crossfired in my system and I seem to be having problems disabling/re-enabling them. Basically I get a black screen and device disconnected noise and then ……Nothing!



When I reboot I get the same issue. I have updated the drivers, tried the hotfixes etc and I still get this issue. Have uninstalled and used driver sweeper in safe mode and still same issue.



Also when I run the crossfire with the original Crysis my performance is worse with the two cards than it is with one although all my other games appear to be fine (hence why I want to disable crossfire – unless theres a way to fix this too?).



Im running at a max resolution of 1920x1080 which is the highest my screen can support.



I run Windows 7 Premium 64 bit and have tried Radeon pro Profiles with no luck.



Can anyone help? This is my first time posting so I have tried to add my system spec in my signature.



Thanks in advance and take it easy on a confused noob.



Edit: Just to add - screen is sometimes jumping on desktop but that may have been one of the settings I tried on Radeon Pro (Vsync).



AMD Phenom II X 4 965BE @4.0GHZ
Powercolor PCS+ HD5870 1GB
XFX Radeon HD5870 1GB (Crossfired)
Corsair TX 750W
Corsair H50 CPU Cooler
Kingston DDR3 Hyperx 8GB @1600MHZ
Asus Crosshair IV Mobo
Samsung 1TB F3 7200rpm
post #2 of 10
Don't use driver sweeper.

Is Crysis fully patched?
Have you tried both the 32 and 64bit Crysis versions?
One runs better than the other, don't remember which.

Did you also install the catalyst application profiles(CAP)?

If you're using 2 crossfire bridges, switch to one and install it on the cfx finger to the rear of the card, make sure the A1 connector is attached to the top card.

Oh and have you ever disabled ULPS?
Edited by grunion - 3/30/11 at 4:31am
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
post #3 of 10
Thread Starter 
Quote:
Originally Posted by grunion;12928367 
Don't use driver sweeper.

Is Crysis fully patched?
Have you tried both the 32 and 64bit Crysis versions?
One runs better than the other, don't remember which.

Did you also install the catalyst application profiles(CAP)?

If you're using 2 crossfire bridges, switch to one and install it on the cfx finger to the rear of the card, make sure the A1 connector is attached to the top card.

Oh and have you ever disabled ULPS?

Hi there, Thanks for respons.
Crysis is patched to 1.2 as 1.21 on windows 7 64 bit causes the game not to launch (think 1.21 was for 32 bit). I think the 64bit runs better but can't be 100% certain. Have installed latest CAP profiles with no effect.

Also I'm using the one bridge at the mo. and I think it was fine up until I installed the latest drivers. Im going to try the previous drivers I had up until last week and see if they work ok. Any ideas on the black screen problem?
post #4 of 10
Quote:
Originally Posted by jokerz798321;12928549 
Hi there, Thanks for respons.
Crysis is patched to 1.2 as 1.21 on windows 7 64 bit causes the game not to launch (think 1.21 was for 32 bit). I think the 64bit runs better but can't be 100% certain. Have installed latest CAP profiles with no effect.

Also I'm using the one bridge at the mo. and I think it was fine up until I installed the latest drivers. Im going to try the previous drivers I had up until last week and see if they work ok. Any ideas on the black screen problem?

Blackscreen is likely a refresh rate issue, I've had mine go black but it returns after a few seconds.
Are you using the dvi output?

Oh and you don't have to disable cfx via ccc, you can use radeonpro to set Crysis to run on a single card.
It just shouldn't come to that, Crysis for me responds well to cfx.
Edited by grunion - 3/30/11 at 5:15am
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
post #5 of 10
Thread Starter 
Quote:
Originally Posted by grunion;12928596 
Blackscreen is likely a refresh rate issue, I've had mine go black but it returns after a few seconds.
Are you using the dvi output?

Oh and you don't have to disable cfx via ccc, you can use radeonpro to set Crysis to run on a single card.
It just shouldn't come to that, Crysis for me responds well to cfx.

Can I use Radeon Pro rather than Catalyst or do i need to run catalyst regardless?

Crysis runs fine in the Paradise lost level but stutters for no reason in the earlier part of the game. Whereas if I disable one card it runs smooth at 1920 1080. it is odd and I can live with using the single card for this one game but it kinda defeats the object?

As for the back screen I am using DVI for it. however the black screen just stays and wont switch to desktop. Could this be driver problems/issues?

i notice there are new drivers available as of yesterday. Any idea if they work ok?

Sorry whats ULPS (like i said Noob)
post #6 of 10
Quote:
Originally Posted by jokerz798321;12928701 
Can I use Radeon Pro rather than Catalyst or do i need to run catalyst regardless?

Crysis runs fine in the Paradise lost level but stutters for no reason in the earlier part of the game. Whereas if I disable one card it runs smooth at 1920 1080. it is odd and I can live with using the single card for this one game but it kinda defeats the object?

As for the back screen I am using DVI for it. however the black screen just stays and wont switch to desktop. Could this be driver problems/issues?

i notice there are new drivers available as of yesterday. Any idea if they work ok?

I don't use ccc for anything other than monitor adjustments, eyefinity and screen rotations.

I've had good luck with both the 11.4 pre and the current 11.3 whql drivers.
But I haven't played Crysis recently.
I can do a quick run through later to see if there are Crysis issues.

ULPS is the power control feature, mainly for multi mon set ups.
Disabling it can cause driver issues, bsods, black screens.
Edited by grunion - 3/30/11 at 5:32am
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
post #7 of 10
Thread Starter 
Quote:
Originally Posted by grunion;12928723 
I don't use ccc for anything other than monitor adjustments, eyefinity and screen rotations.

I've had good luck with both the 11.4 pre and the current 11.3 whql drivers.
But I haven't played Crysis recently.
I can do a quick run through later to see if there are Crysis issues.

ULPS is the power control feature, mainly for multi mon set ups.
Disabling it can cause driver issues, bsods, black screens.

Thank you for your help. Where's the option for ULPS so I can check this?

Thing is its fine for Crysis 2, Crysis Warhead BC2 etc its just this one game! Anyway, if it can be fixed so I can disable Crossfire with no probs then thats fine.

How do you disable Crossfire in Radeon pro?
post #8 of 10
Quote:
Originally Posted by jokerz798321;12928831 
Thank you for your help. Where's the option for ULPS so I can check this?

Thing is its fine for Crysis 2, Crysis Warhead BC2 etc its just this one game! Anyway, if it can be fixed so I can disable Crossfire with no probs then thats fine.

How do you disable Crossfire in Radeon pro?

Don't worry about ulps, it's a registry edit, if you didn't change it them it's not an issue.

Add crysis to your profiles menu, choose turn off crossfire, apply and start the game using radeonpro.

[ATTACH]202755[/ATTACH]
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
post #9 of 10
Thread Starter 
Quote:
Originally Posted by grunion;12929873 
Don't worry about ulps, it's a registry edit, if you didn't change it them it's not an issue.

Add crysis to your profiles menu, choose turn off crossfire, apply and start the game using radeonpro.

[ATTACH]202755[/ATTACH]

That simple? excellent! Thanks

Gonna try the driver I was using last week - i updated to 11-2 and had trouble since so lets go back and see what happens.

I was wondering if the PSU may be causing an issue although it has been doing a great job running DX11 games like Bad Company 2 and Metro 2033 as well as Crysis 2 and Warhead. Anychance the PSU might be inadequate (please say its fine!!!! - Wife will kill me if I want to spend on a new one!!!!)

Thank you for your help
post #10 of 10
Quote:
Originally Posted by jokerz798321;12929980 
That simple? excellent! Thanks

Gonna try the driver I was using last week - i updated to 11-2 and had trouble since so lets go back and see what happens.

I was wondering if the PSU may be causing an issue although it has been doing a great job running DX11 games like Bad Company 2 and Metro 2033 as well as Crysis 2 and Warhead. Anychance the PSU might be inadequate (please say its fine!!!! - Wife will kill me if I want to spend on a new one!!!!)

Thank you for your help

That power supply is just fine for your setup.
Turbo Chicken
(30 items)
 
HTPC
(15 items)
 
Server
(18 items)
 
  hide details  
Reply
Turbo Chicken
(30 items)
 
HTPC
(15 items)
 
Server
(18 items)
 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Crossfire HD5870 - Black Screen when Disabling/Re-enabling Crossfire