Overclock.net › Forums › Graphics Cards › NVIDIA › First EVGA 570 SC died at 1.1v. The RMA card died 5 minutes after installation.
New Posts  All Forums:Forum Nav:

First EVGA 570 SC died at 1.1v. The RMA card died 5 minutes after installation. - Page 4

post #31 of 35
Quote:
Originally Posted by bavarianblessed View Post
You don't NEED a 750-800 watt PSU for your system. A quality 600 watt unit would suffice easily. The Corsair units linked earlier are some of the best units available. As are their OEM SeaSonic counterparts.
That's correct,but why go for bare min.? and what happens when he decide to go SLI/CF one day ?
    
CPUMotherboardGraphicsRAM
i7 4930K Rampage IV Gene SLI Evga GTX 780 Classy 16Gb TeamX2400c9 
Hard DriveCoolingOSMonitor
Samsung 840 Pro/ Hitachi Deskstar 1TB  H20 (NexXxoS 420+280) w7x64 VG248QE 
KeyboardPowerMouseAudio
Logitech G110 SuperNOVA 1300 G2 G502 Proteus Core Foobar2K/WASAPI >NuForce Icon HDP >Crack with S... 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 4930K Rampage IV Gene SLI Evga GTX 780 Classy 16Gb TeamX2400c9 
Hard DriveCoolingOSMonitor
Samsung 840 Pro/ Hitachi Deskstar 1TB  H20 (NexXxoS 420+280) w7x64 VG248QE 
KeyboardPowerMouseAudio
Logitech G110 SuperNOVA 1300 G2 G502 Proteus Core Foobar2K/WASAPI >NuForce Icon HDP >Crack with S... 
  hide details  
Reply
post #32 of 35
Yikes. 570s really seem like a lottery atm. Better luck next time OP.
post #33 of 35
you should not have overvolted after one of your card died already!
Dream PC
(17 items)
 
Surface Pro 3
(9 items)
 
 
CPUMotherboardGraphicsRAM
INTEL Core i7 6700K ASUS Maximus VIII Hero Z170 MSI Geforce GTX 980 Ti Gaming 6G G.SKILL Ripjaws 4 series 16GB DDR4 3000 
Hard DriveHard DriveCoolingOS
SAMSUNG SM951 NVMe 512GB SAMSUNG 850 EVO 1TB COOLER MASTER Nepton 280L MICROSOFT Windows 10 Pro x64 
MonitorMonitorKeyboardPower
BENQ XL2420TE DELL UltraSharp U2415 WASD V2 custom CORSAIR HX850i 
CaseMouseAudioOther
NZXT H440 white CORSAIR Vengeance M95 CREATIVE Sound Blaster Z CPU Delid 
Other
LED Lighting 
CPUMotherboardGraphicsRAM
Intel Core i5 4300U Microsoft Surface Intel HD Graphics 4400 8 GB DDR3L 
Hard DriveOSKeyboardMouse
256 GB SSD Windows 10 Pro x64 Surface Pro 4 Type Cover with Fingerprint ID Microsoft Arc Mouse Surface Edition 
  hide details  
Reply
Dream PC
(17 items)
 
Surface Pro 3
(9 items)
 
 
CPUMotherboardGraphicsRAM
INTEL Core i7 6700K ASUS Maximus VIII Hero Z170 MSI Geforce GTX 980 Ti Gaming 6G G.SKILL Ripjaws 4 series 16GB DDR4 3000 
Hard DriveHard DriveCoolingOS
SAMSUNG SM951 NVMe 512GB SAMSUNG 850 EVO 1TB COOLER MASTER Nepton 280L MICROSOFT Windows 10 Pro x64 
MonitorMonitorKeyboardPower
BENQ XL2420TE DELL UltraSharp U2415 WASD V2 custom CORSAIR HX850i 
CaseMouseAudioOther
NZXT H440 white CORSAIR Vengeance M95 CREATIVE Sound Blaster Z CPU Delid 
Other
LED Lighting 
CPUMotherboardGraphicsRAM
Intel Core i5 4300U Microsoft Surface Intel HD Graphics 4400 8 GB DDR3L 
Hard DriveOSKeyboardMouse
256 GB SSD Windows 10 Pro x64 Surface Pro 4 Type Cover with Fingerprint ID Microsoft Arc Mouse Surface Edition 
  hide details  
Reply
post #34 of 35
Quote:
Originally Posted by Booty Warrior View Post
Yikes. 570s really seem like a lottery atm.
I know, right? Just got my Zotac 570 & planning to install it tomorrow... I'm a kind of nervous
post #35 of 35
I just returned my GTX 590 and was planning on grabbing 2 570s for SLI goodness, without the GTX590 quircks...but the 570 has weak VRMs also..

The good ones are the ASUS GTX570 directCuII, those have beefed-up VRMs...but they are triple-sloters...can't fit two on my board...

And for the RMA'ed card that died, I had that happening to me once with an EVGA replacement card (8800GTS640) I complained and they shipped me back a GTX260 Core 216 instead!
Edited by delavan - 4/1/11 at 7:23pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › First EVGA 570 SC died at 1.1v. The RMA card died 5 minutes after installation.