Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Sound problem hoping for some help (sound goes after wine install)
New Posts  All Forums:Forum Nav:

Sound problem hoping for some help (sound goes after wine install)

post #1 of 8
Thread Starter 
So I have done a ton of googling and haven't seemed to find anything. Hoping someone here could help me out!

I am running crunchbang (found out it had everything I wanted out of an os almost perfectly right away).

I installed wine, but as soon as I went to run SteamInstall.exe I get this in the terminal

fixme:mixer:ALSA_MixerInit No master control found on HD-Audio Generic, disabling mixer

This cuts my sound out to my whole system.

The only way I have had sound since this is while using VLC for an .avi, is choosing 2 front 2 rear for Audio Device.

I hope this is just me being a noob in general to linux as to why its happening, but its super annoying either way.

Thanks
cave
(20 items)
 
couch
(14 items)
 
cave2
(10 items)
 
CPUMotherboardGraphicsRAM
i3 2100 Biostar H61MU3 Nvidia 550 Ti Crucial 4gb 1333 
Hard DriveHard DriveHard DriveOptical Drive
Samsung Spinpoint 1TB Seagate 2TB Barracuda  WD Blue 160GB ASUS 24X DVD Burner 
OSMonitorKeyboardPower
Windows 7 64 Bit LG 32LD400 32-Inch Logitech k360 OCZ ModXtreme Pro 500 
CaseMouse
Silverstone Grandia GD07B Logitech M510 
CPUMotherboardRAMHard Drive
Intel Celeron G620 Gigabyte Z68MX-UD2H-B3 G-Skill Eco 4gb WD 160GB Blue 
OSKeyboardPowerCase
Ubuntu 12.04 CM Storm Quick Fire Rapid Antec Earthwatts 430W Antec SX1030b 
MouseMouse Pad
Logitech MX510 Steelseries QCK 
  hide details  
Reply
cave
(20 items)
 
couch
(14 items)
 
cave2
(10 items)
 
CPUMotherboardGraphicsRAM
i3 2100 Biostar H61MU3 Nvidia 550 Ti Crucial 4gb 1333 
Hard DriveHard DriveHard DriveOptical Drive
Samsung Spinpoint 1TB Seagate 2TB Barracuda  WD Blue 160GB ASUS 24X DVD Burner 
OSMonitorKeyboardPower
Windows 7 64 Bit LG 32LD400 32-Inch Logitech k360 OCZ ModXtreme Pro 500 
CaseMouse
Silverstone Grandia GD07B Logitech M510 
CPUMotherboardRAMHard Drive
Intel Celeron G620 Gigabyte Z68MX-UD2H-B3 G-Skill Eco 4gb WD 160GB Blue 
OSKeyboardPowerCase
Ubuntu 12.04 CM Storm Quick Fire Rapid Antec Earthwatts 430W Antec SX1030b 
MouseMouse Pad
Logitech MX510 Steelseries QCK 
  hide details  
Reply
post #2 of 8
Did you run winecfg and set your correct sound settings?
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
post #3 of 8
Thread Starter 
Quote:
Originally Posted by error10 View Post
Did you run winecfg and set your correct sound settings?
That would be a negative ghostrider.

At this point I'd rather uninstall wine since the steam installing business kept freezing anyway.. but thats beyond the point.

How would I go about configuring them? Is the VLC thing weird or is that normal.
cave
(20 items)
 
couch
(14 items)
 
cave2
(10 items)
 
CPUMotherboardGraphicsRAM
i3 2100 Biostar H61MU3 Nvidia 550 Ti Crucial 4gb 1333 
Hard DriveHard DriveHard DriveOptical Drive
Samsung Spinpoint 1TB Seagate 2TB Barracuda  WD Blue 160GB ASUS 24X DVD Burner 
OSMonitorKeyboardPower
Windows 7 64 Bit LG 32LD400 32-Inch Logitech k360 OCZ ModXtreme Pro 500 
CaseMouse
Silverstone Grandia GD07B Logitech M510 
CPUMotherboardRAMHard Drive
Intel Celeron G620 Gigabyte Z68MX-UD2H-B3 G-Skill Eco 4gb WD 160GB Blue 
OSKeyboardPowerCase
Ubuntu 12.04 CM Storm Quick Fire Rapid Antec Earthwatts 430W Antec SX1030b 
MouseMouse Pad
Logitech MX510 Steelseries QCK 
  hide details  
Reply
cave
(20 items)
 
couch
(14 items)
 
cave2
(10 items)
 
CPUMotherboardGraphicsRAM
i3 2100 Biostar H61MU3 Nvidia 550 Ti Crucial 4gb 1333 
Hard DriveHard DriveHard DriveOptical Drive
Samsung Spinpoint 1TB Seagate 2TB Barracuda  WD Blue 160GB ASUS 24X DVD Burner 
OSMonitorKeyboardPower
Windows 7 64 Bit LG 32LD400 32-Inch Logitech k360 OCZ ModXtreme Pro 500 
CaseMouse
Silverstone Grandia GD07B Logitech M510 
CPUMotherboardRAMHard Drive
Intel Celeron G620 Gigabyte Z68MX-UD2H-B3 G-Skill Eco 4gb WD 160GB Blue 
OSKeyboardPowerCase
Ubuntu 12.04 CM Storm Quick Fire Rapid Antec Earthwatts 430W Antec SX1030b 
MouseMouse Pad
Logitech MX510 Steelseries QCK 
  hide details  
Reply
post #4 of 8
You running pulseaudio? yes/no?

If you aren't you should look at setting up a ~/.asoundrc or a /ect/asound.conf and manually set the default audio devices. I'm guessing that's your problem, once you force settings (.asoundrc is user specific and /etc/asound.conf is system wide) you will get sound.


[edit]
https://wiki.archlinux.org/index.php...#In_User_Space

This is exactly what you need to set up in either file.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #5 of 8
Thread Starter 
when I uninstall wine all of my sound works perfectly. I will look at the post before this, as wine (or something in it is the issue)

I am at the point where as long as I can play games.. I will use linux only. I look forward to only having linux (especially after booting into windows to play css the other day.. seemed sluggish)

The previous post, could someone possibly pm with the changes being made? I am trying to stay on top of my install
cave
(20 items)
 
couch
(14 items)
 
cave2
(10 items)
 
CPUMotherboardGraphicsRAM
i3 2100 Biostar H61MU3 Nvidia 550 Ti Crucial 4gb 1333 
Hard DriveHard DriveHard DriveOptical Drive
Samsung Spinpoint 1TB Seagate 2TB Barracuda  WD Blue 160GB ASUS 24X DVD Burner 
OSMonitorKeyboardPower
Windows 7 64 Bit LG 32LD400 32-Inch Logitech k360 OCZ ModXtreme Pro 500 
CaseMouse
Silverstone Grandia GD07B Logitech M510 
CPUMotherboardRAMHard Drive
Intel Celeron G620 Gigabyte Z68MX-UD2H-B3 G-Skill Eco 4gb WD 160GB Blue 
OSKeyboardPowerCase
Ubuntu 12.04 CM Storm Quick Fire Rapid Antec Earthwatts 430W Antec SX1030b 
MouseMouse Pad
Logitech MX510 Steelseries QCK 
  hide details  
Reply
cave
(20 items)
 
couch
(14 items)
 
cave2
(10 items)
 
CPUMotherboardGraphicsRAM
i3 2100 Biostar H61MU3 Nvidia 550 Ti Crucial 4gb 1333 
Hard DriveHard DriveHard DriveOptical Drive
Samsung Spinpoint 1TB Seagate 2TB Barracuda  WD Blue 160GB ASUS 24X DVD Burner 
OSMonitorKeyboardPower
Windows 7 64 Bit LG 32LD400 32-Inch Logitech k360 OCZ ModXtreme Pro 500 
CaseMouse
Silverstone Grandia GD07B Logitech M510 
CPUMotherboardRAMHard Drive
Intel Celeron G620 Gigabyte Z68MX-UD2H-B3 G-Skill Eco 4gb WD 160GB Blue 
OSKeyboardPowerCase
Ubuntu 12.04 CM Storm Quick Fire Rapid Antec Earthwatts 430W Antec SX1030b 
MouseMouse Pad
Logitech MX510 Steelseries QCK 
  hide details  
Reply
post #6 of 8
Thread Starter 
double post .. please delete
cave
(20 items)
 
couch
(14 items)
 
cave2
(10 items)
 
CPUMotherboardGraphicsRAM
i3 2100 Biostar H61MU3 Nvidia 550 Ti Crucial 4gb 1333 
Hard DriveHard DriveHard DriveOptical Drive
Samsung Spinpoint 1TB Seagate 2TB Barracuda  WD Blue 160GB ASUS 24X DVD Burner 
OSMonitorKeyboardPower
Windows 7 64 Bit LG 32LD400 32-Inch Logitech k360 OCZ ModXtreme Pro 500 
CaseMouse
Silverstone Grandia GD07B Logitech M510 
CPUMotherboardRAMHard Drive
Intel Celeron G620 Gigabyte Z68MX-UD2H-B3 G-Skill Eco 4gb WD 160GB Blue 
OSKeyboardPowerCase
Ubuntu 12.04 CM Storm Quick Fire Rapid Antec Earthwatts 430W Antec SX1030b 
MouseMouse Pad
Logitech MX510 Steelseries QCK 
  hide details  
Reply
cave
(20 items)
 
couch
(14 items)
 
cave2
(10 items)
 
CPUMotherboardGraphicsRAM
i3 2100 Biostar H61MU3 Nvidia 550 Ti Crucial 4gb 1333 
Hard DriveHard DriveHard DriveOptical Drive
Samsung Spinpoint 1TB Seagate 2TB Barracuda  WD Blue 160GB ASUS 24X DVD Burner 
OSMonitorKeyboardPower
Windows 7 64 Bit LG 32LD400 32-Inch Logitech k360 OCZ ModXtreme Pro 500 
CaseMouse
Silverstone Grandia GD07B Logitech M510 
CPUMotherboardRAMHard Drive
Intel Celeron G620 Gigabyte Z68MX-UD2H-B3 G-Skill Eco 4gb WD 160GB Blue 
OSKeyboardPowerCase
Ubuntu 12.04 CM Storm Quick Fire Rapid Antec Earthwatts 430W Antec SX1030b 
MouseMouse Pad
Logitech MX510 Steelseries QCK 
  hide details  
Reply
post #7 of 8
Quote:
Originally Posted by mushroomboy View Post
You running pulseaudio? yes/no?

If you aren't you should look at setting up a ~/.asoundrc or a /ect/asound.conf and manually set the default audio devices. I'm guessing that's your problem, once you force settings (.asoundrc is user specific and /etc/asound.conf is system wide) you will get sound.


[edit]
https://wiki.archlinux.org/index.php...#In_User_Space

This is exactly what you need to set up in either file.
its crunchbang, it doesn't use pulse audio...

it does use alsa, alsa on its own, not configured correctly, is filled with upmixing problems...you will need to configure it so more than one program (even at times,after the program has terminated) to be able to have sound always, unless you like restarting or forcing alsa to restart.

this thread here seems to be similar to the problem you are having, read thru it, to see if it gives you any ideas, this is why i still use pulse or in those weird times, i have removed alsa/pulse and replaced it with OSSv4...i would actual recommend removing alsa and replacing it with OSSv4, since it is debian based, should be similar to any debian how to guides available for ossv4.
Bazinga Punk
(12 items)
 
ooh shiny!
(6 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon 3440 AsRock P55 extreme Evga 8800 GT 512 MB Gskill Ripjaws 
Hard DriveCoolingOSMonitor
Western Digital Blue Antec Khuler 620 Ubuntu 11.10 Asus vw264H 
KeyboardPowerCaseMouse
GIGABYTE KM7600 CORSAIR TX 650 Cooler Master 590 GIGABYTE GM-M6800 
CPUMotherboardGraphicsRAM
Intel Core I5 6500 Gigabyte z170xp-SLI Nvidia 970gtx Corsair 16gb ddr4 2666mhz  
Hard DriveOS
250gb Samsung Evo 850 Windows 10 & Ubuntu 15.10 
  hide details  
Reply
Bazinga Punk
(12 items)
 
ooh shiny!
(6 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon 3440 AsRock P55 extreme Evga 8800 GT 512 MB Gskill Ripjaws 
Hard DriveCoolingOSMonitor
Western Digital Blue Antec Khuler 620 Ubuntu 11.10 Asus vw264H 
KeyboardPowerCaseMouse
GIGABYTE KM7600 CORSAIR TX 650 Cooler Master 590 GIGABYTE GM-M6800 
CPUMotherboardGraphicsRAM
Intel Core I5 6500 Gigabyte z170xp-SLI Nvidia 970gtx Corsair 16gb ddr4 2666mhz  
Hard DriveOS
250gb Samsung Evo 850 Windows 10 & Ubuntu 15.10 
  hide details  
Reply
post #8 of 8
ive been meaning to try replacing alsa with ossv4 on my crunchbang install if it gets checked out and goes well let me know... havent spent the time latey to do any tweaking in linux
Kinda meh now...
(13 items)
 
  
CPUMotherboardGraphicsRAM
PhII 940 BE asus M4N82 Deluxe 2x 8800gts(g92) 2x 1g ocz ddr2 1066 
Hard DriveOptical DriveOSMonitor
/dev/sd[abc] /dev/sr0 WinXP/Linux 22in acer 
PowerCaseMouseMouse Pad
950w rosewill timebomb Antec 900 (2small) Voodoo Deathadder (RED!) X-Trac Pads Ripper XL 
  hide details  
Reply
Kinda meh now...
(13 items)
 
  
CPUMotherboardGraphicsRAM
PhII 940 BE asus M4N82 Deluxe 2x 8800gts(g92) 2x 1g ocz ddr2 1066 
Hard DriveOptical DriveOSMonitor
/dev/sd[abc] /dev/sr0 WinXP/Linux 22in acer 
PowerCaseMouseMouse Pad
950w rosewill timebomb Antec 900 (2small) Voodoo Deathadder (RED!) X-Trac Pads Ripper XL 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Sound problem hoping for some help (sound goes after wine install)