Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Rebooted Ubuntu, all sound cards have disappared from alsa and pulse
New Posts  All Forums:Forum Nav:

Rebooted Ubuntu, all sound cards have disappared from alsa and pulse

post #1 of 6
Thread Starter 
I just installed fluxbox, (Haven't removed anything gnome related yet.) I rebooted and now pulse and alsa aren't recognising any of my sound card modules. The modules are still there and I reloaded them with modprobe and they still wont appear on also or pulse.

Edit: When I try to enter the module for my realtek manually via alsamixer, it says that the module cannot be found >.<
Edited by sP00N - 4/9/11 at 11:16am
ASUS G75VW-BBK5
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-3610qm 2.3ghz ASUS Proprietary Nvidia Geforce GTX 660m 2gb 4x4gb ddr3 (16gb) 
Hard DriveHard DriveOptical DriveCooling
128gb crucial m4 ssd 1 tb 7200rpm  DVDRW ASUS Proprietary 
OSMonitorMonitorKeyboard
Windows 8.1 Pro x64 17.3" laptop display 2x Acer 23" lcds ASUS proprietary + Lenovo media keyboard 
PowerMouseMouse PadAudio
Big 'ol power brick trackpad, logitech g400 + microsoft wireless mo... none klipsch pro media 2.1 speakers 
Audio
Sennheiser HD 360 headphones 
  hide details  
Reply
ASUS G75VW-BBK5
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-3610qm 2.3ghz ASUS Proprietary Nvidia Geforce GTX 660m 2gb 4x4gb ddr3 (16gb) 
Hard DriveHard DriveOptical DriveCooling
128gb crucial m4 ssd 1 tb 7200rpm  DVDRW ASUS Proprietary 
OSMonitorMonitorKeyboard
Windows 8.1 Pro x64 17.3" laptop display 2x Acer 23" lcds ASUS proprietary + Lenovo media keyboard 
PowerMouseMouse PadAudio
Big 'ol power brick trackpad, logitech g400 + microsoft wireless mo... none klipsch pro media 2.1 speakers 
Audio
Sennheiser HD 360 headphones 
  hide details  
Reply
post #2 of 6
did it happen to install a new kernel on you?
Bazinga Punk
(12 items)
 
ooh shiny!
(6 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon 3440 AsRock P55 extreme Evga 8800 GT 512 MB Gskill Ripjaws 
Hard DriveCoolingOSMonitor
Western Digital Blue Antec Khuler 620 Ubuntu 11.10 Asus vw264H 
KeyboardPowerCaseMouse
GIGABYTE KM7600 CORSAIR TX 650 Cooler Master 590 GIGABYTE GM-M6800 
CPUMotherboardGraphicsRAM
Intel Core I5 6500 Gigabyte z170xp-SLI Nvidia 970gtx Corsair 16gb ddr4 2666mhz  
Hard DriveOS
250gb Samsung Evo 850 Windows 10 & Ubuntu 15.10 
  hide details  
Reply
Bazinga Punk
(12 items)
 
ooh shiny!
(6 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon 3440 AsRock P55 extreme Evga 8800 GT 512 MB Gskill Ripjaws 
Hard DriveCoolingOSMonitor
Western Digital Blue Antec Khuler 620 Ubuntu 11.10 Asus vw264H 
KeyboardPowerCaseMouse
GIGABYTE KM7600 CORSAIR TX 650 Cooler Master 590 GIGABYTE GM-M6800 
CPUMotherboardGraphicsRAM
Intel Core I5 6500 Gigabyte z170xp-SLI Nvidia 970gtx Corsair 16gb ddr4 2666mhz  
Hard DriveOS
250gb Samsung Evo 850 Windows 10 & Ubuntu 15.10 
  hide details  
Reply
post #3 of 6
I was thinking we need the output of two commands:

aplay -l (alsa's list of available sound cards)

lspci (if the system is reconizing the cards)

After that we can guide you in a better direction.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #4 of 6
Thread Starter 
aplay -l

Quote:
aplay: device_list:235: no soundcards found...
lspci:

Quote:
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge Alternate
00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:0a.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 5)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:00.0 VGA compatible controller: ATI Technologies Inc Juniper [Radeon HD 5700 Series]
01:00.1 Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
03:06.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]
03:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
edit: switching back to an older kernel brings all of the audio devices back online. But now any media player will not play any songs. (The progress bar doesn't move when I hit play. >.<)
Edited by sP00N - 4/9/11 at 4:27pm
ASUS G75VW-BBK5
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-3610qm 2.3ghz ASUS Proprietary Nvidia Geforce GTX 660m 2gb 4x4gb ddr3 (16gb) 
Hard DriveHard DriveOptical DriveCooling
128gb crucial m4 ssd 1 tb 7200rpm  DVDRW ASUS Proprietary 
OSMonitorMonitorKeyboard
Windows 8.1 Pro x64 17.3" laptop display 2x Acer 23" lcds ASUS proprietary + Lenovo media keyboard 
PowerMouseMouse PadAudio
Big 'ol power brick trackpad, logitech g400 + microsoft wireless mo... none klipsch pro media 2.1 speakers 
Audio
Sennheiser HD 360 headphones 
  hide details  
Reply
ASUS G75VW-BBK5
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-3610qm 2.3ghz ASUS Proprietary Nvidia Geforce GTX 660m 2gb 4x4gb ddr3 (16gb) 
Hard DriveHard DriveOptical DriveCooling
128gb crucial m4 ssd 1 tb 7200rpm  DVDRW ASUS Proprietary 
OSMonitorMonitorKeyboard
Windows 8.1 Pro x64 17.3" laptop display 2x Acer 23" lcds ASUS proprietary + Lenovo media keyboard 
PowerMouseMouse PadAudio
Big 'ol power brick trackpad, logitech g400 + microsoft wireless mo... none klipsch pro media 2.1 speakers 
Audio
Sennheiser HD 360 headphones 
  hide details  
Reply
post #5 of 6
Thread Starter 
switching back to an older kernel brings all of the audio devices back online in pulse. (not aplay) But now any media player will not play any songs. (The progress bar doesn't move when I hit play. >.<)

Here's the error totem outputs when I try to play a song:

(totem:2807): Totem-WARNING **: Failed to create dbus proxy for org.gnome.SettingsDaemon: Could not get owner of name 'org.gnome.SettingsDaemon': no such name

edit: still cant hear anything from any program. Will Linux ever have a non sucky audio platform that doesn't break when I update? Answer: NO.
Edited by sP00N - 4/9/11 at 5:11pm
ASUS G75VW-BBK5
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-3610qm 2.3ghz ASUS Proprietary Nvidia Geforce GTX 660m 2gb 4x4gb ddr3 (16gb) 
Hard DriveHard DriveOptical DriveCooling
128gb crucial m4 ssd 1 tb 7200rpm  DVDRW ASUS Proprietary 
OSMonitorMonitorKeyboard
Windows 8.1 Pro x64 17.3" laptop display 2x Acer 23" lcds ASUS proprietary + Lenovo media keyboard 
PowerMouseMouse PadAudio
Big 'ol power brick trackpad, logitech g400 + microsoft wireless mo... none klipsch pro media 2.1 speakers 
Audio
Sennheiser HD 360 headphones 
  hide details  
Reply
ASUS G75VW-BBK5
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-3610qm 2.3ghz ASUS Proprietary Nvidia Geforce GTX 660m 2gb 4x4gb ddr3 (16gb) 
Hard DriveHard DriveOptical DriveCooling
128gb crucial m4 ssd 1 tb 7200rpm  DVDRW ASUS Proprietary 
OSMonitorMonitorKeyboard
Windows 8.1 Pro x64 17.3" laptop display 2x Acer 23" lcds ASUS proprietary + Lenovo media keyboard 
PowerMouseMouse PadAudio
Big 'ol power brick trackpad, logitech g400 + microsoft wireless mo... none klipsch pro media 2.1 speakers 
Audio
Sennheiser HD 360 headphones 
  hide details  
Reply
post #6 of 6
If your soundcard supports it, I highly recommend you get rid of ALSA/Pulse and go with OSSv4. Here's the instructions for how to switch. Be sure to follow them to a "t".

Also, choose the "build from source" method. And instead of using the Mercurial repo as the wiki says, go here and download the 4.2 source directly.

I think I am going to write a tutorial on how to do this and sig it.
Skylake Build
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-6600k Gigabyte Z-170 Gaming 7 Gigabyte R9 390  Gskill Ripjaws V DDR4 
Hard DriveCoolingOSMonitor
Samsung 850 Evo Corsair H115i Windows 10 Pro Asus  
KeyboardPowerCaseMouse
Generic EVGA NEX750 G1 Phanteks Eclipse P400 GSkill MX780 
  hide details  
Reply
Skylake Build
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-6600k Gigabyte Z-170 Gaming 7 Gigabyte R9 390  Gskill Ripjaws V DDR4 
Hard DriveCoolingOSMonitor
Samsung 850 Evo Corsair H115i Windows 10 Pro Asus  
KeyboardPowerCaseMouse
Generic EVGA NEX750 G1 Phanteks Eclipse P400 GSkill MX780 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Rebooted Ubuntu, all sound cards have disappared from alsa and pulse