Overclock.net › Forums › AMD › AMD - General › My athlon x4.. Seems to have forgotten it's got 4 cores
New Posts  All Forums:Forum Nav:

My athlon x4.. Seems to have forgotten it's got 4 cores

post #1 of 11
Thread Starter 
Alright, so I've got a question for you geniuses here at OCN. I have an athlon x4 630. That's obviously a quad core. I noticed today that only 3 cores are up and running. Why would that be? I looked in bios and i didn't even have an option to mess w/ core 1. just core 2 and 3. What should I do?

Edited by Vegnagun - 4/11/11 at 11:08pm
Das Boot
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon II X4 630 3.5ghz Gigabyte GA-880GM-UD2H nVidia 9600GT 512mb 4GB Patriot DDR3 1333MHZ 
Hard DriveOptical DriveOSMonitor
Western Digital 320 GB Samsung DVD/RW Windows 10 Acer 19" WS 1440x900 
KeyboardPowerCaseMouse
USB Keyboard Antec Earthwatts 500 Watts Antec Sonata Logitech usb 
Mouse Pad
None 
  hide details  
Reply
Das Boot
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon II X4 630 3.5ghz Gigabyte GA-880GM-UD2H nVidia 9600GT 512mb 4GB Patriot DDR3 1333MHZ 
Hard DriveOptical DriveOSMonitor
Western Digital 320 GB Samsung DVD/RW Windows 10 Acer 19" WS 1440x900 
KeyboardPowerCaseMouse
USB Keyboard Antec Earthwatts 500 Watts Antec Sonata Logitech usb 
Mouse Pad
None 
  hide details  
Reply
post #2 of 11
try this.

go to your start menu type in Msconfig, press enter_

a menu(window) should pop up_ Go under Boot tab, then click on advance options
Check number of processors and select 4 if the option is there_

that might or may not do it, but give it a go
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i72600K Sandybridge @ 4.8ghz MSi P67A-GD65 Galaxy GTX 580 @930mhz GSkill CL7 2x4gb 1333 @ 1866 9-10-9-24-1T 
Hard DriveOptical DriveOSMonitor
Crucial C300 128gb SSD w/1TB HDD Asus DVD-RW/CDRW Windows 7 Professional Gateway HD2201 22in LED 1080 
PowerCase
Seasonic X-850 Azza Salano 1000 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i72600K Sandybridge @ 4.8ghz MSi P67A-GD65 Galaxy GTX 580 @930mhz GSkill CL7 2x4gb 1333 @ 1866 9-10-9-24-1T 
Hard DriveOptical DriveOSMonitor
Crucial C300 128gb SSD w/1TB HDD Asus DVD-RW/CDRW Windows 7 Professional Gateway HD2201 22in LED 1080 
PowerCase
Seasonic X-850 Azza Salano 1000 
  hide details  
Reply
post #3 of 11
Quote:
Originally Posted by Vegnagun View Post
Alright, so I've got a question for you geniuses here at OCN. I have an athlon x4 630. That's obviously a quad core. I noticed today that only 3 cores are up and running. Why would that be? I looked in bios and i didn't even have an option to mess w/ core 1. just core 2 and 3. What should I do?
You should RMA the CPU to AMD .
It could be either defective , practically qualified for a 3 core , either a faked quad.
Just RMA .
If you can t RMA (no warranty documentation) ,just use brute force to the guy that sold it to you
   
AMD HTPC
(13 items)
 
CPUMotherboardGraphicsRAM
AMD FX 6300  Asus Sabertooth 990FX R 2.0 Sapphire 6950 unlocked Geil 
Hard DriveOptical DriveCoolingOS
WD Sony Corsair H60 Mepis Tetris 
MonitorKeyboardPowerCase
LG HD  Logitech G11 OCZ 750 F1 Nexus Clodius Black 
MouseMouse PadAudio
Logitech G5R Mionix Creative X-Fi Xteme Music 
CPUMotherboardGraphicsRAM
AMD Athlon 860K MSI A88X-G41 PC Mate Sapphire R7 265 Crucial Elite 2 X 4 
Hard DriveOptical DriveCoolingOS
WD /Seagate Optiarc/LG Cooler Master Hyper TX2 Mepis Tetris 
MonitorKeyboardPowerCase
LG HD  Logitech generic Corsair CS650 Nexus Clodius White 
MouseMouse PadAudio
A4 Crap Mionix Anus Xonar D1 
CPUMotherboardGraphicsRAM
AMD Athlon 5150 ASUS AM1M-A  IGD Crucial 2X2G 
Hard DriveOptical DriveCoolingOS
Seagate 640Gb junk SONY DVD-RW Stock OpenSuse/Ubuntu 
MonitorKeyboardPowerCase
LED TV Logitech wireless FSP Foxconn 
Mouse
Logitech wireless 
  hide details  
Reply
   
AMD HTPC
(13 items)
 
CPUMotherboardGraphicsRAM
AMD FX 6300  Asus Sabertooth 990FX R 2.0 Sapphire 6950 unlocked Geil 
Hard DriveOptical DriveCoolingOS
WD Sony Corsair H60 Mepis Tetris 
MonitorKeyboardPowerCase
LG HD  Logitech G11 OCZ 750 F1 Nexus Clodius Black 
MouseMouse PadAudio
Logitech G5R Mionix Creative X-Fi Xteme Music 
CPUMotherboardGraphicsRAM
AMD Athlon 860K MSI A88X-G41 PC Mate Sapphire R7 265 Crucial Elite 2 X 4 
Hard DriveOptical DriveCoolingOS
WD /Seagate Optiarc/LG Cooler Master Hyper TX2 Mepis Tetris 
MonitorKeyboardPowerCase
LG HD  Logitech generic Corsair CS650 Nexus Clodius White 
MouseMouse PadAudio
A4 Crap Mionix Anus Xonar D1 
CPUMotherboardGraphicsRAM
AMD Athlon 5150 ASUS AM1M-A  IGD Crucial 2X2G 
Hard DriveOptical DriveCoolingOS
Seagate 640Gb junk SONY DVD-RW Stock OpenSuse/Ubuntu 
MonitorKeyboardPowerCase
LED TV Logitech wireless FSP Foxconn 
Mouse
Logitech wireless 
  hide details  
Reply
post #4 of 11
Quote:
Originally Posted by httuner View Post
try this.

go to your start menu type in Msconfig, press enter_

a menu(window) should pop up_ Go under Boot tab, then click on advance options
Check number of processors and select 4 if the option is there_

that might or may not do it, but give it a go
Was it ever showing 4 cores since you bought it? Or always been at 3 cores?

Try doing a Clear CMOS on your motherboard, if it doesn't help, I'd suggest contacting your computer store and asking for an RMA for the CPU.

However, I'd first suggest you to update your motherboard's BIOS just in case it is motherboard related, that is a weird issue indeed...
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
post #5 of 11
Thread Starter 
Quote:
Originally Posted by kcuestag View Post
Was it ever showing 4 cores since you bought it? Or always been at 3 cores?

Try doing a Clear CMOS on your motherboard, if it doesn't help, I'd suggest contacting your computer store and asking for an RMA for the CPU.

However, I'd first suggest you to update your motherboard's BIOS just in case it is motherboard related, that is a weird issue indeed...
Yea it was! I upgraded from xp to vista and well now my core had disappeared. I've never played w/ a BIOS upgrade but, I will def look around. I'll clear CMOS now.
Das Boot
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon II X4 630 3.5ghz Gigabyte GA-880GM-UD2H nVidia 9600GT 512mb 4GB Patriot DDR3 1333MHZ 
Hard DriveOptical DriveOSMonitor
Western Digital 320 GB Samsung DVD/RW Windows 10 Acer 19" WS 1440x900 
KeyboardPowerCaseMouse
USB Keyboard Antec Earthwatts 500 Watts Antec Sonata Logitech usb 
Mouse Pad
None 
  hide details  
Reply
Das Boot
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon II X4 630 3.5ghz Gigabyte GA-880GM-UD2H nVidia 9600GT 512mb 4GB Patriot DDR3 1333MHZ 
Hard DriveOptical DriveOSMonitor
Western Digital 320 GB Samsung DVD/RW Windows 10 Acer 19" WS 1440x900 
KeyboardPowerCaseMouse
USB Keyboard Antec Earthwatts 500 Watts Antec Sonata Logitech usb 
Mouse Pad
None 
  hide details  
Reply
post #6 of 11
If you had 4 cores before, there's a reason to think it should be software related, but then again, you should be able to see 4 cores in the BIOS too, that's weird...

Have you tried updating your board's BIOS?
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
post #7 of 11
Thread Starter 
Alright, so I reset CMOS then reseated the processor. As I pulled the proc up to clean off the old thermal i looked at the pins and in the center was a small spec of dust. Do you think it's possible for that spec of dust to have done this? Either way, the dust was removed and everything is back to normal.

Thanks all for the posts.
Das Boot
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon II X4 630 3.5ghz Gigabyte GA-880GM-UD2H nVidia 9600GT 512mb 4GB Patriot DDR3 1333MHZ 
Hard DriveOptical DriveOSMonitor
Western Digital 320 GB Samsung DVD/RW Windows 10 Acer 19" WS 1440x900 
KeyboardPowerCaseMouse
USB Keyboard Antec Earthwatts 500 Watts Antec Sonata Logitech usb 
Mouse Pad
None 
  hide details  
Reply
Das Boot
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon II X4 630 3.5ghz Gigabyte GA-880GM-UD2H nVidia 9600GT 512mb 4GB Patriot DDR3 1333MHZ 
Hard DriveOptical DriveOSMonitor
Western Digital 320 GB Samsung DVD/RW Windows 10 Acer 19" WS 1440x900 
KeyboardPowerCaseMouse
USB Keyboard Antec Earthwatts 500 Watts Antec Sonata Logitech usb 
Mouse Pad
None 
  hide details  
Reply
post #8 of 11
It was most probably a bad contact between the CPU and the motherboard, thus not detecting one of the cores, or maybe just pure coincidence and resetting the CMOS did the job.

Glad I could help you somehow, and glad to see it's fixed!
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
post #9 of 11
Quote:
Originally Posted by Vegnagun View Post
Alright, so I reset CMOS then reseated the processor. As I pulled the proc up to clean off the old thermal i looked at the pins and in the center was a small spec of dust. Do you think it's possible for that spec of dust to have done this? Either way, the dust was removed and everything is back to normal.

Thanks all for the posts.
It would of been the BIOS that was causing this not hardware.

Clearing the CMOS was what fixed your problem, I'm over 99% sure of this.
My Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 970T @ X6 LAPPED ASUS M4A785TD-V EVO XFX REF HD 6870 (1000/1200/1.26) 2x2gb DDR3 Kingston Vapor-X 1600mhz CL9 
Hard DriveOSMonitorKeyboard
Crucial M4 64gb SSD + 640gb WD Windows 8 x64 22" 1080p LG flatron MS wired 600 
PowerCaseMouse
900w Modular Inwin CM Storm Sentinel 
  hide details  
Reply
My Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 970T @ X6 LAPPED ASUS M4A785TD-V EVO XFX REF HD 6870 (1000/1200/1.26) 2x2gb DDR3 Kingston Vapor-X 1600mhz CL9 
Hard DriveOSMonitorKeyboard
Crucial M4 64gb SSD + 640gb WD Windows 8 x64 22" 1080p LG flatron MS wired 600 
PowerCaseMouse
900w Modular Inwin CM Storm Sentinel 
  hide details  
Reply
post #10 of 11
Thread Starter 
Quote:
Originally Posted by kcuestag View Post
It was most probably a bad contact between the CPU and the motherboard, thus not detecting one of the cores, or maybe just pure coincidence and resetting the CMOS did the job.

Glad I could help you somehow, and glad to see it's fixed!
Me too! Thanks
Das Boot
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon II X4 630 3.5ghz Gigabyte GA-880GM-UD2H nVidia 9600GT 512mb 4GB Patriot DDR3 1333MHZ 
Hard DriveOptical DriveOSMonitor
Western Digital 320 GB Samsung DVD/RW Windows 10 Acer 19" WS 1440x900 
KeyboardPowerCaseMouse
USB Keyboard Antec Earthwatts 500 Watts Antec Sonata Logitech usb 
Mouse Pad
None 
  hide details  
Reply
Das Boot
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon II X4 630 3.5ghz Gigabyte GA-880GM-UD2H nVidia 9600GT 512mb 4GB Patriot DDR3 1333MHZ 
Hard DriveOptical DriveOSMonitor
Western Digital 320 GB Samsung DVD/RW Windows 10 Acer 19" WS 1440x900 
KeyboardPowerCaseMouse
USB Keyboard Antec Earthwatts 500 Watts Antec Sonata Logitech usb 
Mouse Pad
None 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD - General
Overclock.net › Forums › AMD › AMD - General › My athlon x4.. Seems to have forgotten it's got 4 cores