Overclock.net › Forums › Graphics Cards › AMD/ATI › HD6950 weirdness
New Posts  All Forums:Forum Nav:

HD6950 weirdness

post #1 of 19
Thread Starter 
Hi all.
So i just installed my HD6950, and im running it with a DVI-VGA adaptor to my monitor. When i did this with my nVidia GTS 250 it was fine, but now CPU-Z recognizes my GPU's name as "standard VGA graphics adaptor" and my max available res is 1600x1200. How do i fix this?
post #2 of 19
Should be driver issue, try reinstall
My Rig
(14 items)
 
Ex-wife's Rig
(15 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 4460 AsRock H81M-DG4 Sapphire Rx470 Platinum KVR 1600 16Gb 
Hard DriveHard DriveCoolingOS
2x Seagate 3Tb Samsung 850 EVO 120 Scythe Ninja 3 Rev.B Windows 10 Pro 
MonitorKeyboardPowerCase
Fujitsu Siemens A17-2A Logitech K280e SuperFlower SF-550K12XP Thermaltake Versa H25 
MouseAudio
Logitech G402 Sony MDR XD150 
CPUMotherboardGraphicsRAM
Athlon 750K 4.0Ghz AsRock FM2A75 Pro4+ Sapphire R9 270X Dual-X Kingston 2x4Gb 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 EVO 120  Western Digital 320Gb LiteON DVD-RW CoolerMaster Hyper Z600 
OSMonitorKeyboardPower
Windows 7 Pro x64 Toshiba 32" FullHD TV Logitech FSP Hexa 550 
CaseMouse
DeLUX Logitech 
  hide details  
Reply
My Rig
(14 items)
 
Ex-wife's Rig
(15 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 4460 AsRock H81M-DG4 Sapphire Rx470 Platinum KVR 1600 16Gb 
Hard DriveHard DriveCoolingOS
2x Seagate 3Tb Samsung 850 EVO 120 Scythe Ninja 3 Rev.B Windows 10 Pro 
MonitorKeyboardPowerCase
Fujitsu Siemens A17-2A Logitech K280e SuperFlower SF-550K12XP Thermaltake Versa H25 
MouseAudio
Logitech G402 Sony MDR XD150 
CPUMotherboardGraphicsRAM
Athlon 750K 4.0Ghz AsRock FM2A75 Pro4+ Sapphire R9 270X Dual-X Kingston 2x4Gb 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 EVO 120  Western Digital 320Gb LiteON DVD-RW CoolerMaster Hyper Z600 
OSMonitorKeyboardPower
Windows 7 Pro x64 Toshiba 32" FullHD TV Logitech FSP Hexa 550 
CaseMouse
DeLUX Logitech 
  hide details  
Reply
post #3 of 19
update your hd 6950 drivers
Wayne-The-Brain
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 870 @ 4.0ghz (HT) on EVGA FTW p55 e657 Evga 580 Gtx @ 972/2083 1.15v Hydro Copper 2 Corsair 4x4GB 1600 DDR3 
Hard DriveOptical DriveCoolingOS
OCZ 30GB SSD os /1tb 2x WD black Raid 0 Blu Ray Rasa 240 RX gentle typhoon push pull Windows 7 64bit 
MonitorPowerCaseMouse Pad
47 inch LG LCD 1080p Corsair ax850 gold Antec 300 Illusion (Modded) None 
  hide details  
Reply
Wayne-The-Brain
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 870 @ 4.0ghz (HT) on EVGA FTW p55 e657 Evga 580 Gtx @ 972/2083 1.15v Hydro Copper 2 Corsair 4x4GB 1600 DDR3 
Hard DriveOptical DriveCoolingOS
OCZ 30GB SSD os /1tb 2x WD black Raid 0 Blu Ray Rasa 240 RX gentle typhoon push pull Windows 7 64bit 
MonitorPowerCaseMouse Pad
47 inch LG LCD 1080p Corsair ax850 gold Antec 300 Illusion (Modded) None 
  hide details  
Reply
post #4 of 19
Thread Starter 
I downloaded the catalyst control center, and all it seems to do when i press install is go away
post #5 of 19
Thread Starter 
How do i get my nvidia drivers to go away and my amd drivers to recognize my card?
post #6 of 19
Quote:
Originally Posted by pangolinman View Post
I downloaded the catalyst control center, and all it seems to do when i press install is go away
Cute. Try running manually the setup file, should be in the appropriate for your OS folder (something like Win7x64 maybe).

Mind you, you need the display driver, not the Catalyst Control Center.
My Rig
(14 items)
 
Ex-wife's Rig
(15 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 4460 AsRock H81M-DG4 Sapphire Rx470 Platinum KVR 1600 16Gb 
Hard DriveHard DriveCoolingOS
2x Seagate 3Tb Samsung 850 EVO 120 Scythe Ninja 3 Rev.B Windows 10 Pro 
MonitorKeyboardPowerCase
Fujitsu Siemens A17-2A Logitech K280e SuperFlower SF-550K12XP Thermaltake Versa H25 
MouseAudio
Logitech G402 Sony MDR XD150 
CPUMotherboardGraphicsRAM
Athlon 750K 4.0Ghz AsRock FM2A75 Pro4+ Sapphire R9 270X Dual-X Kingston 2x4Gb 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 EVO 120  Western Digital 320Gb LiteON DVD-RW CoolerMaster Hyper Z600 
OSMonitorKeyboardPower
Windows 7 Pro x64 Toshiba 32" FullHD TV Logitech FSP Hexa 550 
CaseMouse
DeLUX Logitech 
  hide details  
Reply
My Rig
(14 items)
 
Ex-wife's Rig
(15 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 4460 AsRock H81M-DG4 Sapphire Rx470 Platinum KVR 1600 16Gb 
Hard DriveHard DriveCoolingOS
2x Seagate 3Tb Samsung 850 EVO 120 Scythe Ninja 3 Rev.B Windows 10 Pro 
MonitorKeyboardPowerCase
Fujitsu Siemens A17-2A Logitech K280e SuperFlower SF-550K12XP Thermaltake Versa H25 
MouseAudio
Logitech G402 Sony MDR XD150 
CPUMotherboardGraphicsRAM
Athlon 750K 4.0Ghz AsRock FM2A75 Pro4+ Sapphire R9 270X Dual-X Kingston 2x4Gb 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 EVO 120  Western Digital 320Gb LiteON DVD-RW CoolerMaster Hyper Z600 
OSMonitorKeyboardPower
Windows 7 Pro x64 Toshiba 32" FullHD TV Logitech FSP Hexa 550 
CaseMouse
DeLUX Logitech 
  hide details  
Reply
post #7 of 19
Thread Starter 
It keeps on giving me failure to install notices
post #8 of 19
darn....that is not good news....I had that happen and windows re-install was my only option. But perhaps you need the driver patch from windows? Did you recently update to Windows SP1? I think there was a patch from microsoft that came in. I am sure someone will help you out here.
Wife's bane
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.5 Ghz Gigabyte Z77 UD3H HIS R9-290 8 GB Samsung Wonder RAM 
Hard DriveHard DriveOptical DriveCooling
Crucial SSD for OS Samsung Spinpoint F3 Asus XSPC water block, 360 radiator, and 720 reservo... 
CoolingOSMonitorKeyboard
GPU cooling - XSPC Razer full GPU blocks Win 7 Home Premium Asus PB278Q 2560 X 1440p ISP Logitech G15 
PowerCaseMouseMouse Pad
NZXT Hale90 V2 NZXT Switch 810 Logitech G500 Steelseries QcK 
Audio
Optical out to Sony receiver; Deftech Monitor 3... 
  hide details  
Reply
Wife's bane
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.5 Ghz Gigabyte Z77 UD3H HIS R9-290 8 GB Samsung Wonder RAM 
Hard DriveHard DriveOptical DriveCooling
Crucial SSD for OS Samsung Spinpoint F3 Asus XSPC water block, 360 radiator, and 720 reservo... 
CoolingOSMonitorKeyboard
GPU cooling - XSPC Razer full GPU blocks Win 7 Home Premium Asus PB278Q 2560 X 1440p ISP Logitech G15 
PowerCaseMouseMouse Pad
NZXT Hale90 V2 NZXT Switch 810 Logitech G500 Steelseries QcK 
Audio
Optical out to Sony receiver; Deftech Monitor 3... 
  hide details  
Reply
post #9 of 19
Thread Starter 
I did not update. should i update to SP1?
post #10 of 19
Did you try cleansweeper to get rid of your Nvidia drivers? There might be something preventing you from installing the AMD drivers.
    
CPUMotherboardGraphicsRAM
Intel i5 3570K [Delid] Asrock Z77E-ITX XFX Radeon R9 Fury X G.SKILL 2133MHz 8GB DDR3 
Hard DriveHard DriveHard DriveHard Drive
Crucial M4 256GB Silicon Power S60 120GB Western Digital Blue Scorpio 1TB Seagate Constellation 2 1TB 
CoolingCoolingCoolingCooling
Swiftech Apogee Drive II XSPC RX240+EX240 [Painted White] 5x 2150RPM Gentle Typhoons PWM [Painted Black+W... Bitspower Water Tank Z-Multi 80 Inline Reservoir  
OSMonitorMonitorKeyboard
Windows 10 LG 34UC88-B 34" Ultrawide 3440x1440 75Hz HP ZR2240w IPS WASD CODE 87-Key [MX Clear + PBT Keycaps] 
PowerCaseMouseAudio
Seasonix X-750 Case Labs Mercury S3 Logitech G502 Sennheiser HD 598 SE 
Audio
Micca OriGen 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i5 3570K [Delid] Asrock Z77E-ITX XFX Radeon R9 Fury X G.SKILL 2133MHz 8GB DDR3 
Hard DriveHard DriveHard DriveHard Drive
Crucial M4 256GB Silicon Power S60 120GB Western Digital Blue Scorpio 1TB Seagate Constellation 2 1TB 
CoolingCoolingCoolingCooling
Swiftech Apogee Drive II XSPC RX240+EX240 [Painted White] 5x 2150RPM Gentle Typhoons PWM [Painted Black+W... Bitspower Water Tank Z-Multi 80 Inline Reservoir  
OSMonitorMonitorKeyboard
Windows 10 LG 34UC88-B 34" Ultrawide 3440x1440 75Hz HP ZR2240w IPS WASD CODE 87-Key [MX Clear + PBT Keycaps] 
PowerCaseMouseAudio
Seasonix X-750 Case Labs Mercury S3 Logitech G502 Sennheiser HD 598 SE 
Audio
Micca OriGen 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › HD6950 weirdness