Overclock.net › Forums › Video Games › PC Gaming › Help TF2 won't run
New Posts  All Forums:Forum Nav:

Help TF2 won't run

post #1 of 9
Thread Starter 
I have played the game many times on this system. I rolled ATI/AMD 5770 drivers back to 10.6 to see if that would help (was on 11.2) with no go.

My other games will load and play fine (Grid, Dirt2, AvP ... etc...)

But TF2 just says launching then stops. I've tried many of the fixes I've seen online:
-window -safemode and a few others

So short of uninstalling steam or reinstalling TF2 are there any known problems I can attempt to fix first?
post #2 of 9
I'm assuming you've tried verifying the game files through Steam?
    
CPUMotherboardGraphicsRAM
3570k GA-Z77MX-D3H Palit Jetstream 680 4GB 4 X 2GB G.Skill Ripjaws X (1600MHz/CAS8 @ 1.5v) 
Hard DriveCoolingOSMonitor
60GB Corsair Force + 2TB RAID0 + 500GB Antec Kühler 620 w/AP-14 Windows 7 Professional x64 Dell U2711 (2560 x 1440) 
KeyboardPowerCaseMouse
Filco Majestouch (MX Blues) Corsair HX650 Lian Li PC-U6B Razer Deathadder 3.5G 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
3570k GA-Z77MX-D3H Palit Jetstream 680 4GB 4 X 2GB G.Skill Ripjaws X (1600MHz/CAS8 @ 1.5v) 
Hard DriveCoolingOSMonitor
60GB Corsair Force + 2TB RAID0 + 500GB Antec Kühler 620 w/AP-14 Windows 7 Professional x64 Dell U2711 (2560 x 1440) 
KeyboardPowerCaseMouse
Filco Majestouch (MX Blues) Corsair HX650 Lian Li PC-U6B Razer Deathadder 3.5G 
  hide details  
Reply
post #3 of 9
What exactly happens when you click Play?

Does nothing pop up?
Revofev
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 EVGA E770 2x EVGA GTX 570 6GB Mushkin Redline Ridgeback 
Hard DriveOptical DriveOSMonitor
128GB Crucial M4/ 4x1TB WD Black/ 1TB F3 Lite-On 24x Win 7 Ultimate x64 Acer H233H 
KeyboardPowerCaseMouse
Filco Majestouch 2 w/ Red Switches Corsair AX850 800D Logitech G500 
Mouse Pad
Steelseries QcK+ 
  hide details  
Reply
Revofev
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 EVGA E770 2x EVGA GTX 570 6GB Mushkin Redline Ridgeback 
Hard DriveOptical DriveOSMonitor
128GB Crucial M4/ 4x1TB WD Black/ 1TB F3 Lite-On 24x Win 7 Ultimate x64 Acer H233H 
KeyboardPowerCaseMouse
Filco Majestouch 2 w/ Red Switches Corsair AX850 800D Logitech G500 
Mouse Pad
Steelseries QcK+ 
  hide details  
Reply
post #4 of 9
Thread Starter 
Launching comes up but just disappears


Yes i've verified the game
post #5 of 9
Try completely exiting out of steam, make sure steam.exe is not running in processes.

Then open back up Steam and try again.
Revofev
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 EVGA E770 2x EVGA GTX 570 6GB Mushkin Redline Ridgeback 
Hard DriveOptical DriveOSMonitor
128GB Crucial M4/ 4x1TB WD Black/ 1TB F3 Lite-On 24x Win 7 Ultimate x64 Acer H233H 
KeyboardPowerCaseMouse
Filco Majestouch 2 w/ Red Switches Corsair AX850 800D Logitech G500 
Mouse Pad
Steelseries QcK+ 
  hide details  
Reply
Revofev
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 EVGA E770 2x EVGA GTX 570 6GB Mushkin Redline Ridgeback 
Hard DriveOptical DriveOSMonitor
128GB Crucial M4/ 4x1TB WD Black/ 1TB F3 Lite-On 24x Win 7 Ultimate x64 Acer H233H 
KeyboardPowerCaseMouse
Filco Majestouch 2 w/ Red Switches Corsair AX850 800D Logitech G500 
Mouse Pad
Steelseries QcK+ 
  hide details  
Reply
post #6 of 9
When you verify the files, make sure you aren't doing anything while it's verifying.
yo this my rig yo
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-750 @ 3.8 GHz Gigabyte P55-USB3 Gigabyte GTX460 1GB OC 8GB Kingston HyperX Genesis 1600 C9 
OSMonitorPowerCase
Win7 64bit LG W2261VP Corsair HX520 (getting old now heh) HAF 922 
Mouse PadAudio
A picture of your mom. Corsair SP2200 
  hide details  
Reply
yo this my rig yo
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-750 @ 3.8 GHz Gigabyte P55-USB3 Gigabyte GTX460 1GB OC 8GB Kingston HyperX Genesis 1600 C9 
OSMonitorPowerCase
Win7 64bit LG W2261VP Corsair HX520 (getting old now heh) HAF 922 
Mouse PadAudio
A picture of your mom. Corsair SP2200 
  hide details  
Reply
post #7 of 9
Thread Starter 
I have and rebooted also.

Its not run the past few days
post #8 of 9
Delete the TF2 and redownload it?
yo this my rig yo
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-750 @ 3.8 GHz Gigabyte P55-USB3 Gigabyte GTX460 1GB OC 8GB Kingston HyperX Genesis 1600 C9 
OSMonitorPowerCase
Win7 64bit LG W2261VP Corsair HX520 (getting old now heh) HAF 922 
Mouse PadAudio
A picture of your mom. Corsair SP2200 
  hide details  
Reply
yo this my rig yo
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-750 @ 3.8 GHz Gigabyte P55-USB3 Gigabyte GTX460 1GB OC 8GB Kingston HyperX Genesis 1600 C9 
OSMonitorPowerCase
Win7 64bit LG W2261VP Corsair HX520 (getting old now heh) HAF 922 
Mouse PadAudio
A picture of your mom. Corsair SP2200 
  hide details  
Reply
post #9 of 9
Thread Starter 
Quote:
Originally Posted by luanswan2002 View Post
Delete the TF2 and redownload it?
I only have 1.5 mb/s down and am currently dloading Bioshock 2 (got it today for $3.75)
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Help TF2 won't run