Overclock.net › Forums › Video Games › PC Gaming › Bad company 2 white screen crash
New Posts  All Forums:Forum Nav:

Bad company 2 white screen crash

post #1 of 6
Thread Starter 
Hi Guys,

I have seen many threads on various forums for this and nothing I try fixes it.

It worked fine until recently. The thing is I have made a lot of changes and cannot think at which point the problem started. I think I upgraded my card to a 560ti but i'm pretty sure it worked fine for a while after that.

I have tried various drivers and this does not seem to help. I have just updated my system to my sig rig and this didnt help either.

It's generally after 5 min of game play. I have checked my temps and they reach aroun 70 degrees C. My processor reaches aroun 80 under load....is this high for this processor? It is over clocked as in sig
computer of doom
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 @4GHz Asus P6T se Gigabyte GTX560ti 1GB Inno 3d 9800Gt (Physx) 6x 2gb OCZ OCZ3G1333LV6GK DDR3 PC3 10666 Gold T... 
Hard DriveOSMonitorPower
Seagate 1.5TB 7200rpm +2x2TB wd + 2tb Samsung e... Windows 7 Ultimate Sony Bravia 40" 1080p OCZ 700 
Mouse
Sharkoon Fireglider 
  hide details  
Reply
computer of doom
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 @4GHz Asus P6T se Gigabyte GTX560ti 1GB Inno 3d 9800Gt (Physx) 6x 2gb OCZ OCZ3G1333LV6GK DDR3 PC3 10666 Gold T... 
Hard DriveOSMonitorPower
Seagate 1.5TB 7200rpm +2x2TB wd + 2tb Samsung e... Windows 7 Ultimate Sony Bravia 40" 1080p OCZ 700 
Mouse
Sharkoon Fireglider 
  hide details  
Reply
post #2 of 6
Temps are fine...Other than that i don't know of any other help.

also that heat sink is....crap. Get a better one like the Megahelms or even a Mugen II
 
Gsvlip Dudyrm
(15 items)
 
Oda'maksv
(9 items)
 
CPUMotherboardGraphicsRAM
3770k @ 4.5 1.312 load Zotac Z77 ITX Wifi GTX 1070 Gaming 2126/2249 w/ Hybrid cooler TridentX 16GB 2400MHz 
Hard DriveHard DriveCoolingCooling
Samsung 850 Pro 1TB Seagate 2TB H105 EVGA Hybrid GPU cooler 
OSMonitorKeyboardPower
Windows 10 Asus MG279Q - 24" 144Hz 1080p Filco Majestic II w/ Cherry Reds Seasonic X 760W 
CaseMouseMouse PadAudio
Bitfelix Prodigy Logitech G400 Razer Goliath AKG A701 
AudioAudio
JDS Labs Objective 2 JDS Labs ODAC 
CPUMotherboardGraphicsRAM
Core i5 750 3.99 (190x21) 1.376v Load ASUS P7P55d-E Pro GTX 670 FTW <- Poor overclocker :( 8GB (4x2GB) G.Skill DDR3 1600 
Hard DriveHard DriveOptical DriveOS
Samsung 830 Evo 128GB 2x 2TB  Some DVD drive OSX 10.10.4 
MonitorPowerCaseMouse
Asus 1080P Crap TX 750 HAF 922 G400s 
Mouse PadOther
Apple Keyboard Xbox One controler 
CPURAMHard DriveHard Drive
C2D 2,26GHz under volted @ .978v 8GB  Crucial M4 64GB SSD 500GB Scorpio Black 
OSMonitorKeyboardMouse
OS X 10.0 1280x800 Built-in Trackpad 
Audio
Built-in 
  hide details  
Reply
 
Gsvlip Dudyrm
(15 items)
 
Oda'maksv
(9 items)
 
CPUMotherboardGraphicsRAM
3770k @ 4.5 1.312 load Zotac Z77 ITX Wifi GTX 1070 Gaming 2126/2249 w/ Hybrid cooler TridentX 16GB 2400MHz 
Hard DriveHard DriveCoolingCooling
Samsung 850 Pro 1TB Seagate 2TB H105 EVGA Hybrid GPU cooler 
OSMonitorKeyboardPower
Windows 10 Asus MG279Q - 24" 144Hz 1080p Filco Majestic II w/ Cherry Reds Seasonic X 760W 
CaseMouseMouse PadAudio
Bitfelix Prodigy Logitech G400 Razer Goliath AKG A701 
AudioAudio
JDS Labs Objective 2 JDS Labs ODAC 
CPUMotherboardGraphicsRAM
Core i5 750 3.99 (190x21) 1.376v Load ASUS P7P55d-E Pro GTX 670 FTW <- Poor overclocker :( 8GB (4x2GB) G.Skill DDR3 1600 
Hard DriveHard DriveOptical DriveOS
Samsung 830 Evo 128GB 2x 2TB  Some DVD drive OSX 10.10.4 
MonitorPowerCaseMouse
Asus 1080P Crap TX 750 HAF 922 G400s 
Mouse PadOther
Apple Keyboard Xbox One controler 
CPURAMHard DriveHard Drive
C2D 2,26GHz under volted @ .978v 8GB  Crucial M4 64GB SSD 500GB Scorpio Black 
OSMonitorKeyboardMouse
OS X 10.0 1280x800 Built-in Trackpad 
Audio
Built-in 
  hide details  
Reply
post #3 of 6
Thread Starter 
Well saying it's crap is just your opinion.

Here's what my thoughts are on it.

I'm wondering wether it is a power issue as it happens in a few of the games a I play recently. The screen goes black as if it looses signal then comes back on either crashed or resumed. With BC2 doing this returns with white screen but you can hear gae play. I went to plug the part of the 4 pin eatx plug but to find that it does not fit. The layout of it is 8 pins in total with different shaped hole. It's next to the CPU and the holes vary from square to less square shape. Both my power connectors fit in the fist one but not the second 4 pins. Could this be the issue? Do I need to add the second one with an addaptor or something? I have all 24 pins plugged in on the main power connector.

Is there a way of testing if the power is the failiure here?
computer of doom
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 @4GHz Asus P6T se Gigabyte GTX560ti 1GB Inno 3d 9800Gt (Physx) 6x 2gb OCZ OCZ3G1333LV6GK DDR3 PC3 10666 Gold T... 
Hard DriveOSMonitorPower
Seagate 1.5TB 7200rpm +2x2TB wd + 2tb Samsung e... Windows 7 Ultimate Sony Bravia 40" 1080p OCZ 700 
Mouse
Sharkoon Fireglider 
  hide details  
Reply
computer of doom
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 @4GHz Asus P6T se Gigabyte GTX560ti 1GB Inno 3d 9800Gt (Physx) 6x 2gb OCZ OCZ3G1333LV6GK DDR3 PC3 10666 Gold T... 
Hard DriveOSMonitorPower
Seagate 1.5TB 7200rpm +2x2TB wd + 2tb Samsung e... Windows 7 Ultimate Sony Bravia 40" 1080p OCZ 700 
Mouse
Sharkoon Fireglider 
  hide details  
Reply
post #4 of 6
Well, you're not alone. You may have already seen this - it's the "official" bad Company 2 freeze/crash/etc. thread for OCN.

http://www.overclock.net/pc-games/963377-bfbc2-freezing-crashing-guide-solutions.html

A lot of people have the problem - I get it sometimes as a hard crash. As I'm sure you've learned, there are a bunch of theories, and probably more than one cause. The first post in the thread I linked to focuses on Punkbuster as the cause. As for myself, I found that the crashes became less frequent after I improved cooling on my rig. Why? I don't know. I didn't expect it - my temps seemed ok to me, no worse than in any other game - but I'll take it.
post #5 of 6
Thread Starter 
So here's what I have tried so far.

I have removed my physx card and a hard disk to reduce power consumption.
I have tried a different hdmi cable
I have ran a driver cleaner and re installed drivers that I know worked before.
I changed the rendering settings to 0
Fully re installed operating system
Disabled overclock

It seems to last longer without crashing but after 10-15 minutes just goes. MAx temp on card 77 degrees C


Help!!!
computer of doom
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 @4GHz Asus P6T se Gigabyte GTX560ti 1GB Inno 3d 9800Gt (Physx) 6x 2gb OCZ OCZ3G1333LV6GK DDR3 PC3 10666 Gold T... 
Hard DriveOSMonitorPower
Seagate 1.5TB 7200rpm +2x2TB wd + 2tb Samsung e... Windows 7 Ultimate Sony Bravia 40" 1080p OCZ 700 
Mouse
Sharkoon Fireglider 
  hide details  
Reply
computer of doom
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 @4GHz Asus P6T se Gigabyte GTX560ti 1GB Inno 3d 9800Gt (Physx) 6x 2gb OCZ OCZ3G1333LV6GK DDR3 PC3 10666 Gold T... 
Hard DriveOSMonitorPower
Seagate 1.5TB 7200rpm +2x2TB wd + 2tb Samsung e... Windows 7 Ultimate Sony Bravia 40" 1080p OCZ 700 
Mouse
Sharkoon Fireglider 
  hide details  
Reply
post #6 of 6
Thread Starter 
Re installed punk buster and just played for 20 min no crash....fingers crossed
computer of doom
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 @4GHz Asus P6T se Gigabyte GTX560ti 1GB Inno 3d 9800Gt (Physx) 6x 2gb OCZ OCZ3G1333LV6GK DDR3 PC3 10666 Gold T... 
Hard DriveOSMonitorPower
Seagate 1.5TB 7200rpm +2x2TB wd + 2tb Samsung e... Windows 7 Ultimate Sony Bravia 40" 1080p OCZ 700 
Mouse
Sharkoon Fireglider 
  hide details  
Reply
computer of doom
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 @4GHz Asus P6T se Gigabyte GTX560ti 1GB Inno 3d 9800Gt (Physx) 6x 2gb OCZ OCZ3G1333LV6GK DDR3 PC3 10666 Gold T... 
Hard DriveOSMonitorPower
Seagate 1.5TB 7200rpm +2x2TB wd + 2tb Samsung e... Windows 7 Ultimate Sony Bravia 40" 1080p OCZ 700 
Mouse
Sharkoon Fireglider 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Bad company 2 white screen crash