Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Programs hang for a while before loading in Win 7
New Posts  All Forums:Forum Nav:

Programs hang for a while before loading in Win 7

post #1 of 20
Thread Starter 
Lately I've been having these strange hang-ups in Windows 7. An example would be opening up one of the main libraries such as Videos or Documents. It hangs for like 10 seconds sometimes then finally loads it. Sometimes get this same occurrence with programs such as Media Player Classic. If anything, I thought opening programs and documents would be a lot faster with an SSD. I didn't have this problem when I first installed it. Everything was fine for a couple months. I'm not sure what this problem is related to, be it hardware or software. What do you guys think could be causing this hiccup?
EvuL Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Ivy Bridge GIGABYTE GA-Z77X-UP5 TH EVGA GeForce GTX770 SuperClocked 2GB G.SKILL Ripjaws X Series 16GB (2 x 8GB) DDR3 1600 
Hard DriveHard DriveCoolingOS
SAMSUNG 840 Pro Series 256GB  2xSAMSUNG Spinpoint F3 1TB Thermalright Silver Arrow SB-E Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Dell UltraSharp U2713HM Deck Legend - Ice (Linear) CORSAIR Professional Series Gold AX750 SilverStone Fortress Series FT02B-W 
MouseAudioAudio
Logitech G400s NuForce Icon HDP Sennheiser HD 650 Headphones 
  hide details  
Reply
EvuL Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Ivy Bridge GIGABYTE GA-Z77X-UP5 TH EVGA GeForce GTX770 SuperClocked 2GB G.SKILL Ripjaws X Series 16GB (2 x 8GB) DDR3 1600 
Hard DriveHard DriveCoolingOS
SAMSUNG 840 Pro Series 256GB  2xSAMSUNG Spinpoint F3 1TB Thermalright Silver Arrow SB-E Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Dell UltraSharp U2713HM Deck Legend - Ice (Linear) CORSAIR Professional Series Gold AX750 SilverStone Fortress Series FT02B-W 
MouseAudioAudio
Logitech G400s NuForce Icon HDP Sennheiser HD 650 Headphones 
  hide details  
Reply
post #2 of 20
Quote:
Originally Posted by Vitaminx View Post
Lately I've been having these strange hang-ups in Windows 7. An example would be opening up one of the main libraries such as Videos or Documents. It hangs for like 10 seconds sometimes then finally loads it. Sometimes get this same occurrence with programs such as Media Player Classic. If anything, I thought opening programs and documents would be a lot faster with an SSD. I didn't have this problem when I first installed it. Everything was fine for a couple months. I'm not sure what this problem is related to, be it hardware or software. What do you guys think could be causing this hiccup?
I have three questions:
  • Do you have AHCI mode enabled?
  • If so, then which driver are you using? The generic driver that comes with Windows, or Intel's Rapid Storage Technology driver?
  • How often do you benchmark the drive with software that provides Write speed results?
It's a computer!
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveOptical DriveOptical Drive
250 GB Samsung 840 EVO (OS) 3 TB Toshiba P300 (storage) Samsung SH-S243N 24x DVD Burner Samsung SH-S203N 20X DVD Burner 
CoolingOSMonitorKeyboard
Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) Filco Majestouch 104-key Cherry MX Blues w/NKRO 
PowerCaseMouseMouse Pad
Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate Basic, but premium round 
AudioAudio
X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveOptical DriveOptical Drive
250 GB Samsung 840 EVO (OS) 3 TB Toshiba P300 (storage) Samsung SH-S243N 24x DVD Burner Samsung SH-S203N 20X DVD Burner 
CoolingOSMonitorKeyboard
Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) Filco Majestouch 104-key Cherry MX Blues w/NKRO 
PowerCaseMouseMouse Pad
Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate Basic, but premium round 
AudioAudio
X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #3 of 20
Thread Starter 
Quote:
Originally Posted by TwoCables View Post
I have three questions:
  • Do you have AHCI mode enabled?
  • If so, then which driver are you using? The generic driver that comes with Windows, or Intel's Rapid Storage Technology driver?
  • How often do you benchmark the drive with software that provides Write speed results?
1st Question - Yes
2nd Question - I don't really know (How do I check)
3rd Question - I benchmarked it like twice when I first installed. Benchmarked it earlier today when I updated the firmware. That's about it.
EvuL Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Ivy Bridge GIGABYTE GA-Z77X-UP5 TH EVGA GeForce GTX770 SuperClocked 2GB G.SKILL Ripjaws X Series 16GB (2 x 8GB) DDR3 1600 
Hard DriveHard DriveCoolingOS
SAMSUNG 840 Pro Series 256GB  2xSAMSUNG Spinpoint F3 1TB Thermalright Silver Arrow SB-E Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Dell UltraSharp U2713HM Deck Legend - Ice (Linear) CORSAIR Professional Series Gold AX750 SilverStone Fortress Series FT02B-W 
MouseAudioAudio
Logitech G400s NuForce Icon HDP Sennheiser HD 650 Headphones 
  hide details  
Reply
EvuL Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Ivy Bridge GIGABYTE GA-Z77X-UP5 TH EVGA GeForce GTX770 SuperClocked 2GB G.SKILL Ripjaws X Series 16GB (2 x 8GB) DDR3 1600 
Hard DriveHard DriveCoolingOS
SAMSUNG 840 Pro Series 256GB  2xSAMSUNG Spinpoint F3 1TB Thermalright Silver Arrow SB-E Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Dell UltraSharp U2713HM Deck Legend - Ice (Linear) CORSAIR Professional Series Gold AX750 SilverStone Fortress Series FT02B-W 
MouseAudioAudio
Logitech G400s NuForce Icon HDP Sennheiser HD 650 Headphones 
  hide details  
Reply
post #4 of 20
Do you have anything in Services stopping? Event viewer?
post #5 of 20
Quote:
Originally Posted by Vitaminx View Post
1st Question - Yes
2nd Question - I don't really know (How do I check)
3rd Question - I benchmarked it like twice when I first installed. Benchmarked it earlier today when I updated the firmware. That's about it.
Damn. I was hoping you had IDE mode enabled. hehehe

I can see this is going to be tougher than I thought. So let's get Intel's Rapid Storage Technology installed and then see what happens (it's an awesome driver anyway):

http://downloadcenter.intel.com/Deta...&DwnldID=19607

If this doesn't fix the issue, then I'll only be somewhat surprised because it's all I would know to try.
It's a computer!
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveOptical DriveOptical Drive
250 GB Samsung 840 EVO (OS) 3 TB Toshiba P300 (storage) Samsung SH-S243N 24x DVD Burner Samsung SH-S203N 20X DVD Burner 
CoolingOSMonitorKeyboard
Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) Filco Majestouch 104-key Cherry MX Blues w/NKRO 
PowerCaseMouseMouse Pad
Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate Basic, but premium round 
AudioAudio
X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveOptical DriveOptical Drive
250 GB Samsung 840 EVO (OS) 3 TB Toshiba P300 (storage) Samsung SH-S243N 24x DVD Burner Samsung SH-S203N 20X DVD Burner 
CoolingOSMonitorKeyboard
Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) Filco Majestouch 104-key Cherry MX Blues w/NKRO 
PowerCaseMouseMouse Pad
Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate Basic, but premium round 
AudioAudio
X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #6 of 20
Thread Starter 
Quote:
Originally Posted by TwoCables View Post
Damn. I was hoping you had IDE mode enabled. hehehe

I can see this is going to be tougher than I thought. So let's get Intel's Rapid Storage Technology installed and then see what happens (it's an awesome driver anyway):

http://downloadcenter.intel.com/Deta...&DwnldID=19607

If this doesn't fix the issue, then I'll only be somewhat surprised because it's all I would know to try.
I should download that even though my SSD is OCZ?
EvuL Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Ivy Bridge GIGABYTE GA-Z77X-UP5 TH EVGA GeForce GTX770 SuperClocked 2GB G.SKILL Ripjaws X Series 16GB (2 x 8GB) DDR3 1600 
Hard DriveHard DriveCoolingOS
SAMSUNG 840 Pro Series 256GB  2xSAMSUNG Spinpoint F3 1TB Thermalright Silver Arrow SB-E Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Dell UltraSharp U2713HM Deck Legend - Ice (Linear) CORSAIR Professional Series Gold AX750 SilverStone Fortress Series FT02B-W 
MouseAudioAudio
Logitech G400s NuForce Icon HDP Sennheiser HD 650 Headphones 
  hide details  
Reply
EvuL Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Ivy Bridge GIGABYTE GA-Z77X-UP5 TH EVGA GeForce GTX770 SuperClocked 2GB G.SKILL Ripjaws X Series 16GB (2 x 8GB) DDR3 1600 
Hard DriveHard DriveCoolingOS
SAMSUNG 840 Pro Series 256GB  2xSAMSUNG Spinpoint F3 1TB Thermalright Silver Arrow SB-E Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Dell UltraSharp U2713HM Deck Legend - Ice (Linear) CORSAIR Professional Series Gold AX750 SilverStone Fortress Series FT02B-W 
MouseAudioAudio
Logitech G400s NuForce Icon HDP Sennheiser HD 650 Headphones 
  hide details  
Reply
post #7 of 20
Quote:
Originally Posted by Vitaminx View Post
I should download that even though my SSD is OCZ?
Yeah, because it's connected to an Intel-controlled SATA port. The driver is for the southbridge, mostly.
It's a computer!
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveOptical DriveOptical Drive
250 GB Samsung 840 EVO (OS) 3 TB Toshiba P300 (storage) Samsung SH-S243N 24x DVD Burner Samsung SH-S203N 20X DVD Burner 
CoolingOSMonitorKeyboard
Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) Filco Majestouch 104-key Cherry MX Blues w/NKRO 
PowerCaseMouseMouse Pad
Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate Basic, but premium round 
AudioAudio
X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveOptical DriveOptical Drive
250 GB Samsung 840 EVO (OS) 3 TB Toshiba P300 (storage) Samsung SH-S243N 24x DVD Burner Samsung SH-S203N 20X DVD Burner 
CoolingOSMonitorKeyboard
Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) Filco Majestouch 104-key Cherry MX Blues w/NKRO 
PowerCaseMouseMouse Pad
Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate Basic, but premium round 
AudioAudio
X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #8 of 20
Thread Starter 
Quote:
Originally Posted by TwoCables View Post
Yeah, because it's connected to an Intel-controlled SATA port. The driver is for the southbridge, mostly.
Ok, I installed it. Do I have do anything with it once it is installed?
EvuL Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Ivy Bridge GIGABYTE GA-Z77X-UP5 TH EVGA GeForce GTX770 SuperClocked 2GB G.SKILL Ripjaws X Series 16GB (2 x 8GB) DDR3 1600 
Hard DriveHard DriveCoolingOS
SAMSUNG 840 Pro Series 256GB  2xSAMSUNG Spinpoint F3 1TB Thermalright Silver Arrow SB-E Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Dell UltraSharp U2713HM Deck Legend - Ice (Linear) CORSAIR Professional Series Gold AX750 SilverStone Fortress Series FT02B-W 
MouseAudioAudio
Logitech G400s NuForce Icon HDP Sennheiser HD 650 Headphones 
  hide details  
Reply
EvuL Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Ivy Bridge GIGABYTE GA-Z77X-UP5 TH EVGA GeForce GTX770 SuperClocked 2GB G.SKILL Ripjaws X Series 16GB (2 x 8GB) DDR3 1600 
Hard DriveHard DriveCoolingOS
SAMSUNG 840 Pro Series 256GB  2xSAMSUNG Spinpoint F3 1TB Thermalright Silver Arrow SB-E Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Dell UltraSharp U2713HM Deck Legend - Ice (Linear) CORSAIR Professional Series Gold AX750 SilverStone Fortress Series FT02B-W 
MouseAudioAudio
Logitech G400s NuForce Icon HDP Sennheiser HD 650 Headphones 
  hide details  
Reply
post #9 of 20
Quote:
Originally Posted by Vitaminx View Post
Ok, I installed it. Do I have do anything with it once it is installed?
Fortunately, no.
It's a computer!
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveOptical DriveOptical Drive
250 GB Samsung 840 EVO (OS) 3 TB Toshiba P300 (storage) Samsung SH-S243N 24x DVD Burner Samsung SH-S203N 20X DVD Burner 
CoolingOSMonitorKeyboard
Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) Filco Majestouch 104-key Cherry MX Blues w/NKRO 
PowerCaseMouseMouse Pad
Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate Basic, but premium round 
AudioAudio
X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveOptical DriveOptical Drive
250 GB Samsung 840 EVO (OS) 3 TB Toshiba P300 (storage) Samsung SH-S243N 24x DVD Burner Samsung SH-S203N 20X DVD Burner 
CoolingOSMonitorKeyboard
Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) Filco Majestouch 104-key Cherry MX Blues w/NKRO 
PowerCaseMouseMouse Pad
Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate Basic, but premium round 
AudioAudio
X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #10 of 20
Thread Starter 
Just an update: The problem is still occurring it seems. Maybe not as bad as before though, but it is still there.
EvuL Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Ivy Bridge GIGABYTE GA-Z77X-UP5 TH EVGA GeForce GTX770 SuperClocked 2GB G.SKILL Ripjaws X Series 16GB (2 x 8GB) DDR3 1600 
Hard DriveHard DriveCoolingOS
SAMSUNG 840 Pro Series 256GB  2xSAMSUNG Spinpoint F3 1TB Thermalright Silver Arrow SB-E Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Dell UltraSharp U2713HM Deck Legend - Ice (Linear) CORSAIR Professional Series Gold AX750 SilverStone Fortress Series FT02B-W 
MouseAudioAudio
Logitech G400s NuForce Icon HDP Sennheiser HD 650 Headphones 
  hide details  
Reply
EvuL Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Ivy Bridge GIGABYTE GA-Z77X-UP5 TH EVGA GeForce GTX770 SuperClocked 2GB G.SKILL Ripjaws X Series 16GB (2 x 8GB) DDR3 1600 
Hard DriveHard DriveCoolingOS
SAMSUNG 840 Pro Series 256GB  2xSAMSUNG Spinpoint F3 1TB Thermalright Silver Arrow SB-E Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Dell UltraSharp U2713HM Deck Legend - Ice (Linear) CORSAIR Professional Series Gold AX750 SilverStone Fortress Series FT02B-W 
MouseAudioAudio
Logitech G400s NuForce Icon HDP Sennheiser HD 650 Headphones 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Programs hang for a while before loading in Win 7