Overclock.net › Forums › Intel › Intel Motherboards › DOA mobo??
New Posts  All Forums:Forum Nav:

DOA mobo??

post #1 of 9
Thread Starter 
So I received my Asrock extreme 6 and placed it in my case. I do not have the cpu yet but wanted to make sure the board was working. I plugged in the 24 & 8 pin power but did not see any lights come on. Is the board dead?? I know the psu works because I used it to leak test my water cool setup. What's wrong?

Sent from my PC36100 using Tapatalk
Edited by eggdrop - 4/16/11 at 9:43pm
P67 Venom
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K ASRock P67 Extreme6 MSI GTX 560 ti SLI 8GB Corsair Vengeance DDR1600 
OSKeyboardPowerCase
Windows 7 x64 Ultimate Razer Tarantula XFX Black Edition 750w Cooler Master 690 II Advanced Nvidia 
MouseMouse Pad
Razer Mamba Razer eXactMat 
  hide details  
Reply
P67 Venom
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K ASRock P67 Extreme6 MSI GTX 560 ti SLI 8GB Corsair Vengeance DDR1600 
OSKeyboardPowerCase
Windows 7 x64 Ultimate Razer Tarantula XFX Black Edition 750w Cooler Master 690 II Advanced Nvidia 
MouseMouse Pad
Razer Mamba Razer eXactMat 
  hide details  
Reply
post #2 of 9
wait until you complete the build, then you will tell if its DOA or not.
my first child
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 3.2ghz Evga X58 Sli3 2x Gtx 460 @ 820Mhz [SLI] 12GB G skill 1600 
Hard DriveHard DriveHard DriveCooling
Corsair Force GT 120gb SSD x2 1TB Western digital Caviar Black 1TB 5900 rpm Seagate (Storage) Corsair H50 
OSMonitorKeyboardPower
Windows 7 pro 64 bit Samsung 27" 1920x1080 Saitek Eclipse II Corsair AX 850w 
CaseMouseAudio
Haf X R.A.T. 7 Albino Klipsch Promedia 2.1 w/ 200W sub 
  hide details  
Reply
my first child
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 3.2ghz Evga X58 Sli3 2x Gtx 460 @ 820Mhz [SLI] 12GB G skill 1600 
Hard DriveHard DriveHard DriveCooling
Corsair Force GT 120gb SSD x2 1TB Western digital Caviar Black 1TB 5900 rpm Seagate (Storage) Corsair H50 
OSMonitorKeyboardPower
Windows 7 pro 64 bit Samsung 27" 1920x1080 Saitek Eclipse II Corsair AX 850w 
CaseMouseAudio
Haf X R.A.T. 7 Albino Klipsch Promedia 2.1 w/ 200W sub 
  hide details  
Reply
post #3 of 9
Quote:
Originally Posted by kyle7412 View Post
wait until you complete the build, then you will tell if its DOA or not.
This

At least have the CPU in before you assess whether or not the board is DOA
Edited by kiwiasian - 4/16/11 at 9:40pm
post #4 of 9
Thread Starter 
Will the power led not turn on without the cpu? The psu does not turn on when connected to the mobo. Is that normal?

Sent from my PC36100 using Tapatalk
P67 Venom
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K ASRock P67 Extreme6 MSI GTX 560 ti SLI 8GB Corsair Vengeance DDR1600 
OSKeyboardPowerCase
Windows 7 x64 Ultimate Razer Tarantula XFX Black Edition 750w Cooler Master 690 II Advanced Nvidia 
MouseMouse Pad
Razer Mamba Razer eXactMat 
  hide details  
Reply
P67 Venom
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K ASRock P67 Extreme6 MSI GTX 560 ti SLI 8GB Corsair Vengeance DDR1600 
OSKeyboardPowerCase
Windows 7 x64 Ultimate Razer Tarantula XFX Black Edition 750w Cooler Master 690 II Advanced Nvidia 
MouseMouse Pad
Razer Mamba Razer eXactMat 
  hide details  
Reply
post #5 of 9
Quote:
Originally Posted by eggdrop View Post
Will the power led not turn on without the cpu? The psu does not turn on when connected to the mobo. Is that normal?

Sent from my PC36100 using Tapatalk
Try turning on the PSU by itself, without having it connected to the motherboard. It might be a DOA PSU if the PSU doesn't even turn on (the POWER_SW header on the FP connector to main ATX is an independent circuit, so if you couldn't turn it on using your power button then your PSU might be faulty)
post #6 of 9
Thread Starter 
It's not the psu. I have already used it to power things up. I did a 24 hour leak test for my water cooling setup. I also used it to test my case fans and cathodes. I did that by plugging in a power bypass that came with the water kit.

Sent from my PC36100 using Tapatalk
P67 Venom
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K ASRock P67 Extreme6 MSI GTX 560 ti SLI 8GB Corsair Vengeance DDR1600 
OSKeyboardPowerCase
Windows 7 x64 Ultimate Razer Tarantula XFX Black Edition 750w Cooler Master 690 II Advanced Nvidia 
MouseMouse Pad
Razer Mamba Razer eXactMat 
  hide details  
Reply
P67 Venom
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K ASRock P67 Extreme6 MSI GTX 560 ti SLI 8GB Corsair Vengeance DDR1600 
OSKeyboardPowerCase
Windows 7 x64 Ultimate Razer Tarantula XFX Black Edition 750w Cooler Master 690 II Advanced Nvidia 
MouseMouse Pad
Razer Mamba Razer eXactMat 
  hide details  
Reply
post #7 of 9
Quote:
Originally Posted by eggdrop View Post
It's not the psu. I have already used it to power things up. I did a 24 hour leak test for my water cooling setup. I also used it to test my case fans and cathodes. I did that by plugging in a power bypass that came with the water kit.

Sent from my PC36100 using Tapatalk
Then just wait til you get your CPU.
post #8 of 9
Thread Starter 
So in other words, I still have a little hope? I just want to make sure that I an not wasting time when I can start the rma process and be set to go when everything is in.

Sent from my PC36100 using Tapatalk
P67 Venom
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K ASRock P67 Extreme6 MSI GTX 560 ti SLI 8GB Corsair Vengeance DDR1600 
OSKeyboardPowerCase
Windows 7 x64 Ultimate Razer Tarantula XFX Black Edition 750w Cooler Master 690 II Advanced Nvidia 
MouseMouse Pad
Razer Mamba Razer eXactMat 
  hide details  
Reply
P67 Venom
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K ASRock P67 Extreme6 MSI GTX 560 ti SLI 8GB Corsair Vengeance DDR1600 
OSKeyboardPowerCase
Windows 7 x64 Ultimate Razer Tarantula XFX Black Edition 750w Cooler Master 690 II Advanced Nvidia 
MouseMouse Pad
Razer Mamba Razer eXactMat 
  hide details  
Reply
post #9 of 9
Quote:
Originally Posted by eggdrop View Post
So in other words, I still have a little hope? I just want to make sure that I an not wasting time when I can start the rma process and be set to go when everything is in.

Sent from my PC36100 using Tapatalk
To be honest, I don't know. I've never tried POSTing (or even trying to turn on a motherboard) without a CPU installed. There is still some hope.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › DOA mobo??