Overclock.net › Forums › Components › Keyboards › water spilled
New Posts  All Forums:Forum Nav:

water spilled

post #1 of 7
Thread Starter 
Water spilled on my Logitech wifi keyboard. I took the batteries out, and I think got out all the water out by shaking it. At first some of the keys worked, but the numerical keys was not. eg if 4 was pressed, 4 and 5 would displayed. I then took the batteries out, opened up the keyboard there was few droplets of water present. I dried all trace of water put it back together, now the the number pad seems to stopped working. Only the directional keys seems to work on the numerical pad. I tried repeatedly pressing the the num-lock key, reset the keyboard no change. Do guys think, thats it got to get a new board? What do you think. In fact I used it to post this thread.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 940 Deneb @3.5 Gigabyte GA_MA790X-UD4P Nvidia Geforce 9500gt Patriot Viper ser pc2-6400 800mhz (2x2gb)4-4-4-12 
Hard DriveOptical DriveOSMonitor
Hitachi DESKSTAR 1 TB WD 1TB Samsung 500 Gb Lightscribe DVD win 7 64bits DCLCD 20" LCD 
KeyboardPowerCaseMouse
dell Ultra 600 watt powerup mid tower A4tech 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 940 Deneb @3.5 Gigabyte GA_MA790X-UD4P Nvidia Geforce 9500gt Patriot Viper ser pc2-6400 800mhz (2x2gb)4-4-4-12 
Hard DriveOptical DriveOSMonitor
Hitachi DESKSTAR 1 TB WD 1TB Samsung 500 Gb Lightscribe DVD win 7 64bits DCLCD 20" LCD 
KeyboardPowerCaseMouse
dell Ultra 600 watt powerup mid tower A4tech 
  hide details  
Reply
post #2 of 7
try a hair dryer and get inbetween those keys nice and hot. if it still does not work, get a new one.
X79-GCN
(22 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3930K 4.5GHz HT GIGABYTE GA-X79-UP4 AMD R9-290X GEil Evo Potenza DDR3 2400MHz CL10 (4x4GB) 
Hard DriveCoolingCoolingCooling
Samsung 840 Pro 120GB EK Supremacy (CPU) NF F12's P/P (360 Rad)  NF A14's (420 Rad)  
CoolingCoolingCoolingCooling
XSPC Chrome Compression Fittings EK RES X3 150 Primochill PremoFlex Advanced LRT Clear 1/2 ID EK-FC (R9 290X) 
CoolingCoolingCoolingOS
EK D5 Vario Top-X  Phobya G-Changer V2 360mm Phobya G-Changer V2 420mm Win 10 x64 Pro 
MonitorKeyboardPowerCase
BenQ XR3501 35" Curved Corsair Vengeance K90 Seasonic X-1250 Gold (v2) Corsair 900D 
MouseAudio
Logitech G400s Senn HD 598 
  hide details  
Reply
X79-GCN
(22 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3930K 4.5GHz HT GIGABYTE GA-X79-UP4 AMD R9-290X GEil Evo Potenza DDR3 2400MHz CL10 (4x4GB) 
Hard DriveCoolingCoolingCooling
Samsung 840 Pro 120GB EK Supremacy (CPU) NF F12's P/P (360 Rad)  NF A14's (420 Rad)  
CoolingCoolingCoolingCooling
XSPC Chrome Compression Fittings EK RES X3 150 Primochill PremoFlex Advanced LRT Clear 1/2 ID EK-FC (R9 290X) 
CoolingCoolingCoolingOS
EK D5 Vario Top-X  Phobya G-Changer V2 360mm Phobya G-Changer V2 420mm Win 10 x64 Pro 
MonitorKeyboardPowerCase
BenQ XR3501 35" Curved Corsair Vengeance K90 Seasonic X-1250 Gold (v2) Corsair 900D 
MouseAudio
Logitech G400s Senn HD 598 
  hide details  
Reply
post #3 of 7
i spilled koolaid on mine....ooh that was a mess...

just check for water more
my first build
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2300 2.8GHz GIGABYTE GA-P67A-UD3-B3 MSI N460GTX Hawk GeForce GTX 460 @ 900/1800/2062 2x2gb kingston valueram 
Hard DriveOptical DriveOSMonitor
WDC Blue 500GB, 2x80GB WD in raid0 crappy cd-rw win 7 ult 2 random LCD's 
PowerCaseMouse
RAIDMAX HYBRID 2 RX-630SS 630W Xigmatek ASGARD II B/O logitech 
  hide details  
Reply
my first build
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2300 2.8GHz GIGABYTE GA-P67A-UD3-B3 MSI N460GTX Hawk GeForce GTX 460 @ 900/1800/2062 2x2gb kingston valueram 
Hard DriveOptical DriveOSMonitor
WDC Blue 500GB, 2x80GB WD in raid0 crappy cd-rw win 7 ult 2 random LCD's 
PowerCaseMouse
RAIDMAX HYBRID 2 RX-630SS 630W Xigmatek ASGARD II B/O logitech 
  hide details  
Reply
post #4 of 7
put it in a bowl of dry rice for like 8 hours and then see if it works

edit: will soak up any water...
---eYe SeVen---
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 4415 mhz Gigabyte X58A-OC ASUS ENGTX560 TI DCII G.Skill 6gb 2000 mhz CL9 
Hard DriveOptical DriveCoolingOS
Intel X25-M 120GB SSD Lite On/Asus Corsair/Asus DCUII Windows 7 64-bit 
MonitorKeyboardPowerCase
Samsung 23" LED HDMI Microsoft SideWinder X4 ABS Majesty 900watt Corsair Special Edition White 600T 
MouseMouse PadAudio
Logitech G700 Xtrac PADS FAT MAT HT Omega STRIKER 7.1 
  hide details  
Reply
---eYe SeVen---
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 4415 mhz Gigabyte X58A-OC ASUS ENGTX560 TI DCII G.Skill 6gb 2000 mhz CL9 
Hard DriveOptical DriveCoolingOS
Intel X25-M 120GB SSD Lite On/Asus Corsair/Asus DCUII Windows 7 64-bit 
MonitorKeyboardPowerCase
Samsung 23" LED HDMI Microsoft SideWinder X4 ABS Majesty 900watt Corsair Special Edition White 600T 
MouseMouse PadAudio
Logitech G700 Xtrac PADS FAT MAT HT Omega STRIKER 7.1 
  hide details  
Reply
post #5 of 7
I bet if you let that sucker sit in the sun for 15 minutes it would be dry out well.

I doubt that its broken, I dont think there would be enough voltage in there to cause any damaging shorting. If you get it fully dry I bet it will be okay.
post #6 of 7
Thread Starter 
well I tried the blow dryer, no changes.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 940 Deneb @3.5 Gigabyte GA_MA790X-UD4P Nvidia Geforce 9500gt Patriot Viper ser pc2-6400 800mhz (2x2gb)4-4-4-12 
Hard DriveOptical DriveOSMonitor
Hitachi DESKSTAR 1 TB WD 1TB Samsung 500 Gb Lightscribe DVD win 7 64bits DCLCD 20" LCD 
KeyboardPowerCaseMouse
dell Ultra 600 watt powerup mid tower A4tech 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 940 Deneb @3.5 Gigabyte GA_MA790X-UD4P Nvidia Geforce 9500gt Patriot Viper ser pc2-6400 800mhz (2x2gb)4-4-4-12 
Hard DriveOptical DriveOSMonitor
Hitachi DESKSTAR 1 TB WD 1TB Samsung 500 Gb Lightscribe DVD win 7 64bits DCLCD 20" LCD 
KeyboardPowerCaseMouse
dell Ultra 600 watt powerup mid tower A4tech 
  hide details  
Reply
post #7 of 7
Thread Starter 
By the way, this happened since Tuesday. Its just the numbers don't work and the enter button on the numerical pad. It appears as if the num-lock key is off. if I could get it on the on.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 940 Deneb @3.5 Gigabyte GA_MA790X-UD4P Nvidia Geforce 9500gt Patriot Viper ser pc2-6400 800mhz (2x2gb)4-4-4-12 
Hard DriveOptical DriveOSMonitor
Hitachi DESKSTAR 1 TB WD 1TB Samsung 500 Gb Lightscribe DVD win 7 64bits DCLCD 20" LCD 
KeyboardPowerCaseMouse
dell Ultra 600 watt powerup mid tower A4tech 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 940 Deneb @3.5 Gigabyte GA_MA790X-UD4P Nvidia Geforce 9500gt Patriot Viper ser pc2-6400 800mhz (2x2gb)4-4-4-12 
Hard DriveOptical DriveOSMonitor
Hitachi DESKSTAR 1 TB WD 1TB Samsung 500 Gb Lightscribe DVD win 7 64bits DCLCD 20" LCD 
KeyboardPowerCaseMouse
dell Ultra 600 watt powerup mid tower A4tech 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Keyboards
Overclock.net › Forums › Components › Keyboards › water spilled