Overclock.net › Forums › Software, Programming and Coding › Networking & Security › "Turn on Network Discovery" won't.
New Posts  All Forums:Forum Nav:

"Turn on Network Discovery" won't.

post #1 of 5
Thread Starter 
I'm trying to run Java PS3 Media Sever, and one of the troubleshooting tips it describes it to turn on Network Discovery in Vista/7. I keep trying to turn it on and "Save Changes" (I have UAC turned off), but when I come back to see if the changes really were saved, they weren't. Windows keeps resetting the option to "Turn off Network Discovery".

[EDIT]
Well, I got PS3 Media Server to work by completely uninstalling it and then reinstalling it, but I'd still like to know why Windows keeps resetting Network Discovery.
Edited by predcon - 4/21/11 at 2:27pm
    
CPUMotherboardGraphicsRAM
AMD FX-8150 SABERTOOTH 990FX MSI R6970 Lightning Corsair  
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB / WD Caviar Black 1TB MSI 24X DVD-RW Windows 7 Ultimate 64-Bit 22" ViewSonic 720p HDTV 
KeyboardPowerCaseMouse
Saitek Cyborg Corsair HX 850W Rosewill Challenger CM Storm Sentinel Advance 
Mouse Pad
SteelSeries 4HD 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
AMD FX-8150 SABERTOOTH 990FX MSI R6970 Lightning Corsair  
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB / WD Caviar Black 1TB MSI 24X DVD-RW Windows 7 Ultimate 64-Bit 22" ViewSonic 720p HDTV 
KeyboardPowerCaseMouse
Saitek Cyborg Corsair HX 850W Rosewill Challenger CM Storm Sentinel Advance 
Mouse Pad
SteelSeries 4HD 
  hide details  
Reply
post #2 of 5
1. Firewalls play a major role in Networking. As such, my first suggestion is to temporarily turn off any firewall or security softwares such as avast antivirus. If firewall is the problem, you'll have to change its configuration. If you need any help with it, please check with the software vendor.
Note that some firewalls must be completely uninstalled to stop them from affecting your networking.
2. Run ping command to test network connection.
Hold the Windows key and press R, then type CMD to open a command prompt.
In the command prompt window that opens, type the following command:
PING and press Enter.
PING and press Enter.
Where:
- is the x.x.x.x IP address
- is the computer name
A failure to PING is almost always a firewall configuration issue. Any failure to PING needs to be corrected before you go any further. Once you figure out if firewall is the problem, you may choose whether or not to continue with this post.
3. Run the Network troubleshooter to see if it can help diagnose and solve your problem.

Open the Network troubleshooter by right-clicking the network icon in the notification area, and then clicking Troubleshoot problems.
4. All computers should be in the same workgroup for computer browsing to function properly.

5. Make sure that computer is on and that you've enabled file and printer sharing on your network.

6. If you encounter difficulties accessing computers that are visible in Network Neighborhood, make sure the computer being accessed has an account with the same name/password as the system connecting to it.

7. Check your Services. Ensure that the required services are Started on all the computers:
Go to Start\Control Panel\ Administrative Tools\ Services.
o Computer Browser
o DHCP Client
o DNS Client
o Network Connections
o Network Location Awareness
o Remote Procedure Call (RPC)
o Server
o TCP/IP Netbios helper
o Workstation
All of these services should be started, and their startup type should be automatic.
To change the startup type, double-click on the service name and change accordingly.
This should do the trick.
post #3 of 5
Nice copy and paste
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
post #4 of 5
I had the same problem too but I've fixed it, you have to enable all the services above, plus enable a service called SSDP Discovery.
That's what fixed it for me, and I hope it does for you to.
post #5 of 5
Same here. All of the above + SSDP thumb.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › "Turn on Network Discovery" won't.