Overclock.net › Forums › Graphics Cards › AMD/ATI › [Solution/Workaround] Battlefield: Bad Company 2 Locking up/Freezing/Crashing
New Posts  All Forums:Forum Nav:

[Solution/Workaround] Battlefield: Bad Company 2 Locking up/Freezing/Crashing - Page 5

post #41 of 51
Quote:
Originally Posted by Doba View Post
Looking for some ideas.. Im getting a black screen in BC2 with this 6950 using latest drivers 11.8.. I did the recommended procedure on page 1 but with no success so I just went and uninstalled Afterburner.. then tried older video drivers .. 11.6 and 11.5 dont even work.. 11.7 and 11.8 do the same thing.. Black screen in BC2

Both these drivers dont even install without some sort of errors.. not sure what they are but I know that I cant run CCC

no idea *** is going on
black screen only in gameplay or in menu also?
is there sound?

maybe its set to resolution your monitor not support

(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i3-540 Asus P7H55-M/USB3 Asus EAH 6850 1GB Kingston HyperX 4x2GB 
Hard DriveOptical DriveOSMonitor
WD Black 1TB SATA3 Asus 24B1ST DVDRW Windows 7 Ultimate 64bit AOC 23" e2343 1080p 
KeyboardPowerCaseMouse
Microsoft Wireless Keyboard 800 Seasonic X650 Gold Sharkoon T9 Value Black Razer DeathAdder 3.5G 
  hide details  
Reply

(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i3-540 Asus P7H55-M/USB3 Asus EAH 6850 1GB Kingston HyperX 4x2GB 
Hard DriveOptical DriveOSMonitor
WD Black 1TB SATA3 Asus 24B1ST DVDRW Windows 7 Ultimate 64bit AOC 23" e2343 1080p 
KeyboardPowerCaseMouse
Microsoft Wireless Keyboard 800 Seasonic X650 Gold Sharkoon T9 Value Black Razer DeathAdder 3.5G 
  hide details  
Reply
post #42 of 51
previous card was msi r4890 oc'ed with 1920x1200 res.. played no problems with high 50's FPS

although you may to onto something.. i lowered my resolution to 1680x1050 and screen came back but choppy as hell .. raised it back to 1920x1200 nothing.. I played around with it a few times and at ome point 1920x1200 came on also.. sometimes it didnt

and even though FPS show 60-120 its choppy as hell unplayable something still wrong

I really think its WinXP related.. outdated and not DX11..
Edited by Doba - 9/17/11 at 12:17pm
My Crap
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 4790K   Gigabyte z97x-soc force EVGA GTX 970 Patriot 2x4 DDR3-1333 
Hard DriveCoolingOSMonitor
SAMSUNG 850 EVO 2.5" 250GB NZXT Kraken X61 Win7 64 Ultimate Asus 28" monitor 144Hrz 
KeyboardPowerCaseMouse
Logitech G710+ Corsair TX750 Corsair 500R  Razer Deathadder Chrome 
Mouse PadAudio
Steel Series QCK+ Filo E10K 
  hide details  
Reply
My Crap
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 4790K   Gigabyte z97x-soc force EVGA GTX 970 Patriot 2x4 DDR3-1333 
Hard DriveCoolingOSMonitor
SAMSUNG 850 EVO 2.5" 250GB NZXT Kraken X61 Win7 64 Ultimate Asus 28" monitor 144Hrz 
KeyboardPowerCaseMouse
Logitech G710+ Corsair TX750 Corsair 500R  Razer Deathadder Chrome 
Mouse PadAudio
Steel Series QCK+ Filo E10K 
  hide details  
Reply
post #43 of 51
So the solution to this is now kernel mode in MSI AB 2.2.0 B10?
Edited by heroxoot - 1/17/12 at 11:56am
POWERFUL
(19 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 6800K X99-UD3P-CF AMD Radeon R9 200 Series 16gb G.skill RipjawX 2400mhz DDR4 
Hard DriveHard DriveHard DriveOptical Drive
Samsung spinpoint f3  Western digital Caviar Black Adata SU800 512gb LG Super Multi DVD Burner 
CoolingOSMonitorMonitor
Noctua NH-U14S Windows 10 x64 pro Asus VA32AQ 31.5" 1440p Acer 19" LED 900p 
KeyboardPowerCaseMouse
Logitech G19 OCZ ZX 850w gold Cooler Master HAF XB Logitech G600 
Mouse PadAudioAudio
Custom Artscow Sennheiser 429 Logitech Z313 
  hide details  
Reply
POWERFUL
(19 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 6800K X99-UD3P-CF AMD Radeon R9 200 Series 16gb G.skill RipjawX 2400mhz DDR4 
Hard DriveHard DriveHard DriveOptical Drive
Samsung spinpoint f3  Western digital Caviar Black Adata SU800 512gb LG Super Multi DVD Burner 
CoolingOSMonitorMonitor
Noctua NH-U14S Windows 10 x64 pro Asus VA32AQ 31.5" 1440p Acer 19" LED 900p 
KeyboardPowerCaseMouse
Logitech G19 OCZ ZX 850w gold Cooler Master HAF XB Logitech G600 
Mouse PadAudioAudio
Custom Artscow Sennheiser 429 Logitech Z313 
  hide details  
Reply
post #44 of 51
Maaan, I did so much testing trying to find any instability on my system, but there again this ***** PB was causing this....
Removed MSI Afterburner and so far playing 2 hours without a problem.
Does that concern CCC too? I mean do you think PB can go wrong with CCC as well and cause a system freeze?
post #45 of 51

It has nothing to do with CCC.

 

Download and install MSI Afterburner 2.2.0 Beta 11

 

Then disable "Enable low-level hardware access interface" in the Afterburner settings.


Edited by Ken1649 - 1/24/12 at 2:38pm
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
post #46 of 51
Well no need, I was only using MSI Afterburner cause I liked the interface more... My card does 970MHz core and 1050MHz memory without any voltage adjustments needed, so I'm good to go with CCC just to avoid annoying issues smile.gif
post #47 of 51
Thanks anyway for this thread as I had no clue it was cased by MSI Afterburner until I saw this biggrin.gif
post #48 of 51
Thread Starter 
Quote:
Originally Posted by Ken1649 View Post

It has nothing to do with CCC.

Download and install MSI Afterburner 2.2.0 Beta 11

Then disable "Enable low-level hardware access interface" in the Afterburner settings.

Yes this should work too.
 
HTPC
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q6600 GIGABYTE GA-EP45-UD3R ATI Radeon HD 5670 4 GB OCZ Reaper DDR2 1066 
Hard DriveOptical DriveOSMonitor
2x 1 TB WD Caviar Black, 1x WD20EARS SAMSUNG 22X DVD+RW Windows 7 Ultimate x64, Vista Ultimate x64 42" Philips 1080p 120 Hz (Blue version) 
KeyboardPowerCaseMouse
Logitech EX Wireless Mouse+KB 500W OCZ ModXStream SilverStone HTPC Case Logitech EX Wireless Mouse+KB 
  hide details  
Reply
 
HTPC
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q6600 GIGABYTE GA-EP45-UD3R ATI Radeon HD 5670 4 GB OCZ Reaper DDR2 1066 
Hard DriveOptical DriveOSMonitor
2x 1 TB WD Caviar Black, 1x WD20EARS SAMSUNG 22X DVD+RW Windows 7 Ultimate x64, Vista Ultimate x64 42" Philips 1080p 120 Hz (Blue version) 
KeyboardPowerCaseMouse
Logitech EX Wireless Mouse+KB 500W OCZ ModXStream SilverStone HTPC Case Logitech EX Wireless Mouse+KB 
  hide details  
Reply
post #49 of 51
Ok guys, i tried most of the things mentioned above: updating Realtek drivers and whatsoever. However, nothing helped.
My troubles began with new monitor, on the old 1280x1024 BC2 ran like a dream. Then i got myself a new 1920x1080 and thats where things went interesting. Hardlocks began, first i thought it may be my PC is unable to run it on all settings maxed and high resolution. Downgraded graphics and reso and everything, no help. Switched even back to old monitor for once, still nothing. Then i started to dig into these posts about MSI AB possible conflict with PB and such. Thing is, i even didnt use AB because my rig is good enough to run all those games i have and play, BC2 included.

To make sure it is caused by PB, i joined one non-PB server and could play for 1.5 hours. However, it was non-hardcore server and therefore i dont enjoy playing there.....
To cut long, sad story, full of anger and hatred short, i removed DELL Powernap service which came with my new monitor. I blame myself now that i didnt remove it earlier, while i read that PB hates monitoring programs. I must still test it further, but i did following things this morning and then played BC2 for 1.5 hours.

1) Downloaded processexplorer.

2) Removed Dell Powernap from my PC

3) Killed CCC and softOSD in processexplorer (thought that maybe this has something to do with crashes as well)

4) played the game for some 2 hours a row smile.gif

Im gonna test it later if CCC and softOSD interfere with BC2 or not, hopefully it was DELL thingie only.


Maybe this will help others who dont use MSI AB or other that kind of programs and STILL hardlock their PC.
post #50 of 51
I revive this thread to state the obvious, after all these years PB issue is still alive

its a shame because is a great game, my BC2 copy of Steam still hard hang my PC

Im not even using AB
GTR-PC
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570k 4.3Ghz  ASRock Z77 Extreme 6 EVGA GTX 770 4GB FTW Crucial Ballistix Sport 8GB 1600 
Hard DriveCoolingOSMonitor
Zotac SSD - WD 1TB (x2) Zalman Performa W10 64 Bits HP 2509 25" 1080p 
KeyboardPowerCaseMouse
Sidewinder X6 Thermaltake Smart 700w 80Plus CM Storm Enforcer Mionix Naos 3200 
Mouse Pad
SteelSeries QcK Gaming Mouse Pad 
  hide details  
Reply
GTR-PC
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570k 4.3Ghz  ASRock Z77 Extreme 6 EVGA GTX 770 4GB FTW Crucial Ballistix Sport 8GB 1600 
Hard DriveCoolingOSMonitor
Zotac SSD - WD 1TB (x2) Zalman Performa W10 64 Bits HP 2509 25" 1080p 
KeyboardPowerCaseMouse
Sidewinder X6 Thermaltake Smart 700w 80Plus CM Storm Enforcer Mionix Naos 3200 
Mouse Pad
SteelSeries QcK Gaming Mouse Pad 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › [Solution/Workaround] Battlefield: Bad Company 2 Locking up/Freezing/Crashing