Overclock.net › Forums › Components › Keyboards › Why won't my Razer BlackWidow logo light up?
New Posts  All Forums:Forum Nav:

Why won't my Razer BlackWidow logo light up?

post #1 of 4
Thread Starter 
Is it defective? I have the latest drivers and everything too. When I first plugged it in it didn't light up and I thought it was a driver issue, so I reinstalled and the razer logo still will not light up.

What troubleshooting steps should I take?
post #2 of 4
ultimate or non?

have you tried pressing fn+f12 (the button combination to go through the lighting options)
Winter Heater
(10 items)
 
Maxes Minesweeper
(10 items)
 
IP Dealer
(8 items)
 
CPUMotherboardGraphicsGraphics
i7 2600K Gigabyte P67A-UD3-B3 Galaxy GTX 460 768MB Galaxy GTX 460 768MB 
RAMHard DriveHard DriveCooling
Corsair XMS3 DDR3 1333 2x4GB 64GB ADATA S596 Turbo SSD WD Blue 500GB Scythe Big Shuriken 2 REV.B 
PowerCase
SeaSonic SS-650HT 650W Cooler Master Elite 360 
CPUMotherboardGraphicsRAM
Phenom II X6 1055T  ASUS M4A87TD EVO XFX Radeon HD 5850 1GB AMD Performance Edition DDR3 1333 2X2GB  
Hard DriveHard DriveHard DriveCooling
32GB ADATA S596 Turbo SSD 32GB ADATA S596 Turbo SSD 1TB WD Green Scythe Mugen 2 Rev. B 
PowerCase
OCZ Fatal1ty 550W  COOLER MASTER HAF 932 
  hide details  
Reply
Winter Heater
(10 items)
 
Maxes Minesweeper
(10 items)
 
IP Dealer
(8 items)
 
CPUMotherboardGraphicsGraphics
i7 2600K Gigabyte P67A-UD3-B3 Galaxy GTX 460 768MB Galaxy GTX 460 768MB 
RAMHard DriveHard DriveCooling
Corsair XMS3 DDR3 1333 2x4GB 64GB ADATA S596 Turbo SSD WD Blue 500GB Scythe Big Shuriken 2 REV.B 
PowerCase
SeaSonic SS-650HT 650W Cooler Master Elite 360 
CPUMotherboardGraphicsRAM
Phenom II X6 1055T  ASUS M4A87TD EVO XFX Radeon HD 5850 1GB AMD Performance Edition DDR3 1333 2X2GB  
Hard DriveHard DriveHard DriveCooling
32GB ADATA S596 Turbo SSD 32GB ADATA S596 Turbo SSD 1TB WD Green Scythe Mugen 2 Rev. B 
PowerCase
OCZ Fatal1ty 550W  COOLER MASTER HAF 932 
  hide details  
Reply
post #3 of 4
Thread Starter 
Quote:
Originally Posted by Sainesk;13223119 
ultimate or non?

have you tried pressing fn+f12 (the button combination to go through the lighting options)

Thanks, worked. +Rep
post #4 of 4
Haha, I just got mine yesterday and thought, aww only lights up on the Ultimate, FN F12, logo lights!

Repped also
Clover
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition Gigabyte GA-MA770-UD3 XFX GTX 260 216 @ [735/1530/1200] OCZ 4GB Dual Channel (2x2gb) 800Mhz 
Hard DriveOptical DriveOSMonitor
500GB Maxtor(Win7) 2x Maxtor 1TB (Back) LG SataII DVDRW Windows 7 64-Bit Samsung Syncmaster 2333 23" (1920x1080) 
KeyboardPowerCaseMouse
Razer Black Widow Antec Basiq 550W Corsair 650D Logitech G700 
Mouse Pad
Razer Goliathus Control 
  hide details  
Reply
Clover
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition Gigabyte GA-MA770-UD3 XFX GTX 260 216 @ [735/1530/1200] OCZ 4GB Dual Channel (2x2gb) 800Mhz 
Hard DriveOptical DriveOSMonitor
500GB Maxtor(Win7) 2x Maxtor 1TB (Back) LG SataII DVDRW Windows 7 64-Bit Samsung Syncmaster 2333 23" (1920x1080) 
KeyboardPowerCaseMouse
Razer Black Widow Antec Basiq 550W Corsair 650D Logitech G700 
Mouse Pad
Razer Goliathus Control 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Keyboards
Overclock.net › Forums › Components › Keyboards › Why won't my Razer BlackWidow logo light up?