Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Enabling cool n quiet on kde MInt
New Posts  All Forums:Forum Nav:

Enabling cool n quiet on kde MInt

post #1 of 6
Thread Starter 
The title pretty much says it all.

I can't figure out how to control the frequency scaling on my laptop and this thing is getting toasty!

I've run plenty of Gnome desktops, all of them just use cpufreq to take care of things.

I can't find any comparable application in KDE. Google is giving me nothing.
post #2 of 6
Quote:
Originally Posted by TEntel View Post
The title pretty much says it all.

I can't figure out how to control the frequency scaling on my laptop and this thing is getting toasty!

I've run plenty of Gnome desktops, all of them just use cpufreq to take care of things.

I can't find any comparable application in KDE. Google is giving me nothing.
This functionality was intentionally removed from KDE (due, according to the developers, to it being unnecessary).

Unfortunately, it may be that you don't have any package installed to manage the CPU frequency. Try installing cpufreqd which will manage it automatically in the background based on actual CPU load. You can also install cpufrequtils for some command line utilities if you're the sort who can't stand a computer that does anything automatically.
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
post #3 of 6
i use KDE and with speedstep enabled, it works like it is suppose to, scales based on demand, or am i missing something here? i don't believe i have cpufreq installed...
Bazinga Punk
(12 items)
 
ooh shiny!
(6 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon 3440 AsRock P55 extreme Evga 8800 GT 512 MB Gskill Ripjaws 
Hard DriveCoolingOSMonitor
Western Digital Blue Antec Khuler 620 Ubuntu 11.10 Asus vw264H 
KeyboardPowerCaseMouse
GIGABYTE KM7600 CORSAIR TX 650 Cooler Master 590 GIGABYTE GM-M6800 
CPUMotherboardGraphicsRAM
Intel Core I5 6500 Gigabyte z170xp-SLI Nvidia 970gtx Corsair 16gb ddr4 2666mhz  
Hard DriveOS
250gb Samsung Evo 850 Windows 10 & Ubuntu 15.10 
  hide details  
Reply
Bazinga Punk
(12 items)
 
ooh shiny!
(6 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon 3440 AsRock P55 extreme Evga 8800 GT 512 MB Gskill Ripjaws 
Hard DriveCoolingOSMonitor
Western Digital Blue Antec Khuler 620 Ubuntu 11.10 Asus vw264H 
KeyboardPowerCaseMouse
GIGABYTE KM7600 CORSAIR TX 650 Cooler Master 590 GIGABYTE GM-M6800 
CPUMotherboardGraphicsRAM
Intel Core I5 6500 Gigabyte z170xp-SLI Nvidia 970gtx Corsair 16gb ddr4 2666mhz  
Hard DriveOS
250gb Samsung Evo 850 Windows 10 & Ubuntu 15.10 
  hide details  
Reply
post #4 of 6
Thread Starter 
Quote:
Originally Posted by error10 View Post
This functionality was intentionally removed from KDE (due, according to the developers, to it being unnecessary).

Unfortunately, it may be that you don't have any package installed to manage the CPU frequency. Try installing cpufreqd which will manage it automatically in the background based on actual CPU load. You can also install cpufrequtils for some command line utilities if you're the sort who can't stand a computer that does anything automatically.
\\


Problem solved!

Solution

Code:
sudo apt-get install cpufreqd && sudo apt-get install cpufrequtils
sudo cpufreq-set -g ondemand
post #5 of 6
Quote:
Originally Posted by error10 View Post
This functionality was intentionally removed from KDE (due, according to the developers, to it being unnecessary).

...
I raged a bit when I found out myself. A very GNOMEish thing to do. Anyway, as already figured out, you can use cpufreq. You can also use powerdevil to do the power state switching; just change the permissions on cpufreq and tell powerdevil to use a particular cpufreq command at profile load.
Magicbox
(17 items)
 
crapbox
(13 items)
 
 
CPUMotherboardGraphicsRAM
FX 8320 Sabertooth 990FX Nitro+ RX480 Kingston HyperX Fury 
Hard DriveHard DriveHard DriveCooling
Samsung 850 EVO  Kingston HyperX 3K Seagate Barracuda 7200.14 Noctua NH-D15 
OSOSMonitorKeyboard
Kubuntu  Windows 10 Pro Dell U2515H CM Quickfire TK (Cherry Blue) 
PowerCaseMouseMouse Pad
Cooler Master Silent Pro M 850W Enthoo Pro Logitech G502 Logitech G440 
Audio
Xonar DX 
CPUMotherboardGraphicsRAM
Sempron 3300+ HP stock mobo (laptop) 200M (IGP) 2x1GB PC3200 
Hard DriveOptical DriveOSMonitor
100GB ATA133 DVD/CDRW Kubuntu 32 bit 14.1" (1280x768) 
Power
6 cell 
  hide details  
Reply
Magicbox
(17 items)
 
crapbox
(13 items)
 
 
CPUMotherboardGraphicsRAM
FX 8320 Sabertooth 990FX Nitro+ RX480 Kingston HyperX Fury 
Hard DriveHard DriveHard DriveCooling
Samsung 850 EVO  Kingston HyperX 3K Seagate Barracuda 7200.14 Noctua NH-D15 
OSOSMonitorKeyboard
Kubuntu  Windows 10 Pro Dell U2515H CM Quickfire TK (Cherry Blue) 
PowerCaseMouseMouse Pad
Cooler Master Silent Pro M 850W Enthoo Pro Logitech G502 Logitech G440 
Audio
Xonar DX 
CPUMotherboardGraphicsRAM
Sempron 3300+ HP stock mobo (laptop) 200M (IGP) 2x1GB PC3200 
Hard DriveOptical DriveOSMonitor
100GB ATA133 DVD/CDRW Kubuntu 32 bit 14.1" (1280x768) 
Power
6 cell 
  hide details  
Reply
post #6 of 6
Quote:
Originally Posted by Melcar View Post
I raged a bit when I found out myself. A very GNOMEish thing to do. Anyway, as already figured out, you can use cpufreq. You can also use powerdevil to do the power state switching; just change the permissions on cpufreq and tell powerdevil to use a particular cpufreq command at profile load.
I dunno, I can see an argument for it. After all, this is something most users should never have to mess with. The distro should be setting this up automatically, and it appears the poster's distro didn't.
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Enabling cool n quiet on kde MInt