Overclock.net › Forums › Specialty Builds › Servers › Windows Server 2008 R2 FTP Issues
New Posts  All Forums:Forum Nav:

Windows Server 2008 R2 FTP Issues

post #1 of 2
Thread Starter 
So I've been working all day to get this stupid FTP server working, and I'm out of ideas. I hope someone here has more experience than me with IIS 7.

I installed the webserver role and ran the FTP server wizard as usual, except my ISP blocks port 21 so I changed it to port 1337 (biggrin.gif). I proceeded to create a user group with read/write access, and finished up the wizard. Then in the parameters I set the IP internal IP to 192.168.1.172, and port forwarded it on my Untangle router. The passive ports were set to 41000 to 41099 on the server, and external address to my external IP. As I don't have a static IP, I set up a DynDNS updater on the server, and routed the hostname to my IP.

Now, I'd expect this all to work just fine, and it does from my internal network, but not from the external network. If I try to use ftptest.net I get all the way down to "Opening binary mode DATA connection" and then the connection times out. It works fine from my LAN, and I don't understand why it wouldn't from the external network. Any ideas?

Thanks for your help!
     
CPUGraphicsRAMHard Drive
Intel Core i7-2720QM Intel HD 3000 8GB DDR3-1333 Samsung 850 EVO 120GB 
OSMonitor
Arch Linux w/ OpenBox B156HW01 V.4 FHD Panel 
CPUMotherboardGraphicsRAM
Xeon L5639 @ 3.24-3.60GHz Asus P6X58D Premium Gigabyte HD7950 Windforce3 6x2GB G.Skill Pi 1600MHz CL7-8-7 @ 1440MHz 
Hard DriveOSMonitorKeyboard
Crucial M4 64GB + Samsung 1TB 2.5" Windows 7 x64 2x Dell U2311H Rosewill RK-9000 
PowerCase
Seasonic SS-850HT Lian Li PC-9F 
  hide details  
Reply
     
CPUGraphicsRAMHard Drive
Intel Core i7-2720QM Intel HD 3000 8GB DDR3-1333 Samsung 850 EVO 120GB 
OSMonitor
Arch Linux w/ OpenBox B156HW01 V.4 FHD Panel 
CPUMotherboardGraphicsRAM
Xeon L5639 @ 3.24-3.60GHz Asus P6X58D Premium Gigabyte HD7950 Windforce3 6x2GB G.Skill Pi 1600MHz CL7-8-7 @ 1440MHz 
Hard DriveOSMonitorKeyboard
Crucial M4 64GB + Samsung 1TB 2.5" Windows 7 x64 2x Dell U2311H Rosewill RK-9000 
PowerCase
Seasonic SS-850HT Lian Li PC-9F 
  hide details  
Reply
post #2 of 2
Thread Starter 
Alright nevermind guys, apparently Windows Server 2008 R2 decided it didn't feel like telling me to reboot after I made my config changes, it all works now.
     
CPUGraphicsRAMHard Drive
Intel Core i7-2720QM Intel HD 3000 8GB DDR3-1333 Samsung 850 EVO 120GB 
OSMonitor
Arch Linux w/ OpenBox B156HW01 V.4 FHD Panel 
CPUMotherboardGraphicsRAM
Xeon L5639 @ 3.24-3.60GHz Asus P6X58D Premium Gigabyte HD7950 Windforce3 6x2GB G.Skill Pi 1600MHz CL7-8-7 @ 1440MHz 
Hard DriveOSMonitorKeyboard
Crucial M4 64GB + Samsung 1TB 2.5" Windows 7 x64 2x Dell U2311H Rosewill RK-9000 
PowerCase
Seasonic SS-850HT Lian Li PC-9F 
  hide details  
Reply
     
CPUGraphicsRAMHard Drive
Intel Core i7-2720QM Intel HD 3000 8GB DDR3-1333 Samsung 850 EVO 120GB 
OSMonitor
Arch Linux w/ OpenBox B156HW01 V.4 FHD Panel 
CPUMotherboardGraphicsRAM
Xeon L5639 @ 3.24-3.60GHz Asus P6X58D Premium Gigabyte HD7950 Windforce3 6x2GB G.Skill Pi 1600MHz CL7-8-7 @ 1440MHz 
Hard DriveOSMonitorKeyboard
Crucial M4 64GB + Samsung 1TB 2.5" Windows 7 x64 2x Dell U2311H Rosewill RK-9000 
PowerCase
Seasonic SS-850HT Lian Li PC-9F 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Servers
Overclock.net › Forums › Specialty Builds › Servers › Windows Server 2008 R2 FTP Issues