Overclock.net › Forums › Intel › Intel Motherboards › Asus P6X58D-E Marvell Controller
New Posts  All Forums:Forum Nav:

Asus P6X58D-E Marvell Controller

post #1 of 13
Thread Starter 
Hey guys,

Well, I can't get my SSD to work on my Marvell controller. I no longer get the CTRL-M boot up option anymore either.

I can go into my normal BIOS and it can see that the disk is attached to my SATAIII ports but it wouldn't let me boot from it.

I've done a full bios reset, removed all disks and booted then attached my SSD only and booted to no avail, I've wiped the disk and tried, that didn't work. I can figure it out, I also updated my BIOS.

Any ideas?

Comps
post #2 of 13
Make sure you have the Marvell Sata 6 Controller Enabled in the BIOS, and set it to normal mode (if you are not going to RAID).

Also change the disk boot order and update the SSDs firmware (if there are any updates).

Thats all I can think of right now. Good luck!
post #3 of 13
Thread Starter 
Yep, done that and it still doesn't work
post #4 of 13
What BIOS version do you have? 602 was released just a few days ago but still doesn't appear on the Asus website. It supposedly adds TRIM support for the Marvell controller.

Have a look here.

BTW does the SSD work on the Intel controller?
post #5 of 13
Thread Starter 
If you mean my normal SATAII controller yes it does, without any issues as well.

I want it on my SATA III controller because i'll be getting a second one soon for RAID0
post #6 of 13
Have you tried both IDE and AHCI mode? Try to connect the drive to the other Sata 6 port if you haven't already.

Connect any regular drive or peripheral to the Sata 6 controller and see if Windows recognizes it.
post #7 of 13
Thread Starter 
Tried both IDE and AHCI

Attached my Samsung to the ports which worked fine

Windows sees the controller

My BIOS see's the hard drive connected to the controller.

Still doesn't work
post #8 of 13
Thread Starter 
Do you get the HIt CTRL-M for your RAID bios when you boot up?

Comps
post #9 of 13
I would like to try it out but my GPU is FUBAR and my 8800GT also died a month or 2 ago... I can't boot my PC so I can't try it out sry.

I don't have my drives connected to the Marvell controller so I guess ctrl+m wouldn't work for me. I need to press ctrl+i to enter the Intel RAID config. But I have read on other forums that ctrl-m doesnt work for many people, so Sata 6 RAID is usually done through the Asus Drive Xpert in the BIOS

I can't think of anything else to check for... You already said that you did a full BIOS reset, but did you completely cleared the CMOS? Take the battery out for a few minutes or press the Clear CMOS swith located on the rear I/O panel.
post #10 of 13
Thread Starter 
Yep, battery was out and I reset the bios that way

I just really want to get this working. I might just wait until I get my second SSD and do it then.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › Asus P6X58D-E Marvell Controller