Possible to mod an Asus/AMI X570 bios to unlock hidden PCH fan controls? - Overclock.net - An Overclocking Community
Forum Jump: 

Possible to mod an Asus/AMI X570 bios to unlock hidden PCH fan controls?

 
Thread Tools
post #1 of 9 (permalink) Old 06-19-2020, 05:59 AM - Thread Starter
New to Overclock.net
 
Join Date: Jun 2020
Posts: 7
Rep: 0
Possible to mod an Asus/AMI X570 bios to unlock hidden PCH fan controls?

So is it possible and if how? It´s a c8f board, here is a screenshot from the hidden settings in amibcp https://imgur.com/BlQYLq9


If anyone knows it please help, the fan goes up to 3500rpm at 70°C and it´s an annyoing sound, the pc stands on my desk not very far from me. The fan is kind of quiet at 2000rpm, so I want to let it run at 2000rpm always.

Last edited by bobby_b; 06-19-2020 at 06:07 AM.
bobby_b is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-19-2020, 02:44 PM
New to Overclock.net
 
aGeoM's Avatar
 
Join Date: Jul 2007
Location: Portugal
Posts: 112
Rep: 13 (Unique: 8)
Quote: Originally Posted by bobby_b View Post
So is it possible and if how? It´s a c8f board, here is a screenshot from the hidden settings in amibcp https://imgur.com/BlQYLq9


If anyone knows it please help, the fan goes up to 3500rpm at 70°C and it´s an annyoing sound, the pc stands on my desk not very far from me. The fan is kind of quiet at 2000rpm, so I want to let it run at 2000rpm always.
Hi
You need to give more information about your system like CPU in use and link to the BIOS.

My Smarter choice
(9 items)
CPU
Ryzen 7 1700
Motherboard
MSI B350 TomaHawk
GPU
Radeon (TM) RX 480 Graphics
RAM
Crucial
Hard Drive
SAMSUNG SSD EVO 850
Power Supply
NOX NX750W
Cooling
AMD Spire
Case
AeroCool Cruiserstar
Operating System
Windows10 x64
▲ hide details ▲
aGeoM is offline  
post #3 of 9 (permalink) Old 06-19-2020, 04:01 PM - Thread Starter
New to Overclock.net
 
Join Date: Jun 2020
Posts: 7
Rep: 0
okay, no problem. here is the link to the bios file https://dlcdnets.asus.com/pub/ASUS/m...-ASUS-2010.zip


system specs:
mainboard: asus crosshair VIII formula x570
bios version: 2010
cpu: ryzen 9 3900x
bobby_b is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 06-19-2020, 06:36 PM
New to Overclock.net
 
aGeoM's Avatar
 
Join Date: Jul 2007
Location: Portugal
Posts: 112
Rep: 13 (Unique: 8)
Quote: Originally Posted by bobby_b View Post
okay, no problem. here is the link to the bios file https://dlcdnets.asus.com/pub/ASUS/m...-ASUS-2010.zip


system specs:
mainboard: asus crosshair VIII formula x570
bios version: 2010
cpu: ryzen 9 3900x
...and modded BIOS.

My Smarter choice
(9 items)
CPU
Ryzen 7 1700
Motherboard
MSI B350 TomaHawk
GPU
Radeon (TM) RX 480 Graphics
RAM
Crucial
Hard Drive
SAMSUNG SSD EVO 850
Power Supply
NOX NX750W
Cooling
AMD Spire
Case
AeroCool Cruiserstar
Operating System
Windows10 x64
▲ hide details ▲
aGeoM is offline  
post #5 of 9 (permalink) Old 06-20-2020, 04:22 AM - Thread Starter
New to Overclock.net
 
Join Date: Jun 2020
Posts: 7
Rep: 0
thanks a lot, but unfortunately it does not work. flashed it with asus flashback and the flashing process works, but the system won´t boot. the initialization led stays yellow and the display of the mainboard shows that the system does basically nothing. code 00



btw it is nice that you also provided the worklfow. I want to learn from it so I can do it myself if there is a new bios version. perhaps you or someone else can see what went wrong?
bobby_b is offline  
post #6 of 9 (permalink) Old 06-20-2020, 04:47 AM
New to Overclock.net
 
aGeoM's Avatar
 
Join Date: Jul 2007
Location: Portugal
Posts: 112
Rep: 13 (Unique: 8)
Sorry about it. I can try to re do the all thing, or you can try your self, the only thing I can think atm is some kind of security update to the BIOS, here is the same mod applied to my STRIX X570-E BIOS v.1409.




Edit:

Try this one

For some reason the bios 2 from previous mod was not aligned. This new one will work.
Attached Images
File Type: bmp 200620123739.BMP (3.00 MB, 160 views)

My Smarter choice
(9 items)
CPU
Ryzen 7 1700
Motherboard
MSI B350 TomaHawk
GPU
Radeon (TM) RX 480 Graphics
RAM
Crucial
Hard Drive
SAMSUNG SSD EVO 850
Power Supply
NOX NX750W
Cooling
AMD Spire
Case
AeroCool Cruiserstar
Operating System
Windows10 x64
▲ hide details ▲

Last edited by aGeoM; 06-20-2020 at 05:14 AM.
aGeoM is offline  
post #7 of 9 (permalink) Old 06-20-2020, 07:19 AM - Thread Starter
New to Overclock.net
 
Join Date: Jun 2020
Posts: 7
Rep: 0
no need to be sorry, your help is much appreciated and the new version works . thank you!


so if I were to follow the exact same procedure in your youtube video for future bios versions, it should work? or is what went wrong also in the video? could you explain or show with a screenshot what you mean by "not aligned" , so that I know what I have to look for when I try it myself?
bobby_b is offline  
post #8 of 9 (permalink) Old 06-20-2020, 10:00 AM
New to Overclock.net
 
aGeoM's Avatar
 
Join Date: Jul 2007
Location: Portugal
Posts: 112
Rep: 13 (Unique: 8)
Quote: Originally Posted by bobby_b View Post
no need to be sorry, your help is much appreciated and the new version works . thank you!


so if I were to follow the exact same procedure in your youtube video for future bios versions, it should work? or is what went wrong also in the video? could you explain or show with a screenshot what you mean by "not aligned" , so that I know what I have to look for when I try it myself?
I reviewed the video and found nothing wrong, just find your bios (2) position at 1001000 like this:



mod it and make sure that the modded one is replaced at exact same location. Was what happened at the first time, I misplaced it (not aligned) for some reason not visible in video.

Be well...
Attached Thumbnails
Click image for larger version

Name:	Bios2Position.jpg
Views:	3
Size:	222.3 KB
ID:	355718  


My Smarter choice
(9 items)
CPU
Ryzen 7 1700
Motherboard
MSI B350 TomaHawk
GPU
Radeon (TM) RX 480 Graphics
RAM
Crucial
Hard Drive
SAMSUNG SSD EVO 850
Power Supply
NOX NX750W
Cooling
AMD Spire
Case
AeroCool Cruiserstar
Operating System
Windows10 x64
▲ hide details ▲
aGeoM is offline  
post #9 of 9 (permalink) Old 06-20-2020, 05:14 PM - Thread Starter
New to Overclock.net
 
Join Date: Jun 2020
Posts: 7
Rep: 0
ah, this is what I thought you meant with not aligned but I wasn´t sure. cheers
bobby_b is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off